Copyrights and Trademarks

Copyright © 2013 FrontRange Solutions USA Inc. All Rights Reserved.

USE OF THIS SOFTWARE, SUBSCRIPTION SERVICES AND RELATED USER DOCUMENTATION IS SUBJECT TO THE TERMS AND CONDITIONS OF THE APPLICABLE FRONTRANGE SOLUTIONS END-USER LICENSE AGREEMENT, HEAT CLOUD SUBSCRIPTION SERVICES AGREEMENT AND ANY TERMS OF SERVICE (“SUBSCRIPTION AGREEMENT”). YOU MUST AGREE TO THE TERMS AND CONDITIONS OF THE SUBSCRIPTION AGREEMENT IN ORDER TO USE THE SOFTWARE AND SUBSCRIPTION SERVICE.

WARNING: The software described in this manual and its related user documentation are protected by copyright law. In no event, shall any part of the related user documentation be copied, reproduced, distributed, transmitted, stored in a retrieval system, or translated into any language, without the express written permission of FrontRange Solutions USA Inc.

FrontRange Trademark Information

The following are trademarks of FrontRange Solutions USA Inc. and/or its affiliates in the United States and/or other countries: FrontRange Solutions®, FrontRange™, SaaSIT™, ModernizeIT™, SaaS2™, GoldMine®, GoldSync®, GoldMine® Answer Wizard™, GoldMine® Management Intelligence™, GoldMine® Manager's Console™, iGoldMine™, HEAT®, HEAT® Service & Support™, HEAT® PowerDesk™, iHEAT™, HEAT® Self Service™, HEAT® Manager's Console™, HEAT® Answer Wizard™, HEAT® Quick Start Wizard™, InfoCenter®, Automated Processes™, First Level Support®, enteo®, DeviceWall®, Centennial Discovery®, Discovery Dashboard®, MicroAudit®, SAM™, The HEAT Is On™ and other FrontRange products and brands.

Other Trademark Information

Microsoft® SQL Server™ is Copyright© 2008, Microsoft Corporation. All rights reserved.
This software includes software developed by the Apache Software Foundation (http://www.apache.org/).
This program includes Firebird SQL Database Engine v1.5. Firebird SQL Database Engine v1.5 was developed by Inprise Corporation, now called Borland Software Corporation Copyright © 2001-2005. All Rights Reserved.
For FBExport see http://fbexport.sf.net.
The Sentry Spelling-Checker Engine Copyright © 1999 Wintertree Software Inc.
Portions Copyright © 1998-2008 The OpenSSL Project. All rights reserved.
The Edraw Component provided in this product is copyrighted by EdrawSoft.
Microsoft products, brands and trademarks, including Microsoft, Windows, Windows Server, Windows Vista, SQL Server, and Internet Explorer, are the property of Microsoft Corporation in the United States and/or other countries.
Other products and brands are the trademarks of their respective owners or companies.
Contact FrontRange Solutions USA Inc. at legal@frontrange.com

(March 2014)
# Table of Contents

## Getting Started

<table>
<thead>
<tr>
<th>Overview</th>
<th>15</th>
</tr>
</thead>
<tbody>
<tr>
<td>The GoldMine File System</td>
<td>15</td>
</tr>
<tr>
<td>File Server and Client/Server Architecture</td>
<td>16</td>
</tr>
</tbody>
</table>

## User Administration

<table>
<thead>
<tr>
<th>Managing User Security and Access</th>
<th>17</th>
</tr>
</thead>
<tbody>
<tr>
<td>Record Ownership</td>
<td>17</td>
</tr>
<tr>
<td>Record Curtaining</td>
<td>18</td>
</tr>
<tr>
<td>Users Properties</td>
<td>18</td>
</tr>
<tr>
<td>Clone User Settings</td>
<td>24</td>
</tr>
<tr>
<td>User Passwords</td>
<td>24</td>
</tr>
<tr>
<td>Setting Options on the Personal Tab</td>
<td>26</td>
</tr>
<tr>
<td>Setting Options for the Record Tab</td>
<td>26</td>
</tr>
<tr>
<td>Setting Options for the Calendar Tab</td>
<td>29</td>
</tr>
<tr>
<td>Setting Options for the Schedule Tab</td>
<td>32</td>
</tr>
<tr>
<td>Setting Options for the Alarms Tab</td>
<td>33</td>
</tr>
<tr>
<td>Setting Options for the Lookup Tab</td>
<td>33</td>
</tr>
<tr>
<td>Setting Options for the E-mail Tab</td>
<td>34</td>
</tr>
<tr>
<td>Setting Options for the Telephony Tab</td>
<td>40</td>
</tr>
<tr>
<td>Setting Options for the System Tab</td>
<td>41</td>
</tr>
<tr>
<td>Setting Options for the Speller Tab</td>
<td>41</td>
</tr>
<tr>
<td>Setting Options for the Messaging Tab</td>
<td>42</td>
</tr>
<tr>
<td>Setting Options for the Login Tab</td>
<td>43</td>
</tr>
<tr>
<td>Updating Undocked Users</td>
<td>44</td>
</tr>
<tr>
<td>GoldMine .INI Files</td>
<td>44</td>
</tr>
<tr>
<td>GM.ini Settings</td>
<td>44</td>
</tr>
<tr>
<td>Username.ini</td>
<td>46</td>
</tr>
<tr>
<td>Changing Settings in the INI File in GoldMine</td>
<td>49</td>
</tr>
<tr>
<td>Changing the User INI Settings</td>
<td>51</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Setting E-mail Preview Text Amounts</td>
<td>51</td>
</tr>
<tr>
<td>Setting Keep or Clear on Tagged Records</td>
<td>51</td>
</tr>
<tr>
<td>Setting Calendar Publishing Output to XML</td>
<td>51</td>
</tr>
<tr>
<td>Username.tbi</td>
<td>52</td>
</tr>
<tr>
<td>Configuring System Settings</td>
<td>52</td>
</tr>
<tr>
<td>Automatic Upgrade of Workstations</td>
<td>52</td>
</tr>
<tr>
<td>Contact Records and Notes Formatting</td>
<td>52</td>
</tr>
<tr>
<td>Duplicate E-mail on Records</td>
<td>52</td>
</tr>
<tr>
<td>File Type Previews</td>
<td>53</td>
</tr>
<tr>
<td>User Password Policy</td>
<td>53</td>
</tr>
<tr>
<td>Unattended Installation</td>
<td>53</td>
</tr>
<tr>
<td>Mobile Device Messaging</td>
<td>53</td>
</tr>
<tr>
<td>GoldMine Macros</td>
<td>54</td>
</tr>
<tr>
<td>Working with Macros</td>
<td>54</td>
</tr>
<tr>
<td>DDE Macros</td>
<td>55</td>
</tr>
<tr>
<td>GoldMine Report Macros</td>
<td>61</td>
</tr>
<tr>
<td>Contact Management Administration</td>
<td>65</td>
</tr>
<tr>
<td>Overview</td>
<td>65</td>
</tr>
<tr>
<td>About Record-Related Settings</td>
<td>65</td>
</tr>
<tr>
<td>Setting Phone Formatting in the Record-Related Settings</td>
<td>66</td>
</tr>
<tr>
<td>Setting Ownership in the Record-Related Settings</td>
<td>67</td>
</tr>
<tr>
<td>Setting Alerts in the Record-Related Settings</td>
<td>68</td>
</tr>
<tr>
<td>Changing the Delay Time on Alerts</td>
<td>69</td>
</tr>
<tr>
<td>Setting Digital IDs in Contact Details</td>
<td>69</td>
</tr>
<tr>
<td>Contact Communication Administration</td>
<td>71</td>
</tr>
<tr>
<td>Overview</td>
<td>71</td>
</tr>
<tr>
<td>Setting Default File Name and Folder Location for Templates</td>
<td>71</td>
</tr>
<tr>
<td>Setting E-mail Account Properties</td>
<td>72</td>
</tr>
<tr>
<td>Configuring Your Computer to Access Your ISP</td>
<td>73</td>
</tr>
<tr>
<td>Configuring Internet E-mail Retrieval</td>
<td>73</td>
</tr>
<tr>
<td>Creating E-mail Rules</td>
<td>75</td>
</tr>
<tr>
<td>Using the Document Management QuickStart Wizard</td>
<td>78</td>
</tr>
<tr>
<td>Customizing Auto-dialer Settings</td>
<td>79</td>
</tr>
<tr>
<td>Configure Calls with SoftPhone</td>
<td>79</td>
</tr>
<tr>
<td>Data Maintenance and Management</td>
<td>81</td>
</tr>
<tr>
<td>Overview</td>
<td>81</td>
</tr>
<tr>
<td>Choosing an Edition of SQL Server</td>
<td>81</td>
</tr>
<tr>
<td>About Contact Set Databases</td>
<td>81</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>-------------------------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Defining Contact Set Profiles</td>
<td>82</td>
</tr>
<tr>
<td>Opening Databases</td>
<td>82</td>
</tr>
<tr>
<td>About Creating Databases</td>
<td>83</td>
</tr>
<tr>
<td>Using the Databases Wizard</td>
<td>83</td>
</tr>
<tr>
<td>Rehosting a Firebird Database</td>
<td>87</td>
</tr>
<tr>
<td>About Maintaining Databases</td>
<td>87</td>
</tr>
<tr>
<td>Attaching Databases</td>
<td>88</td>
</tr>
<tr>
<td>About the Lookup.ini</td>
<td>88</td>
</tr>
<tr>
<td>Examples of Using Lookup.ini</td>
<td>88</td>
</tr>
<tr>
<td>Using the Lookup.ini to Launch External Applications or Macros</td>
<td>93</td>
</tr>
<tr>
<td>Moving Linked Documents and Attachments</td>
<td>94</td>
</tr>
<tr>
<td>Backing Up Databases</td>
<td>95</td>
</tr>
<tr>
<td>Restoring SQL Databases</td>
<td>96</td>
</tr>
<tr>
<td>SQL Query for Counting Contacts</td>
<td>96</td>
</tr>
<tr>
<td>Using the GoldMine Maintenance Wizard</td>
<td>96</td>
</tr>
<tr>
<td>Indexing Databases</td>
<td>97</td>
</tr>
<tr>
<td>Sorting and Verifying Databases</td>
<td>97</td>
</tr>
<tr>
<td>Setting Up Automatic Maintenance</td>
<td>98</td>
</tr>
<tr>
<td>Viewing System Logs</td>
<td>99</td>
</tr>
<tr>
<td>Purging Log Entries</td>
<td>99</td>
</tr>
<tr>
<td>About the Database Alias Manager</td>
<td>99</td>
</tr>
<tr>
<td>Using the Database Alias Manager for SQL Databases</td>
<td>100</td>
</tr>
<tr>
<td>Globally Replacing Field Data</td>
<td>101</td>
</tr>
<tr>
<td>Globally Replacing Fields with a Value</td>
<td>101</td>
</tr>
<tr>
<td>Globally Updating Fields Using Advanced Options</td>
<td>102</td>
</tr>
<tr>
<td>Globally Exchanging the Values of Two Fields</td>
<td>103</td>
</tr>
<tr>
<td>Importing and Exporting Data</td>
<td>104</td>
</tr>
<tr>
<td>Using the Import Contact Records Wizard</td>
<td>106</td>
</tr>
<tr>
<td>Using the Export Contact Records Wizard</td>
<td>108</td>
</tr>
<tr>
<td>About Importing and Exporting XML Files</td>
<td>108</td>
</tr>
<tr>
<td>Importing from Other Applications</td>
<td>112</td>
</tr>
<tr>
<td>Using the Outlook Conversion Wizard</td>
<td>112</td>
</tr>
<tr>
<td>Exporting to GoldMine From Microsoft Excel</td>
<td>114</td>
</tr>
<tr>
<td>Importing and Exporting iCalendar Files</td>
<td>114</td>
</tr>
<tr>
<td>Merging and Purging Records</td>
<td>115</td>
</tr>
<tr>
<td>Using the Merge/Purge Records Wizard</td>
<td>116</td>
</tr>
<tr>
<td>Selecting the Merge and Purge Methods</td>
<td>116</td>
</tr>
<tr>
<td>Using the Delete Wizard</td>
<td>118</td>
</tr>
<tr>
<td>Monitoring Processes</td>
<td>118</td>
</tr>
<tr>
<td>Understanding GoldMine Data Files</td>
<td>119</td>
</tr>
<tr>
<td>GoldMine Table Structure</td>
<td>119</td>
</tr>
<tr>
<td>GoldMine Tables</td>
<td>119</td>
</tr>
<tr>
<td>Contract Tables</td>
<td>124</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Overview</td>
<td>133</td>
</tr>
<tr>
<td>Sample Dashboard Tutorial</td>
<td>133</td>
</tr>
<tr>
<td>Creating a New Dashboard</td>
<td>134</td>
</tr>
<tr>
<td>Creating a New Data Source</td>
<td>135</td>
</tr>
<tr>
<td>Adding a Label</td>
<td>136</td>
</tr>
<tr>
<td>Adding a Chart</td>
<td>137</td>
</tr>
<tr>
<td>Adding a Drop-down List</td>
<td>139</td>
</tr>
<tr>
<td>External Database Dashboard</td>
<td>140</td>
</tr>
<tr>
<td>Creating a New Dashboard</td>
<td>140</td>
</tr>
<tr>
<td>Adding a Label</td>
<td>141</td>
</tr>
<tr>
<td>Creating a New Data Source for the Chart</td>
<td>141</td>
</tr>
<tr>
<td>Adding a Chart</td>
<td>142</td>
</tr>
<tr>
<td>Adding a Drop-Down List</td>
<td>143</td>
</tr>
<tr>
<td>Adding an Event to the Drop-Down List</td>
<td>144</td>
</tr>
<tr>
<td>Tabs and Splitters</td>
<td>145</td>
</tr>
<tr>
<td>Working with Tabs</td>
<td>145</td>
</tr>
<tr>
<td>Working with Splitters</td>
<td>146</td>
</tr>
<tr>
<td>Dashboard Part Properties Details</td>
<td>146</td>
</tr>
<tr>
<td>Setting the Dashboard Part Properties</td>
<td>147</td>
</tr>
<tr>
<td>Types of Charts</td>
<td>159</td>
</tr>
<tr>
<td>Data Source Management</td>
<td>163</td>
</tr>
<tr>
<td>Managing Data Sources</td>
<td>163</td>
</tr>
<tr>
<td>Dashboard Macros</td>
<td>166</td>
</tr>
<tr>
<td>Dashboard Tables</td>
<td>167</td>
</tr>
<tr>
<td>Adding a Column to an Existing Table</td>
<td>167</td>
</tr>
<tr>
<td>Removing a Column from an Existing Table</td>
<td>167</td>
</tr>
<tr>
<td>Changing the Column Label Displayed in the Dashboard</td>
<td>168</td>
</tr>
<tr>
<td>Creating Table Cell Hyperlinks</td>
<td>168</td>
</tr>
<tr>
<td>Dashboard Management</td>
<td>168</td>
</tr>
<tr>
<td>Removing a Part from a Dashboard</td>
<td>169</td>
</tr>
<tr>
<td>Repositioning and Relocating a Dashboard Part</td>
<td>169</td>
</tr>
<tr>
<td>Creating a Copy of a Dashboard</td>
<td>169</td>
</tr>
<tr>
<td>Deleting a Dashboard</td>
<td>170</td>
</tr>
<tr>
<td>Events and Actions</td>
<td>171</td>
</tr>
<tr>
<td>Viewing the Events and Actions Dialog Box</td>
<td>171</td>
</tr>
<tr>
<td>Import and Export Dashboards</td>
<td>174</td>
</tr>
<tr>
<td>Importing a Dashboard XML File</td>
<td>174</td>
</tr>
<tr>
<td>Exporting a Dashboard XML File</td>
<td>174</td>
</tr>
</tbody>
</table>
Editing Field Properties (Layout Tab) ................................................................. 205
Editing Field Properties (Security Tab) .............................................................. 205
Adding Expression Fields to Screens ................................................................. 207
Customizing Field Typing ..................................................................................... 208
Inserting Labels in Reports .................................................................................. 208
Hiding Field Labels and Values .......................................................................... 209
Combining Hiding and Color .............................................................................. 209
Adding Fields to Screens .................................................................................... 210
About the GM+View Tab ..................................................................................... 211
About the GM+Browser ....................................................................................... 212
Working with GM+View Templates ..................................................................... 214
Creating GM+View Templates .......................................................................... 215
Editing GM+View Templates ............................................................................. 216
Setting GM+View Default Templates ................................................................. 217
Creating GM+View Rules .................................................................................... 218
Creating GM+View Rules for Field Values ......................................................... 218
Creating GM+View Rules for dBASE Expressions ............................................ 218
Creating GM+View Rules for the User Selected Option ..................................... 219
Online Searching ................................................................................................. 219
Searching the Internet for Contact Record Information .................................. 219
Modifying the iSearch.ini File .......................................................................... 219
About the Record Types Administration Center ................................................ 220
Customizing the Opportunity and Project Managers Properties ....................... 220

Mobile Settings ........................................................................................................ 223
Overview ............................................................................................................... 223
Configuring Mobile Settings .............................................................................. 223
Troubleshooting GoldMine Mobile .................................................................... 224

Plug-Ins .................................................................................................................. 225
Overview ............................................................................................................... 225
ActiveX Controls .................................................................................................. 225
HTML Integrations .............................................................................................. 225
Plug-in Description File ....................................................................................... 226
  HTML .................................................................................................................. 226
  ActiveX .............................................................................................................. 228
Plug-in Security ..................................................................................................... 229
Adding a Local Plug-in Directory ........................................................................ 229
# Reporting

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>231</td>
</tr>
<tr>
<td>About the Reports Center</td>
<td>232</td>
</tr>
<tr>
<td>Report Center Toolbar</td>
<td>232</td>
</tr>
<tr>
<td>Adding .JPG Previews to the Reports Center</td>
<td>233</td>
</tr>
<tr>
<td>Report Types</td>
<td>233</td>
</tr>
<tr>
<td>Using the Reports Center</td>
<td>234</td>
</tr>
<tr>
<td>Setting Report Properties</td>
<td>234</td>
</tr>
<tr>
<td>Setting Report Properties, Profile Tab</td>
<td>235</td>
</tr>
<tr>
<td>Setting Report Properties, Sort Tab</td>
<td>235</td>
</tr>
<tr>
<td>Setting Report Properties, Options Tab</td>
<td>236</td>
</tr>
<tr>
<td>Creating Reports</td>
<td>237</td>
</tr>
<tr>
<td>Reports Layout Local Menu</td>
<td>238</td>
</tr>
<tr>
<td>Reports Layout Toolbars</td>
<td>238</td>
</tr>
<tr>
<td>Cloning Reports</td>
<td>240</td>
</tr>
<tr>
<td>Editing Report Layouts</td>
<td>241</td>
</tr>
<tr>
<td>Editing Report Parameters</td>
<td>242</td>
</tr>
<tr>
<td>Inserting Sections in Reports</td>
<td>242</td>
</tr>
<tr>
<td>Editing Report Sections</td>
<td>242</td>
</tr>
<tr>
<td>Editing Break Field in Reports</td>
<td>243</td>
</tr>
<tr>
<td>Inserting Report Fields</td>
<td>245</td>
</tr>
<tr>
<td>Creating Dialog Fields for Reports</td>
<td>245</td>
</tr>
<tr>
<td>Editing Report Fields</td>
<td>246</td>
</tr>
<tr>
<td>Examples of Formatting Sections</td>
<td>247</td>
</tr>
<tr>
<td>Modifying the Appearance of Report Fields</td>
<td>248</td>
</tr>
<tr>
<td>Fields in Reports</td>
<td>251</td>
</tr>
<tr>
<td>Working with Field Properties in Reports</td>
<td>253</td>
</tr>
<tr>
<td>About Report Filters</td>
<td>256</td>
</tr>
<tr>
<td>Editing Global Report Filters</td>
<td>256</td>
</tr>
<tr>
<td>Editing Section Filters in Reports</td>
<td>257</td>
</tr>
<tr>
<td>Editing Macros in Filters</td>
<td>257</td>
</tr>
<tr>
<td>Previewing GoldMine Reports</td>
<td>259</td>
</tr>
<tr>
<td>Printing Reports</td>
<td>260</td>
</tr>
<tr>
<td>Saving Reports with Data</td>
<td>261</td>
</tr>
<tr>
<td>Viewing Saved Reports</td>
<td>261</td>
</tr>
<tr>
<td>Sorting Report Data</td>
<td>261</td>
</tr>
<tr>
<td>Reporting Services Integration</td>
<td>262</td>
</tr>
<tr>
<td>Configuring for E-Mail Delivery</td>
<td>266</td>
</tr>
<tr>
<td>Configuring the INI File</td>
<td>267</td>
</tr>
</tbody>
</table>
# Automated Processes

- Overview ................................................................. 269
- Automated Processes Components .......................... 269
  - Designing Automated Processes .............................. 269
- Automated Processes Center Components .............. 271
- Process Options Update ........................................... 272
- Creating Automated Processes ................................ 272
- Working with Automated Processes ......................... 275
- Creating Processes .................................................. 275
  - Editing Processes ................................................. 276
- Creating Events ....................................................... 277
  - Using the Automated Processes Center .................. 277
  - Event Properties Dialog Box .................................. 277
  - Editing Events ..................................................... 278
- Creating Triggers ..................................................... 278
  - Creating or Editing Filters and dBASE Expressions ... 280
- Creating Actions ....................................................... 281
- Attaching Processes to a Contact ........................... 285
- Executing Processes ............................................... 286
- Removing Attached Automated Processes ................. 286
- Trigger Dialog Boxes ............................................... 287

# Synchronization

- Overview ................................................................. 289
- About Transfer Sets .................................................. 291
  - About Synchronizing with Microsoft Outlook .......... 292
  - Configuring Synchronization with Microsoft Outlook 292
  - Using Copy/Move Records ....................................... 295
  - Using the Sync Spy ................................................. 296
- About the Synchronization Wizard .......................... 297
  - Using the Synchronization Wizard ......................... 297
  - Configuring the Synchronization Connection Method 298
- About GoldSync .......................................................... 300
  - GoldSync Key Terms and Concepts ......................... 301
  - GoldSync Implementation Considerations ................ 302
  - Planning a GoldSync System .................................. 302
  - GoldSync Sites Local Menu .................................... 305
  - Configuring Synchronization Settings .................... 306
  - Using the GoldSync Administration Center ............. 308
  - Creating Sites ..................................................... 309
  - Configuring the GoldSync Site Group Override Options 309
  - Creating Site Groups ............................................. 311
# Table of Contents

- Configuring the General Options (Site Groups) .................................................. 311
- Configuring the Retrieve Options ........................................................................ 312
- Creating Servers ................................................................................................... 313
- Cloning Site Settings ............................................................................................. 314
- Creating Server Processes ..................................................................................... 315
- Configuring the Number of Connections .............................................................. 315
- Configuring Incoming E-mail Settings ................................................................. 315
- Configuring Outgoing E-mail Settings .................................................................. 315
- Configuring the Active Periods for Synchronization ............................................ 316
- Synchronization Verification Codes ..................................................................... 316
- Running GoldSync as a Service ........................................................................... 316
- Configuring GoldSync as a Service ..................................................................... 317
- Adding the Users Table as an Option for Sync ...................................................... 318
- Adding Macros to the GoldSync.ini File ............................................................... 318
- About One-Button Synchronization ...................................................................... 319
- Synchronizing Using One-Button Synchronization .............................................. 319
- Creating One-Button Synchronization Profiles ................................................... 320
- Retrieving One-Button Synchronization Profiles ................................................ 321
- E-mailing One-Button Synchronization Profile to Remote ................................... 322
- Creating Installation Files for One-button Synchronization ................................. 323
- Retrieving One-Button Synchronization Installation Files ................................... 323
- Configuring Send Options ..................................................................................... 324

## Server Agents

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>327</td>
</tr>
</tbody>
</table>

- Overview .................................................................................................................. 327
- Starting the Server Agents ....................................................................................... 327
- Configuring the Sending and Retrieving of E-mail .................................................. 328
- Configuring GoldSync ............................................................................................... 329
- Configuring Outlook Sync ......................................................................................... 329
- Configuring Printing and Faxing .............................................................................. 330

## F2 Lookup Lists

<table>
<thead>
<tr>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>331</td>
</tr>
</tbody>
</table>

- Overview .................................................................................................................. 331
- Using the F2 Lookup ................................................................................................. 332
- Managing F2 Lookup Lists ....................................................................................... 332
  - Creating F2 Lookup Entries .................................................................................. 333
  - Setting Dependency Between Lookup Lists ....................................................... 334
  - Configuring F2 Lookup List Security ................................................................... 336
  - Editing F2 Lookup Entries .................................................................................. 337
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Synchronizing Outlook and GoldMine Manually</td>
<td>364</td>
</tr>
<tr>
<td>Matching Outlook Contacts Automatically to GoldMine Contacts.</td>
<td>364</td>
</tr>
<tr>
<td>Auto-Linking Outlook Messages</td>
<td>364</td>
</tr>
<tr>
<td>Defining Outlook Folders for Auto-Linking</td>
<td>365</td>
</tr>
<tr>
<td>Displaying the Linked Contact Details in Outlook</td>
<td>366</td>
</tr>
<tr>
<td>Setting the Contact/E-Mail Pane Display Options</td>
<td>367</td>
</tr>
<tr>
<td>Outlook Calendar</td>
<td>367</td>
</tr>
<tr>
<td>Outlook Tasks</td>
<td>368</td>
</tr>
<tr>
<td>Google Apps Integration Administration</td>
<td>369</td>
</tr>
<tr>
<td>Overview</td>
<td>369</td>
</tr>
<tr>
<td>Prerequisites for Google Apps</td>
<td>369</td>
</tr>
<tr>
<td>Google Apps Integration Set Up</td>
<td>370</td>
</tr>
<tr>
<td>Synching the Calendar between Google and GoldMine</td>
<td>371</td>
</tr>
<tr>
<td>Troubleshooting Google Apps Calendar Sync</td>
<td>372</td>
</tr>
<tr>
<td>Licensing</td>
<td>375</td>
</tr>
<tr>
<td>Overview</td>
<td>375</td>
</tr>
<tr>
<td>About GoldMine Licenses</td>
<td>375</td>
</tr>
<tr>
<td>License Types</td>
<td>375</td>
</tr>
<tr>
<td>License Serial Number</td>
<td>376</td>
</tr>
<tr>
<td>Master License</td>
<td>377</td>
</tr>
<tr>
<td>Using Net-Update</td>
<td>377</td>
</tr>
<tr>
<td>Using the License Manager</td>
<td>377</td>
</tr>
<tr>
<td>About Sub-licenses</td>
<td>378</td>
</tr>
<tr>
<td>Site License</td>
<td>378</td>
</tr>
<tr>
<td>Creating Site Licenses</td>
<td>379</td>
</tr>
<tr>
<td>Creating Undocked User License</td>
<td>380</td>
</tr>
<tr>
<td>Creating GoldSync Licenses</td>
<td>381</td>
</tr>
<tr>
<td>Undocked Users</td>
<td>381</td>
</tr>
<tr>
<td>Removing Licenses</td>
<td>382</td>
</tr>
<tr>
<td>Updating Registration Information</td>
<td>382</td>
</tr>
<tr>
<td>Integration</td>
<td>383</td>
</tr>
<tr>
<td>Overview</td>
<td>383</td>
</tr>
<tr>
<td>Integrating with HEAT</td>
<td>383</td>
</tr>
<tr>
<td>How Configuration with GoldMine Works</td>
<td>384</td>
</tr>
<tr>
<td>Configuration Process</td>
<td>386</td>
</tr>
<tr>
<td>About the Tickets Tab</td>
<td>390</td>
</tr>
<tr>
<td>Launching HEAT from GoldMine</td>
<td>390</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Sending E-mail to HEAT/HEAT PowerDesk Agent</td>
<td>391</td>
</tr>
<tr>
<td>HEAT/HEAT PowerDesk Options</td>
<td>391</td>
</tr>
<tr>
<td>Integrating with IPCM</td>
<td>391</td>
</tr>
<tr>
<td>IPCM/GoldMine Configuration</td>
<td>392</td>
</tr>
<tr>
<td>Integrating with .NET</td>
<td>398</td>
</tr>
</tbody>
</table>

### Resources

- Additional Documentation: 399
- Contact Us: 399

### Glossary

- 401

### Index

- 407
Getting Started

Overview

Now that you have installed GoldMine Premium Edition, this chapter will help you understand the GoldMine Architecture. For more information and procedures, see the GoldMine User Guide PDF or in the topic in the Online Help.

The GoldMine File System

GoldMine stores information in one or more databases in which related records are logically organized. Storing information in a database provides advantages such as a common point of access for multiple users, applications, and data security.

Network applications managing information typically organize shared data in a relational database structure, supervised by a Database Management System (DBMS). The DBMS supervises maintenance of and access to the database. It has a database engine that defines the database structure, stores data, and responds to requests by retrieving data from the stored locations. The DBMS can organize data in one large database that stores all system data or in multiple unique databases in the same system.

Information systems today facilitate quick and reliable data management and retrieval using the relational database. At the most basic level, a relational database consists of tables organizing data in columns and rows. The cell at any column/row can contain only one value. Columns and rows work together to define the type of information a cell contains.

GoldMine, acting as a DBMS, uses a number of different files to store various elements of the data it collects. In a GoldMine Premium Edition installation, the shared database files and Contact files are hosted on the server database while licensing and user files remain local to the GoldMine folder.

In a network environment, you can run workstations from the executable on the server. You can also install GoldMine’s executable files locally to a workstation if the data files are centrally located and accessible to all GoldMine users. The physical configuration of GoldMine on the hard drive is important. The main GoldMine executables should always be one level deep in a directory structure. The path to GoldMine should be x:\GoldMine, where “x” is the network drive where GoldMine is installed. Installing by using Universal Naming Convention (UNC) paths, the server path should be \server\GoldMine\GoldMine or \server\sharename\GoldMine.
File Server and Client/Server Architecture

Networks require configuration that manages shared data stored in a central location. Users need a way of accessing information from the central file(s), and the organization needs a way of protecting data integrity and controlling traffic to maintain the availability of shared resources. These needs are met using file server and client/server architecture.

**Client/Server Architecture**

GoldMine Premium Edition utilizes a client/server architecture:

- The client/server uses network resources more efficiently to reduce network traffic and respond to requests for data while maintaining data security.
- The client/server architecture effectively divides the functions of the DBMS between the client and the server.
- The server acts as the database engine maintaining and administering access to the data.
- When the server receives a request from a client, the server scans the database for data on the server and returns only the requested piece rather than a whole block.
- Processing occurs at the server, so the server sends back the data in final form as the response to the query.
- Structured Query Language (SQL) is the tool enabling the application user interface to communicate with the server database engine.

**NOTE:** To encrypt database traffic between GoldMine and SQL Server, turn on Force Protocol Encryption option in the properties of the Native Client Configuration for SQL server. Note that file attachments are transferred using Microsoft networking file system and might not be encrypted.
Managing User Security and Access

GoldMine's security is based on user groups and users, which must be set up to make the security effective.

Each GoldMine user should have a unique user name and password. This is the first level of security. The GoldMine administrator assigns each user the minimum level of necessary access without restricting the functionality related to the user’s job performance.

Define user groups according to the function users perform. User and user group security access applies to:

- **GoldMine Functions.** The administrator can permit or deny access to GoldMine functions. For example, permit or deny a user or user group the ability to create new Contact Records, delete records, or access other users’ Calendars.

- **Menu Commands, Toolbar, and Taskbar Settings.** Remove menu items from the user’s menu customizing the selection of available menu options and customize toolbars and the Taskbar.

- **Contact Databases.** Assign user groups access to databases. If a database is assigned to a user or user group, only members of the group can open the database in GoldMine. Each database can have different access restrictions.

- **Screens and Fields.** Restrict access rights to user-defined screens attached to particular contact databases. If a screen is public, all GoldMine users can view the information. If access is set to a user group, only members of the group can see the screen.

- **Record Ownership.** Each Contact Record is assigned an owner. The default owner is public; however, assign a record or group of records to a user or user group. If a record is owned by a group, each group member is treated as the owner of the record. Ownership determines whether a user who is not an owner can read all or part of the Contact Record or whether a user can edit the record.

The GoldMine administrator can also restrict access to such items as the Relationship Trees, InfoCenter entries, and the ability to launch HEAT from GoldMine Premium Edition.

Users with Master Rights can access all parts of the system and bypass all the security settings except for the user’s:

- **Personal Contacts**
- **PersonalBase files in the InfoCenter**
- **Encrypted e-mail**

Master Rights users are the only users permitted to access and modify user settings. GoldMine administrators should have Master Rights.

Record Ownership

Contact records can be owned by everyone (public), by a user, or by user groups. Ownership determines security on contact records. Consider the following when setting record ownership:

- Records owned by (public) can be viewed and edited by all users. Viewing and editing security can be set on individual fields.

- Record Ownership is used when record curtaining (see "Record Curtaining" on page 18) is applied. Ownership is stored in the Owner field in the Contact1 table.
OWNERSHIP CAN BE SET WHEN YOU

- Create a Contact Record (see "To Set the User Profile" on page 19)
- Configure Record Ownership (see "Setting Ownership in the Record-Related Settings" on page 67)

Record Curtaining

Record curtaining (see "Setting Ownership in the Record-Related Settings" on page 67) lets you hide information in a contact record from those individuals who do not own the record. With record curtaining active, if you try displaying a contact record you do not own, the lower portion or all of the contact record is “curtained,” hiding the data from view.

NOTE: Curtaining status is stored in the Contact1 table. The level of curtaining is stored in the second position in the Status field. A blank or zero indicates no curtaining, a 1 indicates partial curtaining, a 2 indicates complete curtaining, and a 3 indicates semi-partial curtaining.

Record curtaining is controlled by the record Owner. Each contact record can be either “public” or “private.” When a new record is added to the database, ownership defaults to (public). Public records can be viewed by all GoldMine users. Private records are records with an assigned an owner, either an individual GoldMine user, or a user group. If you select complete record curtaining, private records can be viewed only by their owners, or by members of the owner user group. If you select partial curtaining, other users can see only the company, contact, and phone number for the private records.

NOTE: When an non-owning user performs global operations, such as mass deletions or field updates, GoldMine ignores completely curtained records. In addition, scheduled activities linked to a curtailed record appear as unlinked to unauthorized users.

Curtaining Levels

- **None**: All users can view the entire Contact Record.
- **Semi-partial (hide tabs)**: Users who are not record owners can view the upper four panes, but cannot view the Tabs.
- **Partial**: Users who are not record owners can view only the contact name, and phone number areas.
- **Complete**: Users who are not owners cannot access any of the contact information.

NOTE: Curtaining status is stored in the Contact1 table. The level of curtaining is stored in the second position in the Status field. A blank or zero indicates no curtaining, a 1 indicates partial curtaining, a 2 indicates complete curtaining, and a 3 indicates semi-partial curtaining.

To set the record curtaining, select **Edit > Record Properties > Record-related Settings**, Then click the **Ownership** tab.

TIP: The Global Replace Wizard can be used to perform a mass update to change ownership of records. For more information, see "Globally Replacing Field Data" on page 101.

Users Properties

Control a user’s security access in GoldMine through the **User Properties**, which define a user’s security and access in GoldMine (**Tools > Users’ Settings**).

NOTE: For new users, click the **New** button. For existing users, select the user and then click the **Properties** button.

- The **Profile** tab defines security, automatic record ownership, and forced log-out for a user (see "To Set the User Profile" on page 19).
- The **Membership** tab assigns or removes a user from a group (see "To Set Up User Membership" on page 19).
- The **Access** tab sets general security to control user access to GoldMine features (see "To Set User Access" on page 20).
- The **Menu** tab configures menu options available to the user (see "To Set User Menus" on page 22).
- The **Time Clock** tab displays a log showing the user’s activity in GoldMine (see "To View the User Time Clock" on page 23).
- The **Outlook** tab contains options for synchronization between Outlook and GoldMine (see "To Set the Outlook Sync Options" on page 23).
Best Practices for a GoldMine Administrator

Create one or several ideal users to reflect basic settings applicable to many users. For example, you might have two prototype users: Sales Staff and Supervisor. Each of these user types has different rights and menus in GoldMine. Allow the Sales Staff to add and edit new contacts but not to delete contacts or view other’s calendars. The Supervisor can add and delete contacts and view anyone’s calendar. After the ideal user or users are created, clone the user’s settings (see "Clone User Settings" on page 24) for each actual user with the same rights.

To Set the User Profile

Use the Profile tab to create and set basic user information such as a user name, initial security, and force log out (forcing users out at a particular time or when inactive for a period of time).

Use the following procedure to set up a user profile.

1. Select Tools > Users' Settings.
2. At the Users' Master File dialog box, click New to create a new user, or select an existing user and click Properties.
3. At the user’s Properties dialog box, click the Profile tab.
4. Type the Username (up to 8 characters; must begin with a letter).
5. Type the user's Full Name.
6. Type the user’s E-mail address.
7. In the Security area configure these settings:
   - **Password.** Type the password assigned to the user. You must provide the user name and password you created so the user can log into GoldMine.
   - **Valid for days.** In the drop-down list, select the number of days the user’s password is valid, or accept the default (Always).
   - **Next change.** If you change the Valid for days field, select the date the password becomes invalid and the user cannot launch GoldMine.
   - **Master Rights.** Select this option to give the user unrestricted access to all of GoldMine.
   - **Ownership** button displays the New Record Ownership dialog box. Ownership lets you specify whether the new Contact Records the user adds to the database are public records or owned by a specific user or user group (see "Record Ownership" on page 17).
   - **Forced Logout** button opens the Forced Logout dialog box with the following options:

     **NOTE:** The Forced Logout option is disabled (set to 0) by default. The Forced Logout works only when both the When idle for value is more than 0 and the Forced logout only after this time is not blank.

     - **Log out user and terminate GoldMine when idle for a period of time.** Click this box to automatically log the user out of GoldMine and activate the following settings:
     - **When idle for.** Select the period of inactivity before users are automatically logged out of GoldMine.
     - **Forced logout only after this time.** Select the time for a forced logout.

     These fields are useful for making your system available for nightly maintenance, without forcing users to log out during the business day.

     **TIP:** The Force log out options are important in managing a limited number of licenses.; many maintenance functions can be performed only if all users are logged out of GoldMine.

8. Select one of the E-mail Options:
   - **Always use e-mail server (recommended)** sends the e-mail message using the address entered above.
   - **Use GoldMine messaging when available** uses the user-to-user messaging for e-mails send within GoldMine.
9. Click OK to save the user’s Profile settings without configuring the detailed user security settings, or click the Membership tab to continue configuring the user’s properties

To Set Up User Membership

Users can belong to several groups, allowing them access to the group’s contacts for collaboration. Groups must be created before assigning a user to a user group. If user groups were not created, click User Groups Setup to add the user to a group
or to create a group(s). See "Setting Up User Groups" on page 20.

Use the following procedure to set up a user membership

1. Select **Tools > Users' Settings**.
2. Select the user and then click **Properties**.
3. Click the **Membership** tab.
   
   The **Member of Groups** list indicates which groups the user already belongs to. The Excluded from list indicates which groups the user is not a member of. To change the user's membership, double-click the user name to move the user from one column to the other.
4. To create user groups or refine the membership, click **User Groups Setup**.
5. At the User Groups Setup dialog box, highlight the group to which to add the user.
6. Click **Member Setup** to launch the **Group Membership Setup dialog box**.
7. Double-click the user's name in the **Users' List** box to add the user to the **Group Members** list.
8. To add the user to other groups, return to the User Groups Setup dialog box and highlight the new group.
   
   Click **Member Setup** to launch the Group Membership Setup dialog box and double-click the user's name in the Users' List box.
   
   **NOTE**: You can create User Groups while adding the user to a group. On the User Groups Setup dialog box, click **New** and follow the steps.
9. Click **OK** and then click **Close**.
   
   The Member of Groups list displays the groups of which the user is a member.
10. Click **OK** to return to the Users' Master File, or click the **Access** tab to continue configuring user properties.

**Setting Up User Groups**

It is recommended that you logically group users according to functions they perform. User group names store in the Lookup table; user group members are encrypted in the **User.dbt** table.

Use the following procedure to set up user groups.

1. Select **Tools > User Groups**.
2. At the User Groups Setup dialog box, click **New**.
3. Type the **User Group's name** in the field and click **OK**.
   
   The user group displays in the **User Groups** box.
4. To add users, click **Members Setup**.
   
   The Group Membership Setup dialog box opens.
5. To add individual users or all members of an existing group to the **Group Members** box, double-click the user in the **User List**, or the group in the **Group List**, to add users to the **Group Members** list.
6. Click **OK**.
7. After creating groups and adding members, click **Close**.

**To Set User Access**

Use the **Access** tab to configure a user’s access rights on Contact Records, access to information of other users, and miscellaneous access rights. If an item is selected, the user can perform the action in GoldMine.

1. Select **Tools > Users' Settings**.
2. Select the user's name and click **Properties**.
3. Click the **Access** tab.
4. In the **Contact Record** area, select:
   
   - **Add New**. Add a contact record.
   - **Edit Fields**. Edit fields in the top half of the contact record, the user-defined fields in the **Fields** tab, and the **Notes** tab.
NOTE: Without Edit Fields rights, users cannot edit fields on any contact records, including the records they own.

- **Delete.** Delete contact records.
- **Required field override.** Authorize an override on a required field.
- **Assign Owner.** Assign Contact Record ownership to other users.
- **Edit Tab Folders.** Edit data in the tabs.

NOTE: Without Edit Tab folders rights, users cannot edit tab folders on any contact records, including the records they own.

- **Schedule Process.** Assigns an automated process to a contact.

5. In the **General Access** area, select:

- **Build Groups.** Build their own groups of Contact records in the Filters and Groups dialog box.
- **‘Output to’ menu.** Enable the Output to option in the local menus in GoldMine to allow output to printer, Word, Excel, and clipboard.

NOTE: Non-Master users cannot select Printer in the Output to menu because of Reports security considerations.

- **Net-Update connections.** Run a version update on the live system using the Internet.

⚠️ IMPORTANT: This option should be carefully controlled by the GoldMine administrator.

- **Delete unlinked e-mail.**
- **Issue SQL Queries.** Write and send SQL queries to retrieve data for display.
- **Real-Time folder.** View the Real-Time tab in the Activity List. Displays all users’ completed activities. The Real-time folder displays history items that were updated within the selected date range. It is not based on the completion date for the activity.

NOTE: When applied to many users, this option can affect network performance.

- **Customize Toolbar.** Add and remove toolbar icons.
- **SQL Logon name and SQL Password.**
  
  If using GoldMine with a SQL database and you assigned the user an individual or group logon name and password in SQL, type the information in the text boxes. This launches GoldMine without requiring the user’s SQL logon name and password each time.

6. In the **Notes Access** area, select:

- **Insert Notes.** Allow endusers to add notes.
- **Edit/Delete.** Allow endusers to edit or delete their own notes.
- **Edit/Delete others’ notes.** Allow endusers to edit or delete notes from other users.
7. In the **Access to Others** area, select the options and modify as needed.

   **NOTE:** Access to other user’s Calendars, History, and Forecasts are hidden from a user when access to others has been removed.

   - **Calendar.** Select this option to do the following:
     - Designate the available options from the **User** drop-down on the Calendar or Activity List window.
     - Designate if the **Edit** function is available from the popup menu for activities owned by another user. If this option is not selected, the user cannot edit the activities on the **Pending** tab. Therefore the Edit and Delete options are not available to the user in the pop up menu.

   - **History.** Select this option to do the following:
     - View other users’ completed activities in the Closed or Filed tab of the **Activity List**.
     - Edit or delete history records in the **History** tab on the contact record or the **Real-Time** tab in the **Activity List**.
     - Build contact groups based on another users’ completed activities, or view other users’ completed sales activities in the Completed Activities Analysis dialog box.

   - **Forecast.** Select this option to designate the users available when you click the **Select User(s)** button on the Forecasted Sales Analysis window. *(Go To > Analysis > Forecast Analysis).* Checking (or unchecking) this option will change what is viewed on the **Pending** tab.

   - **Reports.** Access other users’ reports.

   - **Template.** Access other users’ templates in the Document Management Center.

   - **Filters.** Access other users’ Contact record filters.

   - **Groups.** Access other users' groups of contacts.

   - **Links.** Access and launch other users’ linked documents.

   - **Opp/projects.** View opportunities and projects assigned to other users.

   - **Cases.** View cases (on the Cases tab and in the Service Center) assigned to other users.

8. Click **OK** to return to the Users' Master File, or click the **Menu** tab to continue configuring the user’s properties.

**To Set User Menus**

Use the **Menu** tab to configure menu options available to users. This is another way of setting security and controlling user access to features. Also create templates of menu options to apply to users as you create their properties.

Use the following procedure to set up a user menu.

1. Select **Tools > Users’ Settings**.
2. Highlight the user and click **Properties**.
3. Click the **Menu** tab in the User Properties dialog box.
4. To use a menu, select one option:
   - Apply a menu template you created by selecting the template name in the drop-down list.
   - Click **Expand** to display all menu options.

   To expand the menu display, click the icon next to each option to change the status. When the icon is red, the option is unavailable to the user. When the icon is green, the option is available.

   **NOTE:** If the Resize menu option located under **Edit > Record Details > Resize** is restricted, the custom screens in the **Fields** tab display as GoldMine menu options.

5. **OK** to save the **Menu** configuration and return to the Users’ Master File, or click the **Time Clock** tab to continue configuring the user’s properties.

**Restricting User Options Access**

The GoldMine Administrator can restrict a user’s access to the User Options dialog box.

1. Open the **Tools** menu and select **Users’ Settings**.
2. Select a user from the list.
3. Click Properties and then select Menu.
4. Choose available main menu items for the selected user and then click Save.

Menu layouts can be saved for instant recall for any user.

Creating User Menu Templates

Save User Property Menu configurations as a template and apply the template to other users.

Use the following procedure to set up a user menu template.

1. Select Tools > Users' Settings.
   Highlight the user and click Properties.
2. Click the Menu tab in the User Properties dialog box.
3. Click Expand to display menu options.
4. Click the icon beside the option to change the status.
   When the icon is red, the menu option is unavailable to the user. When the icon is green, it is available.
5. Click Save to save the setup as a menu template.
6. At the Save Menu Template dialog box, type the name of the template.
7. Click OK to save the template.

   NOTE: To delete a Menu template, select it in the drop-down list and click Delete.

To View the User Time Clock

The Time Clock tab is a management tool rather than a configuration option. View the user’s activities in GoldMine.

- Date. Date of the logged activity by the selected user.
- Login. Time the user logged into GoldMine.
- Logout. Time the user logged out of GoldMine.
- Logged. Total time the user was logged into GoldMine, including any time logged away.
- In. Total number of times the user logged into GoldMine.
- Keys. Number of keystrokes pressed by the user while working in GoldMine.
- Clicks. Number of mouse clicks performed by the user while working in GoldMine.
- CRC. Indicates whether the data in the user log was modified outside of GoldMine. This column displays OK for every log entry that is free of tampering; that is, external.

To Set the Outlook Sync Options

The Outlook tab allows you to set synchronization abilities for the user.

1. Select Tools > Users' Settings.
   Highlight the user and click Properties.
2. Click the Outlook tab in the User Properties dialog box.
3. Select from the following options:
   - Enable on-demand sync with Outlook
     This option determines if user has an access to a menu item Synchronize with Outlook menu option (Tools > Synchronize > Synchronize with Outlook). Disabling this menu item does not necessarily mean that sync does not occur for this user. A user with Master rights can configure the Outlook profile for automatic synchronization.

     NOTE: This option is automatically selected and enabled for Master users.
   - Enable sync with Outlook when system time zone is different from user’s home time zone
     This option determines if sync can occur if Windows time zone changed since the last time sync took place.
4. Click OK to return to the Users' Master File, or click another tab to continue configuring the user’s properties.
Clone User Settings

After creating an ideal user with settings applying to many users, clone the user’s Properties. All security settings in the User Properties apply to the new user except the Username, Full Name, and Password on the Profile tab.

Use the following procedure to clone a user setting.

1. Open the Tools menu and select Users’ Settings.
2. Right-click the user whose settings you want to clone and select Clone from the menu.
3. At the New User Properties dialog box, enter the Username, Full Name, and Password; select the other Profile settings.
   The Membership, Access, and Menu settings apply to the new user.
4. Change the individual user properties as needed.
5. Click OK.

User Passwords

GoldMine users are not required to have passwords to login to GoldMine. There is an option in the GoldMine System Settings that allows any Master user (typical the GoldMine Administrator) to enforce passwords for all users. Enforcing passwords helps restrict the unauthorized use and increases the security of the system. This option, and others regarding passwords, is located on the Password Policy tab in the System Settings.

To Enforce User Passwords

1. Open the Tools menu and select Configure > System Settings.
2. Click the Password Policy tab.
3. Enter the Minimum password length number or use the up/down arrows. “0” means that passwords are not enforced.
4. If you want to limit the number of incorrect attempts made when trying to login, check the Block the account after 3 invalid logon attempts option.

   IMPORTANT: If a user fails to login in after 3 attempts, their account becomes disabled. Only a user with Master rights (see "To Set the User Profile" on page 19) can enable a disabled user account.

5. If you want to limit the repetition of passwords, select a value in the New password cannot repeat any of the previous <#> passwords.
6. Click OK to apply your changes.

For more information about re-enabling accounts, see "To Enable a User Account" on page 24 and "To Enable a Master User Account" on page 25.

To Enable a User Account

If a user fails to login after 3 attempts, the account becomes disabled (locked) and can only be reinstated by a user with Master rights (see "To Set the User Profile" on page 19). To enable a user’s account that has been locked, follow the steps below.

1. Open the Tools menu and select Users’ Settings.
2. Select the user that needs to be enabled from the list and then click the Properties button.
3. On the Profile tab, click the Unblock Account button and then click OK.
To Enable a Master User Account

The option to enforce a password effects all users, including Master users. If the Block the account after 3 invalid logon attempts option is checked on the Password Policy tab (see "User Passwords" on page 24) and a Master user fails to login after 3 attempts, any other Master user can reinstate the account (see "To Enable a User Account" on page 24).

However, if there are no other Master users to reinstate the account, you can follow the steps below to reinstate the account.

1. Browse to the GoldMine installation folder (typically \Program Files\GoldMine or \ProgramData\GoldMine)
2. Locate the licenseGM.bin file and rename it to licenseGM.temp.
3. Launch GoldMine.
4. Enter your license information for validation purposes and then click Next.
5. Enter a Username and optional Password, then click Finish to display the GoldMine login dialog box.
6. Enter your login information and then click OK.
7. Browse to the GoldMine installation folder and delete the newly generated licenseGM.bin file.
8. Rename the licenseGM.temp file to licenseGM.bin.

Managing User Options

Define GoldMine settings unique to you. GoldMine saves user options (settings that control how GoldMine looks and acts for each user) settings in your user’s initialization file (username.ini).

**NOTE:** While the User Options tabs have settings that allow users to customize their work environment, many GoldMine administrators configure these settings for users and then restrict their ability to change the Options. For more information, see "Restricting User Options Access" on page 22.

Set User Options on the following tabs:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Personal</td>
<td>Change your password and add personal information. See &quot;Setting Options on the Personal Tab&quot; on page 26.</td>
</tr>
<tr>
<td>Record</td>
<td>Control the appearance of Contact records, tab displays, and zip code validation. See &quot;Setting Options for the Record Tab&quot; on page 26.</td>
</tr>
<tr>
<td>Calendar</td>
<td>Determine calendar appearance and functions. See &quot;Setting Options for the Calendar Tab&quot; on page 29.</td>
</tr>
<tr>
<td>Schedule</td>
<td>Set parameters for scheduling and working with activities. See &quot;Setting Options for the Schedule Tab&quot; on page 32.</td>
</tr>
<tr>
<td>Alarms</td>
<td>Configure GoldMine alarms. See &quot;Setting Options for the Alarms Tab&quot; on page 33.</td>
</tr>
<tr>
<td>Lookup</td>
<td>Set display options for Contact records and the Contact Search Center. See &quot;Setting Options for the Lookup Tab&quot; on page 33.</td>
</tr>
<tr>
<td>E-mail</td>
<td>Configure settings for your e-mail server, login information, and rules to apply when sending and receiving e-mail. See &quot;Setting Options for the E-mail Tab&quot; on page 34.</td>
</tr>
<tr>
<td>Telephony</td>
<td>Control settings for your computer’s modem and dialing options and SoftPhone advanced settings in GoldMine. See &quot;Setting Options for the Telephony Tab&quot; on page 40.</td>
</tr>
</tbody>
</table>
Setting Options on the Personal Tab

Use the following procedure to set up user personal information.

1. Select Tools > Options.
2. At the User’s Options dialog box, select Personal.
   The Personal tab displays User Name and Full Name.
   
   NOTE: A Master Rights user can change the Full Name in the User Profile.
3. Click Change Password to change your GoldMine Password.
4. In the Title field, type your professional title.
   
   NOTE: For Title and following Department, Phone, and FAX text boxes, selecting the Select contents of field option chooses the entire contents of a field. If this option if selected and your screen saver is set to On, you might inadvertently delete the contents of the field when you clear the screen saver. If you press ESC before leaving the field, the data is replaced.
5. In the Department field, type the name of the organization or group you are affiliated with.
6. In the Phone field, type your primary telephone number.
7. In the FAX field type your fax number.
8. Click OK to save the settings and close the dialog box.

To Change Your Password

To change your GoldMine Login password, you must be the user logged into GoldMine.

1. Select Tools > Options.
2. At the User’s Options dialog box, select the Personal tab.
3. Click Change Password.
4. At the Change Password dialog box, type your current password in the Enter your current password field.
5. Type your new password in the Please enter a new password field, and then type it again in the next text box.
6. Click OK to save the new password and return to the Personal tab.

Setting Options for the Record Tab

Use the Record tab to customize the display of the contact record and set the ZIP code validation and title appearing on the contact window.

1. Select Tools > Options.
2. At the User’s Options dialog box, select Record.
3. In the Appearance area select:
   - Dark background. Browse windows appear with a gray background.
   - Bright background. Browse windows appear with a white background.
   - Use Large Font. Displays dialog box text in a large font.
This setting is designed for use with monitor display resolution of 1024x768 or higher using Windows’ small font option. It is not available if your display is set to a resolution of 640x480 or if using Windows’ large font option.

The Use Large Font option does not apply to the GM+View tab. To increase the display font size in IE 6.0, select View > Text Size and select the appropriate size.

- **Label Color.** Displays the Color dialog box to select a color for all field labels displayed in Contact Records.
- **Data Color.** Displays the Color dialog box to select a color for all field data displayed in Contact Records.
- **Tabs.** Displays the Display Tabs dialog box to select the tabs to appear in the contact record and the tab order.
- **Select contents of fields.** Selects or highlights data entered in a field when you click inside it.
- **Use a word format for user-defined dates.** Displays dates in text form based on the format selected in the drop-down list.

**NOTE:** Typically, this setting affects fields in the Fields tab of the Contact Record, but the selected format affects user-defined fields placed anywhere in the Contact Record. The user-defined date format you select from this tab overrides the Show dates format of the local settings option if selected in the Misc tab.

- **Show numerics aligned to the right.** Right-aligns numbers.
- **Show sort-by field on status bar.** Displays the sort field on the left side of the status bar.
- **Open org tree when maximized.** Displays the organization tree automatically when you maximize a contact record.

4. In the Zip Code Validation area, select:

- **No Validation.** GoldMine does not perform ZIP Code validation. When adding a new Contact Record or editing an existing record, the City field is edited first, followed by the State and Zip fields.
- **Default to primary city.** GoldMine automatically validates ZIP Code entries on the contact record. When adding a new record or editing an existing record, the Zip field is edited first. If the entered ZIP code is found in the ZIP Code file, the city and state from the first matching ZIP Code record is placed automatically in the City and State fields on the Contact Record.
- **Show window of cities.** When more than one city exists for a particular ZIP Code, GoldMine displays a browse window containing all the cities that ZIP Code is valid for. To select the appropriate city from the window, highlight the record, then press ENTER or double-click the entry.
- **Show 9 digits in lookup.** Enlarges the ZIP column in the All ZIP Codes Lookup list to display a ZIP plus four entry.

**NOTE:** A complete ZIP Code database is available. Call your local FrontRange Solutions Partner or FrontRange Solutions Inc. for information.

5. In the Contact Window Title area, select:

- **Contact name.** Displays the name of the contact in the title bar of each Contact Record. For example, if the contact name entry is John Doe, the title bar displays John Doe for that Contact Record.

  **NOTE:** Whether this option displays Contact name or another name depends on the field label in GoldMine. If the field name is Contact, the label can be customized by the administrator.

- **Company name.** Displays the company name in the title bar of the contact record.

  **NOTE:** Whether this option displays Company name or another name depends on the field label in GoldMine. If the field name is Company, the label can be customized by the administrator.

6. Click OK to save the settings and close the dialog box.
To Change User Labels and Data Colors

When you click the Label Color or Data Color buttons on the Record tab, the Color dialog box displays. Use this dialog box to select from a predefined palate of colors or customize the color selection.

Picking a New Color for Labels or Data

1. On the User’s Options dialog box, click the Record tab.
2. Click the Label Color or Data Color button.
3. Use one of the following methods to pick a color:
   - Select a color from the Basic colors pallet.
   - Define and add a custom color to the Custom colors pallet.
4. Click OK to use the selected color.

Creating a Custom Color

1. On the Record tab, click the Define Custom Colors button.
2. Click anywhere in the color picker to select the approximate color.
3. Move the luminosity slider (located on the right of the color pallet) up or down to adjust the color brightness.
   Alternately, you can enter the Hue, Saturation, Luminosity, as well as the Red, Green, and Blue levels manually by typing in their respective values.
4. Click the Add to Custom Colors button.
   Custom colors are added to Custom colors pallet and are also available for future selection
5. Select the new color on the Custom colors pallet.
6. Click OK to use the selected color.
To Set the Contact Record Tabs

The User's access to Contact Record tabs can be configured by a Master User. After being set for the user (or all users) by a Master User, only the tabs selected in the Tabs Access dialog box are available.

1. On the User's Options dialog box, click the Record tab.
2. Click the Tabs button.

3. Make the following changes as desired:
   - Check the tabs that you want available for the selected user.
   - Reposition the tabs by selected the tab name and clicking the Move Up and Move Down buttons.
   - Rename any selected tab by clicking the Rename button and making your change on the Edit Tab Label dialog box.
   - Apply these changes to all users by checking the Customize globally option.

4. Click OK to apply your changes and close the dialog box.

Setting Options for the Calendar Tab

Use the Calendar tab to set up your calendar appearance and functions.

1. Select Tools > Options.
2. At the User's Options dialog box, select Calendar.
3. At the Calendar Settings area, select:
   - **Work day starts at**: Enter the time or using the F2 graphical clock to indicate the time you typically arrive at the office. This information is used to set up your available time on the calendar.
   - **Work day ends at**: Enter the time or using the F2 graphical clock to indicate the time you typically leave the office each day.
   - **Increment time by**: Select a time from the drop-down list. This option sets the minutes in your displayed calendar. The default is 30 minutes. If you select 10 minutes, for example, the daily and weekly calendar will be divided into 10-minute increments.
   - **Set color as**: Select your calendar color from the drop-down list.
   - **Font size**: Select the font size from the drop-down list.
4. Click **More Options** to open the Calendar Options dialog box to set the **Activity Details**, **Publishing**, and **Free/Busy** tab settings.

For information about these tabs, see the following topics:
- To Configure the Calendar Options Activity Details Settings (see page 31)
- To Configure the Calendar Options Publishing Settings (see page 32)
- To Configure the Calendar Options Free/Busy Settings (see page 32)

5. Click **Holidays** to open the Calendar Options dialog box to the **Holidays** tab.

For information about the **Holidays** tab, see "To Configure the Calendar Options Holidays Settings" on page 30.

6. In the **Work Days** area, select the days of the week you work.

Days selected display as a lighter shade in the calendar. Days cleared display as a darker shade and are not considered work days.

7. In the **Auto Roll-over** area, select the types of activities to automatically roll the activity to the next day if it is not completed.

    **NOTE:** Auto Roll-over is not normally set for Appointments or Forecasted Sales because users cannot make today’s 10:00 appointment tomorrow or the next day at the same time. They should reschedule.

Select **Sync Roll-overs** for the new roll-over date to synchronize to remote users. Clear the box to preserve the original date.

8. Set the **Calendar refresh rate (sec):** by typing the number of seconds or scrolling through the numbers in the text box.

GoldMine updates the Calendar entries at the end of the interval you specify in number of seconds. The default entry 0 disables the option so GoldMine will not automatically update the calendar.

    **NOTE:** Increasing the Calendar refresh rate sends a signal to the server to update every x seconds and sends you the same data again if no changes are made to your Calendar. Setting this option to update too frequently might increase the network load unnecessarily.

9. Click **OK** to save the settings and close the dialog box.

**To Configure the Calendar Options Holidays Settings**

Use the following procedure to add predefined holidays to your calendar display, or create your own.

    **NOTE:** Only users with Master Rights can add or edit Holiday Categories. The Holiday Categories are available to all users with access to their User Options. They can select the categories appearing on their individual calendars.

1. Open the **Tools** menu and select **Options**.

2. On the **Calendar** tab, click **Holidays**.

The Calendar Options dialog box opens with the Holiday tab active.

3. In the **Holiday Categories** list, select any predefined holiday category(s) you are adding to your calendar display.

Holidays for the selected categories display in the Holidays list. Predefined sets include both fixed holidays such as New Year’s Day and variable holidays such as Easter.

4. To create a new Holiday Category, click **New** and then enter the name in the text box on the **Add a Holiday Category** dialog box and click **OK**. The new category adds to the list.

5. To manage the **Holiday Categories** use the following options:
   - **Import.** Imports iCalendar (.ics) holidays.
   - **Export.** Exports holidays to iCalendar.
   - **Reset.** Removes user-defined categories and adds predefined categories previously removed.
   - **New.** The Add a Holiday Category dialog box opens.
   - **Remove.** Removes the select category.
   - **Edit.** The Add a Holiday Category dialog box opens. Edit the category name.
Adding or Editing Holidays

1. At the Holidays area, click New.
2. At the Add a Holiday dialog box, type a name of the holiday in the Holiday field.
3. In the Repeats area, type or select how often the holiday repeats in the Every: x year(s) field.
4. In the Duration area, type or select the number of days the holiday lasts in the # Days: field.
5. Select the holiday either by:
   6. Specific Date. Select the month and day in the drop-down lists.
   7. Day of the Week. Select the week, the day of the week, and the month in the drop-down lists.
8. Click OK.

Adding and Editing Holidays to Categories

1. Highlight the Holiday Category to which you are adding the holiday.
2. In the Holidays area, click New.
3. The Add a Holiday dialog box opens.
4. To change the settings for a holiday, highlight the holiday and click Edit.
5. The Edit a Holiday dialog box opens. The editing options are the same as the Add a Holiday dialog box options.
6. To remove a holiday, select the holiday and click Remove.

To Configure the Calendar Options Activity Details Settings

Use the Activity Details tab to configure how scheduled and completed activities display on your calendar.

1. Open the Tools menu and select Options.
2. On the Calendar tab, click More Options.
3. At the Calendar Options dialog box, select the Activity Details tab.
4. In the Scheduled Activity Detail Display area and the Completed Activity Detail Display area, select from the following options:
   - Show “Contact’s Name. Reference” displays the name of the contact before the activity reference information in the calendar entry on the Day tab, Week tab, and Month tab. This is the default display option.
   - Show “Reference. Contact’s Name” displays the activity reference information before the name of the contact in the calendar entry on the Day tab, Week tab, and Month tab.
   - Show “Company Name: Reference” displays the company name information before the activity reference information in the calendar entry on the Day tab, Week tab, and Month tab.
   - Show “Reference: Company Name” displays the activity reference information before the company name information in the calendar entry on the Day tab, Week tab, and Month tab.
   - Show results of an xBase expression allows users to specify text appearing for each activity in the calendar on the Day tab, Week tab, and Month tab. Type the expression in the text box. For example, to display an entry listing the contact’s city then reference information, type this expression: Trim(Contact1->City)+ "::"
5. Select Show Activity Code to display the three-character activity code as the first part of the calendar entry on the Day tab, Week tab, and Month tab.

The activity code appears first, if available, when selected with any other format option; that is, with Contact’s Name: Reference, Reference: Contact’s Name, and xBase expression.
To Configure the Calendar Options Publishing Settings

1. Open the Tools menu and select Options.
2. On the Calendar tab, click More Options.
3. At the Calendar Options dialog box, select the Publishing tab.

For more information, see "Calendar Options Dialog Box, Publishing Tab" on page 74.

To Configure the Calendar Options Free/Busy Settings

1. Open the Tools menu and select Options.
2. On the Calendar tab, click More Options.
3. Set the options as desired.

For more information, see "Calendar Options Dialog Box, Free/Busy Tab" on page 74.

Setting Options for the Schedule Tab

Use the Schedule tab to set parameters for scheduling and working with activities.

1. Select Tools > Options.
2. At the User’s Options dialog box, select Schedule.
3. To configure the Schedule, select from the following:

   - **Check for timing conflicts while scheduling** notifies you of a scheduling conflict.

   - **Prompt to schedule a follow-up activity when completing an activity** is an optional and “best practices” workflow. When an activity is completed in GoldMine, there is a Schedule a follow-up checkbox at the bottom of the dialog. If you select this option, it prompts you to schedule a follow-up activity with a contact, allowing you to not lose track of the contact and keep in contact with them.

   - **Carry over completion notes when scheduling follow-up calls.** The notes are carried over from the completed activity to the follow-up activity.

     Selecting this option means the notes from a completed call are available in the scheduled follow-up call. This allows for consistency when working with the customer by providing information about previous conversations.

   - **Start timer when completing activities** helps managers review team member activities in Statistical Analysis. If not activated, numbers do not appear in analysis features. Users do not need to know this is turned on.

   - **Show the details section in the Activity Listing window** displays two detail panes in the Activity List that include the contact, company, create on, as well as notes and related information for the activity.

   - **Sync the Contact window with the Activity Listing window** displays the contact record for the selected activity in the Activity Listing window.

   **NOTE:** For Administrators: You might want to disable the prompt for the following options to prevent user error. For Example: if an activity is scheduled for multiple contacts, and then one is completed but the wrong prompt is selected, the activity will be marked as completed for all contacts.

   - **Show prompt when completing an activity with other associated** displays a dialog box asking whether you want to complete a single instance or multiple instances at one time. If you choose not to show the prompt, GoldMine will apply to a single instance without asking.

   - **Show prompt when editing an activity with other associated** displays a dialog box asking whether you want to edit a single instance or multiple instances at one time. If you choose not to show the prompt, GoldMine will apply to a single instance without asking.

   - **Show prompt when deleting an activity with other associated** displays a dialog box asking whether you want to delete a single instance or multiple instances at one time. If you choose not to show the prompt, GoldMine will apply to a single instance without asking.

4. Click OK to save the settings and close the dialog box.
Setting Options for the Alarms Tab

Use the Alarms tab to select how GoldMine notifies you of an appointment.

1. Select **Tools > Options**.
2. At the User’s Options dialog box, select **Alarms**.
3. Select one of the following:
   - **Disable alarms**. Turns alarms off and disables the remaining alarm options.
   - **Pop-up alarms**. An alarm window pops up on your screen.
   - **Task-bar notification**. The notification alarm displays on the Windows taskbar and an alarm icon appears in the system tray.
4. After you select **Pop-up alarms** or **Task-bar notification**, select the Alarms default lead time. x minutes to specify the number of minutes before an event the alarm pops up.
5. Set the **Scan for alarms every. x seconds** to specify how often GoldMine scans for alarms.
6. Set the **Task-bar notification reminder. x minutes**. This option determines the number of minutes before an event the taskbar notice appears. GoldMine also plays an alarm sound if specified.
7. Set the number of minutes on the **When I ignore alarms, snooze the ignored alarm for. x minutes** option.
8. Select **Page me with the alarm** when not acknowledged within x minutes and set the time. This only works if you configured the Pager tab notify you if an alarm is not acknowledged.
9. Select **Play alarm sound file** and browse to the sound file to play as an alarm signal.
10. Select **Place GoldAlarm icon on my desktop** to place a shortcut to the GoldAlarm.exe on the desktop and place the icon in the system tray when GoldAlarm is running in the background.

   **NOTE**: GoldAlarm notifies you about alarms even when GoldMine is not running.

12. Click the **More Options** button to select from activity types for which the alarm is automatically turned on.

   **NOTE**: The **Show a single alarm for activities linked to multiple contacts** option prevents multiple alarms when there are more than one contact for an appointment.

13. Click **OK** to save the settings and close the dialog box.

Setting Options for the Lookup Tab

The options on the **Lookup** tab on the <User> Options dialog box allow you to configure the display attributes and functionality of the Contact Search Center.

1. Select **Tools > Options**.
2. At the **User’s Options** dialog box, select **Lookup**.
3. Select from the following options:
   - **Show SQL query editor in the Search Center** to display the Query Editor on the Contact Search Center page (see "Contact Search Center Query Editor" on page 175).
   - **Sync the Contact window with the Search Center window** to display the selected record in the Contact Search Center as the active record in the work area.
4. Type or select the **Lookup alignment delay while typing (1/10 sec)**.
   This specifies the delay in tenths of a second between when you type an entry in the **Find Value** field of the Contact Search and when the Contact Search Center window displays a record that matches the entry.
5. In the **Default Lookup by** area, select an option: **Contact, Company, or Remember Lookup by**.
   This option becomes the Contact Search Center window default when selected on the toolbar or the menu.
6. In the Once a record is selected from the Search Center area, select one of the following:
   - **Move the Search Center window to the back** brings the Contact Record to the front and places the Contact Search Center behind the contact record.
   - **Close the Search Center window** closes the Contact Search Center.
   - **Minimize the Search Center window** minimizes the Contact Search Center.

7. Click the More Options button to view the Select CSC fields options.
   This opens a dialog which lists the fields available on the system. A check box by each field allows the user to control which fields are displayed in the Search-by list (see "Searching for Contact Records" in the User Guide or Online Help).

8. Check the fields that you want to be available in the Search by drop-down list for the current user.

9. Click **OK** to save the settings and close the dialog box.

### Setting Options for the E-mail Tab

To send and retrieve e-mail through GoldMine, configure e-mail options on the E-mail tab.

**NOTE:** You cannot edit E-mail Options while the E-mail Center window is active on the screen.

1. Select Tools > Options.
2. At the User’s Options dialog box, select **E-mail**.
3. In the Getting Mail area, complete the fields:
   - **Server.**
     - Select either the **POP3** or the **IMAP** protocol radio button.
     - Type your e-mail server name or IP address. It can be your local Exchange server or the POP3 or IMAP server for your ISP.

   **NOTE:** POP3 and IMAP are two types of protocols for receiving e-mail. They are not compatible with each other, and use different port numbers on the server side. Contact your network administrator or ISP if you are unsure of which protocol to use.

   - **Username.** Type your login for the Exchange server or ISP e-mail account.
   - **Password.** Type your password on the Exchange server or your ISP e-mail account.
   - **Use encrypted connection (SSL).** Select this checkbox to use a secure connection. This ensures the privacy of the connection between your account and the server. Enabling SSL does not verify the identity of your account or the e-mail server, but does prevent a third party from listening or recording messages sent between them.

   **NOTE:** Select Over SSL changes port numbers on the server side. Servers usually have dedicated ports for secure connections.

4. Select the **Use GoldMine as Explorer’s e-mail client** option so that Microsoft Internet Explorer (IE) recognizes GoldMine as your Internet e-mail application.

5. Select the **Use Outlook for linked E-mail Addresses** option to set Outlook as the default e-mail application. After you make this change, any e-mail address link that you click will open Outlook to compose a new e-mail message. For more information about Outlook, see "Outlook Integration Administration" on page 353.

6. In the Sending Mail area, complete the fields:
   - **SMTP server.** Type your e-mail server name or IP address. It can be your local Exchange server or the SMTP server for your ISP.
   - **Your return address.** Type your complete e-mail address on the Exchange server or your ISP.
   - **Use encrypted connection (SSL).** The same protocol used for retrieving e-mail securely. Choosing this option will also cause a switch to a dedicated secure connection port number on the SMTP server.

7. In the Network connection area, select:
   - **User Dial-up networking.** Dials your Internet provider automatically when you send and retrieve Internet e-mail. If you subscribe to more than one Internet provider, select the provider you want GoldMine to dial by selecting the Internet account in the drop-down list next to the field that appears below this option.
   - **Hang up when done.** Terminates the telephone connection after finishing sending and retrieving Internet e-mail.
8. Click **More Options** to configure e-mail settings in more detail:

- **Composing** (see "To Set E-mail Options on the Composing Tab" on page 35)
- **Retrieval** (see "To Set E-mail Options on the Retrieval Tab" on page 36)
- **Accounts** (see "To Set E-mail Options on the Accounts Tab" on page 37)
- **Security** (see "To Set E-mail Options on the Security Tab" on page 37)
- **E-mail Center** (see "To Set E-mail Options on the E-mail Center Tab" on page 39)
- **Advanced** (see "To Set E-mail Options on the Advanced Tab" on page 39)

9. The **Accounts** button takes you directly to the Accounts tab that is also available through **More Options**.

### To Set E-mail Options on the Composing Tab

Define settings for GoldMine to apply when writing an Internet e-mail.

1. Select **Tools > Options**.

2. At the **User's Options** dialog box, select the **E-mail** tab.

3. Click the **More Options** button.

4. At the **E-Mail Options** dialog box, select the **Composing** tab.

5. In the **General** area, select:

   - **Show public E-mail templates.** The drop-down list in the e-mail Subject line lists all e-mail templates saved to (public) in the **E-mail Templates** dialog box.

   - **Attach VCard to outgoing E-mail.** Attaches your VCard (.VCF file) to each e-mail message. A VCard contains information similar to a contact record. If the receiving system has VCard capabilities, the system will decipher the .VCF file to import this information.

   - **Use signature file.** Attaches a signature file (a text file containing information about you, your organization, telephone number quotations, and so on) to messages for the single account or for the default account if additional Internet accounts were defined in the Accounts tab. This entry overrides an entry for the default account made in the **Accounts** tab; however, the entry has no effect on other accounts. Type or browse to the signature file in the field below the option label.

     **NOTE:** When composing HTML messages and using a signature file, you must add the break tag "<BR>" into the signature file wherever you want a line break.

   - **When forcing line wrap, wrap at column x.** Specifies how many characters GoldMine includes before the text wraps to the next line.

   - **Send attachments as links for GM users.** Provides the link to each attached file for GoldMine users instead of sending the files to each recipient. This is a space saver for users on the same shared network.

6. In the **Replies** area, select:

   - **Complete original message.** Places the original message in the History tab when you reply or forward a message. If you do not want to designate the original message as a completed activity when you respond, clear the check box.

   - **Use line quote style with prefix.** Specifies the characters GoldMine uses to identify lines quoted from the original message when you copy those lines into your reply. By default, GoldMine uses `>>`.

   - **Quote entire message by default.** GoldMine copies the entire text of the original message in your reply, using the characters entered in Use line quote style with prefix.

   - **Wrap quoted lines in replies at column x:** Specifies the number of characters GoldMine uses before wrapping to the next line of quoted text. You can use this option to create an indented block for text quoted from the original message.

7. In the **Misc.** area, select:

   - **Use 8 bit encoding.** Converts 7-bit encoding into 8-bit encoding. Useful for international GoldMine users.

   - **Always send a Bcc to myself.** Sends a blind courtesy copy (bcc) of each outgoing message to your e-mail account.

   - **Use user supplied VCard.** Ensures the VCard attached to your outgoing e-mail includes updates.

   - **Encode E-mail using character set.** To encode your messages with a special character set, type the character set in the field. For example, to use the Western European character code, type iso-8859-1. If left blank, GoldMine uses the local default character set for encoding.
8. In the **Default templates** area, select Public or your user-defined templates in the drop-down lists:
   - For new outgoing E-mail messages
   - For replies
   - For forwarded messages

   **NOTE:** Templates must be created before they are available in the drop-down lists.

9. Click **OK** to save the settings and close the window, or click the next Internet Options tab to configure.

**To Set E-mail Options on the Retrieval Tab**

Specify a variety of Internet e-mail retrieval options to define attachment locations, scan intervals, and the criteria GoldMine uses to select messages for retrieval.

1. Select **Tools > Options > E-mail**.
2. Click the **More Options** button.
3. At the **E-Mail Options** dialog box, select the **Retrieval** tab.
4. In the **Retrieval Options** area, select:
   - **Open ‘Read E-mail’ dialog on retrieval.** After the e-mail is retrieved, GoldMine opens and displays the first retrieved message.
   - **Use date from mail header.** Sets the date of incoming mail to the date sent as indicated in the header information of the message and posts e-mail in true chronological order on your calendar.
     If you do not retrieve e-mail frequently, you might want to clear the check box corresponding to this option.
   - **Scan mail for UUEncoded data.** GoldMine scans the Internet mail server for any e-mail messages that contain UUEncoded attachments. Selecting this option does not affect the retrieval of MIME-encoded files.
   - **Prompt if E-mail address is not on file.** GoldMine displays the **Attach E-mail** to Contact dialog box upon retrieving an unlinked e-mail message. Options are available for linking the message.
   - **Preview x lines of the message.** Specifies the number of lines of text GoldMine displays in the lower pane of the E-mail Center. By default, GoldMine displays 15 lines.
   - **Do not retrieve VCard attachments.** If you select this option, GoldMine will not retrieve VCards with incoming e-mail.
   - **Mark incoming messages as private.** Limits the information available to other users about your incoming messages and prevents unauthorized users from reading the text.
     **Example:** On the **Pending** tab, received messages are marked (Private); Master users can read the messages, but other users cannot.

5. In the **Background E-mail Retrieval** area, select:
   - **Retrieve mail every x minutes.** GoldMine connects with your POP3mail server to check for new mail at the interval you specified. For example, to retrieve waiting Internet e-mail every 2 hours, type 120 in this field. The default value of 15 sets GoldMine to scan for and retrieve waiting e-mail every 15 minutes. If you do not select Auto-retrieve on the Accounts tab but select Retrieve mail every x minutes and Send queued messages, GoldMine sends queued mail only.
     The following options are available only if you select Retrieve mail automatically every x minutes.
     - **Skip read mail (recommended).** Bypasses displaying e-mail messages you already read.
     - **Skip mail larger than x KB.** GoldMine retrieves only Internet e-mail messages that are equal to or smaller than the kilobyte (KB) value in this field.
     - **Skip messages from contacts not on file.** GoldMine retrieves only e-mail from those contacts who have Internet e-mail addresses in their detail records.
     - **Send queued messages.** GoldMine sends all queued messages when automatically retrieving mail.

6. Type or browse to the location of the **Attachments** directory. This is the destination folder for retrieved e-mail attachments.

   **NOTE:** These directories should be shared so other users can access the attachments.

7. Select **Save attachments as linked documents** to link files attached to incoming e-mail to the senders’ contact records.
To prevent linking attachments to your contacts, clear this option.

8. Click OK to save the settings and close the window, or click the Internet Options tab to configure.

To Set E-mail Options on the Accounts Tab

Add and edit additional Internet accounts for sending e-mail from GoldMine. Establish a non-standard authentication protocol for your primary account.

1. Select Tools > Options > E-mail.
2. Click the More Options button.
3. At the E-Mail Options dialog box, select the Accounts tab.
   The accounts are listed in the field.
4. To add an account, click New.
5. At the E-mail Account Properties dialog box, define properties for an Internet e-mail account.
   A user can log in and retrieve mail for up to 256 separate accounts.
6. To edit an existing account, select the account and click Edit.
   At the E-mail Account Properties dialog box, make changes to the Internet e-mail account.
7. To remove an Internet account, select the account and click Delete.

![WARNING: No confirmation prompt appears to verify the deletion.]

8. With multiple accounts, set one account as your primary account by highlighting it and clicking Set as Default.
   The default account is indicated by a green ball or dot in the accounts display box.
9. Select Show only the default account in the E-mail Center if you have multiple accounts but only want the default account to display in the E-mail Center.
   The accounts set to display in the E-mail Center are indicated by eyeglasses to the left of the account name in the Accounts display box.
   **NOTE:** By default, GoldMine shows all accounts in the E-mail Center letting you check Internet accounts from one location in GoldMine.
10. Change the order of the accounts displayed in the E-mail Center.
    Click Move Up to move the highlighted account up one line. Click Move Down to move the highlighted account down one line.
11. Click OK to save the settings and close the window, or click the next Internet Options tab to configure.

To Set E-mail Options on the Security Tab

If you have a digital ID (digital certificate) to verify your signature and receive encrypted e-mail messages, GoldMine lets you configure your Internet Options to include the information when sending a message.

**TIP:** For information about Windows Certificates, see "Import Windows Certificates to Decrypt E-mails" on page 38.

1. Select Tools > Options.
2. At the User's Options dialog box, select the E-Mail tab.
3. Click the More Options button.
4. At the E-Mail Options dialog box, select the Security tab.
5. Click Digital ID(s) to configure your IDs.
   The Manage Digital IDs dialog box opens.
6. In the Signature Settings area, you can select one option:
7. To encrypt all outgoing messages by default, select **Encrypt ALL outgoing E-mail, by default** (Recipients' Certificates are required in advance). Selecting this option sets the encryption to digital IDs on outgoing messages. With this option selected, you can still select **Do not Encrypt** on the encryption menu on the Edit E-mail toolbar.

8. In the **Other Settings** area, select:
   - **Import new/updated certificates for ALL incoming signed E-mails, by default.** Automatically imports the digital ID on all signed incoming messages into the contact's Record Properties > Contact Details > Digital IDs tab.
   - **Save ALL incoming S/MIME e-mails as 'clear' messages.** Saves all S/MIME encoded (opaque) messages and all encrypted messages as clear, or not encoded. As clear-text messages, all GoldMine users with access to the e-mail record can read the messages. If this option is not selected, the messages are saved as they were received. Whenever GoldMine users want to read the e-mail message, they must enter the password for the private key of the GoldMine recipient.

   **NOTE:** If you do not select this setting, encrypted messages from contacts are unreadable by other users on the History and Pending tabs. Carefully consider the consequences before clearing this option.

9. Click another tab or click **OK** to save and close the dialog box.

### Import Windows Certificates to Decrypt E-mails

Certificates from Windows can be imported into GoldMine using the following actions procedure.

1. Select **Tools > Options.**
2. At the **User's Options** dialog box, select the **E-Mail** tab.
3. Click the **More Options** button.
4. At the **E-Mail Options** dialog box, select the **Security** tab.
5. Click **Digital ID(s) to configure your IDs.**

   The **Manage Digital IDs** dialog box opens.

6. Click the **Trusted Certificate Authorities** tab.
7. Click the **Import** button.
8. Select the **Import from your Windows system certificate stores** option.

   **NOTE:** Expired certificates from Windows are not imported into GoldMine and matching certificates between Windows and GoldMine are skipped during import.

9. Click **OK.**

   **NOTE:** Some of the certificates that are imported into GoldMine are not available as “Trusted Root Certification Authorities” or “Intermediate Certification Authorities” in Windows.
To Set E-mail Options on the E-mail Center Tab

Configure the E-mail Center using the E-mail Center tab of the Internet Options dialog box.

1. Select Tools > Options.
2. At the User’s Options dialog box, select the E-mail tab.
3. Click the More Options button.
4. At the E-Mail Options dialog box, select the E-mail Center tab.
5. In the General Settings area, select:
   - Show both E-mail Address and Account Name (if available) for Online accounts. Select to list the accounts in the E-mail Center by both the E-mail Address and the Account Name. If the Account Name is left blank, GoldMine uses the e-mail address as the account name. If the Account Name contains an entry and you clear this option, GoldMine lists the account by the Account Name only.
   - Show Outlook Folder. Displays the Outlook folder from the local computer in the E-mail Center.
6. In the Trash Can Settings area, select:
   - Move deleted E-mail to Trash Can. Places deleted mail in the Deleted folder in the E-mail Center. GoldMine holds the mail until you select Empty trash can in the local menu.
   - Empty Trash Can when closing the E-mail Center. Automatically deletes any messages placed in the Deleted folder when you close the E-mail Center.
   - Confirm before emptying Trash Can. Displays a warning prompt for confirmation to delete messages in the Deleted folder.
7. In the Header Display Options area, select one option:
   - Hide Headers. Shows no header information in the e-mail message.
   - Show Summary Headers. Shows relatively high-level information only in the e-mail message such as date, sender, subject, recipient, and so on. This option does not show detailed routing information.
   - Show ALL Headers. Shows all header information in the e-mail message including routing information and message ID.
8. In the Mail Folders Display Options area, select one option:
   - Long date format. Spells out the date in the E-mail Center including the day.
   - Short date format. Uses numeric format for month, day, year, and transmission time.
9. In the Auto-filed Folders’ Storage Options area, select one option:
   - Organize Auto-filed mail in month-year folders. Uses one level to store incoming messages by month, year.
   - Organize Auto-filed mail by year folders first, and by month sub-folders second. Uses two levels to store incoming messages in month folders under separate folders for each year.
10. Check the Show most recent Auto-filed folders at the top option if you want to sort the folders by most recent date.
    - Click More Auto-filed Folders’ Options to change the default month-name labels assigned to folders. The Auto-filed Folders’ Month Names dialog box appears. Select Override the default month names and type the new label names to assign to the Filed folders.
11. Click OK to return to the E-mail Center tab.
12. Click OK to save the settings and close the window, or click the next Internet Options tab to configure.

To Set E-mail Options on the Advanced Tab

Define advanced Internet settings to apply globally to your E-mail Center, existing attachment files, message operations, and data imported from a Web site.

Use the following procedure to set up Internet Options on the Advanced tab.

1. Select Tools > Options.
2. At the User’s Options dialog box, select the E-mail tab.
3. Click the More Options button.
4. At the E-Mail Options dialog box, select the Advanced tab.
5. In the **E-mail Center** area, select from:
   - Enable ‘Delete All Server Mail’. Activate the Delete all messages on the server button on the **E-mail Center** toolbar to delete all messages on the Internet mail server. By default, GoldMine excludes this icon in the **E-mail Center** toolbar.
   - **Download old messages first.** Retrieve messages from the mail server in chronological order (oldest to newest). By default, GoldMine retrieves messages in reverse chronological order (newest to oldest).
   - **Suppress file overwrite prompt.** Do not display a warning before overwriting an existing file with an attached file having the same name.

6. In the **Existing attachment default action** area, specify the default method for handling a file of the same name:
   - **NOTE:** This option will not work automatically unless the Suppress file overwrite prompt option is also selected.
   - **Overwrite existing file.** Replaces the existing file.
   - **Choose a new file name.** Lets you rename the file.
   - **Auto name assignment.** Appends a number to the file name. If GoldMine cannot append a number (up to 64), a random, unique name assigns to the new file.
   - **Do not save the file.** Deletes the attached file.

7. In the **Message** area, select from:
   - **Use HTML when creating new E-mail.** GoldMine recognizes HTML encoding in incoming messages, and applies HTML formatting to outgoing messages. This option adds an HTML editing toolbar to the Create Internet E-mail dialog box letting you add a formatting attributes, such as color, picture file insertion, and alignment.
   - **Auto spell-check before sending.** Checks the spelling in a message when selecting Send in the Create Internet E-mail dialog box.
   - **Link e-mail address to contact record by default.** When retrieving an e-mail message that is linked to a contact record, selecting this option causes the From: address in the message to be linked to the same contact. To link messages to contacts without linking the e-mail address, un-select this option.
   - **Mark attachments for synching by default.** Marks e-mail attachments as linked documents to be synchronized, except for VCards and transfer sets.
   - **Delete attachments when deleting the mail.** Deletes attachments when you delete messages.

8. In the **WebImport** area, select from:
   - **Import data when retrieving E-mail Center mail.** Imports WebImport data when GoldMine retrieves e-mail messages. To manually import WebImport data, clear this option.
   - **Import data on background e-mail retrieval.** Imports WebImport data when GoldMine performs background e-mail retrieval.
   - **Discard message after importing data.** Deletes the WebImport message from the Web site after GoldMine retrieves the message.

9. In the **Communication timeout** field, type the number of seconds GoldMine remains idle before disconnecting from the mail server (default is 60 seconds).

10. Click **OK** to save the settings and close the window.

### Setting Options for the Telephony Tab

Configure special modem and dialing settings to use with GoldMine's auto-dialer feature.

**NOTE:** You must have a TAPI modem locally installed and working on your computer before you can successfully configure the modem settings.

Use the following procedure to set up options on the Telephony tab.

1. Select **Tools > Options**.
2. At the User’s Options dialog box, select **Telephony**.
3. In the **Modem Settings** area, configure these settings:
   - **TAPI Line.** Select the TAPI settings in the drop-down list that match your computer’s Phone Dialer TAPI settings.
4. In the **Dial Number Formatting** area, configure:
   - **Let TAPI format phone numbers.** Allows TAPI to add numbers required for dialing a phone number such as international access and country codes.
   - **Dial numbers as entered.** Dials the numbers as they are formatted in GoldMine.
   - **Local Area Code.** The area code you are dialing from.
   - **Dial Prefix.** A number sequence accessing a special line or service.
   - **Dial Suffix.** A number sequence after the telephone number to access a special line or service.
   - **Hang up after:** x sec. Specifies the number of seconds before GoldMine tries to reconnect.

5. In the **SoftPhone** area, enter the local extension number and set SoftPhone as the default. Access and edit SoftPhone advanced settings by clicking the **Advanced** button.

6. Click **OK** to save the settings and close the dialog box.

### Setting Options for the System Tab

Click the System tab on the **Options** dialog box to define your GoldMine system settings.

1. Navigate to **Tools > Options.** The **Options** dialog box opens.
2. Select the **System** tab.
3. In the **Navigation** area, select the checkbox next to the following options as needed:
   - **Use classic GoldMine menu.** Select this option to display the default main menu rather than the current menu configuration.
   - **Show status bar.** Select this option to use the status bar.
   - **Recent item shown.** In the dropdown box, select the number of recent items you want to display.
4. In the **Classic toolbar** area, click **Show button text** to show the Classic GoldMine toolbar buttons.
5. In the **Activity tabs** area, select **Show activity code in history tabs** to show the activity code in the **History** tab.
6. In the **Date and Time** area, select the checkbox next to the following options as needed:
   - **Show time in 24 hour format.** Select this option to display time in a 24-hour format on the status bar and the time fields of windows. For example, 9:00 P.M. appears as 21:00 in the 24-hour time format.
   - **Set EPOCH.** Select this option to determine how GoldMine interprets dates when no century is indicated, that is, a date entry containing only the last two digits of the year. To scroll through values by five-year increments, click the up and down arrows next to the field. For example, if you set the value to 80, GoldMine will interpret the entry 03/10/80 as March 10, 1980 and the entry 10/01/70 as October 1, 2070.
7. In the **Help** area, select the checkbox next to **Show tips at startup** to display the User Tips when you launch GoldMine. Do not select this checkbox if you do not want to see the User Tips.
   
   **NOTE:** For best results, assign the same user name in both GoldMine and MS Outlook.

8. At the **MS Outlook user name if not the same as the GoldMine user** text box, type the Microsoft Outlook user name if the Outlook user name is different than the GoldMine user name.
9. After making all of your selections, click **OK.**

### Setting Options for the Speller Tab

Use the **Speller** tab to select settings for the spell-checking options. Use spell checking in GoldMine windows offering text editing such as e-mail messages and the InfoCenter.

1. Select **Tools > Options.** The User’s Preferences dialog box appears.
2. Select **Speller.**
3. In the **Spelling Options** area, select from the following options:
   - **Ignore capitalized words**: Ignores proper names.
   - **Ignore all-caps words**: Ignores acronyms and initialisms.
   - **Ignore words with numbers**: Ignores words with numeric characters in them.
   - **Ignore words with mixed case**: Ignores specialized words such as GoldMine.
   - **Ignore domain name**: Ignores Web and Internet addresses.
   - **Report doubled words**: Notifies when the same word appears twice.
   - **Case sensitive**: Spell checker evaluates a word beginning with a capital letter as different from the same word that does not begin with a capital letter.
   - **Phonetic suggestions**: Offers phonetic suggestions that sound like the targeted word.
   - **Typographical suggestions**: Offers words with a similar letter organization to the targeted word.
   - **Suggest split words**: Suggests two words for compound words that do not appear in the dictionary.
   - **Auto correct**: When enabled, words marked with "Auto Change" actions are automatically changed to their specified replacements. When disabled, you are prompted before the words are changed.

4. In the **Suggestions** area, select one of the following options:
   - **Fast but less accurate**: Evaluates your unrecognized word based on your Spelling Options and quickly generates a broadly based suggestion list.
   - **Moderately fast and accurate**: Evaluates your unrecognized word based on your Spelling Options and generates a fast and accurate suggestion list.
   - **Slow but accurate**: Evaluates your unrecognized word based on your Spelling Options and generates a carefully constructed suggestion list.

5. In the **Dictionaries** area, select your Main Dictionary language in the drop-down list. There are 18 dictionaries to select from.

6. Click **Setup Dictionaries** to launch the Dictionaries dialog box where you create and customize .tlx dictionary files (see "Creating Dictionaries" in the GoldMine User Guide PDF or in the Online Help).

7. Click **OK** to save the settings and close the dialog box.

### Setting Options for the Messaging Tab

Use the Messaging tab to enable sending SMS messaging (Short Message Service) to your mobile device for reminders of upcoming scheduled activities.

**NOTE:** The **Messaging** tab is only available after a GoldMine Mobile license (M-License) has been added to the License Manager.

**IMPORTANT:** Before GoldMine can send Activity reminders to mobile device users, sending must be enabled within the GoldMine system (**Tools > Configure > System Settings > Messaging** tab). See "Configuring System Settings" on page 52.

1. Navigate to **Tools > Options**. The **Options** dialog box opens.
2. Click on the **Messaging** tab.
3. Check the **Send activity alarms as a message to my device** box.
4. Specify the GoldMine Mobile User’s e-mail address used for receiving SMS messages in the **E-mail address for the mobile device** text box.
   **NOTE:** This option is also available for non-master rights users provided that message sending has already been enabled in the **Messaging** tab in the System Settings (see "Configuring System Settings" on page 52).

   **TIP:** For assistance in determining the e-mail address, refer to the following article for a listing of service providers’ SMS gateways: [http://en.wikipedia.org/wiki/List_of_SMS_gateways](http://en.wikipedia.org/wiki/List_of_SMS_gateways)

5. Click **OK** to save the settings and close the dialog box.
Setting Options for the Login Tab

Use the Login tab to set default databases and login information. This tab is available only to users with Master Rights.

---

**WARNING:** These settings rewrite the GM.ini file and are global. Note that the changes you make affect all users.

1. Navigate to **Tools > Options.**
   The Options dialog box opens.
2. Click on the **Login** tab.
3. At the **GoldMine home directory field,** browse to the GoldMine directory location for which you want to set the default.
   If you are working on a network, this should be the drive mapped to the main GoldMine directory, for example, G:\Apps\GoldMine.
4. At the **GoldMine database,** select the alias for which you want to set the default from the drop-down list (for example, GoldMine 9.0).
5. At the **Default contact database,** select the alias for the database for which you want to set the default in the drop-down list (for example, MSSQL: GoldMine: dbo).
6. Click on the **Default login user** checkbox to write to the local gm.ini file.
   This is fine for single-user installations but not for network installations. For network installations, each workstation generally has a different user with their own login.

**To Modifying the GoldMine Login**

On some operating systems, especially NT-based operating systems, the Default login user is not respected and the GoldMine login defaults to the network login name.

1. On a network workstation where you log in to GoldMine with a login differing from your network login, create a GoldMine shortcut on the desktop.
2. Right-click the shortcut and select **Properties > Shortcut.**
3. In the **Target** text box, type `/u:username` (where username is your GoldMine login).
   An example of a full path is: \GoldMine\gmw.exe/u:username.
   This populates the GoldMine login with your correct GoldMine login name.
4. The **Time Clock** drop-down list contains three options for monitoring the login activity of the user. The information displays on the Time Clock tab in each User Properties dialog box. Select from the following:
   - **Disable Time Clock.** Turns off the login and time tracking.
   - **Track daily totals.** Monitors the total number of times a user logs into GoldMine and displays the cumulative amount of time the user is logged in per day. These statistics appear in the Time Clock tab of the User Properties dialog box.
   - **Track each login.** Monitors the amount of time a user is logged in to GoldMine for each login session. These statistics appear in the Time Clock tab of the [Username] Properties dialog box.
5. Click on the **Bypass login banner** checkbox to skip the login banner if there is no password for the user.
6. Click on the **Open files exclusively** checkbox to allow only the currently logged in user to open GoldMine.
   A **NOTE:** Open files exclusively is useful for GoldMine administrators working in the database who need to keep other users out. When you are finished using the files exclusively, remove this option so other users can log in. When selected, this option writes the line Exclusive=1 in the [GoldMine] section of the GM.ini file and locks the Flags.bin table. Do not enable this feature if planning to use the GoldMine Backup Wizard.
7. Click **OK** to save the settings and close the dialog box.
Updating Undocked Users

IMPORTANT: Do not allow undocked users to synchronize with an updated GoldMine system until that undocked user has updated to the same version the updated site is using.

To update undocked users after performing a Net-Update on the main GoldMine system, locate the gmsetup.exe file. Depending on how undocked users communicate with the network and GoldMine system and on the connection speed, send the gmsetup.exe file to the undocked user by putting it on CD, posting it on an FTP site, e-mailing it, or placing it on an accessible network drive.

Include directions on executing the gmsetup.exe file and what undocked users should expect after the upgrade. After the undocked users update to the same version of GoldMine, they can use Net-Update to sync with the master site.

Use the following procedure to perform an update.

1. Click Net-Update Now and follow the prompts.
2. To change the registration information, select Update Registration Information.

For additional information, see "Creating Undocked User License" on page 380.

GoldMine .INI Files

GoldMine contains .INI files (initialization files) that define program and user parameters. Each GoldMine user has a username.ini and username.tbi (which is the user login name followed by the file extension).

For Example: If the user’s login is JohnS, then the user’s .ini file is johns.ini.

- The username.ini stores options and is in the GoldMine directory. See "Username.ini" on page 46.
- The username.tbi file stores the user’s taskbar settings. See "Username.tbi" on page 52.

GM.ini Settings

GM.ini file found in the main GoldMine folder contains the paths to these locations:

[GoldMine]
GoldDir=GoldMine:
CommonDir=GoldMine:

Select Help > About GoldMine, and then click the System button to view the file locations.

<table>
<thead>
<tr>
<th>Section</th>
<th>Command</th>
<th>Values</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[GoldMine]</td>
<td>UserNameFormat=</td>
<td>1</td>
<td>Orders the username display as FirstName LastName (LoginName). If the command is not added, the default display is LoginName (FirstName LastName).</td>
</tr>
<tr>
<td></td>
<td>UserLogo=</td>
<td>&lt;path\filename&gt;</td>
<td>Places your custom logo on the GoldMine login screen.</td>
</tr>
<tr>
<td></td>
<td>RecAlertSec=</td>
<td>&lt;number of seconds&gt;</td>
<td>Changes the delay before an alert appears.</td>
</tr>
<tr>
<td></td>
<td>NewComplete=</td>
<td>0</td>
<td>Creates only a partial record (Contact1) rather than a full record (Contact1 and Contact2).</td>
</tr>
<tr>
<td>Section</td>
<td>Command</td>
<td>Values</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>--------------------------</td>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>GoldDir=</td>
<td>&lt;database alias&gt;</td>
<td>Database alias for base GoldMine database.</td>
</tr>
<tr>
<td></td>
<td>CommonDir=</td>
<td>&lt;database alias&gt;</td>
<td>Database alias for default Contact database.</td>
</tr>
<tr>
<td></td>
<td>SysDir=</td>
<td>&lt;path\filename&gt;</td>
<td>Path to the GoldMine system files.</td>
</tr>
<tr>
<td></td>
<td>Exclusive=</td>
<td>1</td>
<td>Locks all other users out of GoldMine.</td>
</tr>
<tr>
<td></td>
<td>LastRun=</td>
<td>&lt;number of days&gt;</td>
<td>Set the number of days to wait before performing another Automatic Maintenance.</td>
</tr>
<tr>
<td></td>
<td>HTML_Cal_Notes=</td>
<td>0</td>
<td>Displays the scheduled activity Notes as simple text rather than HTML. To display the Notes as HTML, the value is 1. Also enabled in Tools &gt; Configure &gt; System Settings on the Display tab.</td>
</tr>
<tr>
<td></td>
<td>SQLQueryTimeout=</td>
<td>&lt;minutes&gt;</td>
<td>Sets the global timeout for all database queries.</td>
</tr>
<tr>
<td></td>
<td>LongSQLQueryTimeout</td>
<td>&lt;minutes&gt;</td>
<td>Sets the global timeout for critical operations such as synchronization and database re-indexing.</td>
</tr>
<tr>
<td></td>
<td>AddContactFaxLabel=</td>
<td>&lt;label name&gt;</td>
<td>Sets the label for an alternate phone contact. The default value is “Fax”, but can be changed to “Mobile” or any other text label.</td>
</tr>
<tr>
<td></td>
<td>ROTabs</td>
<td></td>
<td>Renames tabs. Only an Admin with Master rights can record in Detailed view. To access this option open Contact Record in Detailed view, use the Tab Selector arrow-button and select Customize. Then, highlight a tab and click the Rename button.</td>
</tr>
<tr>
<td>[WebImpPassword]</td>
<td>PasswordX=</td>
<td>&lt;password&gt;</td>
<td>Requires passwords on WebImport files. X is the number of the password.</td>
</tr>
<tr>
<td>[WebImportOverwrite]</td>
<td>IAgree=</td>
<td>I Want To Allow Fields To Be Updated By WebImport</td>
<td>Lets fields update by WebImport. Specify the fields using the Fields= setting.</td>
</tr>
<tr>
<td></td>
<td>Fields=</td>
<td>&lt;field names separated by commas&gt;</td>
<td>Specifies the fields updated by WebImport.</td>
</tr>
</tbody>
</table>
To Configure the GM.INI File For Reporting Services

After installing Microsoft SQL Server Reporting Services and configured on the network, add a section to the gm.ini file typically located in Program Files/GoldMine/. This tells GoldMine where the Reporting Services is hosted.

Use the following procedure to configure the ini file

2. Open the gm.ini file using Notepad.
3. Type the following code:

```
[ReportServer]
```

4. Click Save and close Notepad.
5. Open GoldMine.

Username.ini

This file controls user settings not set from interface menus. GoldMine generates some default <username>.ini settings.

**NOTE:** user.ini settings can be inserted to gm.ini but only in [User-Override:GoldMine] section.

The default <username.ini> settings appear in the following table:

<table>
<thead>
<tr>
<th>Section</th>
<th>Command</th>
<th>Options</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>[Internet]</td>
<td>ShowPreview=</td>
<td>0 -- Preview off</td>
<td>E-mail Center Preview settings can be toggled on/off. Right-click an object in the tree pane and select <strong>Show Preview</strong>.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>1 -- Preview on</td>
<td></td>
</tr>
<tr>
<td></td>
<td>BodySizeLimitKB=</td>
<td>Size in KB</td>
<td>Increase the amount of a e-mail message previewed in the E-mail pane</td>
</tr>
<tr>
<td>[GoldMine]</td>
<td>AutoFillAddlAddress=</td>
<td>1 -- Auto-fill selected by default</td>
<td>When creating an additional contact on the Contacts tab, use the primary contact's address information to automatically populate the address fields.</td>
</tr>
<tr>
<td>Section</td>
<td>Command</td>
<td>Options</td>
<td>Notes</td>
</tr>
<tr>
<td>---------------</td>
<td>-----------------------</td>
<td>--------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>AutoFillEmailAddr=</td>
<td>1 -- Auto-fill selected by default</td>
<td>Auto-fills new e-mail addresses with the @&lt;domain.name&gt; of the selected primary e-mail address</td>
<td></td>
</tr>
<tr>
<td>OnByDefault</td>
<td>ACDEMOQST where: A-- appointment C-- Call Back D-- To-do E-- event M-- message O-- other Q-- queued email S-- f.sale T-- next action</td>
<td>Turn calendar alarms on by default (separate setting for each activity type). Also enabled in Tools &gt; Options on the Alarms tab by clicking the Alarms on by Default button.</td>
<td></td>
</tr>
<tr>
<td>FollowUp</td>
<td>0 -- false 1 -- true</td>
<td>Prompt to schedule a follow-up activity when completing an activity. Also enabled in Tools &gt; Options on the Schedule tab. Then, check the Prompt to schedule a follow-up activity when completing an activity box.</td>
<td></td>
</tr>
<tr>
<td>ShowTipOfThe Days</td>
<td>0 -- false 1 -- true</td>
<td>Displays tips at login, which can also be disabled on login page. Also enabled in Tools &gt; Options on the System tab. Then, check the Show tips at startup box.</td>
<td></td>
</tr>
<tr>
<td>MSSQLMaxBrowseRecs</td>
<td>number of recs</td>
<td>Maximum number of records shown in SQL Query results. In the Global settings area, only an Admin with Master rights can make edits. Also enabled in Tools &gt; Configure &gt; System Settings on the Display tab. Then, set Maximum number of records shown in SQL Query results value to any number.</td>
<td></td>
</tr>
<tr>
<td>SearchTopRec</td>
<td>number of recs</td>
<td>The maximum records displayed in Contact Search Center. Only admin with master rights can edit. Admin UI only needs support as corporate override in gm.ini).</td>
<td></td>
</tr>
<tr>
<td>SQLQueryLimit</td>
<td>number of recs</td>
<td>In the Global settings area, only an Admin with Master rights can make edits. Also enabled in Tools &gt; Configure &gt; System Settings on the Display tab.</td>
<td></td>
</tr>
<tr>
<td>MaxRegardingListSize</td>
<td>number of recs default=50</td>
<td>The maximum number of Opportunity, Project, and Case records for E-mail Center.</td>
<td></td>
</tr>
</tbody>
</table>
Add or modify command statements to `<username>.ini` to customize:

- Access to macros of another user
- Title bar display
- Modem and dialing settings
- Configurations for messaging activities

GoldMine updates most of the settings in the `username.ini` when settings in options, toolbars, and other user areas of GoldMine are changed. Manually add or change the settings by editing the file with a text editor.

GoldMine organizes settings in this format:

```
[Section]
Setting=x
```

The section name always appears in brackets, the setting is the specified setting, and (x) represents the value of the designated setting. Be sure to place each new command in the correct section of `<username>.ini`. However, the order of statements within a section does not affect proper execution.

The GoldMine section options are listed in the following table.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AllowDupEmails</td>
<td>0</td>
<td>false Allows e-mail addresses to be duplicated on multiple records.</td>
</tr>
<tr>
<td></td>
<td>1</td>
<td>true Also enabled in Tools &gt; Configure &gt; System Settings on the Advanced tab.</td>
</tr>
<tr>
<td>SyncActiveObj</td>
<td>1</td>
<td>Syncs the current contact record object with the highlighted activity.</td>
</tr>
<tr>
<td>SyncGroupObj</td>
<td>1</td>
<td>Syncs the contact record object as the contact if a group listing is changed.</td>
</tr>
<tr>
<td>PubForm</td>
<td>1</td>
<td>Show (public) user forms in the merge forms menu.</td>
</tr>
<tr>
<td>ROTabs</td>
<td>1</td>
<td>Lets you change labels on the tabs. Type new labels in the order the tabs display on the screen with commas separating the labels and no spaces. For example, Summary, Notes, Fields.</td>
</tr>
<tr>
<td>ROTitle</td>
<td>1</td>
<td>Displays the contact name in the record object title bar.</td>
</tr>
<tr>
<td>MacFile</td>
<td>2</td>
<td>Uses the macros of the user specified</td>
</tr>
</tbody>
</table>
Changing Settings in the INI File in GoldMine

GoldMine has the ability to change some settings in the .ini files by configuring the System Settings and <User> Options tabs. For more information, see "Configuring System Settings" on page 52 and "Managing User Options" on page 25.

You can change the settings in the following table.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Configure</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML_CAL_NOTES</td>
<td><strong>To View Notes as HTML:</strong></td>
</tr>
<tr>
<td></td>
<td>1. In GoldMine, open the Tools menu and select Configure &gt; System</td>
</tr>
<tr>
<td></td>
<td>Settings.</td>
</tr>
<tr>
<td></td>
<td>2. Click the Display tab.</td>
</tr>
<tr>
<td></td>
<td>3. In the Notes Format area, select HTML.</td>
</tr>
<tr>
<td></td>
<td>4. Open any contact, click the Pending tab, and create a new Activity.</td>
</tr>
<tr>
<td></td>
<td>5. Add a Note in the Note area and verify that you can set the font</td>
</tr>
<tr>
<td></td>
<td>color, type, size, and alignment.</td>
</tr>
<tr>
<td>HTML_CAL_NOTES</td>
<td><strong>To View Notes as Plain Text:</strong></td>
</tr>
<tr>
<td></td>
<td>1. In GoldMine, open the Tools menu and select Configure &gt; System</td>
</tr>
<tr>
<td></td>
<td>Settings.</td>
</tr>
<tr>
<td></td>
<td>2. Click the Display tab.</td>
</tr>
<tr>
<td></td>
<td>3. In the Notes Format area, select Plain text.</td>
</tr>
<tr>
<td></td>
<td>4. Open any contact, click the Pending tab, and create a new Activity.</td>
</tr>
<tr>
<td></td>
<td>5. Add a Note in the Note area and verify that you are not able to set</td>
</tr>
<tr>
<td></td>
<td>the font color, type, size, and alignment.</td>
</tr>
<tr>
<td>MSSQLMaxBrowseRecs</td>
<td><strong>To Configure the MSSQLMaxBrowseRecs Setting:</strong></td>
</tr>
<tr>
<td></td>
<td>1. In GoldMine, open the Tools menu and select Configure &gt; System</td>
</tr>
<tr>
<td></td>
<td>Settings.</td>
</tr>
<tr>
<td></td>
<td>2. Click the Display tab.</td>
</tr>
<tr>
<td></td>
<td>3. Set Maximum records shown in contact search center, activity list,</td>
</tr>
<tr>
<td></td>
<td>contact list, and contact record tabs value to any number (10 for</td>
</tr>
<tr>
<td></td>
<td>example).</td>
</tr>
<tr>
<td></td>
<td>4. Test the result by:</td>
</tr>
<tr>
<td></td>
<td>o Running a search in the Contact Search Center</td>
</tr>
<tr>
<td></td>
<td>o Opening any Records Pending tab and schedule more than 10 activities</td>
</tr>
<tr>
<td></td>
<td>(10 records display)</td>
</tr>
<tr>
<td></td>
<td>o Opening the Activity List and view Open Activities (10 records display)</td>
</tr>
<tr>
<td></td>
<td>o Opening Contact List (10 records display)</td>
</tr>
<tr>
<td></td>
<td>5. To restore the default value, set the Maximum records shown in</td>
</tr>
<tr>
<td></td>
<td>contact search center, activity list, contact list, and contact record</td>
</tr>
<tr>
<td></td>
<td>tabs value to 500.</td>
</tr>
</tbody>
</table>

SearchTopRec
<table>
<thead>
<tr>
<th>Setting</th>
<th>Configure</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQLQueryLimit</td>
<td><strong>To Set Maximum Number of Records Shown in SQL Query Results:</strong></td>
</tr>
<tr>
<td></td>
<td>1. In GoldMine, open the <strong>Tools</strong> menu and select <strong>Configure &gt; System</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Settings</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. Click the <strong>Display</strong> tab.</td>
</tr>
<tr>
<td></td>
<td>3. Set <strong>Maximum number of records shown in SQL Query results</strong> value to</td>
</tr>
<tr>
<td></td>
<td>desired number and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td>AllowDupEmails</td>
<td><strong>To Allow Duplicated E-mail Addresses:</strong></td>
</tr>
<tr>
<td></td>
<td>1. In GoldMine, open the <strong>Tools</strong> menu and select <strong>Configure &gt; System</strong></td>
</tr>
<tr>
<td></td>
<td><strong>Settings</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. Click the <strong>Advanced</strong> tab.</td>
</tr>
<tr>
<td></td>
<td>3. Check <strong>Allow e-mail addresses to be duplicated on multiple records</strong></td>
</tr>
<tr>
<td></td>
<td>check box and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td>OnByDefault</td>
<td><strong>To Turn Calendar Alarms On by Default:</strong></td>
</tr>
<tr>
<td></td>
<td>1. In GoldMine, open the <strong>Tools</strong> menu and select <strong>Options</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. Click the <strong>Alarms</strong> tab and then click the <strong>Alarms on by Default</strong></td>
</tr>
<tr>
<td></td>
<td>button.</td>
</tr>
<tr>
<td></td>
<td>3. Check the box(es) next to the desired types of Activity for which</td>
</tr>
<tr>
<td></td>
<td>you want to have alarms and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>4. Click <strong>OK</strong> again to close the dialog box.</td>
</tr>
<tr>
<td>FollowUp</td>
<td><strong>To Set Automatic Scheduling of Follow-Up Activity when Completing</strong></td>
</tr>
<tr>
<td></td>
<td><strong>an Activity:</strong></td>
</tr>
<tr>
<td></td>
<td>1. In GoldMine, open the <strong>Tools</strong> menu and select <strong>Options</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. Click the <strong>Alarms</strong> tab.</td>
</tr>
<tr>
<td></td>
<td>3. Check <strong>Prompt to schedule a follow-up activity when completing</strong></td>
</tr>
<tr>
<td></td>
<td><strong>an activity</strong> check-box and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>When you complete a scheduled Activity, a FollowUp activity creation</td>
</tr>
<tr>
<td></td>
<td>window appears.</td>
</tr>
<tr>
<td>ShowTipOfTheDays</td>
<td><strong>To Switch On the Option of Showing Tips at Every Startup:</strong></td>
</tr>
<tr>
<td></td>
<td>1. In GoldMine, open the <strong>Tools</strong> menu and select <strong>Options</strong>.</td>
</tr>
<tr>
<td></td>
<td>2. Click the <strong>System</strong> tab.</td>
</tr>
<tr>
<td></td>
<td>3. Check <strong>Show Tips at startup</strong> check-box and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>This option can be disabled on the Tip of the Day dialog box.</td>
</tr>
<tr>
<td>ROTabs</td>
<td><strong>To Rename Tabs for One User:</strong></td>
</tr>
<tr>
<td></td>
<td>1. In GoldMine, open any Contact Record.</td>
</tr>
<tr>
<td></td>
<td>2. On the tabs row, click <strong>tab selector</strong> tab (drop-down triangle) and</td>
</tr>
<tr>
<td></td>
<td>select <strong>Customize</strong> from the menu.</td>
</tr>
<tr>
<td></td>
<td>3. High-light the tab to be renamed and then click the <strong>Rename</strong> button</td>
</tr>
<tr>
<td></td>
<td>to give the tab new name.</td>
</tr>
<tr>
<td></td>
<td><strong>To Rename Tabs Globally:</strong></td>
</tr>
<tr>
<td></td>
<td>To rename tabs globally, follow the procedure above, but select</td>
</tr>
<tr>
<td></td>
<td>Customize tab labels globally.</td>
</tr>
</tbody>
</table>
Changing the User INI Settings

1. Open the Username.ini file:
   - From Windows Explorer, double-click Username.ini; the file opens in Notepad.
   - From a text editor (such as Notepad), select File > Open. Navigate to the GoldMine directory and select Username.ini.

2. To customize the file with command statements, see:
   - Setting E-mail Preview Text Amounts (see page 51)
   - Setting Keep or Clear on Tagged Records (see page 51).
   - Setting Calendar Publishing Output to XML (see page 51).

Setting E-mail Preview Text Amounts

By default, GoldMine displays 63 KB of message text. Increase the amount to preview very large messages.

1. Open the Username.ini file.
2. Beneath the [Internet] section, add:

   BodySizeLimitKB=<size in KB>

3. Select File > Save and then exit.

Setting Keep or Clear on Tagged Records

Set a standard of keeping or clearing tagged records.

1. Open the Username.ini file.
2. Beneath the [GoldMine] section, add this line, using a defined number:

   ClickUnselectDefault=<a number (where 0 is always ask, 1 is keep tagged records without asking, and 2 is clear tagged records without asking)>

3. Select File > Save and then exit.
4. Restart GoldMine to apply the changes.

Setting Calendar Publishing Output to XML

By default, GoldMine publishes the calendar to HTML. You can also publish to an XML file.

1. Open the Username.ini file.
2. Beneath the [CalObj] section, add:

   XMLOutput=1 (Publishes to XML. If XMLOutput=0 or if there is not XMLOutput setting, the calendar publishes to HTML.)
3. Use a customized XSLT file when publishing daily, weekly, or monthly calendars. In the same section, specify these transformation files:
   - ExternalXSLDaily=DailyFile.xsl
   - ExternalXSLWeekly=WeeklyFile.xsl
   - ExternalXSLMonthly=MonthlyFile.xsl

4. Select File > Save and then exit.

   **NOTE:** For best results, backup your .ini file before adding or changing any settings, and change only settings exactly as described in the online Help topics or contact Technical Support.

Username.tbi

Copy entire taskbars or just task groups from one user to another. The taskbar has one section, called \[gmbar\]. If you delete the username.tbi, you must log back into GoldMine as the user to recreate the file; however, it only has global task groups. You must copy or manually create the task groups.

Configuring System Settings


2. Select from the following tabs:
   - Auto-Upgrade (see "Automatic Upgrade of Workstations" on page 52)
   - Display (see "Contact Records and Notes Formatting" on page 52)
   - Advanced (see "Duplicate E-mail on Records" on page 52)
   - Preview (see "File Type Previews" on page 53)
   - Password Policy (see "User Password Policy" on page 53)
   - Script for unattended installation (see "Unattended Installation" on page 53)

3. Click OK to close the dialog box.

Automatic Upgrade of Workstations

On the System Settings dialog box, click the Auto-Upgrade tab to setup workstations to automatically upgrade when GoldMine upgrades.

   - UNC path and filename of installer (usually gmsetup.exe). Browse to find location.
   - UNC path and filename of configuration file (usually gm_si.ini). Browse to find location.

Contact Records and Notes Formatting

1. On the System Settings dialog box, click the Display tab to set contact record result limits and Notes formats.

2. At the Limits area:
   - Select the maximum number of records to display in the Contact Search Center, contact lists. Activity list and contact record tab.
   - Select the maximum number of MSSQL query results to display.

3. At the Notes area, select the HTML or Plain text option.

Duplicate E-mail on Records

1. On the System Settings dialog box, click the Advanced tab to allow e-mails to be duplicated on multiple records.

2. At the Contact’s permissions area, click the checkbox to allow e-mails to be duplicated on multiple records.

3. At the Universal Search area, click the button to install or uninstall Universal Search (see the “About Universal Search” in the User Guide or Online Help).
File Type Previews

1. On the System Settings dialog box, click the Preview tab to select the file types to display, such as Microsoft Word Document (doc) or HTML (htm).
2. Click each file type you want to display. All file types are selected by default.
3. To create a new file type, click New and type in the name of the file.
   
   **NOTE:** If you add a new file type, the document will open in the application associated with the file type, not within the GoldMine preview pane.
4. To delete a file type, select the type and click Delete.

User Password Policy

1. On the System Settings dialog box, click the Password Policy tab to set up password policies for users (see "User Passwords" on page 24).
2. Enter a minimum password length value.
3. Check to Block the account after 3 invalid logon attempts to prevent unauthorized access.
4. Enter a password repeat value.

Unattended Installation

1. On the System Settings dialog box, click the Script for unattended installation tab to:
2. Open the drop-down menu and select from the following installation types:
   - GM Upgrade from previous versions
   - New GM installation with connect to existing database
   - New GM installation with new database
3. Select or modify any of the Property Values.
4. Click the Create button to generate the script. The generated script is located in the \GoldMine\Setup\ directory.
   
   **NOTE:** For more information, see “To Create an Unattended Installation Script” in the GoldMine Installation Guide.

Mobile Device Messaging

1. On the System Settings dialog box, click the Messaging tab to set up alarm delivery messages (SMS - Short Message Service) to a users’ mobile device.

   **IMPORTANT:** Before GoldMine can send Activity reminders to mobile device users, receiving must be enabled for the GoldMine selected users (Tools > Options > Messaging tab). See the "Setting Options for the Messaging Tab" on page 42.

   **NOTE:** The Messaging tab is only available when a GoldMine Mobile license (M-License) has been added to the License Manager.
2. Check the Enable GoldMine Messaging box.
3. Specify the GoldMine username used to send GoldMine Alarms from the Send from drop-down list.
   
   **NOTE:** The selected username must have an email account already configured in their user options or the user will not receive reminder messages.
4. In the Message Template area, you can make changes to the following areas:
   - Text: The text the alphanumeric characters preceding the Macro.
Macro: The following macros can be used in the message body:

- [date] – date of an activity (CAL.ONDATE)
- [time] – time of an activity (CAL.ONTIME)
- [link] – link to an activity that is used to open it in GoldMine Mobile
- [reference] – reference (CAL.REF)
- [company] – linked contact name (Contact1.Company)
- [contact] – linked contact name (Contact1.Contact)
- [phone] – linked contact name (Contact1.Phone1)

5. Click the Show Example button to view a sample of the SMS message.

GoldMine Macros

Working with Macros

In GoldMine, a macro is a button or hot key shortcut representing an instruction, action, or a series of instructions, actions, or text inputs. For example, create a macro to launch the Schedule a Call window with a code, color reference, notes predefined, and the cursor waiting in the date field for you to finish editing the activity and save.

TIP: Record a macro using keystrokes rather than mouse-clicks. To use the GoldMine menus, type ALT+<Underlined letter of menu item>. Use the arrow keys or ALT+<Underlined letter of menu item> to navigate the menu options.

NOTE: Macro buttons are not displayed on the Standard Toolbar by default. To show the Record, Edit, Stop, and Pause buttons, add them to the Standard Toolbar. For more information, see "Customizing Toolbars" in the GoldMine User Guide PDF or in the Online Help.

To Record Macros

1. With Macro buttons activated in the Global Toolbar, click Record.
   The macro is ready to record. Also start the recording process by typing CTRL+SHIFT+HOME.

   TIP: Record a macro using keystrokes rather than mouse-clicks. To use the GoldMine menus, type ALT+<Underlined letter of menu item>. Use the arrow keys to navigate the menu options

2. Begin the steps to record.
3. When finished, click Stop on the Global Toolbar or press CTRL+SHIFT+END.
   The Define Macro Button dialog box opens.
4. In the Status Bar Description field, type a description of the macro to serve as the button name and pop-up text.
5. The Optional Hot Key is optional. Type the hot keys you are assigning to the macro; for example, to use ALT+9 as the hot key, hold down the ALT key and the 9 key. The Optional Hot Key box displays ALT+9.

**IMPORTANT:** Define hot keys carefully. SHIFT and a letter runs the macro every time it is typed. For example, using SHIFT+ G as your hot key, and then trying to type a company or contact name that begins with G in a new Contact record, the capital letter will not work. In other areas, such as the Contact Search Center, it runs the macro rather than searching for contacts beginning with capital G.

6. From the Playback drop-down list, select the playback speed for the macro.

   Select **Full Speed** to launch or run the macro quickly, or **Recorded Speed** to run the macro at the speed it was recorded.

**To Add Macros to the Taskbar**

After creating macros (see "To Record Macros" on page 54) use the following procedure to add a macro to the GoldMine Taskbar.

1. Click the Customize button on the Taskbar.
2. Right-click in the task group area and select **Add New Item**.
3. At the Taskbar Group Item Selection dialog box, select **GoldMine Users’ Macro** from the Item Type drop-down list.
4. Select the user who created the macro from the User drop-down list. Highlight the macro to add to the taskbar.
5. Browse to an icon file.
   
   The options display in the area below. Select an icon.
6. Click **OK** to add the item to the taskbar.

**To Delete Macros**

1. With Macro buttons activated in the Global Toolbar, click **Edit**. The Edit Macro Button dialog box appears.
2. Select the macro to delete, then click **Delete**. The Macro button on the Global Toolbar button is deleted.

**DDE Macros**

Facilitate DDEAUTO fields by selecting a macro as the service item. A DDE service item starts with an ampersand (&). When encountered, GoldMine searches an internal table of macro names. If a match is found, the macro processes and the result returns, as if a DDE function or expression was used.

Most macros are sensitive to the setting of the RECORDOBJ function’s SETRECORD subfunction. This function gains access to contacts and supplementary information.

When the SETRECORD type is set to PRIMARY, macros return the value from the corresponding fields in the primary information portion of the contact record.

When set to CONTACTS (additional contacts), or another supplementary record type, macros return the value from the corresponding field in the supplementary file (CONTSUPP).

These macros can be used as DDE service items:

**&Address**

Returns a string containing the values of &ADDRESS1 and &ADDRESS2, separated by a carriage return and line feed character. If &ADDRESS1 or &ADDRESS2 do not contain data, a single line of data returns, without the carriage return and line feed character.

Use this macro to perform rudimentary blank line suppression within linked applications that do not support blank address line suppression internally.

Use the &ADDRESS macro to return an additional contact address using the RECORDOBJ SETRECORD subfunction.
&Address1
Returns the first Address field from the active contact record. Typically, this value is extracted from the Address1 field in the primary display portion of the contact record; however, when using the RECORDOBJ SETRECORD subfunction to change the returned record type to CONTACTS, GoldMine returns the value from the Address1 field on the additional contact record, if a value is entered. When the Address1 field on the additional contact record is blank, the &Address1 macro returns the value in the Address1 field in the primary display portion of the contact record. When the RECORDOBJ SETRECORD type is set to return a record type other than CONTACTS, the &Address1 macro returns the value in Address1 field of the primary display portion of the contact record.

&Address2
Returns the second Address field from the active Contact Record. Typically, this value is extracted from the Address2 field in the primary display portion of the contact record; however, when using the RECORDOBJ SETRECORD subfunction to change the returned record type to ADDITIONAL, GoldMine returns the value from the Address2 field on the additional contact record, if an entry exists in the Address2 field on the additional contact record. When the Address2 field on the additional contact record is blank, the &ADDRESS2 macro returns the value in the Address2 field in the primary display portion of the contact record. When the RECORDOBJ SETRECORD type is set to return record types other than PRIMARY or ADDITIONAL, the &Address2 macro returns the value in the Address2 field of the primary display portion of the contact record.

&BrowseRecNo
Returns the record ID of the last selected record in a browse window.

&CalRefresh
Refreshes the graphical calendar display. Set up GoldMine to run this macro after adding calendar records using DDE.

&City
Returns the City field from the active contact record (similar to the action of the &Address1 macro). Use the &City macro to return an additional contact city using the RECORDOBJ SETRECORD subfunction.

&CityStateZip
Returns a format string of text containing the City, State and Zip fields from the active contact record. This string returns in this format:

   City, State Zip

The action of this macro string is similar to the action of the &Address1. Use the &CityStateZIP macro to return an additional contact city, state, and ZIP Code using the RECORDOBJ SETRECORD subfunction.

&CommonDir
Returns the BDE alias where the contact sets are located.

&Contact
Returns a contact name from the active Contact Record. Typically, this value is extracted from the Contact field in the primary display portion of the contact record; however, use the RECORDOBJ SETRECORD subfunction to change the returned record type to additional contact or another type of supplementary record. When the RECORDOBJ SETRECORD type is set to return record types other than PRIMARY, the &Contact macro returns the value in Contact field in CONTSUPP for the current supplementary record.

&Country
Returns the Country field from the active Contact Record (similar to the action of the &Address1 macro). Use the &Country macro to return an additional contact country using the RECORDOBJ SETRECORD subfunction.
&Dial1
Returns the Phone1 entry from the active Contact Record. The returned phone number is formatted for dialing. GoldMine applies the same rules used to dial the phone via TAPI. If selected, PREDIAL.INI settings are applied to phone number selection.

&Dial2
Returns the Phone2 entry from the active Contact Record. For details, see &Dial1 above.

&Dial3
Returns the Phone3 entry from the active Contact Record. For details, see &Dial1 above.

&DialFax
Returns the FAX entry from the active Contact Record. For details, see &Dial1 above.

&EmailAddress
Returns the primary e-mail address for the selected contact.

&Fax
Returns the fax number as it is sent to an auto-dialer for automatic fax transmission.

&Filter
the activated filter expression.

&FirstName
the first name of the current contact.

&FullAddress
Returns a string containing the address for the Contact Record, composed of values of &Address1, &Address2, &City, &State, and &ZIP.

The action of this macro string is similar to the action of the &Address1. Use the &FullAddress macro to return an additional contact address using the RECORDOBJ SETRECORD subfunction.

&GetRoTabID
the ID of the currently selected tab. Typically, this value verifies that the correct tab is selected when a user starts a custom application.

The following values are valid:
- Value Tab
- 0 Summary
- 1 Fields
- 2 Notes
- 3 Contacts
- 4 Details
- 5 Referral
- 6 Pending
- 7 History
- 8 Links
- 9 Members
- 10 Processes
- 11 Opps
- 12 Projects
13 Tickets

Example: (The following example tests the selection of the Details tab):

```vba
ch = DDEInitiate("GoldMine", "Data")
If DDERequest$(Ch, "&GetRoTabID") <> "4" Then
    MsgBox "You must select a detail record first"
End If
```

&GetRoTabPos

Returns the currently selected tab position. Since the tabs can be rearranged, this method is not always reliable for determining the currently selected tab. For more information, see &GetRoTabID above.

&GoldDir

Path information for BDE alias in which GoldMine is installed.

&LastFirstName

The name of the current contact in the format: last name, first name.

&LicUsers

The number of concurrent users allowed to log in to the installed copy of GoldMine.

&LicUsersAvailable

The number of users allowed to log in to the installed GoldMine license copy.

&NameAddress

Returns a string containing the contact name, company, and complete address of the active Contact Record. Each address line is separated by a carriage return and line feed, and the string is formatted so it can be inserted into a merge template. Any empty address lines on the Contact Record are suppressed. Use this macro to perform rudimentary blank line suppression within linked applications that do not support blank address line suppression internally.

The action of this macro string is similar to the action of the &Address macros, and the &NameAddress macro can be used to return an additional contact address using the RECORDOBJ SETRECORD subfunction.

&NameTitleAddress

Returns a string containing the contact name, title, department, company, and complete address of the active Contact Record. Each line is separated by a carriage return and line feed, and the string is formatted so it can be inserted into a merge template. Any empty lines on the contact record are suppressed. Use this macro to perform rudimentary blank line suppression within linked applications that do not support blank address line suppression internally.

The action of this macro string is similar to the action of the &Address macros, and the &NameTitleAddress macro can be used to return an additional contact address using the RECORDOBJ SETRECORD subfunction.

&NewRecID

Returns a unique record ID, which can be used when creating records.

&Notes

Returns the Notes from the active Contact Record. Typically, this value is extracted from the Notes field in the primary display portion of the Contact Record; however, use the RECORDOBJ SETRECORD subfunction to change the returned record type to additional contact or another type of supplementary record. When the RECORDOBJ SETRECORD type is set to return record types other than PRIMARY, the &Title macro returns the value in Notes field in CONTSUPP for the current supplementary record.

&Phone

Returns a telephone number from the currently selected Contact Record (similar to the action of the &Address1 macro). Use the &Phone macro to return an additional contact telephone number using the RECORDOBJ SETRECORD subfunction.
&Profile(s)

Includes two related macros:

- &Profile. Returns the first matching detail record for the selected contact.
- &Profiles. Returns detail records for the selected contact.

These macros take optional parameters. Each parameter must be separated by a period (.). Although GoldMine does not typically pass parameters with a DDE macro, the structure of &Profiles must be different for DDE fields in Microsoft Word document templates, which do not take DDE commands.

These examples show the syntax for the &Profile(s) macros:

&Profile Example 1
&Profile.ProfileName.Reference.Flags
Retrieves the first profile that matches the ProfilleName and Reference.

&Profiles Example 1
&Profiles.ProfileName.Reference.Flags
Retrieves all profiles matching the ProfileName and Reference.

In both of these examples, the Reference parameter is optional. If passed, it acts as a begin with condition on the profile reference. If the Reference parameter is not passed, all ProfileName profiles are evaluated.

Flag Parameters
The Flags parameter is also optional; it has these values:
- 2 returns the extended profile fields
- 4 returns the ProfileName and Reference

The &Profile(s) macro can easily fill in a Word table with the selected contact’s profile information because tabs separate each field value, and a CR/LF separates each profile record.

&Profile Example 2
This example returns the first e-mail address of the contact:
- &Profile.E-mail Address
- &Profiles Example 2
This example returns computer profiles beginning with the word notebook:
- &Profile Example 3
These examples use the Flag parameter to specify the profile fields to return:
- &Profiles.Computer.NotebookNotebook Toshiba P105-S6167|Notebook HP Pavilion dv9260us|Notebook Lenovo ThinkPad T60|
- &Profiles.Computer.Notebook.4Computer|Notebook Toshiba P105-S6167|Toshiba|1.60GHz|Computer|Notebook Lenovo ThinkPad T60|Lenovo|166GHz|

&RoTabPage
Returns the selected tab. Typically, this value verifies that the correct tab is selected when a user starts a custom application. Values between 1–9 represent tabs in the first row of tabs; for example, 1 represents the Summary tab. Values between 10–18 represent tabs in the second row, and 19–27 represent tabs in the third row.

This example tests the selection of the fifth (Details) tab:
ch=DDEInitiate("GoldMine", "Data")If DDERequest$(Ch, "&RoTabPage") <> "5" ThenMsgBox "You must select a profile record first"End If
&SerialNo
Returns the serial number of the installed GoldMine program.

&ShutDown
Logs out the currently logged user, and quits GoldMine.

&State
Returns the State field from the active Contact Record (similar to the action of the &ADDRESS1). Use the &State macro to return an additional contact state using the RECORDOBJ SETRECORD subfunction.

&SysDir
Returns the GoldMine system directory.

&SysInfo
Displays system information as returned by Help > About GoldMine > System information.

&Title
Returns the Title from the active Contact Record. Normally, this value is extracted from the Title field in the primary display portion of the contact record; however, use the RECORDOBJ SETRECORD subfunction to change the returned record type to additional contact or another type of supplementary record. When the RECORDOBJ SETRECORD type is set to return record types other than PRIMARY, the &Title macro returns the value in the Title field in CONTSUPP for the current supplementary record.

&User_Var
Returns the defined field value from all users, a specified user, or the currently logged user.
The &User_Var macro allows GoldMine users to store specific data that can be retrieved later into applications that are linked via DDE with GoldMine. This macro can be defined in the [user_var] section of both the GM.INI and the username.INI of GoldMine.
Usage Syntax: &User_Var.<variable name>.<GoldMine username>
Example: &User_Var.Territory.Dan
where<variable name> is a descriptive name of the macro and <GoldMine username> assigns a defined value to a specific GoldMine user. <GoldMine username> is optional, as GoldMine will assign these values to the current GoldMine user.

&UserFullName
Returns the full name of the logged in GoldMine user as it appears in the FullName field in the Users Master File.

&UserName
Returns the name of the logged in GoldMine user.

&Version
the version number of the installed GoldMine program.

&WebSite
Returns http://<web site> for the active contact.

&ZIP
Returns the ZIP field from the active Contact Record (similar to the action of the &Address1). Use the &ZIP macro to return an additional contact ZIP Code using the RECORDOBJ SETRECORD subfunction.
GoldMine Report Macros

The following is a compiled listing of information pertaining to the macros used within GoldMine reports along with a short description.

Some macros are only available within the “Calendar Printouts” reports category. The remaining macros are available in all of the report categories. They have been separated within this document for organizational purposes.

All Report Categories

&FullAddress
Displays Address1, Address2, City, State, Zip, and Country. A line feed separates address lines. City, State, Zip values are displayed on one line.

&Company&Address
Displays Contact Name, Company Name, Address1, Address2, City, State, Zip, and Country. A line feed separates all fields except for City, State, and Zip, which are displayed on one line.

&Address1&2
Displays Address1 and Address2 data separated by a line feed.

&Contact, Company
Displays Contact Name and Company Name separated by a semi-colon.

&Name&Address
Displays Contact Name, Title, Department, Company Name, Address1, Address2, City, State, Zip and Country. A line feed separates all fields except for City, State, and Zip, which are displayed on one line.

&Company
Contact Company Name, Contact Name separated by a semi-colon.

&Title&Address
Contact Name, Title, Department, Company Name, Address1, Address2, City, State, Zip, and Country. All fields separated by a line feed, except for City, State, Zip, which appear on the same line.

&CityStateZip
City, State, Zip displayed on the same line. City and state values are separated by comma.

&SourceFile
Returns the name of the database file being accessed in the current Section.

&CalActvName
Outputs the name of the scheduled activity being printed, based on the RECTYPE. For example, if a record of RECTYPE S is printed, the macro will return a value of “Sale”.

&HistActvName
Works in the same manner as &CalActvName, except that it returns names based on history records, not calendar data.

&User
Outputs the user name of the currently logged in user.

&FullName
Returns the full name of the currently logged in user, as defined in File > Configure GoldMine > Users File.
&Licensee
Outputs the “Licensed To:” company name as defined when the GoldMine serial number was specified.

&Sort1
Outputs the data from the field set as the primary sort for the report. Can also be used to specify a break field within a sort header. For example, if the primary sort of a report is set to contact1->company and I insert the value of &Sort1 for the break field in the sort header, the report will then break on contact1->company.

&Sort2
Outputs the data from the field set as the secondary sort for the report. Can also be used to specify a break field in the same manner as the &Sort1 value.

&Sort3
Outputs the data from the field set as the tertiary sort for the report. Can also be used to specify a break field in the same manner as the &Sort1 value.

&Phones
Outputs all three of the phone numbers, the fax number, and the extension fields.

&LocalLabel
Returns the local label of the field specified after the colon.

&Suppfile="xxx" Used to specify break fields and filters within sections of reports. The “xxx” value must be at least two characters, but no greater than three. It is used to specify the database and record types you want to include in a report section. The first two characters specify the database and the third specifies the RECTYPE within that database. Possible values for the different databases are as follows: cs = CONTSUPP.DBF, ca = CALENDAR.DBF, ch = CONTHIST.DBF. The different RECTYPEs that can be specified as the third character are listed in the “Database Structures” section of your manual.

NOTE: The ADDRESS3 field data found in the GoldMine CONTACT1 table is included in those macros that return address information.

Calendar Printouts Section Only

&Detail1
Displays the information that has been specified in the “Options” window for the report.

&Year
Returns the value of the current year in four-digit format, such as 2009. The macro will also return the value of the year for all dates within the specified date range under the report’s options. For example, if the date range is set as 01/01/07 to 01/31/09, the macro will return all values that fall within the date range (i.e. 2007, 2008, and 2009).

&Month Returns the numeric equivalent of the current month. For example, January = 1, February = 2, etc. The macro also returns the value of the month for all dates within the specified date range in the report’s options. For example, if the date range is set as 10/01/08 to 01/31/09, the macro will return all values that fall within the date range (i.e. 10, 11, 12 and 1).

&CMonth
Returns the name of the current month (For Example, January, February, etc.). The macro will also return the value of the month for all dates within the specified date range under the report’s options. For example, if the date range is set as 10/01/08 to 01/31/09, the macro will return all values that fall within the date range (i.e. October, November, December and January).
&CMonthYr
Returns the name of the current month, plus the 4-digit year (For example: January 1998). The macro will also return the value of the month and year for all dates within the specified date range in the report’s options. For example, if the date range is set as 11/01/07 to 01/31/09, the macro will return all values that fall within the date range (i.e. November 2007, December 2008, and January 2009).

&Day
Returns the numeric value of the current day (For example, 12, 100, 300, etc.). The macro will also return the value of the day for all dates within the specified date range under the report’s options. For example, if the date range is set as 01/29/09 to 01/31/09, the macro will return all values that fall within the date range (i.e. 29, 30, and 31).

&Dow
Returns the numeric value of the day of the week. For example, a date which falls on Wednesday would return a value of 4, etc. Sunday is considered as being the 1st day of the week. This macro will also return all values within a date range.

&CDay
much in the same manner as the &Dow macro, except that instead of returning a numeric value, it returns the actual name of the day. For example, if a date falls on a Sunday, the macro will return the value “Sunday” and so forth.

&DayNo
Returns the day number based on the year. For Example: January 2, 2009 = Day 2.

&WeekNo
Returns the week number of the year, similar to &DayNo. Jan 5–11 = Week 2.

&WDay1
Returns the numeric day value of the Monday for the workweek in which the date falls. Assume that we are looking at records that fall on Wednesday January 28, 2009, the value returned by the macro would be 26. Since the 28th is a Wednesday, Monday is the 26th for the week of January 28, 2009.

&WDay3
Functions in the same manner as the macro &Wday1, except that it returns the numeric day value of the third work day of the week, or Wednesday.

&WDay4
Functions in the same manner as the macro &Wday1, except that it returns the numeric day value of the fourth work day of the week, or Thursday.

&WDay7
Functions in the same manner as the macro &Wday1, except that it returns the numeric value of the seventh work day of the week, or Sunday.

&Hour
Displays the time in hourly increments from 7:00 AM to 7:00 PM, generated in 12-hour format.

&Time
Returns the scheduled time for calendar records, in 12-hour format.

&FrDate
Displays the From: date entry from the report’s options.
&ToDate
Displays the To: date entry from the report’s options.

&LastMonth
Generates a graphical representation of the prior month, based on the date of the calendar records on the current report page. For example, if my report is displaying items for the month of January, the macro will print the graphical month of December.

&ThisMonth
Generates a graphical representation of the current month, based on the date of the calendar records on the current report page. For example, if my report is displaying items for the month of January, the macro will print the graphical month of January.

&NextMonth
Generates a graphical representation of the next month, based on the date of the calendar records on the current report page. For example, if my report is displaying items for the month of January, the macro will print the graphical month of “February.”
Contact Management Administration

Overview

GoldMine uses the contact record (contact) as the core component to which all information is tied. When a contact is added to GoldMine's database, a contact record is created. It contains information such as name, address, and telephone information for a person or company. The record's many fields record pertinent and updated information, always making the newest contact information available to GoldMine users.

**NOTE:** The default view for Contact Records is the **Contact List** view. Double-click on a contact to open that Contact Record.

The Contact Record has two basic sections:

- **Upper section** contains standard contact information such as name, address and telephone numbers, and five user-definable fields. This is the primary contact information which displays the company's name and primary contact.

- **Lower part** organizes secondary information, such as Relationships, notes, pending activities, and history records, into Contact tabs storing information linked to the Contact Record.

Each record also has a set of associated customizable properties:

- **Record-related Settings.** Phone number format, record ownership, and alerts.
- **Contact Details.** Occasions, free/busy, and digital IDs.

This section covers Administrator topics. For information on User procedures, refer to the *GoldMine User Guide*.

About Record-Related Settings

You can define or view record-related settings for the active contact record. To access the Record-related Settings dialog box, select **Edit > Record Properties > Record-related Settings** and select a tab:

- **Phone Formatting.** Select the USA Format, which applies the standard telephone number format for the United States and Canada, or the Non-USA Format, which does not apply formatting. See "Setting Phone Formatting in the Record-Related Settings" on page 66.

- **Ownership.** Control what information can be viewed and updated by other users. See"Setting Ownership in the Record-Related Settings" on page 67

- **Alerts.** Assign a code to an active contact record to alert other GoldMine users of a special status or situation regarding the contact. See "Setting Alerts in the Record-Related Settings" on page 68.
Setting Phone Formatting in the Record-Related Settings

GoldMine formats telephone numbers in standard US format if your Windows language setting is English. The standard US format is (999)999-9999. You can type the numbers in without formatting, and GoldMine translates it in the formatted style.

Change the telephone number format for an active contact record from the Phone Formatting tab of the Record-related Settings dialog box.

For other language settings, GoldMine formats telephone numbers in the international telephone number format. The international telephone number format leaves the telephone number as entered.

Each contact record maintains its own telephone format setting. To specify the international telephone number format when adding a new contact record, change the setting of the International Format field in the Add a New Record dialog box.

To Set Up Phone Formatting

1. At the contact detail view, select Edit > Record Properties > Record-related Settings.

   ![Record-related Settings dialog box]

2. Select the Phone Formatting tab and select one of the following:

   USA Format. Formats the telephone number on the contact record to the United States and Canadian standard: (999) 999-9999. No matter how the numbers are entered they will be formatted in this style.

   Non-USA Format. Does not apply formatting to the telephone numbers.

   Use a consistent format for international phone number entries. When checking for duplicate records, GoldMine considers entries for the same number but with differing formatting as separate entries. For example, GoldMine considers 55 12 345-6789 to differ from 5512 345-6789.

3. Click OK.

   The phone format you selected applies to the active contact record.
Setting Ownership in the Record-Related Settings

Record curtaining is controlled by the record Owner. Each contact record can be public or private. Private records are records that have been assigned an owner, either an individual GoldMine user, or a user group. Applying record curtaining hides data on contact records from users who are not owners of the record. With record curtaining, if a user tries to display a contact record that he or she does not own, the contact screen is partially or completely curtained, hiding the data from view.

1. Select **Edit > Record Properties > Record-related Settings**.

2. Select the **Ownership** tab.

3. At the **Owned by** drop-down list, select the owning user or user group.

When new records are added to the database, the default owner is (public) unless the user has specific Ownership settings configured in the User Properties dialog box.

4. In the **Record Curtaining** area, select an option:
   - **None**: All users can view the entire contact record.
   - **Semi-partial (hide tabs)**: All users can view the contact information in the Primary Fields View, but only the owning user or user group can view the information in the Tabs. The tabs are curtained, marked private, and cannot be viewed.
   - **Partial**: All users can view the top four rows of the Primary Fields View. The other rows in the Primary Fields View and the tabs are curtained, marked private. The owning user or user group can view all information in the Contact record.
   - **Complete**: The entire record is curtained, which means that users who do not own the record cannot see it or locate it using the Contact Search Center. The owning user or user group can view all information in the Contact record.

   **NOTE**: Users with Master Rights are able to view information in the contact records, without regard to the owner or what level of curtaining has been set.

5. When you are finished, select **OK**. The settings you configured are now applied to the active contact record.
Setting Alerts in the Record-Related Settings

Assign an alert to an active contact record to notify other GoldMine users of a special status or situation regarding the contact.

To Set Up an Alert

1. Select **Edit > Record Properties > Record-related Settings.**

2. Select the **Alerts** tab.

3. Click on the **Enable alerts** check box. After selecting this option you can activate one or more of the alerts in the panel. By default, GoldMine displays the alert seven seconds after you display the record. However, change the delay period by changing the GM.ini file setting for RecAlertSec.

4. Click **New Alert** to add a new alert.
5. On the **New Contact Alert** dialog box, define these options for the three-character alert code you are creating:
   - **Code.** Type the three-character code representing the alert status.
   - **Alert Description.** Type a brief description of the alert.
     
     **NOTE:** You must enter an Alert Description to save the alert.
   - **Message.** Type the extended message to appear when users activate the Contact record.

6. Click **OK** to return to the Alerts tab.

7. Select one or more alerts to activate when accessing the contact record.

8. Select **Log this alert in history when user is alerted** to log the date, time viewing user, alert code and the assigning user in the **History** tab. GoldMine adds the history record when the alert appears, not when the view user closes the alert.

9. When finished, click **OK.**
   
   The alerts are assigned to the active Contact record.
   
   View available alert codes in the InfoCenter. In the InfoCenter, select **System > Contact Alerts.**

### Changing the Delay Time on Alerts

By default, GoldMine displays an alert 7 seconds after the user displays a contact record to which an alert has been assigned.

To change the time delay before the alert appears, place the following setting in the [GoldMine] section of the **GM.ini** file.

```
RecAlertSec= <number of seconds before alert appears>
```

### Setting Digital IDs in Contact Details

If a contact uses a digital ID when sending you e-mail, configure the contact’s record with the ID information.

**To Set Digital IDs**

1. With the contact record active in GoldMine, select **Edit > Record Properties > Contact Details.**
2. At the Contact Details dialog box select the **Digital IDs** tab.
3. Click **Import** to add a contact’s digital ID file to the GoldMine contact record.
4. At the **Import Digital ID** dialog box, at the **Filename** field type or browse to the *.p7b or *.cer certificate file you are importing.
   
   In the **Name** field, type the name to display.

5. Click **OK** to return to the Digital IDs tab.

6. To export the file to another location, click **Export** and select a location.

7. To review the certificate details, click **View.**
   
   To remove a digital ID, highlight the ID and click **Delete.**
Contact Communication Administration

Overview

You can use GoldMine to print and fax correspondence, send e-mail, send pages, and distribute literature. GoldMine integrates the functionality of your word processor and e-mail software to communicate with contacts and coworkers.

- **E-mail.** Send, retrieve, and manage Internet e-mail. Individuals within an organization can use GoldMine e-mail, providing the same features as Internet e-mail, but not requiring an online connection.

- **Printing and Faxing Correspondence.** GoldMine works with Microsoft Word to merge contact information from GoldMine into templates, generating personalized correspondence. GoldMine's Document Management Center provides a central location to access and manage correspondence.

- **Distributing Literature.** Organizations can manage requests for printed material, such as brochures and price lists, using GoldMine's Literature Fulfillment Center.

- **Paging.** Send a pager message by dialing or sending e-mail.

This section describes Administrator procedures. For User procedures see the *GoldMine User Guide*.

Setting Default File Name and Folder Location for Templates

Use the following procedure to set default document file names and folders for document templates.

1. Using a text editor (such as Windows Notepad), open USER.ini (your <username>.ini).
2. Find the statement under the `[Internet]` section that begins with `AttachDir`:
   
   ```
   AttachDir=C:\Program Files\GoldMine\MailBox\Attach
   ```

3. Replace this with the following:

   ```
   AttachDir=C:\Program Files\GoldMine\Templates
   ForceFilename=1
   ```

   In this example, `C:\Program Files\GoldMine\` should be replaced with the path to your main GoldMine folder. When `ForceFilename` is set to 1, GoldMine forces each file that a user saves to follow a format that includes the user's destination folder\filename_date in the YYYYMMDDformat_incremental three-digit number (to prevent duplicate file names).

   This example shows a force file setup for John:

   ```
   C:\Program Files\GoldMine\Templates\John\BlankLetter_20101115_001.doc
   ```

4. Select **File > Save** to save the changes to the USER.ini and exit the text editor.
Setting E-mail Account Properties

Define properties for individual Internet e-mail accounts when selecting New or Edit from the Accounts tab of the <User’s> Options window. The E-mail Account Properties dialog box opens.

1. On the <User’s> Options dialog box, click the E-Mail tab.

2. Click the Accounts button, highlight the account you are changing and then click Edit; or click New to create a new account.

The E-mail Account Properties dialog box opens.

3. In the Account Name field, type a descriptive name for the account to appear on the E-mail Center > Accounts tab.

4. Select Show the account in the E-mail Center to display the account in the E-mail Center. For the account to not appear in the E-mail Center, clear the option.

5. In the Getting Mail area, configure:
   - E-mail retrieval protocol. Choose either:
     - POP3
     - IMAP
   - Server. The name of the mail server retrieving your mail. For example, the structure of the entry might look like mail.somewhere.com. Typically, the same server is used for outgoing protocol SMTP and retrieval protocols POP3 or IMAP. If you do not know the correct entry for this field, contact your Internet service provider.
     
   
   NOTE: POP3, or Post Office Protocol version 3, and IMAP, or Internet Message Access Protocol, are systems for retrieving e-mail.
   - Username. The name you use to log into your Internet mail server. Type only your user account name, not your entire e-mail address.
   - Password. The password you use to log into your Internet mail server. When you type the password into the field, each character appears as asterisks (*).
   - Auto-retrieve. Select Auto-retrieve for GoldMine to automatically connect with your POP3 or IMAP mail server for the selected account and check for new mail. The interval for checking the account is defined globally in the Retrieval tab. GoldMine checks for new mail in all accounts with this option.
   - Auto-delete. Select Auto-delete to remove messages from the Internet mail server after they have been retrieved.
   - Use encrypted connection (SSL). Select this checkbox to use a secure connection. This ensures the privacy of the connection between your account and the server. Implementing SSL does not verify the identity of your account or the e-mail server, but does prevent third parties from listening or recording messages sent between them.
     
     NOTE: Selecting Use encrypted connection (SSL) changes port numbers on the server side. Servers usually have dedicated ports for secure connections.
   - Port. Type any non-standard port address to the POP3 or IMAP server for the selected account. This option allows greater flexibility in setting up a nonstandard server. The default POP3 Port value is 110. The default IMAP Port value is 143. Typically, this entry should not be changed. However, if your account uses a non-standard POP3 or IMAP server configuration requiring a different port entry, contact your network administrator or Internet service provider.

6. In the Authentication area, configure the way your POP3 or IMAP server recognizes and authenticates your account and password. The selections are:
   - Login
   - NTLM
   - CRAM-MD5
   - Plain
   - None
7. In the **Sending Mail** area, configure:
   - **SMTP server.** Type the name of the mail server sending your mail. For example: mail.somewhere.com. Typically, the same server is used for both SMTP and POP3 or IMAP. If you do not know the correct entry for this field, contact your Internet service provider or network administrator.
   
   **NOTE:** SMTP, or Simple Mail Transport Protocol, is a system for sending mail.
   - **Your return address.** Type your Internet address. This is typically a combination of your Internet user name and server name. For example, johndoe@somewhere.com.

8. In the **Authentication** area, configure the way your SMTP server recognizes and authenticates your account and password.
   - **Use signature file.** Attach a signature file (a text file containing information about you, your organization, telephone number quotations, and so on) to account messages. Select Use signature file and browse to the file location.
   
   **NOTE:** HTML Signature files with embedded images do not display the images properly when sending e-mail from a linked e-mail address to a contact.

9. Click the **Advanced Options** button to set special options for the POP and SMTP server.

10. Select **OK** to return to the Accounts tab of the Internet Preferences window.

---

### Configuring Your Computer to Access Your ISP

If your computer is connected to a LAN or other high-speed internet connection, you need only set account properties in GoldMine to access e-mail and other Internet-based features.

Use the following procedure to create a new network connection in Microsoft Windows.

1. From the desktop, select **Start > Programs > Accessories > Communications > Network Connections.**
   
   The **Network Connections** dialog box opens.

2. At the **Network Tasks** menu, click **Create a new connection.**

3. At the New Connection Wizard welcome screen, follow the on screen instructions to create a new high-speed or dial-up connection.

For more information about configuring Windows networking functions, see *Microsoft Windows Help.*

**NOTE:** Default modem and dialing properties in Windows are set up in the Phone and Modem Options Control Panel. However, select special modem and dialing settings for use only with GoldMine in the Options dialog box under the Telephony tab.

---

### Configuring Internet E-mail Retrieval

To retrieve Internet e-mail within GoldMine using a dial-up Internet Service Provider (ISP), you must use a ISP with true Internet mail access. Internet access provided by most commercial online services, such as *CompuServe* and *Microsoft Network,* will not work with the GoldMine Internet e-mail feature. You must configure Windows for dial-up networking to connect to your ISP.

**NOTE:** For assistance with setting up Windows to communicate with your Internet service provider, contact your service provider.

You can retrieve e-mail two ways: **Manually** or **Automatically.**
To Configure Manual E-mail Retrieval

The default configuration in Windows requires manual dialing.

1. From the Microsoft Windows status bar, click Start.
2. Select Programs > Accessories > Dial-up Networking.
3. In the Dial-Up Networking window, double-click the icon for your service provider.
4. In the Connect To window, ensure all settings are correct, then select Connect.
5. After your computer connects successfully, start or switch to GoldMine, then retrieve Internet e-mail.

To Configure Automatic E-mail Retrieval

Your Internet Preferences must be configured properly in the User's Preferences. Using the Microsoft Internet Explorer, you can configure Windows to automatically dial your ISP when you retrieve Internet e-mail. The default configuration in Windows requires manual dialing.

1. From the Microsoft Windows status bar, click Start and then select Programs > Accessories > Dial-up Networking.
2. In the Dial-Up Networking window, double-click the icon for your service provider.
3. In the Connect To window, ensure all settings are correct, then select Connect.
4. After your computer connects successfully, start or switch to GoldMine, then retrieve Internet e-mail.

Configuring Internet E-mail

Use the following procedure to configure Internet e-mail.

1. Configure e-mail settings by selecting Tools > Options.
   The User's Options dialog opens. Select the E-mail tab.
2. After e-mail options have been set, retrieve internet or Outlook e-mail messages manually or automatically in the E-mail Center.
   - Select Go To > Mail.
     The E-mail Center opens.
3. In the view window of the Navigation Pane, click an account in your Online folder to check internet e-mail, or open the Outlook folder to manage Outlook messages.
   TIP: For more information, see “Configuring the Sending and Retrieving of E-mail” on page 328
Creating E-mail Rules

Create rules set to specify conditions and actions for handling e-mail. For example, use e-mail rules to filter incoming messages, minimizing the amount of unwanted e-mail.

1. In the E-mail Center, right-click and select **Options > Set up E-mail rules** or click **Set up E-mail Rules** from the toolbar.

The E-mail Rules Center welcome page appears. Click **OK**.
2. Right-click the left pane and select **New Rule Set**.
   The E-mail Rules Wizard opens.

3. Type a name in the text box.

4. To apply the rules to different types of messages, select from **Incoming E-mail**, **Outgoing E-mail** or **Incoming and Outgoing**, and then click **Next**.

5. At the E-mail Rules Wizard: Condition page, select one of the following and click **Next**:
   - Select **ALL of the following conditions must be true**.
   - ANY ONE of the following conditions may be true.

   To delete a selected rule condition, click **Delete**.

6. To define or change a condition, click **New** or **Edit**. The E-mail Rule: Condition dialog box appears.
You can define one or more conditions for GoldMine to evaluate when retrieving online messages. These conditions specify attributes for GoldMine to check. If a message meets the conditions, GoldMine can then apply the actions defined using the E-mail Rules Wizard.

- **Mail Field**: Select the e-mail field for GoldMine to search for a specified value, such as **From**, **To**, **CC**, and so on.
- **Logical Condition**: Select a condition such as **Begins with**, **Contains**, **Equal to**, **Not Equal to** and so on.
- **Value**: Type the value for GoldMine to search when evaluating the field selected in *Mail Field*. The Value depends on what Mail Field field and Logical Condition are used. For example, if the Mail Field field is set to **From** and Logical Condition is set to **Contains**, then in the Value field you can set any part of the E-mail address of the sender.

7. Click **OK** to enter the condition.
   - To add another condition, click **New**.
   - To change a selected condition, click **Edit**.

8. After adding all conditions, click **Next**. The E-mail Rules Wizard: Actions dialog box appears.
The actions you set in the E-mail rules determine what happens to the e-mail after conditions are met. The E-mail Rules: Actions dialog box appears after you configure e-mail rule conditions.

a. To create a new rule, click **New**.

![E-mail Rule: Action](image)

- **Action on Mail**: In the drop-down list, select the operation GoldMine will perform upon detecting a message with the specified conditions such as Move to inbox or Delete Attachments.
- **Value**: Provides additional information necessary for GoldMine to complete the operation. For example, if you selected Move to inbox as the Action on Mail, select the subfolder of your inbox where GoldMine will place the messages that meet the condition(s).

**NOTE**: The Value field only appears when a value is needed to complete the action. For example, if you selected Delete Attachments as the Action on Mail, GoldMine needs no further information to process this request, so the Value field does not appear.

b. Click **OK** to enter the rule in the browse window of the Actions screen. To add another action, click New. To change a selected action, click Edit.

c. Click **Finish**. GoldMine adds the rule to the selected rule set. The name of the rule appears in the left pane under the rule set. The selected condition(s) and action(s) of the rule set appear in the right pane.

9. After configuring actions, click **Finish**.

GoldMine adds the rule to the selected rule set. The name of the rule appears in the left pane under the rule set. The selected conditions and actions of the rule set appear in the right pane.

---

**Using the Document Management QuickStart Wizard**

GoldMine Plus for Microsoft Office is installed during the main GoldMine application installation. It can also be installed independently by using the Add/Remove Programs Windows control panel.

GoldMine Plus for Adobe Acrobat is installed from its own installer. For more information about installing and using GoldMine Plus for Adobe Acrobat, refer to the [GMAcrobatLink.pdf](#), located on your GoldMine installer CD, or via: [http://support.frontrange.com](http://support.frontrange.com).

**NOTE**: GoldMine must be installed locally in order to install the Acrobat Link. It will not function from a shared folder location.
This Document Management QuickStart Wizard directs you to an informational web page. It does not install any add-on products.

1. Select **Tools > Quick Start Wizard**.
   The GoldMine QuickStart Wizard dialog box opens.

2. Click the **Document Management Wizard** button.

   A web page opens in your browser showing details about the GoldMine Plus suite of products.

## Customizing Auto-dialer Settings

With the advent of multiple area codes in metropolitan areas and telephone dialing capabilities in computers, GoldMine developed a method for differentiating between local and long distance calls, letting GoldMine users dial the phone using the modem in a computer without entering special dialing codes.

A user-created, configuration settings file called **predial.ini** that is placed in the GoldMine folder handles the differentiation between local and long-distance calls. The file consists of four sections: **[City]**, **[Prefix]**, **[Suffix]**, and **[PBX]**. Each section is scanned in the listed order until a match is found. This terminates the search, and GoldMine uses the values found to dial the phone ignoring settings in lower sections of the **predial.ini**. The exception is the **[Suffix]** section; GoldMine checks this section for a match, thus terminating the search when a match is found.

Set auto-dialer to recognize differing telephone number types, prefixes, and suffixes by creating an **Exception List** in a **predial.ini** file. An exception list provides a set of conditions GoldMine checks when processing telephone numbers formatted for North America. For example, you might need to set up your auto-dialer to recognize different types of telephone numbers, such as local and long distance. Upon finding a match to specified conditions, GoldMine processes telephone numbers according to the formatting entered for the condition.

**NOTE:** See Technical Document 387, “Using and Setting up GoldMine’s PREDIAL.INI for Special Dialing Needs” at [http://support.frontrange.com](http://support.frontrange.com).

## Configure Calls with SoftPhone

SoftPhone integration with GoldMine uses SIP (Session Initiation Protocol) and VoIP (Voice over IP) technology to place and answer contact calls. The SIP Proxy (not included with GoldMine) must be configured and its functionality verified by an administrator. The administrator can then configure GoldMine to make and receive calls through the SIP Proxy Server by setting SoftPhone preferences.

**NOTE:** For administrators: If a SIP Proxy Server is being unused in the environment, edit user properties to remove Launch SoftPhone from the GoldMine menu. This avoids attempts to call through this feature when a SIP Proxy Server is not present.

**IMPORTANT:** You can record phone calls through the use of the Licensed Software. The law on recording phone calls varies from country to country and state to state. FrontRange recommends that you inform the other party or parties to your phone call that you are recording their conversation. However, it is your responsibility to comply with all applicable laws and regulations in your use of the Licensed Software. You agree to abide by all applicable communication, privacy and similar rules, directives and other laws in your use of the Licensed Software. In no event will FrontRange be liable for any action or inaction on your part which leads to or causes you to break the law.
Overview

GoldMine's extensive feature set lets you share data between GoldMine and other applications, to globally replace field data, and to monitor running processes.

Maintaining the data in your GoldMine database ensures the highest performance for your system and the most effective use of information. GoldMine is equipped with many features to help maintain your system.

Choosing an Edition of SQL Server

In most environments, GoldMine works well with SQL Server Express Edition to support about 20 concurrent GoldMine users. In environments with more users or with a significant amount of data in the GoldMine database, select an appropriate edition of SQL Server based on need. For more information about which SQL Server Edition is appropriate for the needs of your organization, please visit Features Supported by the Editions of SQL Server 2012.

About Contact Set Databases

Use the Contact Set Databases dialog box to create, attach, delete, and edit contact database properties. To open the Contact Set Databases dialog box, use the following procedure.

1. Select Tools > Databases > Open Database.
   
   The Contact Set Databases dialog box opens. The currently attached Contact Set databases display in the database list stored in the SPFiles table. The buttons are explained below:
   
   - **New.** Launches the Database Wizard. Create a new database. See "Data Maintenance and Management" on page 81.
   - **Attach.** Opens the Contact Set Profile dialog box. Attach a database to the Contact Set listing. See "Defining Contact Set Profiles" on page 82.
   - **Delete.** Deletes the highlighted database.
   - **Properties.** Opens the Contact Set Profile dialog box. Edit properties of an existing database. See "Defining Contact Set Profiles" on page 82.
   - **Open.** Opens the highlighted database in GoldMine. See "Opening Databases" on page 82.
   - **Close.** Closes the Contact Set Databases dialog box.

2. If you right-click the database list with a database highlighted, select Open, Attach Database, New, Delete, and Properties options, and also select:
   
   - **Maintain Database.** Launches the Maintenance Wizard. See "About Maintaining Databases" on page 87.
   - **Find.** Searches for words in the Description, Access, and Database/Location fields.
   - **Output to.** Output the Contact Set list to the printer in a GoldMine Report format, Word, Excel, or the clipboard.
Defining Contact Set Profiles

The Contact Set Profiles dialog box appears when editing the Properties or Attaching Databases. You can set the description and path, ownership and access, and the SQL login information.

Use the following procedure to define contact set profiles.

1. Select **Tools > Databases > Open Database**.
   The Contact Set Databases dialog box opens.

2. Highlight the database and click **Properties** to edit an existing database, or click Attach to add a database to the Contact Set Database list. The Contact Set Profiles dialog box opens.

3. In the **Contact Set** area, type the **Description** in the field.

4. Type the three-letter **File Code**.
   This is a unique code used to identify a database among multiple databases when GoldMine synchronizes.
   
   **NOTE:** The File Code is required for synchronization.

5. The **Server Type** drop-down list displays the type of database (fixed; you cannot add or change an entry in this field).

6. Select the appropriate **Alias** from the drop-down list (displays known aliases; auto populated based on Database Connections Manager).

7. In the Owner text box, retain the default dbo or type the owner of a SQL database.

8. In the GoldMine File Ownership & Access area, select a user or user group from the Grant access to this file for drop-down list, or leave as (public). Only the owning user or user group can open this Contact Set.
   
   **NOTE:** Users with Master Rights can access all contact databases, without regard to the owner.

9. Select **Grant Access** from this GoldMine license only to let only the currently running GoldMine to open the database.
   
   **NOTE:** Type the Logon name and Password you placed on the SQL database.

10. Click **OK**.

Opening Databases

GoldMine lets you have more than one Contact Set database. For example, departments within your company might use different databases.

1. Select **Tools > Databases > Open Database**.
   The Contact Set Databases dialog box opens.

2. Highlight the database to open and click **Open**. The new database opens with the database name in the lower left corner of the GoldMine status bar.
About Creating Databases

Use the Databases Wizard to create a database for new data or rehost an existing database to a new database. You can create or rehost the Contact files and/or the GoldMine files.

The Contact files contain all the tables related to the Contact records; when you create a new database, the database name is added to the Contact Set Databases dialog box. The GoldMine files contain the shared tables such as Calendar, Filters, Mailbox. When you create a new database of any of these files, GoldMine does not add the database name to the Contact Set Databases dialog box.

Rehosting creates a new database, but copies or converts data from the old database to the new one without affecting the original database. The rehosting process converts dBASE to SQL, letting an organization support multiple platforms.

**NOTE:** To encrypt database traffic between GoldMine and SQL Server, turn on Force Protocol Encryption option in the properties of the Native Client Configuration for SQL server. Note that file attachments are transferred using Microsoft networking file system and might not be encrypted.

Creating SQL Databases

Creating a new SQL database is a three-stage process. Create the:

- SQL database shell
- Alias
- Database in GoldMine

**NOTE:** Follow the steps below to initiate the process, or use the Database Wizard. For detailed information, see your Microsoft SQL documentation.

1. From the Windows Start menu, select Programs > Microsoft SQL Server > SQL Server Manager Studio.
2. Expand the files under the Console Root to locate the correct server. Expand the server to locate Databases.
3. Right-click Databases and select New Database. The Database Properties dialog box appears.
4. In the Name text box, type the database name.
5. Click OK. The new database now appears in the database list.
6. Create an alias for the database in the Database Connections Manager.

Using the Databases Wizard

Use the Databases Wizard to create a new database or contact set. The new database can be created as either a copy of the currently active database, or as an empty database containing the same fields as the currently active database. You can also copy data from a dBASE database.

1. Select Tools > Databases > New Database.
   The Welcome to the Databases Wizard dialog box opens.
Select the check boxes corresponding to the type of data you will create or copy.

- **Contact set tables.** Select this option to create or rehost a new Contact Set.
- **Common GoldMine tables.** Select to create or rehost the shared GoldMine files. Select this option only if you are rehosting from dBASE to SQL or creating a complete copy of the entire database.

**NOTE:** For this example, both contact set and common GoldMine tables are selected.

2. Click Next.
3. To create a new alias or database, click the **Alias Manager** button.

The Database Alias Manager dialog opens. After you create your new alias or database, the Databases Wizard will reopen. See "About the Database Alias Manager" on page 99.

- If you chose to create or copy **contact set tables** in the previous step of the Wizard, select the database alias for the new contact set from the drop-down menu, then enter a description for it in the text field below.
- If you chose to create or copy **common GoldMine tables** in the previous step of the Wizard, select the database alias for the new GoldMine tables from the drop-down menu.

Click **Next**.

![Rehost GoldMine Database](image)

Select the data source for your new database using the radio buttons

- **Create blank tables. (no data, except for a few system records):** Select to create an empty database. Click **Next**, or go to **Select individual tables to rehost** below to individually select the tables for your new database.

- **Copy data from the currently active database.** Select to copy records from the currently active database into the new database. Click **Next**, or go to **Select individual tables to rehost** below to individually select the tables for your new database.

- **Copy data from 6.x dBASE tables:** Select to open a dialog box for defining paths to external dBASE data.

- **Advanced Settings:**
  - **Select individual tables to rehost:** Select this check box to choose individual tables to rehost in your new database.
  - Click **Next**. The Rehost Selected Tables dialog box opens.

After the dBASE and Rehosting processes are completed, (or if you did not select these optional step), the **Database Access** dialog opens.
4. Select from the following options:
   - From the **Allow access to** drop-down list, accept the default (public). This grants access to all users and groups. To select a user or user group, select a name in the drop-down list.
   - In the **Contact set code** text box, type a unique value (such as GM7_P). GoldMine uses this to associate synchronized data with the correct database, regardless of its local name.

   **Example:** An East Coast branch office and a West Coast branch office might have the same Contact Set. Each branch office wants to synchronize data from their local Contact Set with the other office. The East Coast office names the Contact Set *Industrial*; the West Coast office names the same contact set "Manufacturing". As long as each office assigns the same Contact set code value to the local copy of the database, the offices can synchronize data.

5. Clear the **Allow database access only from this GoldMine installation** check box.

   **NOTE:** Selecting this check box allows only the currently active GoldMine system (as determined by serial number) to log into the database. A GoldMine system with a different serial number cannot log into the database.

   Click **Next**. The **Creating Database Files** dialog box opens.

6. Click **Finish**. The status dialog box opens.

   When complete, a message appears asking if you want to open this new database now. Click **No**.
Rehosting a Firebird Database

GoldMine no longer supports Firebird databases. If you upgrade GoldMine and were using Firebird as your database, the Upgrade Wizard provides rehosting of the active database. However, if you were previously using multiple Firebird databases, you must rehost those to SQL as well. GoldMine prompts you to rehost the Firebird database to a SQL database when you try to open that alias.

**NOTE:** If you did not use the standard Upgrade Wizard to rehost a Firebird database, then an alias does not exist. The alias must be created using the Alias Manager (see "About the Database Alias Manager" on page 99).

Click **Yes** to rehost the Firebird database to your installed version of MS SQL.

The Welcome to the Database Wizard dialog box appears. For detailed information about using the Database Wizard, see "Using the Databases Wizard" on page 83.

About Maintaining Databases

GoldMine includes a database Maintenance Wizard that generates indexes, rebuilds and packs the data, and sorts and verifies the database. Indexing ensures data integrity and quick access to the data in indexed fields. Rebuilding and packing creates fresh data files and builds tables, and then repacks the database, minus the deleted records. Sorting the database orders database files by the most-used indexes. Verifying data ensures it is readable, that the fields in the synchronization records are populated and readable, and that unique fields are not duplicated.

- Indexing Databases
- Rebuilding and Packing Databases
- Sorting and Verifying Databases

**IMPORTANT:** Before maintaining the database, always do a full backup of your database. This guarantees you can restore the database if something interrupts the process. For example, a power outage or network failure during the process could cause data loss.

Only one user should be logged into the GoldMine system during maintenance operations. Before the maintenance begins, GoldMine ensures no other user is accessing that data. Once the operation is in progress, GoldMine prevents other users from accessing the system by renaming the License.bin to License.bix. When maintenance is completed, the license renames back to License.bin.

To monitor what database maintenance has been initiated, view the Maintenance Logs.
Attaching Databases

Attach an existing database to make it available in GoldMine. Then tell GoldMine where the database is located, who the owner is, and, if necessary, the SQL login information.

Use the following procedure to attach a database.

1. Select Tools > Databases > Open Database.
2. At the Contact Set Databases dialog box, click Attach.
   The Contact Set Profile dialog box opens.
3. Update the fields as needed. See "Defining Contact Set Profiles" on page 82.
4. Click OK.

About the Lookup.ini

The Lookup.ini file does not exist in GoldMine until you create it using a text editor. It writes as a standard configuration file, similar to the Win.ini and System.ini files and stores in the GoldMine directory.

- **Lookup.ini** performs functions based on a trigger and resulting action:
- Update a Contact1 or Contact2 field based on an entry in another Contact1 or Contact2 field.
- Update Contact1 or Contact2 field based on an expression.
- Launch an external application based on an expression or the occurrence of a specified field entry.
- Apply an activity color code to calendar activities based on either an activity type, an activity code, or both.
- Launch an external application when a new record is created.

**NOTE:** If the Lookup.ini script updates a field based on updates to another field, the update of the second field does not follow the update access security for the second field set in the Field Properties dialog box.

Example: use a Lookup.ini to update Key2 based on updates to Key1. The user has update rights to Key1, but not to Key2 – but can update Key1 and the Lookup.ini updates Key2.

**NOTE:** A Lookup.ini that is configured to automatically update a Key field will only do so if the Key field is empty. This is to ensure that a value specifically entered by the user is not overwritten.

**Lookup.ini** includes:

- **[AutoUpdate]**: Specifies trigger fields (fields that create an update if modified) and the resulting field to be updated. The second section comprises the specific instructions and parameters used when updating the GoldMine field.
- **[OnNewRun]** and **[OnEditRun]**: Determines the external application to launch when a new record is created (a contact record or a supplemental file record adding a new calendar activity).
- **[CalClrCode]**: Specifies the color to assign to the activity being scheduled.

For more information about using the lookup.ini file, see "Examples of Using Lookup.ini" on page 88.

Examples of Using Lookup.ini

**Entering Data in One Field Updates Another**

A company requires that the Salesperson field, **USalesRep**, automatically update **[AutoUpdate]** when the GoldMine user typing data populates the City field.

The Lookup.ini is headed [AutoUpdate]. It is where the trigger and update fields are defined in the format: **Trigger field=Update field**.

There is no need to prefix field names with a database (Contact1->City) because no two fields in the Contact1 or Contact2 data files (except AccountNo) have the same field name.
This example is automatically updating field data.

```
[AutoUpdate]
City=USalesRep
```

When the trigger field (City) is updated, the Lookup.ini evaluates the subroutine of the same update field name (USalesRep). The result of this evaluation determines what is entered into the USalesRep field.

In this example, the subroutine (USalesRep) contains a reference to the trigger field (City) and a list of potential values that could be contained within the City field (Seattle, Aspen, Kansas City).

```
[USalesRep]
Lookup1=Contact1->City
Seattle=Janice Parks
Aspen=Danny Davis
Kansas City=Ken Linden
```

If a match is found, for example, the City field contains Seattle, Lookup.ini populates the USalesRep field with Janice Parks (Seattle=Janice Parks).

For every possible entry in the City field, a Lookup must be listed if it is to update another field.

### Checking a Sequence of Fields to Update Field

A company requires the Salesperson field (USalesRep) automatically update when the GoldMine user entering data populates the City field. If no city is matched, the State field (or other geographic boundary) must be evaluated so a second attempt is made at populating the Salesperson field.

Apply a second Lookup command. If GoldMine cannot match the City field with one of the listed values, it moves on to the next Lookup, which in this case is State. If required, a maximum of 9 different Lookups can be defined.

```
[AutoUpdate]
City=USalesRep
[USalesRep]
Lookup1=Contact1->City
Seattle=Janice Parks
Aspen=Danny Davis
Kansas City=Ken Linden
Lookup2=Contact1->State
WA=Janice Parks
CO=Danny Davis
MO=Ken Linden
```

If the City field does not contain Seattle, Aspen, or Kansas City, the State field is evaluated. If the State returns a value of CO, the USalesRep field populates with Danny Davis. Set every parameter to update the field correctly.

### If No Match is Found

A company requires the Salesperson field (USalesRep) automatically update [AutoUpdate] when the GoldMine user typing data populates the City field. If no state is entered or if an erroneous entry is made, the Salesperson field updates with Unallocated.

The Lookup.ini can update a field with a set entry if no matches are found. The otherwise statement is included after all Lookups 1-9 are listed.
If the City field does not contain Seattle, Aspen, or Kansas City, USalesRep populates with Unallocated.

[AutoUpdate]
City=USalesRep
[USalesRep]
Lookup1=Contact1->City
Seattle=Janice Parks
Aspen=Danny Davis
Kansas City=Ken Linden
Otherwise=Unallocated

Updating Two Fields from One Trigger Field

A company requires the Salesperson field (USalesRep) and the Region field (URegion) populate when the City field populates.

The trigger field launches two subroutines rather than one. Note the [AutoUpdate] section containing a reference to both fields, separated by a comma, and the existence of two separate subroutines.

The order of referencing is important if one field must be updated first because its new value affects the entry in the second field.

If updating both the City and the Salesperson field affected the update of the Region, the USalesRep section must be referenced first under [AutoUpdate].

If updating the Region and the City would affect the Salesperson, the URegion field must be referenced first in the [AutoUpdate] section. If the fields are to be updated independently, either can be referenced first.

[AutoUpdate]
City=USalesRep, URegion
[USalesRep]
Lookup1=Contact1->City
Seattle=Janice Parks
Aspen=Danny Davis
Kansas City=Ken Linden
[URegion]
Lookup1=Contact1->City
Seattle=Northwest
Aspen=Mountain
Kansas City=Midwest
If the Field to Update is Pre-Populated

GoldMine does not automatically overwrite an existing value in a field to be updated unless it specified to do so. The OverWrite statement is a toggle statement (On/Off or True/False). If:

- Overwrite=0: Existing values in the update field are not overwritten.
- Overwrite=1: Existing values in the update field are overwritten.

The statement is placed at the end of the subroutine.

```
[AutoUpdate]
City=USalesRep
[USalesRep]
Lookup1=Contact1->City
Seattle=Janice Parks
Aspen=Danny Davis
Kansas City=Ken Linden
Otherwise=Unallocated
OverWrite=1
```

Update a Field Based on an Expression

The Lookup.ini, by way of expression, returns an actual value to a field that can be used like every other field within GoldMine. The [AutoUpdate] section contains a trigger field and a reference to a subsection to execute.

The subroutine contains an expression rather than a list of returned values from a Lookup1; however, the subroutine must be written in a standard way, and therefore a dummy Lookup1 must be inserted—although it is set to not return any values—so the Otherwise command is invoked.

Use the expression with the Otherwise command, but prefix it with an ampersand (&).

```
The Calculation of Numeric Fields

A Company has quarterly sales figures (USales Qtr1-USalesQtr4) for each customer. It requires a Total (UTotal) field summing business quarters one through four and returns a value.

The [AutoUpdate] section includes four trigger fields: Usales Qtr1-4. When any one of these fields updates, the Lookup.ini runs the subroutine UTotal.

The Lookup1 command looks in a placeholder field. In the example, Contact1->Company is referenced. No values are listed under Lookup1; therefore, no match is found. The Lookup.ini progresses to the Otherwise command.

```
```
Calculation Fields Using Decimal Places

For the Lookup.ini to calculate a value that includes a decimal place, each field referenced when calculating must contain the same amount of decimal places whether needed.

The **Otherwise** command must include a String statement (**STR**) in order to calculate to \( x \) decimal places.

```
[AutoUpdate]
UsalesQtr1=UTotal
UsalesQtr2=UTotal
UsalesQtr3=UTotal
UsalesQtr4=UTotal
[UTotal]
Lookup1=Contact->Company
Otherwise=&STR(Contact2->UsalesQtr1+Contact2->UsalesQtr2+Contact2->UsalesQtr3+Contact2->UsalesQtr4,2,10)
Overwrite=1
```

The **Otherwise** statement ends in \( 2,10 \) where 2 indicates the number of decimal places and 10 the length of the field.

Averaging Blank and Filled Fields Using Hypothesis Values

If the **Otherwise** command holds an expression that calculates the sum of the contents of all fields, then divides the total by the number of fields, those empty fields (set to zero) are also included.

```
Otherwise=&((Contact2->Ufield1+Contact2->Ufield2+Contact2->Ufield3)/3)
```

If the field values were:
- 10, 20 and 30, the Lookup.ini returns a value of 20 (60 divided by 3).
- 10, 20 and 0, the Lookup.ini returns a value of 10 (30 divided by 3).

Inclusion of the blank or zero fields might be inappropriate. In our example the final calculation should be divided by 2 not 3, resulting in an average of 15.

**True/False** fields calculate using an if statement followed by the value indicating whether the value is true, then are suffixed with a value to replace if true, and then a value to replace if false:

```
(iif(field=value,true[x],false[y]))
```

The expression **otherwise=&(iif(contact2->ufield1=0,0,1))** states the value in **Ufield1** should equal 0. If it does (true), the **count** field populates with 0. If the field is not equal to 0 (it contains either a higher or lower value), the count field populates with 1 for false (not true). Each field evaluated must have its own count field.

The Utotal section then calculates the sum of all counter fields and uses that figure to divide the total of the fields **Ufield1-Ufield3**.

The programming standard of 0 = **false** and 1 = **true** has no bearing in this example.

```
[AutoUpdate]
UField1=ucount1, utotal
UField2=ucount2, utotal
UField3=ucount3, utotal
utotal=utotal
[ucount1]
Lookup1=contact1->company
otherwise=&(iif(contact2->ufield1=0,0,1))
Overwrite=1
[ucount2]
Lookup1=contact1->company
otherwise=&(iif(contact2->ufield2=0,0,1))
```
Using the Lookup.ini to Launch External Applications or Macros

Automatically launch external applications or Macros for further processing to occur outside of GoldMine after record data is changed.

- **[OnNewRun]**: Sets up external applications for each type of contact-related record.
- **[OnEditRun]**: Launches applications when a record is changed.

Records in Contact1, Contact2, Cal, ContHist, and ContSupp can be considered by the [OnNewRun] and [OnEditRun] sections. Set up specific record types in Cal, ContHist, and ContSupp to launch different applications by appending the rectype to the table name.

```
[OnNewRun]
  Cal-S=SaleCApp.exe
  Cal-C=CallCApp.exe
  Cal=CalApp.exe
  ContHist-S=SaleHApp.exe
  ContHist-CI=InCallHApp.exe
  ContHist=HistApp.exe
  ContSupp-P=ProfileApp.exe
  Contact1=NewContact.exe
  Otherwise=AnyApp.exe
  AppendRecNo=1
  DisableFromAP=1
```

Or, specify entries under [OnNewRun] and [OnEditRun] for each contact-related record and record type. GoldMine first checks for a specific Rectype entry, then for a general table entry not suffixed with a Rectype. Example: when a sale is completed, check for ContHist-S=. If no ContHist-S=, check for the general ContHist=. If no ContHist= entry, check for Otherwise=. Thus, GoldMine launches ProfileApp.exe if a detail record is added.

**Add to End of Scripts**

- **AppendRecNo=1**: Append the RecNo of new record to the command line. Example: a completed incoming call from the example launches a command=InCallApp.exe 1234 (where 1234=the record number of the completed record in the ContHist file). With this entry, use a DDE command to query GoldMine for the new record’s data.
- **DisableFromAP=1**: Disable the [OnNewRun] options if an activity is processed by Automated Processes.
- **Otherwise=**: Entry is suffixed with the File+RecType, such as “AnyApp Cal-A 1234”.

When a contact record is created and the [AutoUpdate] NewRecord option is specified, that option is executed first so the resulting updates can be used by a subsequent [OnNewRun] Contact1=NewContact.exe entry.
Running Macros

A macro is a button or hot key shortcut representing an instruction, action, or a series of instructions, actions, or text inputs (see "Working with Macros" on page 54). Macros can also be added to the Lookup.ini file.

When you create a macro, it is saved to a file called <username>.mac. The macros are saved in the \GoldMine\macros\ directory. This file lists all the recorded macros with numbers associated to them. When you open this file in a text editor (such as Notepad), you see a list of all the macros that you have recorded. In the list, there is a number that precedes the section with the Title and Description you added when you recorded the macro.

To use a macro in the Lookup.ini, you must use the number associated with the macro in the <username>.mac file. For example:

<table>
<thead>
<tr>
<th>&lt;username&gt;.mac</th>
<th>Field Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>[800] T=OutlookSync D=Synchronize with Outlook F=user.800 H=85,0,1441793 S=1</td>
<td>macro number Title Description Hot Key Code Playback Speed</td>
</tr>
</tbody>
</table>

When you use a macro as part of the Lookup.ini, use the following format for example:

```
[OnNewRun]
Contact1 = &PlayMacro(800)
```

What this will do is watch the Contact1 table. If there is a change, then macro 800 is run. In this example, if the Contact1 table is modified, GoldMine will synchronize with Outlook.

TIP: Macros can also be added to the GoldMine Taskbar. For more information, see "To Add Macros to the Taskbar" on page 55.

Moving Linked Documents and Attachments

E-mail attachments and/or documents linked to contacts, the Knowledge Base and Service Center can be stored in folders on disks.

Use the following procedure to move that folder to another location, (for example from the C: drive to the E: drive, or from Program Files to ProgramData for Vista, Windows 7, and Windows 8 compliance).

NOTE: Synchronization logs will not be created by this tool, so remote machines will not be affected.

Use the following procedure to move linked documents and attachments.


2. Click the Move the Linked Documents, Knowledge Base and Case Attachments to checkbox if not selected and then define destination folder.

   The Move Linked Dots and Attachments dialog box opens.

   □ Go to Step 3 if you want GM to automatically find ALL linked documents, knowledge base and attachments, and move them to destination folder.

   □ Click the Add button and select the source folder(s) to set the list of directories manually.

   Each time a new record will appear in the Move documents from: list.

   □ To remove a record from Move documents from: list highlight it by right mouse click and click Remove.

3. To move mail attachments check the Move all Mailbox Attachments to: checkbox and then define destination folder.
4. In the **Options** area, select one:
   - Move actual files and folders, and update database references.
   - **Update the database reference only.** (Choose this selection when files and folders are already been moved to destination directory).

5. Click **Go** to finish or **Cancel** to cancel operation.
   The files are moved along with all existing subdirectories.

---

**Backing Up Databases**

If you encounter a problem while working in GoldMine that causes data loss or data corruption, the problem can be internal or external to your system. Ensure data availability in the event of data loss or corruption using a regular program of data backup.

To maintain an optimal backup system, make a separate backup on each day for a 2-week cycle. That is, your backup system should include 10 to 14 individual backups. Two weeks of backups are recommended because data corruption might not be discovered for several days. Only 1 or 2 backups might contain corrupted data. Use tape or diskettes as a backup medium. For added security and recovery, keep a backup in secure offsite location (a bank deposit). Ensure you periodically update the backup.

**NOTE:** Maintain regular backups of GoldMine contact data, setup data, and program files. To back up contact data in GoldMine on an MSSQL database, use a utility designed to back up SQL data.

---

**Backing Up SQL Databases**

With an SQL database, the files needed for a backup can be copied to another directory, another drive, a disk, or an external drive. It is recommended that you keep a daily backup on a 2-week cycle, as hardware failures or unforeseen problems can cause you to lose your data.

**NOTE:** It is highly recommended that you create a database backup using SQL Server Management Studio.

A full backup of GoldMine on SQL Server requires you to back up the GoldMine system files and the SQL database. To perform a manual backup of your SQL database, the following GoldMine system files and their typical locations (listed in the table below) must be copied to create a safe backup file.

<table>
<thead>
<tr>
<th>Location</th>
<th>Files</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>\GoldMine\</code></td>
<td>&quot;.exe&quot;</td>
</tr>
<tr>
<td><code>\GoldMine\</code></td>
<td>&quot;.D*&quot;</td>
</tr>
<tr>
<td><code>\GoldMine\Reports</code></td>
<td>&quot;.FP&quot;</td>
</tr>
<tr>
<td>All other subdirectories of <code>\GoldMine\</code></td>
<td>&quot;.D*&quot;</td>
</tr>
</tbody>
</table>

For complete information, see the SQL Server Online Help and SQL Books Online.
Restoring SQL Databases

To use the SQL restore utility, find the SQL Server Enterprise Manager and right-click the database name. Select All Tasks > Restore Database. The SQL Server Restore dialog box appears. Select the backup file to restore and click OK. The Restore Progress window shows the restoration process status.

SQL Query for Counting Contacts

If you are running GoldMine on an SQL database, the Summary tab does not display the database count. Instead you see n/a in the Record field. You can, however, count the number of records in an SQL database by running a query from the SQL Query tab of the Filters and Groups dialog box.

To Run the SQL Counting Query
1. Select Lookup > SQL Queries. The Filters and Groups dialog box opens to the SQL Query tab.
2. In the large upper pane, type this statement:
   
   ```
   Select Count(*) from contact1
   ```
3. Select Query. GoldMine displays the record count results under Column1 in the lower pane.

Using the GoldMine Maintenance Wizard

Configure these maintenance options:

- **Indexing.** Ensures data integrity and quick access to the data in indexed fields. See "Indexing Databases" on page 97.
- **Rebuilding and Packing:** Creates fresh data files and builds tables, then repacks the database minus deleted records.
- **Sorting and Verifying:** Sort reorders records in the tables based on the most-used indexes. Verify checks data for readability. It checks to see if all fields in the synchronization records of the database files are populated and for any duplication of unique fields. See "Sorting and Verifying Databases" on page 97.

Use the following procedure to use the Maintenance Wizard.

2. Select:
   - Current Contact Set Files. Includes currently open contact files. Does not include GoldMine files, such as Calendar, Lookup, or Mailbox.
   - Individual Files. Lets you select individual tables from open contact files and GoldMine files.
   - All Database Files. Lets you select GoldMine files, current Contact Set, or all contact sets.
   - Automatic Maintenance. Lets you configure automatic maintenance options (regular maintenance without user intervention).
3. Click Next. The dialog box that opens varies based on previous selection (each box eventually opens the Rebuild, Sort and Verify Database Files dialog box).

IMPORTANT: Always back up your database before maintaining GoldMine.
Indexing Databases

If a large amount of data is added or removed or statistics update has been disabled, you might want to re-index the database in order to let the SQL engine recalculate index selectivity (also known as index statistics) due to indexes becoming lost or corrupt. Selectivity is an internal measurement of efficiency of the index and it is used by the SQL engine in deciding how best to access the data.

Use the following procedure to index the database.

1. Select Tools > Databases > Maintain Databases.
   The Welcome to the GoldMine Maintenance Wizard dialog box opens.
   
   **NOTE:** Depending on the size of your database, indexing the entire database can be time-consuming. Select All Database Files if you are indexing the entire database. To index a particular table, select Individual Files.

2. Select one of the following options:
   - **Current Contact Set Files.** Indexes only the contact files/tables in the currently open contact database. If you select Current Contact Set Files, the Rebuild, Sort and Verify Database Files dialog box opens.
   - **Individual Files.** Specifies which files/tables in the GoldMine directory and in the open database that GoldMine indexes. If you select Individual Files, the Maintain Selected Tables dialog box opens.
   - **All Database Files.** Indexes and rebuilds contact files/tables in the open contact database, and those contained in the GoldMine system directory. If you select All Database Files, the Maintain All Database Files dialog box opens.
   
   **NOTE:** Select Automatic Maintenance to configure GoldMine to automatically perform indexing and rebuilding. The Automatic Maintenance dialog box opens.

3. Click Next.

4. Based on your selection in step 2:
   - If you selected **Individual Files**, at the Maintain Selected Tables dialog box, select the table or tables to be indexed. Click Next.
     To select all tables, click Set All. To clear all tables, select Reset All.
   - If you selected **All Database Files**, select Files in GoldMine Directory and Current Contact Set Files. Select All Contact Set Files to index other contact databases. Click Next.

5. The Rebuild, Sort and Verify Database Files dialog box opens. To perform a simple indexing, do not select the options. Click Next.

6. Select Force all users to exit GoldMine within x minutes. Set the number of minutes.
   A message is sent to the currently logged in users telling them the GoldMine Administrator is performing maintenance, to complete their work, and close GoldMine.

7. Click Finish. GoldMine deletes the current indexes for the selected table or tables, and creates new ones.

Sorting and Verifying Databases

Sort reorders records in the tables based on the most-used indexes. Verify checks data for readability. It checks to see if all fields in the synchronization records of the database files are populated and for any duplication of unique fields.

**NOTE:** Always back up your database before maintaining GoldMine (see “Backing Up Databases” on page 95).

1. Select Tools > Databases > Maintain Databases.

2. At the Welcome to the GoldMine Maintenance Wizard dialog box select:
   - **Current Contact Set Files.** Includes currently open contact files. Does not include GoldMine files, such as Calendar, Lookup, or Mailbox.
   - **Individual Files.** Lets you select individual tables from both the currently open contact files and the GoldMine files.
   - **All Database Files.** Lets you select GoldMine files, current Contact Set, or all contact sets.
   - **Automatic Maintenance.** Lets you configure automatic maintenance options (regular maintenance without user intervention).
3. Click Next.
   The dialog box that appears varies based on previous selection (each box eventually opens the Rebuild, Sort and Verify Database Files dialog box).
4. Select Rebuild and Pack the database files.
   If using GoldMine with a SQL database, a warning message appears reminding you SQL tables do not need rebuilt.
5. If appropriate, select Sort the database files.
6. If appropriate, select Verify the data and synchronization information. Click Next.
7. From the GoldMine Maintenance Wizard dialog box, select Force all users to exit GoldMine within x minutes. Set the number of minutes. A message is sent to the currently logged in users telling them the GoldMine Administrator is performing maintenance, to complete their work, and close GoldMine.
8. Click Finish.

Setting Up Automatic Maintenance

Configure GoldMine to automatically maintain the database based on specified criteria.
2. Select Automatic Maintenance.
3. Click Next. The Automatic Maintenance dialog box appears.
4. Select the Logged User (designates the user with Master Rights responsible).
   NOTE: The Logged User must be logged into GoldMine at the specified start time and day for the automatic maintenance to run.
5. Type or select the Start Time. Click the right arrow to access the F2 graphical clock.
6. In the Maintain Files box, select a file to maintain.
   NOTE: Because GoldMine forces all network users to log out of GoldMine during indexing and rebuilding, index after regular business hours.
   NOTE: Maintain Calendar File and Sync Log Files often (rebuild and pack weekly).
7. Select the Frequency.
   ○ Pack, rebuild and index: Indexes, rebuilds, and packs the selected files.
   ○ Index only: Only indexes the selected files. Available only for the GoldMine Files, Current Contact Set, All Contact Sets, and System Logs.
8. Select Save.
   View the Maintenance Logs to verify the process has run successfully.
   NOTE: If you maintain a SQL database with the Wizard, you must reset table permissions.
Viewing System Logs

GoldMine records system activity for a variety of operations in System Logs. To view a system log, select Go To > Logs > GoldMine Logs. The left pane displays the log types and the right pane displays the details. To see details, expand the log type until you locate the day to view. Select the day; details appear in the right pane.

The System Logs window displays these log types:

- **Process Monitor Logs**: Activities recorded in the GoldMine Process Monitor.
- **Maintenance Logs**: Dates and outcomes of database maintenance procedures.
- **Users' Login Logs**: Users' login activity.
- **Sync Wizard Logs**: Dates and details for GoldMine synchronization.
- **GoldSync Logs**: Details about GoldSync synchronization.
- **Contact Files Logs**: Changes made to the Contact Set files.
- **GoldMine Files Logs**: Changes made to GoldMine files.
- **Error Logs**: Details of errors.

Use the logs for troubleshooting. To prevent performance problems, periodically purge the logs (see "Purging Log Entries" on page 99).

Purging Log Entries

The System Logs (see "Viewing System Logs" on page 99) can consume a significant amount of disk space. Periodically purge old logs to reduce space required.

2. In the left pane, right-click and select Purge Logs. The Purge Logs dialog box appears.
3. Select the logs to purge from the Log Types area.
4. Select the Cutoff Date using the F2 graphical calendar. The date defaults to the previous month.
5. If purging User's Login Logs, select the Users you are purging from the list.
6. Click OK. The Process Monitor appears, displaying the status of the purging process.

About the Database Alias Manager

The Database Connections Manager lets you establish an “alias” for each database management system used with GoldMine. An alias is required to connect your database to the application. It tells GoldMine where to find the database, collecting information from which to build the ADO connection string.

Use the Manager if you are already using an existing or multiple databases with GoldMine. It imports any existing MSSQL BDE aliases.

**NOTE**: The Database Connections Manager creates the alias and the shell (only two of the three stages for creating a database). If you are creating a new database, use the Databases Wizard. The wizard process leads you through the three-stage process often needed for creating the database and allows you to create the tables as well. To access the wizard, select Tools > Databases > New Database.

See "Using the Database Alias Manager for SQL Databases" on page 100.
Using the Database Alias Manager for SQL Databases

From the menu bar, select **Tools > Databases > Alias Manager**, or from the appropriate window in the Databases Wizard, click the **Alias Manager** button. The Database Alias Manager appears.

To alias a database, click **New Alias**. The **Edit Alias** dialog opens.

**NOTE:** This dialog window contains a form for collecting information used to build an ADO connection string. This information is stored in an INI file.

1. In the **Alias Name** text box, type a name for the alias. There is a 100-character limit.
2. From the **Server Type** drop-down list, select either **MSSQL**.
   **NOTE:** The form will change depending on the Server Type selected.
3. In the **Host** text box, type the name of the computer hosting the database.
4. In the **Database** text box, type the name of the database.
5. In the **Owner** text box, type the database owner's name (typically, this is **dbo**).
6. In the **Login** text box, type the username for the database.
7. In the **Password** text box, type the password for the database.
   **NOTE:** By default, the Password text box displays a fixed number of asterisks as a security measure.
   **NOTE:** This action registers the alias and creates the database specified. The new database will not be created without completing this step, although it will appear in the list. You cannot test it prior to completing this step.
8. Select the **Use Windows Authentication (SSPI)** check box if you have designated Windows Authentication Mode instead of the SQL authentication. [This only applies to MSSQL aliases.]
9. Click **Create New Database**.
10. Click **Test Connection**. This verifies that the alias was created successfully.
11. Repeat this process for each alias you want to create.
12. Click **OK** when done.

**To Edit an Alias**

1. From the menu bar, select **Tools > Databases > Alias Manager**. The Database Alias Manager opens.
2. Select an alias from the list and click **Edit**.
   This activates the associated form.
3. Make appropriate changes to the information in the text boxes.
4. Click **Save** and then click **OK**.

**To Delete an Alias**

1. To delete an alias, select the alias.
2. Click **Delete** and then click **OK**.
Globally Replacing Field Data

The **Global Replace Wizard** helps you replace the value of a field in the contact record.

**IMPORTANT:** Before beginning a global replace, back up the GoldMine databases (see "Backing Up Databases" on page 95).

If using a global replace to operate on a subset of data, first build that subset with a filter or group you can then select during the process.

- Users without Master Rights cannot replace the **Owner** or **Status** fields.
- Apply global updates only to **Contact1** and **Contact2** fields.

**To Use the Global Replace Wizard**

1. Select **Tools > Data Management > Global Replace**.
2. At the **Global Replace Wizard** dialog box, select one option:
   - Replace a Field with a value (see "Globally Replacing Fields with a Value" on page 101)
   - Update a field using advanced options (see "Globally Updating Fields Using Advanced Options" on page 102)
   - Exchange the value of two fields (see "Globally Exchanging the Values of Two Fields" on page 103)
3. Click **Next** to continue with the wizard.

Globally Replacing Fields with a Value

Use the **Replace a Field with a Value** option in the Global Replace Wizard to change the value of a field with another value.

**To Globally Replace Fields with a Value**

1. Select **Tools > Data Management > Global Replace**.
2. At the Global Replace Wizard, select **Replace a Field with a Value**, then click **Next**.
3. Select a **Replace Field** in the drop-down list.
   - This specifies the field to be updated. The data in this field will be replaced by the value specified in the With Value field.
   - Select the GoldMine fields in the drop-down list.
4. Type or select from the F2 Lookup list the **With Value** to insert in the selected field.
   - This option specifies the replacement value that will be placed in the Replace Field. GoldMine will replace the specified field in all contact records with the value in this field. For example, if the Replace Field is City, and the With Value entry is Long Beach, GoldMine will replace all City entries with Long Beach.
5. Click **Next**.
6. Check the fields and replacement values before initiating the process:
   - **Expand partial contact records.** Expands partial contact records in the database into complete records if the field to be replaced is contained in the Contact2.dbf file. If the field is contained in Contact2.dbf, this option is selected by default.
     - If you clear the Expand partial contact records option, partial records are not expanded, and field values in these records are not updated. However, when additional entries require more space, GoldMine converts a partial record to a complete record. Clearing Expand partial contact records prevents GoldMine from automatically converting partial records during a global replacement.
Update linked fields (based on lookup.ini). Changes values in linked fields according to the instructions in the [AutoUpdate] section of the Lookup.ini file. This option is available only if one or more selected fields include fields listed in Lookup.ini.

Log updates in history. Records global changes to fields in the following System Logs:

Process Monitor Logs. Displays the date, time, user, and number of records affected by the global replacement

Contact Files Logs. Displays the date, time, user, field name, and the value inserted by the global replacement. This option appears only if you selected Log updates in history for each field from the Field Label dialog box which you can access by pressing CTRL and double-clicking the field label.

7. You can globally replace more than one field at a time. To add another field and replacement value, click Back.

8. If you have more than one replacement entry, Remove becomes active. You can delete any entry other than a single entry.

9. Click Remove to delete the highlighted global replacement entry.

10. Click Next.

The Global Replace Wizard displays a list of available filters and groups to apply to limit the records updated by the global replacement. The filter or group does not have to be activated prior to selection.

Select the filter or group to apply in the drop-down list, then click Next.

The final Global Replace dialog box appears.

11. Click Finish.

Globally Updating Fields Using Advanced Options

Use the Updating Fields Using Advanced Options in the Global Replace Wizard for the following advanced options:

- Replacing an entire field with a value
- Replacing field text only with a value
- Evaluating the replacement value as a dBase expression
- Replacing field text with a value at the specified position

To Globally Update Fields Using Advanced Options

1. Select Tools > Data Management > Global Replace.

2. At the Global Replace Wizard, select the Update a field using advanced options and click Next.

3. Select from the following options:

- **Update Field.** Specifies the field to replace with the selected option.
- **Replace.** Type the value to insert into the specified field. GoldMine replaces the specified field in all contact records with this value.
- **Replace the entire Field with Value.** Removes any entry in the field and inserts the contents of the field.
- **Replace text with Value.** Removes specified text only from the field and inserts the value from this field. GoldMine conducts a case-sensitive search for the value you enter. An F2 Lookup list is not available for this option.
- **Insert Value at position.** Specifies the position, in character spaces, where the replacement value appears in the specified field.
- **Evaluate Value as dBase expression.** Replaces the field with the result of the dBase expression entered in Replace.
4. In the Convert to area, select one:
   - **Proper case.** Converts characters in the field value to initial capitals. For example, if the field value is ACME PRODUCTS, the entry is converted to Acme Products.
   - **Upper case.** Converts all alphabet characters in the field value to capital letters. For example, if the field value is Acme Products, the entry is converted to ACME PRODUCTS.
   - **Lower case.** Converts all alphabet characters in the field value to lowercase letters. For example, if the field value is Acme Products, the entry is converted to acme products.
   - **Phone format.** Converts all telephone numbers in the replacement entry to the format that was selected for the record. Telephone numbers in contact records set up for a USA format appear as (999)999-9999; telephone numbers in contact records set up for an international phone format have no formatting applied.
   - Click **Next.**

5. Check the fields and replacement values before initiating the process.
   - **Expand partial contact records.** Expands partial records in the database into complete records if the field to replace is contained in the Contact2.dbf file.
     - **NOTE:** If the field is contained in Contact2.dbf, this option is selected by default. If you clear the Expand partial contact records options, partial records are not expanded, and field values in these records are not updated.
   - **Update linked fields (based on lookup.ini).** Changes values in linked fields according to the instructions in the [AutoUpdate] section of the Lookup.ini file. This option is available only if one or more selected fields include the field(s) listed in Lookup.ini.
   - Click **Next.**

6. You can globally replace more than one field at a time.
   - To add another field and replacement value, click **Back.**

7. Click **Remove** to delete the highlighted global replacement entry.
   - If you have more than one replacement entry, Remove becomes active. You can delete any entry other than a single entry.

8. Click **Next.**
   - The Global Replace Wizard displays a list of available filters and groups you can apply to limit the records to be updated by the global replacement. The filter or group does not have to be activated prior to selection.

9. Select the filter or group to apply from the drop-down list and click **Next.**

10. At the final Global Replace dialog box, click **Finish.**

### Globally Exchanging the Values of Two Fields

Use the Global Replace Wizard to update data in one field with data from another field by:
- Exchanging values of two specified fields on a contact record
- Replacing the value of one field on a contact record with the value of another field

**To Globally Exchange the Values of Two Fields**

1. Select **Tools > Data Management > Global Replace.**
2. At the Global Replace Wizard, select **Exchange the values of two fields**, and then click **Next.**
3. Select one option:
   - **Exchange the values of both fields.** Trades the value of one specified field with the value of a second specified field.
   - **Replace value of the left field with the value of the right field.** Inserts the value in the first specified field with the value in the second specified field. The original field remains unchanged.
4. Select the fields to update in the drop-down lists.
   - **Update this field.** The field to replace or exchange.
   - **With this field.** The field to exchange data with the first field or provide the replacement value.

   **NOTE:** GoldMine converts the replacement data into the appropriate data type before copying the data into the selected replace field.

5. Click **Next**.

6. Use the Global Replace Wizard setup dialog box to check fields and replacement values before initiating the process.
   - **Expand partial contact records.** Expands partial records in the database into complete records if the field to replace is contained in the **Contact2.dbf** file. If so, this option is selected by default. If you clear Expand partial contact records, partial records are not expanded, and field values in these records are not updated.
   - **Update linked fields (based on lookup.ini).** Changes values in linked fields according to the instructions in the **[AutoUpdate]** section of the **Lookup.ini** file. This option is available only if one or more selected fields include the fields listed in the **Lookup.ini**.

   You can globally replace more than one field at a time. To add another field and replacement value, click **Back**.

7. Select Remove to delete the highlighted global replacement entry.

   **NOTE:** If you have more than one replacement entry, Remove becomes active. You can delete any entry other than a single entry.

8. Click **Next**. The Global Replace Wizard displays a list of available filters and groups to apply to limit the records to be updated by the global replacement. The filter or group does not have to be activated prior to selection.

9. Select the filter or group to apply, then click **Next**. The final Global Replace dialog box opens.

10. Click **Finish**.

---

**Importing and Exporting Data**

**About Importing Data**

GoldMine provides several ways to import data. Use the GoldMine Import Wizard (see "Using the Import Contact Records Wizard" on page 106) to import data from other applications into GoldMine using predefined profiles or by creating your own profiles using the wizard. A predefined utility is included for importing from ACT!.

   **TIP:** GoldMine also provides a wizard for importing data from an XML file (see "Importing XML" on page 110).

   **NOTE:** For information about collecting contact information from web sites, see "Web Import" on page 175.

**Import Sources**

Import data into GoldMine from these database sources:

**DBF FILE**

The dBASE files are easily identified by the .DBF file extension. A dBASE file identifies fields by name; for example, the company name field might be referenced as Company, and the Contact name field might be referenced as Contact. A dBASE file stores field names internally.
GoldMine can import and export ASCII text files. The delimited ASCII format is the most commonly used file format. When viewed with a word processor or text editor, data saved in a delimited format might look like this:

```
"ABC Company","John Smith","123 Main Street","Anytown","CA","97021"
"Joe's Cleaners","Joe Turner","55 Third St.","Burbank","CA","91502"
"Mr. T's Ribs","","22543 Eton Ave.","New York","NY","10027"
```

Each field in the file is surrounded by a delimiter which is usually the double-quote character ("). Adjacent fields are separated by a field separator which is usually a comma (,). Each record is terminated by a carriage-return/line-feed combination. Carriage return or line feed characters cannot be embedded within the data.

A blank field’s position in the record contains empty quotes as shown in the second field in the third record. In the delimited ASCII format, fields are referred to by their position in the record. For example, company name is field 1, contact name is field 2, and so forth.

Many report generators can suppress the output of titles, headings and page numbers to print only the report detail lines. Most mailing list companies supply mailing lists in the SDF format, called a fixed-length format, commonly used by mainframe computers. This is a sample:

```
ABC Company  John Smith  123 Main Street
Joe's Cleaners Joe Turner  55 First St.
Mr. T's Ribs  
```

Each field has a fixed starting and ending position in the record. Regardless of the length of fields before it, a field starts and ends in the same position in every record. Since each field is padded with spaces until the start of the next field, files employing this format are sometimes called Space Delimited Files (SDF files). Like the Delimited ASCII format, each record is terminated by a carriage-return/line-feed combination.

Fields in the SDF format are referred to by starting and ending character positions. In the above example, the company name field occupies positions 1–16, contact name 17–28, and the address occupies positions 29–45.

The SQL import option is used to import SQL tables from MSSQL or Firebird.

About Exporting Data

The exporting process copies data into a formatted file the receiving application understands. The Export Wizard provides simplifies the task. Using the Export Wizard, create a data file from GoldMine records according to criteria in a predefined profile, or define your own profile. GoldMine can export from the current database in three formats:

- DBF file
- ASCII (TXT) file
- SDF (fixed length) file
- export data to an XML file.
Considerations for Importing and Exporting Data

When:

- Only fields in the Contact1 and Contact2 tables and the primary e-mail and Web site Details are available for standard import or export. The XML import and export lets you import or export the full database.
- Merge information and check for duplicates while importing.
- Save import and export profiles to facilitate the process. A profile is predefined field mappings and specifics of data file locations.
- GoldMine supports the importing and exporting of calendar, history, and supplemental contact information when using the predefined ACT! import profile or XML.
- When importing or exporting, all fields are referenced by their GoldMine field names, which can differ from their label name. After being created, the field name never changes, though the label can be changed by the user.
  
  For example, the field Key1 located in the Contact1 table is commonly labeled Contact Type. This means the field would be listed as Key1 and not as Contact Type in the lists of GoldMine fields in the import and export wizards. This is important because you might not recognize the field name as the field you want to use.

  **NOTE:** If your import requirements include calendar, supplemental contact information, or history records, use third-party utilities to import. Several products designed to work with GoldMine are GoldBox Utilities, Inaport, CRMSwitch, and Beyond Gold. As third-party products, they are not supported by FrontRange Solutions technical support.

Data Preparation

Before importing, establish the source file and destination file components. Do not start the importing procedure until you create necessary fields in GoldMine.

Taking the source file, create a list of all of the field names and lengths, then manually match the GoldMine field and its length. If the fields do not exist or are not long enough, make structural changes to the fields before proceeding. The data should be in ASCII, SDF, SQL, or DBF format for importing.

**IMPORTANT:** Failure to save the file correctly could result in loss of data.

Using the Import Contact Records Wizard

1. Open the **File** menu and select **Import and Export > Import Contact Records**.
   
The Welcome to GoldMine’s Import Wizard dialog box opens.

2. Select one option:
   - **Import a new file:** Incoming data formats according to the profile you define in the Import Wizard. You can save the profile for future use.
   - **Import a new file using an existing profile:** If importing:
     - DBF, ASCII, or SDF, select a profile you created on the Select File to Import dialog box.
     - DBF, select an ACT profile or one you created.
     - ASCII or SDF, select a profile you created.
     - from SQL, the Select SQL Table to Import dialog box appears.
3. Select an option for the file type to import.
   - **CSV file.** A text file that uses a comma to separate the values.
   - **DBF file.** Incoming data is in dBASE file format. Fields in a dBASE file are referred to by field name, for example, the Company field might be referred to as COMPANY, and the Contact field might be referred to as CONTACT.
   - **ASCII file.** Incoming data is in delimited text file format. A delimited text file formats data with field delimiters, field separators, and record separators. In the delimited ASCII format, fields are referred to by their position in the record.
   - **SDF file.** Incoming data is in a text file with fixed-length record format which is commonly used by mainframe computers. Fields in the SDF format are referred to by starting and ending character positions (see "To Import a .SDF File" on page 107).
   - **SQL file.** Incoming data is from an SQL table. Before you import Contacts using this option, you may need to create a dbalias file. See To Import data from an SQL file.

4. Click **Next**.

   The dialog box that appears depends on the options you selected:
   - **Import an new file** from DBF, ASCII, or SDF, the **Import a New File** dialog box opens.
   - **Import a new file** from SQL, the Import a New SQL Table dialog box opens.
   - **Import a new file using an existing profile from DBF, ASCII, or SDF**, the Select File to Import dialog box opens.
   - **Import a new file using an existing profile from SQL**, the Select SQL Table to Import dialog box opens.

### To Import a .SDF File

After selecting the SDF file option in the Import Contact Records Wizard (see "Using the Import Contact Records Wizard" on page 106), continue with the following procedure.

1. Browse to the location of the .sdf file.
2. Selecting file location and then click next. The Import file profile screen displays.
3. On the Import SDF Profile options dialog box, click the **Options** button.
4. Select LF for record separator.
5. Under record structure, enter the field delimiter “|” (SHIFT + "). This will place the “|” mark between contact, company, etc., and separate the data for field mapping.
6. Click **OK** to preview the separated data. If it is correct, click **Next**.
7. On the Field Mappings dialog box, select the **Import Field** item and matching **GoldMine Field**, then click the **Map to GM** button to map to the fields as desired.
8. You can press **Back** to preview the contents without disrupting or removing mappings that you have already selected.
9. After all field mappings are selected and you are satisfied with the content to be imported, click **Next**.
10. If you want to save profile, check **Yes** on the Save Profile dialog box, otherwise click **No**.
11. Click **Next** to view the Ready to Import dialog box.
12. Click **Finish** to import the records that are listed in the SDF file.

### To Import data from an SQL file

If selecting SQL file option in the Import Contact Records Wizard (see "Using the Import Contact Records Wizard" on page 106), you must first create a temporary dbalias for the file in order to import data from MS SQL. The temp dbalias file can be deleted after it is imported.

Create a temporary alias file as follows

1. Login to GoldMine as Administrator or as a Master user
2. From **Tools > Databases > Alias Manager**... select **New Alias**
3. At the **Edit Alias** dialog
   a. Enter an **Alias Name**
   b. Select a **Server Type** (MSSQL)
   c. Enter a **Host** (this is usually the MSSQL host name or MSSQL instance name such as hostname\SQLEXPRESS)
d. Enter the **Database** name

e. Enter the **Owner**

f. Enter the **Login** and **Password** for the database.

g. Optionally, click **Test Connection** to verify the connection to the database

h. Click **OK** at the **Edit Alias** dialog, and again at the **New Alias** dialog

4. Import the file into GoldMine by selecting the **Import a new file using an existing profile from SQL**, the **Select SQL Table to Import** dialog box opens.

5. Select the dbalias file you created and click **Next**.

6. Map your fields to GoldMine fields

7. Click **Finish** to begin the import.

**Using the Export Contact Records Wizard**

1. Select **File > Import and Export > Export Contact Records**.

   The **Welcome to the GoldMine Export Wizard** dialog box opens.

2. Select an export option:

   - **Export to a new file**: GoldMine exports the data according to the settings defined in the Export Wizard. You can save the new settings for future use.
   - **Export to a new file using an existing profile**: Displays the Select Export Profile dialog box where you select a predefined profile GoldMine will use to format the data for export.

3. Select the file type to export into:

   - **DBF file**: Specifies data will export in the dBASE file format. Fields in a dBASE file are referred to by field name; for example, the Company field is called COMPANY, and the Contact field is called CONTACT.
   - **ASCII (TXT) file**: Specifies data will export in the delimited text file format. A delimited text file formats data with field delimiters, field separators, and record separators. In the delimited ASCII format, fields are referred to by their position in the record. For example, company name is field 1, contact name is field 2, and so on.
   - **SDF (fixed length) file**: Specifies data will export to a text file with fixed-length record format which is commonly used by mainframe computers. Fields in the SDF format are referred to by starting and ending character positions.

4. Click **Next**. If you selected:

   - **Export to a new file**, the Select Filter/Group dialog box opens.
   - **Export to a new file using an existing profile**, the Select Export Profile dialog box opens.

**About Importing and Exporting XML Files**

Import and export GoldMine contact data to or from an Extensible Markup Language (XML) format. XML is a meta language used to facilitate the easy exchange of data between systems using different applications. Importing or exporting your GoldMine data as an XML file helps you share information with different applications, such as contact management systems, that support XML.

Like HTML, XML uses tags (words bracketed by `< and `>) and attributes (name = "value"). However, XML provides more flexibility when interpreting the tags and values. For example, HTML specifically defines the meaning of each tag and attribute as well as the appearance of the tagged text when displayed in a browser; XML uses tags only as data delimiters, leaving the interpretation to the receiving application.

**NOTE:** When exchanging data with other GoldMine systems, be sure to synchronize with GoldMine instead of sharing exported data. Synchronization provides features unavailable when you export data as an XML file, including cutoff dates to limit the date range of data and the capability to exchange updates to additional contact data and calendar data.

Use the GoldMine XML Import Wizard to import data from an XML file. The wizard takes you through the process and lets you save the settings in a profile to reuse.
Use the GoldMine XML Export Wizard to export your contact data as an XML file. The wizard guides you through the procedure. All the data you export is placed in one file that the recipient can import and use as a key to map the imported data into the recipient’s database.

Exporting to XML

Export GoldMine contact data to Extensible Markup Language (XML) format. XML is a meta language is used to facilitate the exchange of data between systems using different applications. Exporting your GoldMine data as a .xml file helps you share information with recipients using a different contact management application supporting XML. Data exported is placed in one file the recipient can import and use as a key to map the imported data into the recipient’s database.

The following is a view part of a sample XML export.

```
<accounts>
  <account gm_recid="000000091" gm_accountno="ELAN SOFTWARE CORP.">
    <properties>
      <property name="Acct Mgr" db_name="KEY4">
        <property_string>C.Stott</property_string>
      </property>
      <property name="Actionon" db_name="ACTIONON">
        <property_string>20021109</property_string>
      </property>
      <property name="Address" db_name="ADDRESS1">
        <property_string>1150 Kelly Johnson Boulevard</property_string>
      </property>
      <property name="Asst" db_name="SECR">
        <property_string>Jane</property_string>
      </property>
      <property name="Business" db_name="KEY2">
        <property_string>Comp. Sfw. Dev.</property_string>
      </property>
      <property name="Callbkfreq" db_name="CALLBKFREQ">
        <property_string>0</property_string>
      </property>
      <property name="City" db_name="CITY">
      </property>
      <property name="Company" db_name="COMPANY">
        <property_string>FrontRange Solutions Inc.</property_string>
      </property>
      <property name="Contact" db_name="CONTACT">
        <property_string>Patrick B. Hillyard</property_string>
      </property>
      <property name="Contact Type" db_name="KEY1">
        <property_string>Internal</property_string>
      </property>
    </properties>
  </account>
</accounts>
```

**NOTE:** When exchanging data with other GoldMine users, synchronize with GoldMine instead of sharing exported data. Synchronization provides features unavailable when you export data as an XML file, including cutoff dates to limit the date range of data as well as the capability to exchange updates to additional contact data and calendar data.

To Export GoldMine Contact Data to XML

   - **Export to a new XML file:** Displays the Select GoldMine Data for Export dialog box. GoldMine exports the data according to a profile created as you define settings in the GoldMine XML Export Wizard. You can save the new profile for future use.
   - **Export to a new XML file using an existing profile:** Displays the Select Profile dialog box to select a predefined profile GoldMine will use to format the data for export.
2. Make a selection and click **Next** to advance to the Select GoldMine Data for Export dialog box (new .xml file) or Select Profile dialog box (select an existing profile).

**To Export Data Using an Existing XML Profile**

If you selected Export to a new XML file using an existing profile, the Select Profile dialog box appears.

1. In the Select one of the following, predefined XML export profiles text box, select the existing profile you want to use.
2. Click Delete Profile to delete the highlighted profile.
3. After highlighting your profile, click Next. The Select GoldMine Data for Export dialog box appears.

**Importing XML**

GoldMine can import contact data and user activities from an XML file. The GoldMine XML schema dictates how data is arranged within the XML file in order for GoldMine to recognize contacts, calendar activities, and other data when importing into GoldMine. The XML file you importing into GoldMine must conform to the GoldMine XML schema for the field mapping to work. You can use XSL Transformations (XSLT) to transform XML source documents to GoldMine-compliant XML documents.

**NOTE:** For more about XSLT, see [http://www.w3.org/TR/xslt](http://www.w3.org/TR/xslt).

Create an XML transformation sheet converting the XML file to match the GoldMine schema. Then import the data into GoldMine.

**Example:** Your XML source schema has the contact’s first name in one field and the last name in another field. Because the GoldMine schema requires the first and last names to be in the same field, you must create a transformation sheet merging the two fields in your source XML file. Once your source file matches the GoldMine schema, you can import the XML data into GoldMine.

- To view the GoldMine schema, export your GoldMine data to an XML file and include the schema. Open the file in Internet Explorer and view the schema.
- To create a transformation sheet (a language for transforming XML documents into other XML documents) and transform the data, use Notepad or an XML transformation utility.
Example of the first few lines of a GoldMine schema:

```xml
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
    targetNamespace="http://www frontrange.com/goldmine/xmlexport"
    xmlns="http://www frontrange.com/goldmine/xmlexport" version="1.0">
    <xs:element name="gmddata">
        <xs:complexType>
            <xs:sequence>
                <xs:element ref="header" minOccurs="1" maxOccurs="1" />
                <xs:element ref="accounts" minOccurs="0" maxOccurs="1" />
                <xs:element ref="unlinked_content" minOccurs="0"
                    maxOccurs="1" />
            </xs:sequence>
        </xs:complexType>
    </xs:element>
    <xs:element name="header">
        <xs:complexType>
            <xs:sequence>
                <xs:element ref="goldmine_version" minOccurs="1"
                    maxOccurs="1" />
                <xs:element ref="gmdbdef" minOccurs="0" maxOccurs="1" />
            </xs:sequence>
        </xs:complexType>
    </xs:element>
    <xs:element name="goldmine_version" type="xs:string" />
    <xs:element name="gmdbdef">
        <xs:complexType>
            <xs:sequence>
                <xs:element ref="gmdbfld" minOccurs="0"
                    maxOccurs="unbounded" />
            </xs:sequence>
        </xs:complexType>
    </xs:element>
</xs:schema>
```
To Import GoldMine Contact Data from XML

2. Select one option in the GoldMine XML Import Wizard:
   - Import a new file: Displays the Import a New File dialog box. GoldMine imports the data according to a profile created as you define settings in the GoldMine XML Import Wizard.
   - Import a new file using an existing profile: Displays the Select File to Import dialog box to select a predefined profile GoldMine will use to format the data you import from.
3. Click Next to advance to the Import a New File dialog box or the Select File to Import dialog box.

IMPORT A NEW FILE DIALOG BOX
The Import a New File dialog box appears when you select Import a new file from DBF, ASCII, or SDF on the GoldMine XML Import Wizard dialog box.

1. In the Enter the full path and filename of the file to be imported text box, type or browse to the path of the .xml file to import.
2. Click Next.
Either the Select Data to be Imported From File or Import File Profile dialog box appears.

Importing from Other Applications

Importing Data from ACT!
GoldMine offers an import wizard to help convert ACT! data to GoldMine. Select an import method based on the ACT! version you are importing from.

- If importing from ACT! 6.x, select File > Import and Export > Convert from ACT! 6.0. The Welcome to the ACT! Import Wizard opens.
- If importing from ACT! 2000 or ACT! 4 and lower, select File > Import and Export > Import Contact Records. The Welcome to GoldMine’s Import Wizard opens.

Using the ACT! Import Wizard
The ACT! Import Wizard appears when configuring ACT! data importing using one of these methods:

2. Select File > Import and Export > Import Contact Records.
   
   NOTE: We recommend backing up your data before beginning.
3. On the ACT! Import Wizard dialog box, type or browse to the location of your ACT! .dbf file in the Enter the full path and filename of the ACT! file to be imported text box.
4. In the User field, type the name of the ACT! user.
5. In the Password field, type the user’s password.
6. Click Next. The ACT! Import Options dialog box appears.

Using the Outlook Conversion Wizard
The Outlook Conversion Wizard provides an easy way to convert your Outlook files (Contacts, Calendar, Tasks, and E-mail folders) to GoldMine. This is useful when moving information from Outlook to GoldMine as your business contact management system. The conversion wizard is an import feature and is not to be used in lieu of Outlook synchronization.

NOTE: Outlook contact and calendar notes with rich text formatting and embedded URLs import into GoldMine as plain text.
1. Select File > Import and Export > Convert from Outlook. The Outlook Conversion Wizard dialog box appears.

2. Click Next. The Import Options dialog box appears.
   - Apply GoldMine’s Formatting to phone numbers being imported: Converts the Outlook format—commonly (719) 555-5555—to GoldMine—commonly (719)555-5555.
   - Select the username...: Select the user in the drop-down list who will become the owner of the records and who the calendar and history activities will be assigned to.
   - Select one duplicate checking option:
     - Do not import duplicate records: Does not import any records where the company, contact, and phone fields in Outlook match a GoldMine record.
     - Import all records to GoldMine: Imports all selected records into GoldMine without checking for duplicate records.

3. Click Next. The Contact Folder(s) dialog box appears.
   - To select Contact folders to import, click Add. The Select Folder dialog box appears. Select a contact folder to import and click OK. Repeat the process for each contact folder to import.
   - Click Remove to delete a highlighted folder on the Contact Folder(s) dialog box.
   - If not importing any contact folders, click Next without adding folders to the Folder list.

4. Click Next. The Calendar Folder(s) dialog box appears.
   - To select Calendar folders to import, click Add. The Select Folder dialog box appears. Select a calendar folder to import and click OK. Repeat the process for each calendar folder to import.
   - Click Remove to delete a highlighted folder on the Calendar Folder(s) dialog box.
   - If not importing any calendar folders, click Next without adding folders to the Folder list.

5. Click Next. The Calendar Options dialog box appears.
   - To set the date range of calendar records you are importing, select number of days, months, years before today for the Starting date, and the number of day, month, or year before today for Ending date.

6. Click Next. The Task Folder(s) dialog box appears.
   - To select Task folders to import, click Add. The Select Folder dialog box appears. Select a task folder to import and click OK. Repeat the process for each task folder to import.
   - Click Remove to delete a highlighted folder on the Task Folder(s) dialog box.
   - If not importing any task folders, click Next without adding folders to the Folder list.

7. Click Next. The E-mail Folder(s) dialog box appears.
   - To select E-mail folders to import, click Add. The Select Folder dialog box appears. Select an e-mail folder to import and click OK. Repeat the process for each e-mail folder to import.
     - NOTE: Imported e-mail folders and Inbox messages are categorized and filed in the E-mail Center in a separate Outlook Import folder.
   - Click Remove to delete a highlighted folder on the E-mail Folder(s) dialog box.
   - If not importing any e-mail folders, click Next without adding folders to the Folder list.

8. Click Next. The Ready to Import dialog box appears.

9. Click Back to change any settings and then click Finish.
Exporting to GoldMine From Microsoft Excel

After GoldMine Plus for Microsoft Office is installed, data can be exported from Microsoft Excel to your GoldMine database using new menu options in Excel.

GoldMine Plus for Office adds an export feature to the GoldMine menu in Excel. Use this menu option to map Excel columns to GoldMine fields and initiate the export process.

NOTE: Backup your database before beginning.

NOTE: Before proceeding with the export, verify that phone numbers are formatted consistently and make changes as needed. The format of the phone numbers in your Excel spreadsheet must be the same for the Excel ODBC to interpret the numbers correctly. If formats are inconsistent, the ODBC driver interprets all the values in the column as null and you lose phone number data during the export process. For example, you cannot have one phone number that is 1235557894 and another that is 777-555-1236. Before exporting to GoldMine, specify one format and update all phone numbers in your spreadsheet to match the selected format. When the phone number format is consistent, begin exporting to GoldMine.

1. Launch GoldMine.
2. Open the Excel spreadsheet you are exporting to GoldMine.
3. Select the cells you are exporting to GoldMine and specify the Named Range. In Excel, select Insert > Name > Define. The Define Name dialog box appears. See Excel Help for details.
   NOTE: To perform this function in Microsoft Office 2007, select the cells to export to GoldMine, right-click on the selected cell range and select Name a Range from the drop-down menu. You can also select the Formulas tab, then select Define Name > Define Name from the menu.
4. In the Names text box, type the desired name of the range.
   NOTE: The first row of the selected range must contain only header data.
5. either Workbook or Sheet from the Scope drop-down menu.
   The Welcome to the GoldMine Plus for Microsoft Excel Export Wizard! appears.
7. Click Next. The field mapping dialog box appears.
8. To map columns to GoldMine fields, highlight the column in the Excel Fields list and then highlight the GoldMine field to map the column to. Click Add Mapping. Your selection is added to the Mapped Fields list (for example, Column1<=>C1.Company).
9. Continue to map desired fields. When finished, click Next. The GoldMine is now Ready to export your Excel data! dialog box appears.
10. Click Finish.
    When the import process completes, a dialog box appears, indicating the number of records imported into GoldMine.

Importing and Exporting iCalendar Files

Importing iCalendar Files

1. Select File > Import and Export > Import from an iCalendar file. The Windows Open dialog box appears.
2. Locate the iCalendar (*.ics) files to import and click Open. The Import from an iCalendar file dialog box appears.
3. To import a single iCalendar activity, select the activity and click Import.
   NOTE: When importing iCalendar files from Lotus Notes, GoldMine schedules activities without assigned participants, or invitees, as unlinked. Identify this situation whenever the Organizer entry is UNKNOWN.
4. To import all activities, click Import All.
5. As each activity is processed, the **Attach imported activity to contact** dialog box appears. Select one option:
   - Find an existing contact and then link this activity.
   - Find an existing contact, create a new additional contact and link to it.
   - Create a new contact and then link this activity.
   - Do not link this activity to any contact
6. Click **OK**. Depending on the option selected, different windows and dialog boxes appear.
7. Click **Close**.

### Exporting iCalendar Files

Export iCalendar files so users of iCalendar-enabled applications, such as Microsoft Outlook or Lotus Notes can import activities from your iCalendar file to their calendars.

1. Select **File > Import and Export > Export to an iCalendar file**. The **Export to an iCalendar file** dialog box appears.
2. In the **Select based on Contact(s)/User(s)** area, select one:
   - **Activities based on Contact(s)**: Exports activities scheduled for the current contact record, or for records based on the selected filter.
     - **Current Contact record**: Exports the information for the current record.
     - **Filters/Groups**: Exports information based on the filter or group selected in the drop-down list.
   - **Activities based on the User(s)**: Exports activities scheduled for selected users.
     - **Select the any or all users’ activities to export.**
3. In the **Selection Criteria** area, select the activity types to export.
4. To narrow the export to a range of dates, select **Date range** and select the **From** and **To** dates on the F2 graphical calendar.
5. Click **Export**. The Windows **Save As** dialog box appears.
6. Locate the folder to save the files to and type the **File Name**.
   - Verify the **Save as type** is **iCalendar format (*.ics)**.
7. Click **Save**. The **GoldMine Process Monitor** appears displaying the progress of the export.

---

### Merging and Purging Records

Users can accidentally create duplicate contact records in GoldMine that, over time, might be too great for manual deletion. GoldMine provides several methods for consolidating information and deleting duplicate records ("Using the Delete Wizard" on page 118):

- **Merge/Purge Records Wizard.** Simplifies the replacement process by guiding you through the entire procedure.
- **Merge Open Records.** Updates the contact record with input focus by merging information in two contact records displayed in GoldMine’s work area.
- **Merge Tagged Records.** Creates one contact record by merging information from all tagged records.

**IMPORTANT:** Merging and purging permanently changes the database. We recommend backing up the database first,
Using the Merge/Purge Records Wizard

Use the Merge/Purge Wizard to select records based on a predefined profile or define your own criteria. Set up a custom merge/purge profile by defining:

- **Contact record field.** Select as many as you want GoldMine to use during the evaluation process to match records.
- **Method.** Select a criterion for each record match which can be case sensitive, case insensitive, Soundex, or first n characters.
- **Weight.** Select and assign a numeric weight to each criterion. When a record is evaluated, each match with a criterion accrues the assigned weight value. If the total weight earned by matches between two records and the specified criteria equal or exceed the qualifying weight value, GoldMine selects the records as duplicates.

You can also select the method for disposing of duplicate records. Merge data from two duplicate records to create one updated record, or delete one of the duplicates according to a condition such as deleting the older record. Specify GoldMine process the merge/purge automatically, or display duplicate records for viewing or manual deletion.

---

**IMPORTANT:** Merging and purging permanently changes the database. We recommend you back it up before performing a merge/purge.

**NOTE:** It is highly recommended that you select Prompt me before merging records and Dry run: Only show duplicates—do not merge nor purge before actually performing a purge.

1. Select **Tools > Data Management > Merge/Purge Records > Merge/Purge Records Wizard.** The **GoldMine Merge/Purge Wizard** appears.
2. Select one procedure:
   - **Merge/Purge using a predefined profile:** Displays the Select a Merge/Purge Profile dialog box containing a list of previously defined merge/purge profiles. Highlight the profile to use to search for duplicate records.
   - **Merge/Purge using new criteria:** Set up weighted criteria for the current merge/purge. The settings can be used one time only or saved as a merge/purge profile for future use.
3. Click Next.
   - If you selected **Merge/Purge using a predefined profile,** select the profile from the Select a Merge/Purge Profile dialog box. You can also delete a previously defined profile by selecting Delete Profile. After selecting a profile, click Next. The **Select a Filter/Group** dialog box appears.
   - If you select **Merge/Purge using new criteria,** the **Select a Filter/Group** dialog box appears.

Selecting the Merge and Purge Methods

The **Merge Method** and **Purge Method** dialog boxes contain settings that determine how GoldMine treats records selected as duplicates.

1. The **Merge Method** dialog box appears after selecting merge/purge criteria.
2. Select one merge method:
   - **Keep the record that was Created First:** Selects the contact record saved first. The date is determined by the entry logged in the Creation field of the Summary tab.
   - **Keep the record that was Last Updated:** Selects the contact record changed last. The date is determined by the entry logged in the Last Update field of the Summary tab.
   - **Create Linked Additional Contacts in each record:** GoldMine keeps both records and creates additional contacts in the Contacts tab of the duplicate records. For example, if GoldMine determines Jon Smith and John Smyth are duplicate contacts, Jon Smith is added as an additional contact in the John Smyth contact record. John Smyth is added as an additional contact in the Jon Smith contact record.

   **NOTE:** Selecting Create Linked Additional Contacts does not prompt you for a purge method, but displays the Save the Merge/Purge Profile dialog box.
3. Select one of the following options:
   - Create Additional Contact of non-surviving record: The primary contact of the deleted duplicate record is stored as an additional contact in the surviving contact record. GoldMine stores the new additional contact in the Contacts tab of the surviving contact record.
   - Prompt me before merging records: Check this box for GoldMine to display duplicate records and offer options so the user can make individual decisions on each set of duplicate records.
   - Dry run: Only show duplicates—do not merge nor purge: Check this box for GoldMine to display duplicate records without any options to select records for purging. At the end of the process, duplicate records remain in the contact database.

   **NOTE:** If you select Dry run, GoldMine does not prompt you for a purge method, but displays the Save the Merge/Purge Profile dialog box.
   
   **NOTE:** It is recommended that you select Prompt me before merge records and Dry run: Only show duplicates—do not merge or purge before actually performing a purge.

4. After selecting a merge/purge option, click Next. Unless creating linked additional contacts or performing a dry run, the Purge Method dialog box appears.

5. Select one option:
   - Delete the duplicate record: GoldMine automatically deletes records meeting the qualifying weight specified in the merge/purge profile.
   - Update a field with a value to indicate record deletion: Changes the specified field with a specified value—selecting this option does not purge duplicate records.

   **TIP:** Selecting Update a field with a value to indicate record deletion is the safest way to merge/purge records. This option performs the merge based on your criteria and then marks the non-surviving record but leaves it in your database. Review the records and delete based on the value with which the specified field is updated.

   - Update Field: Select the field in the drop-down list.
   - Value: Type the value you are updating the field with to indicate deletion. If any record had an entry in the specified field, this data overwrites the existing value.

7. Select Merge Calendar, History, and ContSupp records to move this data to the surviving contact record from the purged record. This option moves data from these records:
   - Calendar
   - History
   - Additional contact
   - Referral
   - Detail

8. Click Next. The Save the Merge/Purge Profile dialog box opens.

### Merging Open Contact Records

You can merge two or more open contact records. The active contact record is updated with information from the other record. The non-active contact is deleted.

1. Select Window > New Contact Window. A second contact window opens.
2. Display the second record you are merging. Make the record you are keeping in the database the active contact record.
4. The dialog box reminds you that the active contact record will survive. Information from the other records will be consolidated on the surviving record, and the other records will be deleted.
5. Click Yes.
Merging Tagged Records

You can consolidate information from all tagged contact records into one contact record.

**NOTE:** GoldMine updates the first tagged contact record and deletes all other tagged contact records.

1. Select the records to merge.
2. Select **Tools > Merge/Purge Records > Merge Tagged Records.** The **Merge/Purge Tagged Contact Records** dialog box appears.
3. The dialog box reminds you that the first record tagged will be the surviving record with data from the other records consolidated on that one record. Once consolidated, the other records are deleted.
4. Click **Yes.**

Using the Delete Wizard

To update your contact database by deleting some or all Calendar records, history records, and/or contact records, use GoldMine’s Delete Wizard to reduce the possibility of an unintentional deletion.

**NOTE:** Only users with Master Rights can access the Delete Wizard.

1. Select **Tools > Data Management > Delete Records.** The **Delete Wizard** appears.
2. Select one delete option:
   - **Delete old history records:** Purges old history data from the contact database. Delete all history records from the contact database, or activate a filter or group, then use this option to delete history records from the subset of records.
     **NOTE:** Removing old history records periodically can significantly reduce the amount of disk space used by contact sets.
   - **ALL (filtered) contact records:** Deletes a subset of records from the contact database based on a filter or group.
3. Click **Next.** If you selected **Delete old history records** or **Delete ALL,** the select filter/group dialog box appears.

Monitoring Processes

The GoldMine Process Monitor launches automatically when executing or running processes within GoldMine, including synchronization, Automated Processes, importing and exporting, or merging and purging.

The Process Monitor can float anywhere on the GoldMine screen, or it can be docked to any of the four sides of the GoldMine screen. The window can also be resized to maximize available workspace. For best results, dock the Process Monitor to the bottom of the GoldMine screen.

The upper pane displays processes running and general status, while the lower pane displays the status of the component tasks. Use the toolbar or the local menu to manage process options.

**NOTE:** The Process Monitor uses color codes, assigned to text or the background, to indicate process status.

<table>
<thead>
<tr>
<th>Color</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Black text on default background</td>
<td>Operation normal</td>
</tr>
<tr>
<td>Blue text on default background</td>
<td>Notice</td>
</tr>
<tr>
<td>Black text on yellow background</td>
<td>Warning</td>
</tr>
<tr>
<td>White text on red background</td>
<td>Error</td>
</tr>
<tr>
<td>Green text on default background</td>
<td>Task successfully completed</td>
</tr>
</tbody>
</table>
Understanding GoldMine Data Files

- GoldMine Table Structure (see page 119)
- GoldMine Tables (see page 119)
- Contract Tables (see page 124)
- Rec Types (see page 130)

GoldMine Table Structure

GoldMine tables and Contact tables make up the GoldMine database, which consists of data organized in columns and rows. Cells at any column/row can contain only one value. Columns and rows work together to define the type of information a cell can contain.

Columns: Each column contains values providing information of one type such as Company, City, or State, and each column represents a field. One column, or a combination of columns, is the unique index (the unique value each record can be identified by).

Rows: Each row contains one record consisting of a set of column values. A table can contain as few as 0 rows or an unlimited number of rows. SQL Server can retrieve data from tables by working with relationships represented by common data values between tables. A common data value is a value that is the same between multiple tables. For example, both a Contact1 table and a Cal table contain AccountNo values. The shared value creates the relationship between the records in the 2 tables.

GoldMine Tables

The Cal table contains a record for each scheduled activity. Different record types are distinguished by the RecType. Each record type can use the same field for different purposes. The Cal table is part of the GoldMine files.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USERID</td>
<td>String</td>
<td>8</td>
<td>User Name</td>
</tr>
<tr>
<td>ACCOUNTNO</td>
<td>String</td>
<td>20</td>
<td>Account number of the linked contact</td>
</tr>
<tr>
<td>ONDATE</td>
<td>Date</td>
<td>8</td>
<td>Activity date</td>
</tr>
<tr>
<td>ONTIME</td>
<td>String</td>
<td>5</td>
<td>Activity time</td>
</tr>
<tr>
<td>ENDDATE</td>
<td>Date</td>
<td>8</td>
<td>Ending date of a scheduled activity</td>
</tr>
<tr>
<td>ALARMFLAG</td>
<td>String</td>
<td>1</td>
<td>Alarm flag</td>
</tr>
<tr>
<td>ALARMTIME</td>
<td>String</td>
<td>5</td>
<td>Alarm time</td>
</tr>
<tr>
<td>ALARMDATE</td>
<td>String</td>
<td>8</td>
<td>Alarm date</td>
</tr>
<tr>
<td>ACTVCODE</td>
<td>String</td>
<td>3</td>
<td>Activity code</td>
</tr>
<tr>
<td>RSVP</td>
<td>String</td>
<td>1</td>
<td>RSVP notification</td>
</tr>
<tr>
<td>DURATION</td>
<td>Integer</td>
<td>3</td>
<td>Duration/Probability</td>
</tr>
<tr>
<td>RECTYPE</td>
<td>String</td>
<td>1</td>
<td>Record type</td>
</tr>
<tr>
<td>ACONFIRM</td>
<td>String</td>
<td>3</td>
<td>Meeting confirmation</td>
</tr>
<tr>
<td>APPTUSER</td>
<td>String</td>
<td>10</td>
<td>Meeting confirmation user</td>
</tr>
<tr>
<td>STATUS</td>
<td>String</td>
<td>4</td>
<td>The first character is flag. The second character=1 if notes exist.</td>
</tr>
<tr>
<td>DIRCODE</td>
<td>String</td>
<td>10</td>
<td>Contact Set code of the contact file</td>
</tr>
<tr>
<td>NUMBER1</td>
<td>Integer</td>
<td>8</td>
<td>Sales potential</td>
</tr>
</tbody>
</table>
Fields stores the location and tab order of every field within the Fields tab and the field position and tab order of the primary contact fields.

Filters holds all filters created in the system.

Forms stores the merge form template properties added to the merge forms system.

FormsFld contains information about fields in the merge forms.

FormsQue is a queue of mail-merged documents waiting to be sent.

GMTLog, with the ContTlog table, controls the synchronization process. The Primary Tlog holds the synchronization time stamp for the tables in the GoldMine files, such as Cal, Filters, and others.

GSLogs is the GoldSync log table.

GServer contains the GoldSync server settings.

GSites contains configuration parameters for GoldSync sites.

InfoMine stores data from the InfoCenter. The InfoCenter is part of the GoldMine files.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NUMBER2</td>
<td>Integer</td>
<td>8</td>
<td>Units of a forecasted sale</td>
</tr>
<tr>
<td>COMPANY</td>
<td>String</td>
<td>60</td>
<td>Company/Contact name</td>
</tr>
<tr>
<td>REF</td>
<td>String</td>
<td>80</td>
<td>Reference</td>
</tr>
<tr>
<td>NOTES</td>
<td>Memo</td>
<td>1</td>
<td>Notes</td>
</tr>
<tr>
<td>LINKRECID</td>
<td>String</td>
<td>15</td>
<td>Linked record ID</td>
</tr>
<tr>
<td>LDOCRECID</td>
<td>String</td>
<td>15</td>
<td>Reserved for future use</td>
</tr>
<tr>
<td>LOPRECID</td>
<td>String</td>
<td>15</td>
<td>Linked Opportunity Manager record ID</td>
</tr>
<tr>
<td>CREATEBY</td>
<td>String</td>
<td>8</td>
<td>Created by user</td>
</tr>
<tr>
<td>CREATEON</td>
<td>Date</td>
<td>8</td>
<td>Created date</td>
</tr>
<tr>
<td>CREATEAT</td>
<td>String</td>
<td>8</td>
<td>Creation time</td>
</tr>
<tr>
<td>LASTUSER</td>
<td>String</td>
<td>8</td>
<td>Last modified by</td>
</tr>
<tr>
<td>LASTDATE</td>
<td>String</td>
<td>8</td>
<td>Last modified date</td>
</tr>
<tr>
<td>LASTTIME</td>
<td>Date</td>
<td>8</td>
<td>Last modified time</td>
</tr>
<tr>
<td>RECID</td>
<td>String</td>
<td>15</td>
<td>Record ID</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCOUNTNO</td>
<td>String</td>
<td>20</td>
<td>Account number</td>
</tr>
<tr>
<td>CREATEBY</td>
<td>String</td>
<td>8</td>
<td>Creation user</td>
</tr>
<tr>
<td>RECTYPE</td>
<td>String</td>
<td>10</td>
<td>Record type</td>
</tr>
<tr>
<td>SORTKEY</td>
<td>String</td>
<td>20</td>
<td>Sort key</td>
</tr>
<tr>
<td>TSECTION</td>
<td>String</td>
<td>100</td>
<td>Section</td>
</tr>
<tr>
<td>TOPIC</td>
<td>String</td>
<td>80</td>
<td>Topic</td>
</tr>
<tr>
<td>KEYWORDS</td>
<td>String</td>
<td>80</td>
<td>Keywords</td>
</tr>
<tr>
<td>OPTIONS</td>
<td>String</td>
<td>10</td>
<td>Options</td>
</tr>
<tr>
<td>OPTION1</td>
<td>String</td>
<td>20</td>
<td>Option 1</td>
</tr>
</tbody>
</table>
ImpExp stores the Import/Export profiles used to export and import data.

LeadDbfs holds leads analysis definitions set from the Go To > Analysis menu.

Lookup contains each F2 Lookup entry. The Lookup table is part of the GoldMine files.

**Mailbox stores all GoldMine e-mail.** The Mailbox is part of the GoldMine files. The history display of messages pulls information from here. If an e-mail message has an attachment, it stores in the `\goldmine\mailbox\attach` folder by default.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OPTION2</td>
<td>String</td>
<td>20</td>
<td>Option 2</td>
</tr>
<tr>
<td>LINKEDDOC</td>
<td>Memo</td>
<td>1</td>
<td>Linked document</td>
</tr>
<tr>
<td>NOTES</td>
<td>Memo</td>
<td>1</td>
<td>Notes</td>
</tr>
<tr>
<td>USERREAD</td>
<td>String</td>
<td>8</td>
<td>Read access</td>
</tr>
<tr>
<td>USERWRITE</td>
<td>String</td>
<td>8</td>
<td>Write access</td>
</tr>
<tr>
<td>LASTUSER</td>
<td>String</td>
<td>8</td>
<td>Last modified by</td>
</tr>
<tr>
<td>LASTDATE</td>
<td>Date</td>
<td>8</td>
<td>Last modified date</td>
</tr>
<tr>
<td>LASTTIME</td>
<td>String</td>
<td>5</td>
<td>Last modified time</td>
</tr>
<tr>
<td>RECID</td>
<td>String</td>
<td>15</td>
<td>Record ID</td>
</tr>
<tr>
<td>FIELDNAME</td>
<td>String</td>
<td>11</td>
<td>Field name</td>
</tr>
<tr>
<td>LOOKUPSUPP</td>
<td>String</td>
<td>10</td>
<td>Lookup Options</td>
</tr>
<tr>
<td>ENTRY</td>
<td>String</td>
<td>40</td>
<td>Description</td>
</tr>
<tr>
<td>RECID</td>
<td>String</td>
<td>15</td>
<td>Record ID</td>
</tr>
<tr>
<td>MASTERVER VALUE</td>
<td>String</td>
<td>40</td>
<td>Corresponding value for cross-field validation</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LINKRECID</td>
<td>String</td>
<td>15</td>
<td>Linked Record ID</td>
</tr>
<tr>
<td>FLAGS</td>
<td>String</td>
<td>8</td>
<td>Flags</td>
</tr>
<tr>
<td>USERID</td>
<td>String</td>
<td>8</td>
<td>User name</td>
</tr>
<tr>
<td>FOLDER</td>
<td>String</td>
<td>20</td>
<td>Folder</td>
</tr>
<tr>
<td>FOLDER2</td>
<td>String</td>
<td>20</td>
<td>Subfolder</td>
</tr>
<tr>
<td>ACCOUNTNO</td>
<td>String</td>
<td>20</td>
<td>Account number</td>
</tr>
<tr>
<td>CREATEON</td>
<td>Date</td>
<td>8</td>
<td>Creation date</td>
</tr>
<tr>
<td>MAILSIZE</td>
<td>String</td>
<td>8</td>
<td>Mail size</td>
</tr>
<tr>
<td>MAILDATE</td>
<td>Date</td>
<td>8</td>
<td>Mail date</td>
</tr>
<tr>
<td>MAILTIME</td>
<td>String</td>
<td>8</td>
<td>Mail time</td>
</tr>
<tr>
<td>MAILREF</td>
<td>String</td>
<td>100</td>
<td>Linked contact name and subject line</td>
</tr>
<tr>
<td>RFC822</td>
<td>Memo</td>
<td>1</td>
<td>Mail message</td>
</tr>
</tbody>
</table>
The OpMgr table contains the data in the Opportunity and Project Managers. The OpMgr table is part of the GoldMine files.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RECID</td>
<td>String</td>
<td>15</td>
<td>Record ID</td>
</tr>
</tbody>
</table>

OpMrgFld serves as personal contacts, containing names and phone numbers. The PerPhone table is part of the GoldMine files.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RECID</td>
<td>String</td>
<td>15</td>
<td>Record ID</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USERID</td>
<td>String</td>
<td>8</td>
<td>User name</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>STATUS</td>
<td>String</td>
<td>50</td>
<td>Status</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CYCLE</td>
<td>String</td>
<td>50</td>
<td>Cycle</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>STAGE</td>
<td>String</td>
<td>30</td>
<td>Stage</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SOURCE</td>
<td>String</td>
<td>30</td>
<td>Source</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>String</td>
<td>20</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>F2</td>
<td>String</td>
<td>20</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>F3</td>
<td>String</td>
<td>10</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>STARTDATE</td>
<td>Date</td>
<td>8</td>
<td>Start date</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLOSEDDATE</td>
<td>Date</td>
<td>8</td>
<td>Close date</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLOSEBY</td>
<td>Date</td>
<td>8</td>
<td>Close by</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FORAMT</td>
<td>Float</td>
<td>10</td>
<td>For amount</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FORPROB</td>
<td>Integer</td>
<td>4</td>
<td>Probability</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CLOSEAMT</td>
<td>Float</td>
<td>10</td>
<td>Close amount</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NOTES</td>
<td>Memo</td>
<td>1</td>
<td>Notes</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RECID</td>
<td>String</td>
<td>15</td>
<td>Record ID</td>
</tr>
</tbody>
</table>
- **Report32** holds the report definitions and settings appearing in the Reports Menu dialog box.
- **ResItems** contains the resource(s) you created, such as equipment, facilities, and other resources scheduled from the Resources' Master File. The ResItems table is part of the GoldMine files.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PHONE1</td>
<td>String</td>
<td>16</td>
<td>Phone number</td>
</tr>
<tr>
<td>RECID</td>
<td>String</td>
<td>15</td>
<td>Record ID</td>
</tr>
</tbody>
</table>

- **Scripts** holds telemarketing branching scripts.
- **SPFiles** is the directory of the GoldMine Contact Set databases. The SPFiles table is part of the GoldMine files.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Length</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NAME</td>
<td>String</td>
<td>8</td>
<td>Name</td>
</tr>
<tr>
<td>CODE</td>
<td>String</td>
<td>10</td>
<td>Code</td>
</tr>
<tr>
<td>RESDESC</td>
<td>String</td>
<td>40</td>
<td>Description</td>
</tr>
<tr>
<td>CUSTODIAN</td>
<td>String</td>
<td>8</td>
<td>Custodian</td>
</tr>
<tr>
<td>NOTES</td>
<td>Memo</td>
<td>1</td>
<td>Notes</td>
</tr>
<tr>
<td>RECID</td>
<td>String</td>
<td>15</td>
<td>Record ID</td>
</tr>
</tbody>
</table>

- **SysLog** is a global table used by all databases and processes. It records errors occurring when using the database tables. This table can be deleted if a user is running out of disk space and the old tables are no longer needed for troubleshooting. The system creates a new log.
- **Processes** holds the Automated Processes definitions.
- **UserLog** contains information used for each user’s Time Clock.
Contract Tables

**Contact1**

Contact1 contains the main contact fields, such as name, company, address, and the Key1 through Key5 tables. The Contact1 table is part of the Contact files (The tables storing a database's contact information. Also referred to as Common files. The CommonDir line in the GM.ini points to the default contact files).

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Len</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCOUNTNO</td>
<td>String</td>
<td>20</td>
<td>Account number</td>
</tr>
<tr>
<td>COMPANY</td>
<td>String</td>
<td>40</td>
<td>Company name</td>
</tr>
<tr>
<td>CONTACT</td>
<td>String</td>
<td>40</td>
<td>Contact name</td>
</tr>
<tr>
<td>LASTNAME</td>
<td>String</td>
<td>15</td>
<td>Contact's last name</td>
</tr>
<tr>
<td>DEPARTMENT</td>
<td>String</td>
<td>35</td>
<td>Department</td>
</tr>
<tr>
<td>TITLE</td>
<td>String</td>
<td>35</td>
<td>Contact title</td>
</tr>
<tr>
<td>SECR</td>
<td>String</td>
<td>20</td>
<td>Secretary</td>
</tr>
<tr>
<td>PHONE1</td>
<td>String</td>
<td>25</td>
<td>Phone 1</td>
</tr>
<tr>
<td>PHONE2</td>
<td>String</td>
<td>25</td>
<td>Phone 2</td>
</tr>
<tr>
<td>PHONE3</td>
<td>String</td>
<td>25</td>
<td>Phone 3</td>
</tr>
<tr>
<td>FAX</td>
<td>String</td>
<td>25</td>
<td>Fax number</td>
</tr>
<tr>
<td>EXT1</td>
<td>String</td>
<td>6</td>
<td>Phone extension 1</td>
</tr>
<tr>
<td>EXT2</td>
<td>String</td>
<td>6</td>
<td>Phone extension 12</td>
</tr>
<tr>
<td>EXT3</td>
<td>String</td>
<td>6</td>
<td>Fax extension is EXT3 to maintain compatibility with previous versions</td>
</tr>
<tr>
<td>EXT4</td>
<td>String</td>
<td>6</td>
<td>Phone extension 3</td>
</tr>
<tr>
<td>ADDRESS1</td>
<td>String</td>
<td>40</td>
<td>Address 1</td>
</tr>
<tr>
<td>ADDRESS2</td>
<td>String</td>
<td>40</td>
<td>Address 2</td>
</tr>
<tr>
<td>ADDRESS3</td>
<td>String</td>
<td>40</td>
<td>Address 3</td>
</tr>
<tr>
<td>CITY</td>
<td>String</td>
<td>30</td>
<td>City</td>
</tr>
<tr>
<td>STATE</td>
<td>String</td>
<td>20</td>
<td>State</td>
</tr>
<tr>
<td>ZIP</td>
<td>String</td>
<td>10</td>
<td>Zip code</td>
</tr>
<tr>
<td>COUNTRY</td>
<td>String</td>
<td>20</td>
<td>Country</td>
</tr>
<tr>
<td>DEAR</td>
<td>String</td>
<td>20</td>
<td>Dear (Salutation)</td>
</tr>
<tr>
<td>SOURCE</td>
<td>String</td>
<td>20</td>
<td>Lead Source</td>
</tr>
<tr>
<td>KEY1</td>
<td>String</td>
<td>20</td>
<td>Key 1</td>
</tr>
<tr>
<td>KEY2</td>
<td>String</td>
<td>20</td>
<td>Key 2</td>
</tr>
<tr>
<td>KEY3</td>
<td>String</td>
<td>20</td>
<td>Key 3</td>
</tr>
<tr>
<td>KEY4</td>
<td>String</td>
<td>20</td>
<td>Key 4</td>
</tr>
<tr>
<td>KEY5</td>
<td>String</td>
<td>20</td>
<td>Key 5</td>
</tr>
</tbody>
</table>
### Primary Fields Stored in the Contact1 Table

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Field Label</th>
<th>Indexed Field</th>
</tr>
</thead>
<tbody>
<tr>
<td>COMPANY</td>
<td>COMPANY</td>
<td>Yes</td>
</tr>
<tr>
<td>CONTACT</td>
<td>CONTACT</td>
<td>Yes</td>
</tr>
<tr>
<td>DEPT</td>
<td>DEPT</td>
<td>No</td>
</tr>
<tr>
<td>TITLE</td>
<td>TITLE</td>
<td>No</td>
</tr>
<tr>
<td>SOURCE</td>
<td>SOURCE</td>
<td>No</td>
</tr>
<tr>
<td>LAST</td>
<td>LAST</td>
<td>Yes</td>
</tr>
<tr>
<td>DEAR</td>
<td>DEAR</td>
<td>No</td>
</tr>
<tr>
<td>SECR ASST</td>
<td>ASST</td>
<td>No</td>
</tr>
<tr>
<td>ADDRESS1</td>
<td>ADDRESS1</td>
<td>No</td>
</tr>
<tr>
<td>ADDRESS2</td>
<td>[not displayed]</td>
<td>No</td>
</tr>
<tr>
<td>ADDRESS3</td>
<td>[not displayed]</td>
<td>No</td>
</tr>
<tr>
<td>CITY</td>
<td>CITY</td>
<td>Yes</td>
</tr>
<tr>
<td>STATE</td>
<td>STATE</td>
<td>Yes</td>
</tr>
<tr>
<td>ZIP</td>
<td>ZIP</td>
<td>Yes</td>
</tr>
<tr>
<td>COUNTRY</td>
<td>COUNTRY</td>
<td>Yes</td>
</tr>
<tr>
<td>MERGECODES</td>
<td>MERGECODES</td>
<td>No</td>
</tr>
<tr>
<td>PHONE1</td>
<td>PHONE1</td>
<td>Yes</td>
</tr>
</tbody>
</table>

- **STATUS** String 3 Internal Status
  - Position 1 tracks the type of phone number. If the first character is U, the USA-style phone format is used.
  - Position 2 tracks curtaining level (0=None, 1=partial, 2=full, 3=semi-partial)
  - Position 3 indicates a record alert if the value is 1.

- **NOTES** Memo Notes

- **MERGECODES** String 20 Merge codes (Three-character codes used as the basis for e-mail and document merging for mass mailings) for contact

- **CREATEDBY** String 8 Creation user
- **CREATEDON** Date 8 Creation date
- **CREATEAT** String 8 Creation time
- **LASTUSER** String 8 Last modified by
- **LASTDATE** Date 8 Last modified date
- **LASTTIME** String 6 Last modified time
- **RECID** String 15 Record ID
NOTE: The AccountNo and the RecId fields are also indexed fields

Contact2

Contact2 contains additional fields associated with the Contact Record, primarily the user-defined fields. The Contact2 table is part of the Contact files (The tables storing a database’s contact information. Also referred to as Common files. The CommonDir line in the GM.ini points to the default contact files). The fields listed below are added during installation. Add fields to this table beginning with U.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Len</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCOUNTNO</td>
<td>String</td>
<td>20</td>
<td>Account number</td>
</tr>
<tr>
<td>CALLBACKON</td>
<td>Date</td>
<td>8</td>
<td>Call back date</td>
</tr>
<tr>
<td>CALLBACKAT</td>
<td>String</td>
<td>8</td>
<td>Call back time (unused compatibility field)</td>
</tr>
<tr>
<td>CALLBKFREQ</td>
<td>Smallint</td>
<td>3</td>
<td>Call back frequency</td>
</tr>
<tr>
<td>LASTCONTON</td>
<td>Date</td>
<td>8</td>
<td>Last contact date</td>
</tr>
<tr>
<td>LASTCONTAT</td>
<td>String</td>
<td>8</td>
<td>Last contact time</td>
</tr>
<tr>
<td>LASTATMPON</td>
<td>Date</td>
<td>8</td>
<td>Last attempt date</td>
</tr>
<tr>
<td>LASTATMPAT</td>
<td>String</td>
<td>8</td>
<td>Last attempt time</td>
</tr>
<tr>
<td>MEETDATEON</td>
<td>Date</td>
<td>8</td>
<td>Meeting date</td>
</tr>
<tr>
<td>MEETTIMEAT</td>
<td>String</td>
<td>8</td>
<td>Meeting time</td>
</tr>
<tr>
<td>COMMENTS</td>
<td>String</td>
<td>65</td>
<td>Comments</td>
</tr>
<tr>
<td>PREVRESULT</td>
<td>String</td>
<td>65</td>
<td>Previous results</td>
</tr>
<tr>
<td>NEXTACTION</td>
<td>String</td>
<td>65</td>
<td>Next action</td>
</tr>
<tr>
<td>ACTIONON</td>
<td>Date</td>
<td>8</td>
<td>Next action date</td>
</tr>
<tr>
<td>CLOSEDATE</td>
<td>Date</td>
<td>8</td>
<td>Expected close date</td>
</tr>
<tr>
<td>USERDEF01</td>
<td>String</td>
<td>10</td>
<td>User-defined 1</td>
</tr>
</tbody>
</table>
ContSupp

ContSupp is the Supplementary Contact table, which contains a record for each additional contact, referral, and detail record. The different record types are distinguished by the contents of the RecType (A record type code identifying different types of records within the database) field. The different RecTypes can use each field for a different purpose.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Len</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCOUNTNO</td>
<td>String</td>
<td>20</td>
<td>Account number</td>
</tr>
<tr>
<td>RECTYPE</td>
<td>String</td>
<td>1</td>
<td>Record type (see &quot;Rec Types&quot; on page 130)</td>
</tr>
<tr>
<td>CONTACT</td>
<td>String</td>
<td>30</td>
<td>Contact name/Detail</td>
</tr>
<tr>
<td>TITLE</td>
<td>String</td>
<td>35</td>
<td>Contact’s title/Referral’s account number</td>
</tr>
<tr>
<td>CONTSUPREF</td>
<td>String</td>
<td>35</td>
<td>Reference/Detail header name and Detail tab name/Detail field 1</td>
</tr>
<tr>
<td>DEAR</td>
<td>String</td>
<td>20</td>
<td>Dear (salutation)</td>
</tr>
<tr>
<td>PHONE</td>
<td>String</td>
<td>20</td>
<td>Phone</td>
</tr>
<tr>
<td>EXT</td>
<td>String</td>
<td>6</td>
<td>Phone extension/Detail field 5</td>
</tr>
<tr>
<td>FAX</td>
<td>String</td>
<td>20</td>
<td>Fax number</td>
</tr>
<tr>
<td>LINKACCT</td>
<td>String</td>
<td>20</td>
<td>Linked account/Detail field 2</td>
</tr>
<tr>
<td>NOTES</td>
<td>Memo</td>
<td>1</td>
<td>Notes/Detail header field labels</td>
</tr>
<tr>
<td>ADDRESS1</td>
<td>String</td>
<td>40</td>
<td>Additional contact address/Detail field 7</td>
</tr>
<tr>
<td>ADDRESS2</td>
<td>String</td>
<td>40</td>
<td>Additional contact address 2/Detail field 8</td>
</tr>
</tbody>
</table>
ContHist contains records of completed activities. The ContHist table is part of the Contact files (The tables storing a database's contact information. Also referred to as Common files. The CommonDir line in the GM.ini points to the default contact files).

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Len</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CITY</td>
<td>String</td>
<td>30</td>
<td>Additional contact city/Detail user, date, and time</td>
</tr>
<tr>
<td>STATE</td>
<td>String</td>
<td>20</td>
<td>Additional contact state/Detail field 6</td>
</tr>
<tr>
<td>ZIP</td>
<td>String</td>
<td>10</td>
<td>Additional contact zip/Detail field 4</td>
</tr>
<tr>
<td>COUNTRY</td>
<td>String</td>
<td>20</td>
<td>Additional contact country/Detail field 3</td>
</tr>
<tr>
<td>MERGECODES</td>
<td>String</td>
<td>20</td>
<td>Merge codes (Three-character codes used as the basis for e-mail and document merging for mass mailings)</td>
</tr>
<tr>
<td>STATUS</td>
<td>String</td>
<td>4</td>
<td>First character is a flag, second character=1 if note exists</td>
</tr>
<tr>
<td>LINKEDDOC</td>
<td>Memo</td>
<td>10</td>
<td>Linked document</td>
</tr>
<tr>
<td>LASTUSER</td>
<td>String</td>
<td>8</td>
<td>Last modified by</td>
</tr>
<tr>
<td>LASTDATE</td>
<td>Date</td>
<td>8</td>
<td>Last modified date</td>
</tr>
<tr>
<td>LASTTIME</td>
<td>String</td>
<td>5</td>
<td>Last modified time</td>
</tr>
<tr>
<td>RECID</td>
<td>String</td>
<td>15</td>
<td>Record ID</td>
</tr>
</tbody>
</table>

**ContHist**

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Len</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USERID</td>
<td>String</td>
<td>8</td>
<td>User</td>
</tr>
<tr>
<td>ACCOUNTNO</td>
<td>String</td>
<td>20</td>
<td>Account number</td>
</tr>
<tr>
<td>SRECTYPE</td>
<td>String</td>
<td>1</td>
<td>First character of RecType (A record type code identifying different types of records within the database)</td>
</tr>
<tr>
<td>RECTYPE</td>
<td>String</td>
<td>10</td>
<td>Record type (see &quot;Rec Types&quot; on page 130)</td>
</tr>
<tr>
<td>ONDATE</td>
<td>Date</td>
<td>8</td>
<td>Action date</td>
</tr>
<tr>
<td>ONTIME</td>
<td>String</td>
<td>5</td>
<td>Action time</td>
</tr>
<tr>
<td>ACTVCODE</td>
<td>String</td>
<td>3</td>
<td>Activity code</td>
</tr>
<tr>
<td>STATUS</td>
<td>String</td>
<td>2</td>
<td>First character is flag, second equals 1 if notes exist.</td>
</tr>
<tr>
<td>DURATION</td>
<td>String</td>
<td>8</td>
<td>Duration</td>
</tr>
<tr>
<td>UNITS</td>
<td>String</td>
<td>8</td>
<td>Forecasted sale units</td>
</tr>
<tr>
<td>REF</td>
<td>String</td>
<td>65</td>
<td>Reference</td>
</tr>
<tr>
<td>NOTES</td>
<td>Memo</td>
<td>1</td>
<td>Notes/Detail header field labels</td>
</tr>
<tr>
<td>LINKRECID</td>
<td>String</td>
<td>15</td>
<td>Linked record ID</td>
</tr>
<tr>
<td>LOPRECID</td>
<td>String</td>
<td>15</td>
<td>Linked Opportunity Manager record</td>
</tr>
</tbody>
</table>
ContGrps contains the header defining each group and the members of the groups. ContGrps table is part of the Contact files (The tables storing a database's contact information. Also referred to as Common files. The CommonDir line in the GM.ini points to the default contact files).

Header Records

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Len</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USERID</td>
<td>String</td>
<td>15</td>
<td>Group user</td>
</tr>
<tr>
<td>CODE</td>
<td>String</td>
<td>8</td>
<td>Group code</td>
</tr>
<tr>
<td>ACCOUNTNO</td>
<td>String</td>
<td>20</td>
<td>Header information</td>
</tr>
<tr>
<td>REF</td>
<td>String</td>
<td>24</td>
<td>Group reference</td>
</tr>
<tr>
<td>RECID</td>
<td>String</td>
<td>15</td>
<td>Record ID/Group number</td>
</tr>
</tbody>
</table>

Member Records

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Type</th>
<th>Len</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USERID</td>
<td>String</td>
<td>15</td>
<td>Group number (from group header)</td>
</tr>
<tr>
<td>CODE</td>
<td>String</td>
<td>8</td>
<td>Member sort value</td>
</tr>
<tr>
<td>ACCOUNTNO</td>
<td>String</td>
<td>20</td>
<td>Linked contact account number</td>
</tr>
<tr>
<td>REF</td>
<td>String</td>
<td>24</td>
<td>Member reference</td>
</tr>
<tr>
<td>RECID</td>
<td>String</td>
<td>15</td>
<td>Record ID</td>
</tr>
</tbody>
</table>

ContUdef is a file specific to each database created within GoldMine. It stores name, type, and length of user-defined fields for the database and drives the rebuilding process by recreating the GoldMine database and working with the Fields5 table.
ContTlog tables hold synchronization information for the contact set. Each contact database has its own ContTlog table. When a change is made to a contact database file (not calendar file), an entry is made in the Tlog tables with the field information and date and time of the change. When synchronization occurs, the Tlog tables determine what information transfers.

**NOTE:** The Tlog tables, for example, ContTlog and GMTlog, track (to the millisecond) the date and time of every change to the database to provide greater reliability. The Tlog keeps track of the field-level changes made to tables in the GoldMine database. Each Tlog record consists of two time stamps. LogStamp contains the date and time the record was changed, while SyncStamp contains the date and time the record was last synchronized.

Rec Types

Recatypes are codes identifying different types of records within the Cal, ContSupp, OpMgr, and ContHist tables in the database.

**Calendar Rectypes**

<table>
<thead>
<tr>
<th>Rectype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>Appointment</td>
</tr>
<tr>
<td>C</td>
<td>Phone call</td>
</tr>
<tr>
<td>D</td>
<td>To-do</td>
</tr>
<tr>
<td>E</td>
<td>Event</td>
</tr>
<tr>
<td>F</td>
<td>Literature Request</td>
</tr>
<tr>
<td>L</td>
<td>Form</td>
</tr>
<tr>
<td>M</td>
<td>Sent message</td>
</tr>
<tr>
<td>O</td>
<td>Other Action</td>
</tr>
<tr>
<td>Q</td>
<td>Queued e-mail</td>
</tr>
<tr>
<td>S</td>
<td>Forecasted Sale</td>
</tr>
</tbody>
</table>

**ContSupp Rectypes**

<table>
<thead>
<tr>
<th>Rectype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>C</td>
<td>Additional contract</td>
</tr>
<tr>
<td>E</td>
<td>Automated Process</td>
</tr>
<tr>
<td>L</td>
<td>Linked document</td>
</tr>
<tr>
<td>O</td>
<td>Organizational structure</td>
</tr>
<tr>
<td>P</td>
<td>Detail</td>
</tr>
<tr>
<td>H</td>
<td>Extended Detail header</td>
</tr>
<tr>
<td>R</td>
<td>Referral</td>
</tr>
<tr>
<td>T</td>
<td>Next Action</td>
</tr>
</tbody>
</table>

[Table of RecTypes]
OpMgr Rectypes

<table>
<thead>
<tr>
<th>O</th>
<th>Opportunity</th>
</tr>
</thead>
<tbody>
<tr>
<td>OC</td>
<td>Influencer</td>
</tr>
<tr>
<td>PC</td>
<td>Contact</td>
</tr>
<tr>
<td>PK</td>
<td>Task</td>
</tr>
</tbody>
</table>

ContHist

The Rectypes in ContHist are created by combining letters and by placing the letters in one of four positions.

<table>
<thead>
<tr>
<th>1st</th>
<th>2nd</th>
<th>3rd</th>
<th>4th</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td></td>
<td></td>
<td></td>
<td>Appointment</td>
</tr>
<tr>
<td>C</td>
<td>C</td>
<td></td>
<td></td>
<td>Call back</td>
</tr>
<tr>
<td>C</td>
<td>I</td>
<td></td>
<td></td>
<td>Incoming call</td>
</tr>
<tr>
<td>C</td>
<td>M</td>
<td></td>
<td></td>
<td>Return message</td>
</tr>
<tr>
<td>C</td>
<td>O</td>
<td></td>
<td></td>
<td>Outgoing call</td>
</tr>
<tr>
<td>D</td>
<td></td>
<td></td>
<td></td>
<td>To-Do</td>
</tr>
<tr>
<td>M</td>
<td></td>
<td></td>
<td></td>
<td>When message is scheduled (Phone, GoldMine, or Internet message)</td>
</tr>
<tr>
<td>L</td>
<td></td>
<td></td>
<td></td>
<td>Form (letter)</td>
</tr>
<tr>
<td>M</td>
<td>G</td>
<td></td>
<td></td>
<td>GoldMine e-mail message</td>
</tr>
<tr>
<td>M</td>
<td>I</td>
<td></td>
<td></td>
<td>Incoming Internet e-mail</td>
</tr>
<tr>
<td>M</td>
<td>O</td>
<td></td>
<td></td>
<td>Outgoing Internet e-mail</td>
</tr>
<tr>
<td>S</td>
<td></td>
<td></td>
<td></td>
<td>Completed sales</td>
</tr>
<tr>
<td>T</td>
<td></td>
<td></td>
<td></td>
<td>Next action</td>
</tr>
<tr>
<td>U</td>
<td></td>
<td></td>
<td></td>
<td>Unknown</td>
</tr>
<tr>
<td>U</td>
<td></td>
<td></td>
<td></td>
<td>Unsuccessful</td>
</tr>
<tr>
<td>R</td>
<td></td>
<td></td>
<td></td>
<td>RSVP</td>
</tr>
<tr>
<td>P</td>
<td></td>
<td></td>
<td></td>
<td>Private</td>
</tr>
<tr>
<td>B</td>
<td></td>
<td></td>
<td></td>
<td>Both RSVP and Private</td>
</tr>
</tbody>
</table>
Dashboards Management

Overview

The Dashboards that install with GoldMine have been developed to provide you with the majority of your needs. However, you can modify, customize, and create new Dashboards to fill the needs not met by the predefined Dashboards (see “Predefined Dashboards” in the User Guide or Online Help).

**NOTE:** For an overview of the Dashboard, refer to the “Dashboards” in the User Guide or Online Help.

Below is a list of topics covering in this section.

- Sample Dashboard Tutorial (see page 133)
- External Database Dashboard (see page 140)
- Tabs and Splitters (see page 145)
- Dashboard Part Properties Details (see page 146)
- Data Source Management (see page 163)
- Dashboard Tables (see page 167)
- Dashboard Management (see page 168)
- Events and Actions (see page 171)
- Import and Export Dashboards (see page 174)

Sample Dashboard Tutorial

This section is a tutorial for creating a new Sample Dashboard. The examples used will take you through the Dashboard creation process from start to finish, including initial creation, adding Splitters, Parts, and configuring the Dashboard Parts.

For this tutorial, the Sample Dashboard will consist of the following:

- "Creating a New Dashboard" on page 134
- "Creating a New Data Source" on page 135
- "Adding a Label" on page 136
- "Adding a Chart" on page 137
- "Adding a Drop-down List" on page 139

After adding all the Dashboard Parts to the Sample Dashboard, you can continue to experiment by adding additional Dashboard Parts, Splitters (see "Working with Splitters" on page 146), and Tabs (see "Working with Tabs" on page 145).

When completed, your sample dashboard should resemble the one below.
Creating a New Dashboard

The first step in creating a new Dashboard is to establish the Dashboard’s basic properties. This included, the Category, Grid Size, Name, Timer interval, and Owner of the Dashboard.

NOTE: A user must be defined as a Master user to create a new Dashboard (see "Using the User QuickStart Wizard" in the User Guide or Online Help).

To Create a New Dashboard

1. Click the Dashboards Navigation button or choose Go To > Dashboards from the menu.
2. Click the Design button on the Dashboard toolbar.
3. Click the New button on the Dashboard toolbar.
4. In the Properties pane (below the Dashboard Parts Palette) enter or select the following values:
   - Category: Sample
   - Grid Size: 8
   - Name: MyDashboard
   - Timer: 0
   - Owner: (none)
5. Click the Save button on the Dashboard toolbar.
The new blank Dashboard canvas is now ready to add Dashboard Parts.

Creating a New Data Source

For many Dashboards that you create, you can use one of the many predefined Data Sources that come with GoldMine. For this example, you want to use a Data Source that does not exist in the predefined data sources: Closed Sales by Users. The following procedure demonstrates how to create a new Data Source.

To Create a New Data Source

1. Click New Data Source link at the bottom of the Dashboards Objects panel.
2. Select Closed sales for the Type of data and Start with blank data source for the Creation Method.
3. Click Next to view the General Properties page.
4. Enter the following:
   - Name: Closed Sales by Users
   - Security level: None
   - Owner: (public)
   - Output type: Table
5. Click Next to view the Select page.
6. Click the Add button to view the Add/Edit Field dialog box.
7. Enter the following:
   - Field: Amount
   - Aggregation: SUM
   - Column name: Amount
8. Click OK to return to the Select page.
9. Click the Add button to view the Add/Edit Field dialog box.
10. Enter the following:
   - Field: `CONTHIST(h).USERID`
   - Column name: `USERID`

11. Click OK to return to the Select page.

12. Click Next to view the Predefined Search Criteria dialog box. No changes are needed at this time.
   For additional information, see "About Adding Predefined Search Criteria" on page 136.

13. Click Next to view the Runtime Parameter dialog box.

14. Click Add to view the Add/Edit Runtime Search dialog box and enter the following:
   - Name: `User`
   - Select Field Based
   - Logical: `AND`
   - Field: `CONTHIST(h).USERID`
   - Operator: `Equal to`

15. Click OK and then click Next.
   In the Group by / Order by dialog box, `CONTHIST(h).USERID` already appears in Group by list.

16. Open the Sort by drop-down lists and select:
   - Amount for the category
   - descend for the method

17. Click the Add button.

18. Click Next to review the SQL query code.
   - If you want to validate the code, click the Check button.
   - If you want to preview the query output, click the Preview button.

19. Click Finish.

About Adding Predefined Search Criteria

On the Predefined Search Criteria screen of the New Data Source Wizard, you can add predefined search criteria to the list by clicking the Add button.

   NOTE: When using the Begins, Contains, or In Operator options, you must write the criteria Value in correct SQL expression form (such as `%value`)

Adding a Label

The Label Dashboard Part is typically used to add heading and other title text on the Canvas. Additional functionality can be set to the label, but for this example the Label will be used strictly as reference text on the Dashboard.

Adding the Label requires that you first add the Label Dashboard Part and then set the Label Properties.

- To Add a Label Dashboard Part
- To Set the Label Properties
To Add a Label Dashboard Part

1. Click and drag the Label Dashboard Part from the Palette to the upper-left corner on the canvas.
2. Use the Arrow keys on the keyboard to move the Label, or place the cursor on the part and then click and drag the part to refine the location.
   
   **NOTE:** You can use the canvas’ grid points to help align the various components on the Canvas.
3. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then click and drag the resize point to the desired size.

To Set the Label Properties

1. Click the Label Dashboard Part to select it.
2. In the Properties pane, make the following changes:
   
   **Appearance**
   - BackColor: Window
   - Font: Arial, 12, Bold
   - Horizontal Align: Left
   - Multiline: False
   - TextColor: RoyalBlue.
   - Vertical Align: Top
   
   **Data**
   - DataBinding: False,,,,0
   
   **General**
   - Name: label1
   - Text: Sample Dashboard
   - Value: <blank>
   
   **Layout**
   - Anchors: False, False, False, False

3. Click the View button to preview the Label.
4. Click the Design button to return to the Designer.
5. Make any changes to the size or position of the Label and preview it again until satisfied.

Adding a Chart

The Chart for the Dashboard is used to give you a visual representation of your data. For this tutorial, the Chart will represent Total Sale per User.

Adding the Chart has the following main parts:

- To Add a Chart Dashboard Part
- To Set the Chart Properties
- To Bind Data to the Chart

For the example in this tutorial, the Chart will be a Bar chart representing Users and Sales totals.
To Add a Chart Dashboard Part

1. Click and drag the Chart Dashboard Part from the Palette to the upper-left corner on the canvas below the Label. Leave enough room between the Label and the Chart. You will need to have enough space to insert a Drop-down List (see "To Add a Drop-down List Dashboard Part" on page 139) later in this tutorial.

2. Use the Arrow keys on the keyboard to move the Chart, or place the cursor on the part and then click and drag the part to refine the location.

   NOTE: You can use the canvas’ grid points to help align the various components on the Canvas.

3. The shape by placing the cursor over any of the resize points around the active Dashboard Part, then click and drag the resize point to the desired size.

Chart properties must be set after adding the Chart (see "To Set the Chart Properties" on page 139).

To Set the Chart Properties

1. Click the Chart Dashboard Part to select it.

2. In the Properties pane, make the following changes:

   Property
   - 3D Depth: 20
   - 3D Mode: True
   - Back Color: Control
   - Color Scheme: Solid
   - Colored Values: True
   - Girdlines: None
   - Inside Color: Window
   - Key Axis Title: User Name
   - Stacked: No
   - Title: Closed Sales by Users
   - Value Axis Title: Total Sales
   - View Mode: Bar

   Data
   - DataBinding: Closed Sales by Users (see "To Bind Data to the Chart" on page 139)
   - Retain Source Order: True

   Format
   - Keys: None
   - Keys Decimals: 0
   - Values: Number
   - Values Decimals: 0

   General
   - Name: Closed Sales Chart

   Layout
   - Anchors: False, False, False, False

3. Click the View button to preview the Chart.

4. Click the Design button to return to the Designer.

5. Make any changes to the size or position of the Chart and preview it again until satisfied.
**To Bind Data to the Chart**

1. Click the ellipsis button (...) to the right of the **Data Binding** field.
2. Click the **Mode** tab and select **Multiple Series in Multiple Columns**.
3. Click the **Details** tab and set the following:
   - Data source category: **Closed sales**
   - Data source: **Closed Sales by Users**
   - Data are summarized by: **USERID**
   - Summarized values: **Amount**
4. Click **OK** to set the Chart Data Binding.

**Adding a Drop-down List**

The Drop-down List will be used to select the data (in this case User) which displays in the Chart.

Adding the Drop-down List has three main parts:
- To Add a Drop-down List Dashboard Part
- To Set the Drop-down List Properties
- To Add an Event to the Drop-down List

**To Add a Drop-down List Dashboard Part**

1. Click and drag the **Drop-down list** Dashboard Part from the Palette to the upper-left corner (below the Label) on the canvas.
2. Use the **Arrow** keys on the keyboard to move the Drop-down list, or place the cursor on the Drop-down List and then click and drag the part to refine the location.
   - **NOTE:** You can use the canvas’ grid points to help align the various components on the Canvas.
3. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then click and drag the resize point to the desired size.
4. Continue to the next step: **To Set the Drop-down List Properties.**

**To Set the Drop-down List Properties**

1. Click the Drop-down List Dashboard Part to select it.
2. In the Properties pane, make the following changes:
   - **Data**
     - Data Category: **Manually typed**
     - Data Source: **List of users**
     - Text field: **text**
     - Value field: **value**
   - **General**
     - Name: **User Filter**
     - Tab order
   - **Layout**
     - Anchors: **False, False, False, False**
3. Click the **View** button to preview the Drop-down List.
4. Click the **Design** button to return to the Designer.
5. Make any changes to the size or position of the Drop-down List and preview it again until satisfied.
6. Continue to the next step: **To Add an Event to the Drop-down List.**
To Add an Event to the Drop-down List

1. Select the Drop-down List.
2. Click the Events button to view the Events and Actions dialog box.
3. Enter the following:
   - Select Dashboard Part: User Filter
   - Event: State changed
4. Click the Add button to view the Action's Properties dialog box, and enter the following:
   - Action: Refresh a dashboard part based on user selection
   - Update Dashboard Part: Closed Sales Chart
   - Data Source: Closed Sales by Users
   - Runtime Criteria: User
   - Select Runtime (from part): User Filter and Field: Value
5. Click OK to return to the Events and Actions dialog box, then click OK to close the box.

External Database Dashboard

Dashboards are not limited to linking and displaying data from only the GoldMine database. Data that you have in other SQL databases can be linked to and used to display on a Dashboard. You can create a new Dashboard specifically for the data, or add parts to an existing Dashboard for the desired data.

**NOTE:** The SQL login must have “read” permissions on the database to display the results in the Dashboard.

For this example, we will create a Dashboard that displays the individual Product inventory levels for all products stored in an MSSQL database outside of GoldMine. To do this, we will create a new Dashboard with a Chart and Drop-down List, and then link it to an external SQL database.

Our sample database (Accounting) and table (Inventory) contains a list of products sorted by product type and product.

<table>
<thead>
<tr>
<th>Product</th>
<th>Quantity</th>
<th>ProductLine</th>
</tr>
</thead>
<tbody>
<tr>
<td>Nano</td>
<td>32</td>
<td>iPod</td>
</tr>
<tr>
<td>Touch</td>
<td>44</td>
<td>iPod</td>
</tr>
<tr>
<td>Droid</td>
<td>43</td>
<td>Phones</td>
</tr>
<tr>
<td>Super Mario</td>
<td>14</td>
<td>Games</td>
</tr>
</tbody>
</table>

You can use this database example as a reference when mapping the fields in your own database.

Creating a New Dashboard

The first step in creating a new Dashboard to display your external data is to establish the Dashboard's basic properties. This included, the Category, Grid Size, Name, Timer interval, and Owner of the Dashboard.

**NOTE:** A user must be defined as a Master user to create a new Dashboard (see "Using the User QuickStart Wizard" in the User Guide or Online Help).
**To Create a New Dashboard**

1. Click the **Dashboards** Navigation button or choose **Go To > Dashboards** from the menu.
2. Click the **Design** button on the Dashboard toolbar.
3. Click the **New** button on the Dashboard toolbar.
4. In the Properties panel (below the Dashboard Parts Palette) enter or select the following values:
   - Category: **Sample**
   - Grid Size: 8
   - Name: **ExternalData**
   - Timer: 0
   - Owner: (none)
5. Click the **Save** button on the Dashboard toolbar.

**Adding a Label**

The Label Dashboard Part is typically used to add heading and other title text on the Canvas. Additional functionality can be set to the label, but for this example the Label will be used strictly as reference text on the Dashboard.

**To Add a Label Dashboard Part**

1. Click and drag the **Label** Dashboard Part from the Palette to the upper-left corner on the canvas.
2. Use the Arrow keys on the keyboard to move the Label, or place the cursor on the part and then click and drag the part to refine the location.
   - **NOTE:** You can use the canvas’ grid points to help align the various components on the Canvas.
3. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then click and drag the resize point to the desired size.

**To Set the Label Properties**

1. Click the Label Dashboard Part to select it.
2. In the Properties pane, make the following changes:
   - **General**
     - Text: **Accounting Dashboard**
3. Click the **View** button to preview the Label.
4. Click the **Design** button to return to the Designer.
5. Make any changes to the size or position of the Label and preview it again until satisfied.

**Creating a New Data Source for the Chart**

For the external database linking example, we want to link to a different SQL Database. The following procedure demonstrates how to create a new Data Source for the external database.

**To Create the New Data Source**

1. Click **New Data Source** link at the bottom of the Dashboards Objects panel.
2. On the New Data Source window, select **Manually typed** for the Type of data and **Start with blank data source** for the Creation Method.
3. Click **Next** to view the General Properties page.
4. Enter **Accounting Demo** for the Name, then click **Next** to view the Runtime Parameter page.
5. Click the Add button to view the Add/Edit Runtime Parameter dialog box.

   **NOTE:** The Runtime Parameter expression will enable the product line to be selected by the end user when viewing the Dashboard.

6. Enter **ProductLineParam** for the Name.

7. Select the Custom option and perform the following:
   - Open the Logical drop-down list and select: **AND**
   - Enter the following Expression: **ProductLine = ‘<<VALUE>>’**

8. Click OK and then Next to view the Query dialog box.

9. Enter the SQL query statement in the upper text box:
   - Start with a basic SQL query that returns a list of product and their corresponding quantities.
     
     ```sql
     Select Product, Quantity from Accounting..Inventory order by product
     
     Where “Accounting” is the name of the external SQL database and “Inventory” is the TableName.
     
     Then we add the “Where” clause that will enable the runtime parameter to be used:
     
     Where 1=1 <<ProductLineParam>>
     
     Finally note that additional parameters can be used, for example to enable multiple drop-down lists in a single dashboard. For example:
     
     Where 1=1 <<ProductLineParam>> <<Parameter2>> <<Parameter3>>
     
     Each of these additional parameters (Parameter2, Parameter3) must be set up in the Data Source, on the Runtime Parameters tab.
     
     The final SQL query should resemble the one below:
     
     ```sql
     Select Product, Quantity from Accounting..Inventory Where 1=1 <<ProductLineParam>> <<Parameter2>> <<Parameter3>> order by product
     
     ```

10. To validate the code, click the Check button.

11. To preview the query output, click the Preview button.

12. Click Finish.

### Adding a Chart

The Chart for this Dashboard is used to give you a visual representation of your data. For the example, the Chart will be a Bar chart representing Item and Count totals for Inventory.

**To Add a Chart Dashboard Part**

1. Click and drag the Chart Dashboard Part from the Palette to the upper-left corner on the canvas.

2. Use the Arrow keys on the keyboard to move the Chart, or place the cursor on the part and then click and drag the part to refine the location.

   **NOTE:** You can use the canvas’ grid points to help align the various components on the Canvas.

3. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then click and drag the resize point to the desired size.
To Bind Data to the Chart

1. Select the Chart on the Dashboard.
2. In the Properties panel, scroll down to the Data section and click the ellipses (...) button next to Data Binding.
3. On the Data Binding dialog box, click the Details tab.
4. Make the following changes:
   - Data source category: Manually typed
   - Data source: Accounting Demo
   - Data are summarized by: Product
   - Summarizing key legends: Product
   - Summarized values: Quantity
5. Click OK to apply the changes.
6. Click View to preview the chart.
7. Click Design to return to the Dashboard Designer.

Adding a Drop-Down List

The Drop-down list allows you to select which product you want to view in the Chart. Placement of the list should be in an area where it is easily accessed and visible.

To Add a Drop-Down List Dashboard Part

1. Click and drag the Drop-down List Dashboard Part from the Palette to the upper-left corner (below the Label) on the canvas.
2. Use the Arrow keys on the keyboard to move the Drop-down List, or place the cursor on the Drop-down List and then click and drag the part to refine the location.
3. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then click and drag the resize point to the desired size.
4. In the Properties pane, make the following changes:
   - General
     - Name: ProductLineList

To Create a New Data Source for Drop-Down List

1. Click New Data Source link at the bottom of the Dashboards Objects panel.
2. On the New Data Source window, select Manually typed for the Type of data and Start with blank data source for the Creation Method.
3. Click Next to view the General Properties page.
4. Enter Product Lines - Demo for the Name, then click Next to view the Runtime Parameter page.
5. Click Next to view the Query page and enter the following text:
   - Select distinct ProductLine from Accounting..Inventory order by ProductLine
5. To validate the code, click the Check button.
6. To preview the query output, click the Preview button.
6. Click Finish.
To Bind Data to the Drop-Down List

1. Select the Drop-down List on the Dashboard.
2. In the Properties panel, expand the Data Binding section.
3. Set the following options:
   - Data Category: Manually typed
   - Data Source: Product Line - Demo
   - Text field: ProductLine
   - Value field: ProductLine
4. Click View to preview the Dashboard.
   
   The drop-down list is now functional, but the data does not yet filter based on the drop-down selection. An Event must be added to complete the drop-down list functionality (see "Adding an Event to the Drop-Down List" on page 144).
5. Click the Design button.

Add the “All” Option to the Drop-Down List

If you want to add the “All” option to the drop-down list, you will need to enter a more complex SQL query on the Query tab for the data source (see "To Edit a Data Source" on page 165).

The following example uses information based on a GoldMine database:

```
select 'All' as [text], '<<__INACTIVE_STATE__>>' as [value], 0 as [sort_index] 
union 
select USERNAME as [text], USERNAME as [value], 1 as [sort_index] from USERS
order by [order], [text]
```

Adding an Event to the Drop-Down List

When the drop-down list is used, the Chart needs to update based on the selection made in the drop-down list. A Event must be added to refresh the Chart based on the drop-down list selection.

To Add an Event to the Drop-Down List

1. Right-click the drop-down list and select Events from the menu.
2. On the Events and Actions dialog box, click the Add button.
3. On the Actions’s properties, part, event - State changed dialog box, set the following options:
   - Action: Refresh a dashboard part based on user selection
   - Update dashboard part: chart2 (actual chart name might be different)
   - Data source: Accounting Demo
   - Runtime Parameter: ProductLineParam
   - Runtime (from part) ProductLineList and Field: Value

   NOTE: The actual part names might be different than those listed depending on the order of parts added.
4. OK to close the Action’s properties dialog box.
5. Click OK to close the Events and Actions dialog box.
6. Click View to preview the Dashboard.

   NOTE: You might need to close the Dashboards and reopen again to refresh the Dashboards and view the new Dashboard functionality.
Tabs and Splitters

Tabs and Splitters are elements that you can use to further define the Dashboard. Tabs can increase the usable area on the Dashboard by switching between the tabs to display different data. Splitters are horizontal and vertical bars used to define and segregate regions of the Dashboard for easier viewing.

Working with Tabs

The Dashboards can be further defined by adding tabs. Tabs act like a Dashboard within the current Dashboard and allow you to add additional Dashboard Parts on individual tabs that might not otherwise fit on your canvas. Tabs can be labeled and setup according to the type of information that you view. For example, you might have a tab that displays information about your leads while another might show your forecasted sales.

**NOTE:** Tabs can be added to the canvas or the regions inside of splitters. If you want to tab the full Dashboard canvas, add the tabs before you add the splitters. Otherwise, the tabs will apply to the region within the splitters.

**To Create a Tab**

1. Create a new Dashboard or edit an existing one (see "Creating a New Dashboard" on page 134).
2. Right-click and select **Change to tab frame** from the context menu.
3. Enter a name for the tab in the highlighted tab label.
4. To add more tabs, right-click in the tab and select **Add tab** again.
5. Click the **Save** button to save your changes.

**To Rename a Tab**

1. In the Dashboard Designer, select the tab you want to rename.
2. Place the cursor over the highlighted tab, right-click, and then select **Edit tab** from the context menu.
3. Enter the new tab name in the highlighted text box.
4. Press the **Enter** key or click anywhere outside the tab.
5. Click the **Save** button to save your changes.

**To Delete a Tab**

1. In the Dashboard Designer, select the tab you want to delete.
2. Place the cursor over the highlighted tab, right-click, and then select **Delete tab** from the context menu.
3. Repeat this process for any other tabs you want to delete.
4. Click the **Save** button to save your changes.

**NOTE:** If there is only one tab on the tabbed frame, deleting this tab will also delete the tabbed frame.

**To Delete All Tabs**

1. In the Dashboard Designer, move the cursor to the tabbed area of the frame you want to delete.

| WARNING: Deleting the tabbed frame also deletes all the associated tabs and Dashboard Parts within that tabbed frame. Be sure you want to delete the tabbed frame as there is no undo for this command. |

2. Right-click and select **Delete** from the context menu.
3. Click the **Save** button to save your changes.
Working with Splitters

A splitter is a horizontal or vertical line used to visually divide the canvas into separate areas. Unlike parts, splitters are added from the context menu. A splitter can be moved and deleted after it has been added. After an area has been defined by splitters, you can then add Dashboard Parts and Tabs (see “Working with Tabs” on page 145).

To Add a Splitter

1. Place the mouse in the approximate area where the splitter will be placed.
2. Right-click and select one of the following from the context menu:
   - Add horizontal splitter
   - Add vertical splitter
3. Add additional splitters as desired.
4. Click the Save button to save your changes.

   **NOTE:** The first splitter added extends to the limits of the canvas. Subsequent splitters divide only the area where they are added. If you add a horizontal splitter and then add a vertical splitter, the vertical splitter will only divide the half of the canvas where you initiated the command.

To Move a Splitter

1. Place the mouse over the splitter. The cursor changes to the reposition cursor.
2. Click and hold the Left-Mouse button and move the splitter to the desired location.
3. Repeat this process to move any other vertical or horizontal splitter.

   Any adjoining splitters automatically adjust to the movement of other splitters.

To Delete a Splitter

1. Place the mouse over the splitter. The cursor changes to the reposition cursor.
2. Right-click and select Delete from the context menu.
3. Repeat this process to delete any other vertical or horizontal splitter.

   Any adjoining splitters automatically adjust to the movement of other splitters.
4. Click the Save button to save your changes.

Dashboard Part Properties Details

The Properties pane, located below the Dashboard Parts Palette, displays the properties and values for the currently selected Dashboard Part. The Properties pane is where you can establish, view, and modify the various properties for the selected Dashboard Part. Depending on the property type, you can change the property values by entering them manually, selecting from a drop-down list, or by opening a dialog box.
Setting the Dashboard Part Properties

After you add a Dashboard Part to the Canvas, you must configure properties for the part. Some properties may be optional, while others are mandatory. The properties vary depending on the type of part.

Following is a list of Dashboard Parts and their associated properties as a reference.

- Label Properties (see page 148)
- Button Properties (see page 149)
- Check Box Properties (see page 149)
- Radio Button Properties (see page 150)
- Link Properties (see page 151)
- Text Box Properties (see page 155)
- Drop-down list Properties (see page 156)
- Web View Properties (see page 156)
- Chart Properties (see page 157)
- Table View (see page 158)
- Date Picker (see page 158)

Selecting one of the Property field, displays a description for the field displays in the panel at the bottom of the pane. Selecting the text box to the right of the Property field, activates the field editing for the property.

For examples of adding some of these parts, refer to the "Sample Dashboard Tutorial" on page 133.

Notes About Data Binding Properties

- General > Text and General > Value fields are applicable only if no data binding has been configured. If a data source is selected, then DataBinding > Text Field and DataBinding > Value Field are used instead. This is applicable for all controls which have General > Text and General > Value properties.

- Link control uses two value fields: Primary Key and Secondary Key. If Data Binding is not used, only the Primary Key is available and aliased as General > Value.
## Label Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Appearance</strong></td>
<td></td>
</tr>
<tr>
<td>• Back Color</td>
<td>Background color</td>
</tr>
<tr>
<td>• Font</td>
<td>Label font style</td>
</tr>
<tr>
<td>• Horizontal Align</td>
<td>Horizontal position of the text</td>
</tr>
<tr>
<td>• Multiline</td>
<td>Display text on multiple lines</td>
</tr>
<tr>
<td>• TextColor</td>
<td>Color of the text</td>
</tr>
<tr>
<td>• Vertical Align</td>
<td>Vertical position of the text</td>
</tr>
<tr>
<td><strong>Data</strong></td>
<td></td>
</tr>
<tr>
<td>• DataBinding</td>
<td>Data binding information for the Label</td>
</tr>
<tr>
<td>• Exclusive Data</td>
<td>Data from selected data source will be exclusive (private) for this part or not.</td>
</tr>
<tr>
<td>• Data Category</td>
<td>Bound category of the data source</td>
</tr>
<tr>
<td>• Data Source</td>
<td>Bound data source based on Data Category</td>
</tr>
<tr>
<td>• Text field</td>
<td>Field the Dashboard Part displays</td>
</tr>
<tr>
<td>• Value field</td>
<td>Value the Dashboard Part stores</td>
</tr>
<tr>
<td>• Row</td>
<td>Row the label shows</td>
</tr>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>• Name</td>
<td>Name of the Dashboard Part</td>
</tr>
<tr>
<td>• Text</td>
<td>Dashboard Part text</td>
</tr>
<tr>
<td>• Value</td>
<td>Dashboard Part value</td>
</tr>
<tr>
<td><strong>Layout</strong></td>
<td></td>
</tr>
<tr>
<td>• Anchors</td>
<td>Edge definitions that bound the Dashboard Part.</td>
</tr>
</tbody>
</table>
### Button Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data</td>
<td></td>
</tr>
<tr>
<td>DataBinding</td>
<td>Data binding information for the Dashboard Part</td>
</tr>
<tr>
<td>Exclusive Data</td>
<td>Data from selected data source will be exclusive (private) for this part or not.</td>
</tr>
<tr>
<td>Data Category</td>
<td>Bound category of the data source</td>
</tr>
<tr>
<td>Data Source</td>
<td>Bound data source based on Data Category</td>
</tr>
<tr>
<td>Text field</td>
<td>Field the Dashboard Part displays</td>
</tr>
<tr>
<td>Value field</td>
<td>Value the Dashboard Part stores</td>
</tr>
<tr>
<td>Row</td>
<td>Row the Dashboard Part shows</td>
</tr>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Name of the Dashboard Part</td>
</tr>
<tr>
<td>Tab order</td>
<td>Order of the Button tabs</td>
</tr>
<tr>
<td>Text</td>
<td>Dashboard Part Text label</td>
</tr>
<tr>
<td>Value</td>
<td>Dashboard Part value</td>
</tr>
<tr>
<td>Layout</td>
<td></td>
</tr>
<tr>
<td>Anchors</td>
<td>Edge definitions that bound the Dashboard Part</td>
</tr>
</tbody>
</table>

### Check Box Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appearance</td>
<td></td>
</tr>
<tr>
<td>Back Color</td>
<td>Background color</td>
</tr>
<tr>
<td>Data</td>
<td></td>
</tr>
<tr>
<td>DataBinding</td>
<td>Data binding information for the Dashboard Part</td>
</tr>
<tr>
<td>Exclusive Data</td>
<td>Data from selected data source will be exclusive (private) for this part or not.</td>
</tr>
<tr>
<td>Data Category</td>
<td>Bound category of the data source</td>
</tr>
<tr>
<td>Data Source</td>
<td>Bound data source based on Data Category</td>
</tr>
<tr>
<td>Text field</td>
<td>Field the Dashboard Part displays</td>
</tr>
<tr>
<td>Value field</td>
<td>Value the Dashboard Part stores</td>
</tr>
<tr>
<td>Row</td>
<td>Row the Dashboard Part shows</td>
</tr>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Name of the Dashboard Part</td>
</tr>
<tr>
<td>Tab order</td>
<td>Order of the Check Box tabs</td>
</tr>
<tr>
<td>Text</td>
<td>Dashboard Part Text label</td>
</tr>
<tr>
<td>Value</td>
<td>Dashboard Part value</td>
</tr>
</tbody>
</table>
### Layout

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anchors</td>
<td>Edge definitions that bound the Dashboard Part.</td>
</tr>
</tbody>
</table>

### Radio Button Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appearance</td>
<td></td>
</tr>
<tr>
<td>Back Color</td>
<td>Background color</td>
</tr>
<tr>
<td>Data</td>
<td></td>
</tr>
<tr>
<td>DataBinding</td>
<td>Data binding information for the Dashboard Part</td>
</tr>
<tr>
<td>Exclusive Data</td>
<td>Data from selected data source will be exclusive (private) for this part or not.</td>
</tr>
<tr>
<td>Data Category</td>
<td>Bound category of the data source</td>
</tr>
<tr>
<td>Data Source</td>
<td>Bound data source based on Data Category</td>
</tr>
<tr>
<td>Text field</td>
<td>Field the Dashboard Part displays</td>
</tr>
<tr>
<td>Value field</td>
<td>Value the Dashboard Part stores</td>
</tr>
<tr>
<td>Row</td>
<td>Row the Dashboard Part shows</td>
</tr>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>Group</td>
<td>Group of the Dashboard Part</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the Dashboard Part</td>
</tr>
<tr>
<td>Tab order</td>
<td>Order of the Check Box tabs</td>
</tr>
<tr>
<td>Text</td>
<td>Dashboard Part Text label</td>
</tr>
<tr>
<td>Value</td>
<td>Dashboard Part value</td>
</tr>
<tr>
<td>Layout</td>
<td></td>
</tr>
<tr>
<td>Anchors</td>
<td>Edge definitions that bound the Dashboard Part.</td>
</tr>
</tbody>
</table>
### Link Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appearance</td>
<td></td>
</tr>
<tr>
<td>• Back Color</td>
<td>Background color</td>
</tr>
<tr>
<td>• Font</td>
<td>Label font style</td>
</tr>
<tr>
<td>• Horizontal Align</td>
<td>Horizontal position of the text</td>
</tr>
<tr>
<td>• Multiline</td>
<td>Display text on multiple lines</td>
</tr>
<tr>
<td>• TextColor</td>
<td>Color of the text</td>
</tr>
<tr>
<td>• Vertical Align</td>
<td>Vertical position of the text</td>
</tr>
<tr>
<td>Data</td>
<td></td>
</tr>
<tr>
<td>• DataBinding</td>
<td>Data binding information for the Label</td>
</tr>
<tr>
<td></td>
<td>• Exclusive Data</td>
</tr>
<tr>
<td></td>
<td>• Data Category</td>
</tr>
<tr>
<td></td>
<td>• Data Source</td>
</tr>
<tr>
<td></td>
<td>• Text field</td>
</tr>
<tr>
<td></td>
<td>• Primary Key</td>
</tr>
<tr>
<td></td>
<td>• Secondary Key</td>
</tr>
<tr>
<td></td>
<td>• Row</td>
</tr>
<tr>
<td>• Destination</td>
<td>Hyperlink destination information (see &quot;About Dashboard Link Data Destinations&quot; on page 152)</td>
</tr>
<tr>
<td></td>
<td>• Primary</td>
</tr>
<tr>
<td></td>
<td>• Secondary</td>
</tr>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>• Name</td>
<td>Name of the Dashboard Part</td>
</tr>
<tr>
<td>• Text</td>
<td>Dashboard Part text</td>
</tr>
<tr>
<td>• Value</td>
<td>Dashboard Part value</td>
</tr>
<tr>
<td>Layout</td>
<td></td>
</tr>
<tr>
<td>• Anchors</td>
<td>Edge definitions that bound the Dashboard Part.</td>
</tr>
</tbody>
</table>
About Dashboard Link Data Destinations

Below is a list of all available primary and secondary destinations with corresponding key field names.

<table>
<thead>
<tr>
<th>Destination</th>
<th>Corresponding Field</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact</td>
<td>accountNO</td>
</tr>
<tr>
<td>Opportunity</td>
<td>recid</td>
</tr>
<tr>
<td>Project</td>
<td>recid</td>
</tr>
<tr>
<td>Case</td>
<td>recid</td>
</tr>
<tr>
<td>Calendar Activity</td>
<td>recid</td>
</tr>
<tr>
<td>Activity</td>
<td>recid</td>
</tr>
<tr>
<td>E-mail Message</td>
<td>recid</td>
</tr>
<tr>
<td>Campaign</td>
<td>recid</td>
</tr>
<tr>
<td>Document Template</td>
<td>recid</td>
</tr>
<tr>
<td>InfoCenter</td>
<td>recid</td>
</tr>
<tr>
<td>Leads</td>
<td>recid</td>
</tr>
<tr>
<td>Dashboards</td>
<td>Dashboard</td>
</tr>
<tr>
<td>GoldMine Help</td>
<td>Topic-specific marker (see &quot;Online Help Topic Markers&quot; on page 152)</td>
</tr>
<tr>
<td>Web Resource</td>
<td>URL</td>
</tr>
</tbody>
</table>

Online Help Topic Markers

The Online Help for GoldMine is context-sensitive. What that means is that certain topics in the Online Help have special markers that allow GoldMine to link directly to those topics when used in context. You can benefit from this ability by linking directly to specific topics from the Dashboard when using the Link dashboard part (see "Link Properties" on page 151) and configuring the properties accordingly.

↑ TO CONFIGURE THE LINK

Set the Destination > Primary field to GoldMine Help. Then, enter the Help Link Code for the desired topic in the General > Value field.

For example the H-Dashboards value opens the GoldMine Online Help to the main Dashboards topic.
The following table lists all of the topic-specific Link Code Values currently available in the GoldMine Help.

<table>
<thead>
<tr>
<th>Help Link Code</th>
<th>GoldMine Help Topic</th>
</tr>
</thead>
<tbody>
<tr>
<td>H_Activities_NavPane</td>
<td>Activities</td>
</tr>
<tr>
<td>H_AutomatedProcesses</td>
<td>Automated Processes</td>
</tr>
<tr>
<td>H_BackupDB</td>
<td>Backing Up Databases</td>
</tr>
<tr>
<td>H_Calendar_NavPane</td>
<td>Calendars</td>
</tr>
<tr>
<td>H_CalendarOptsFBTab</td>
<td>Calendar Options Dialog Box, Free/Busy Tab</td>
</tr>
<tr>
<td>H_CalendarOptsPubTab</td>
<td>Calendar Options Dialog Box, Publishing Tab</td>
</tr>
<tr>
<td>H_Campaigns_NavPane</td>
<td>About the Campaign Management Center</td>
</tr>
<tr>
<td>H_ChangePassword</td>
<td>To Change Your Password</td>
</tr>
<tr>
<td>H_CompForecastSales</td>
<td>Completing Forecasted Sales</td>
</tr>
<tr>
<td>H_ConfigEmailOpts</td>
<td>Configuring E-mail Options</td>
</tr>
<tr>
<td>H_Contact_NavPane</td>
<td>Contact Management</td>
</tr>
<tr>
<td>H_ContactSearchCenter</td>
<td>Accessing the Contact Search Center</td>
</tr>
<tr>
<td>H_ContactSetDB</td>
<td>About Contact Set Databases</td>
</tr>
<tr>
<td>H_CopyMoveRecords</td>
<td>Using Copy/Move Records</td>
</tr>
<tr>
<td>H_CreateActions</td>
<td>Creating Actions</td>
</tr>
<tr>
<td>H_CreateCustomScr</td>
<td>Creating Custom Screens</td>
</tr>
<tr>
<td>H_CreateDatabase</td>
<td>About Creating Databases</td>
</tr>
<tr>
<td>H_CreateDistLists</td>
<td>Creating Distribution Lists</td>
</tr>
<tr>
<td>H_CreateEmailRules</td>
<td>Creating E-mail Rules</td>
</tr>
<tr>
<td>H_CreateEmailTemplates</td>
<td>Creating E-mail Templates</td>
</tr>
<tr>
<td>H_CreateGMViewTemplates</td>
<td>Creating GM+View Templates</td>
</tr>
<tr>
<td>H_CreateMtgRequests</td>
<td>Creating Meeting Requests</td>
</tr>
<tr>
<td>H_CreateSQL</td>
<td>Creating SQL Databases</td>
</tr>
<tr>
<td>H_CreateTriggers</td>
<td>Creating Triggers</td>
</tr>
<tr>
<td>H_Dashboards</td>
<td>Dashboards</td>
</tr>
<tr>
<td>H_DefineContactSetProfile</td>
<td>Defining Contact Set Profiles</td>
</tr>
<tr>
<td>H_DeleteContactRecs</td>
<td>Deleting Contact Records</td>
</tr>
<tr>
<td>H_DigitalID</td>
<td>Using Digital IDs with E-mail Messages</td>
</tr>
<tr>
<td>H_DocMgmtCenter</td>
<td>About the Document Center</td>
</tr>
<tr>
<td>H_EditFieldProps</td>
<td>Editing Field Properties</td>
</tr>
<tr>
<td>H_EmailAcctProps</td>
<td>Setting E-mail Account Properties</td>
</tr>
<tr>
<td>H_F2Lookup</td>
<td>F2 Lookup Lists</td>
</tr>
<tr>
<td>H_FirstTopic</td>
<td>GoldMine Help Start Page</td>
</tr>
<tr>
<td>H_GlobalReplaceWiz</td>
<td>Globally Replacing Field Data</td>
</tr>
<tr>
<td>Help Link Code</td>
<td>GoldMine Help Topic</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------</td>
</tr>
<tr>
<td>H_GMProcessMonitor</td>
<td>Monitoring Processes</td>
</tr>
<tr>
<td>H_GMViewTab</td>
<td>About the GM+View Tab</td>
</tr>
<tr>
<td>H_GoldMinePlus</td>
<td>Goldmine Plus for Microsoft Office</td>
</tr>
<tr>
<td>H_GoldSync</td>
<td>About GoldSync</td>
</tr>
<tr>
<td>H_GoldSyncAdminCntr</td>
<td>Using the GoldSync Administration Center</td>
</tr>
<tr>
<td>H_HistoryTab</td>
<td>About the History Tab</td>
</tr>
<tr>
<td>H_ImportContactRecords</td>
<td>Using the Import Contact Records Wizard</td>
</tr>
<tr>
<td>H_ImportData</td>
<td>About Importing Data</td>
</tr>
<tr>
<td>H_KnowledgeBase_NavPane</td>
<td>Knowledge Base</td>
</tr>
<tr>
<td>H_LaunchGM</td>
<td>Launching GoldMine</td>
</tr>
<tr>
<td>H_LeadsAnalysis</td>
<td>Using Leads Analysis</td>
</tr>
<tr>
<td>H_Leads_NavPane</td>
<td>About the Leads Management Center</td>
</tr>
<tr>
<td>H_Licensing</td>
<td>Licensing</td>
</tr>
<tr>
<td>H_LoginTabPrefs</td>
<td>Setting Options for the Login Tab</td>
</tr>
<tr>
<td>H_Mail_NavPane</td>
<td>Contact Communication</td>
</tr>
<tr>
<td>H_MaintainDB</td>
<td>About Maintaining Databases</td>
</tr>
<tr>
<td>H_MergePurge</td>
<td>Merging and Purging Records</td>
</tr>
<tr>
<td>H_NewFilter</td>
<td>Creating Filters</td>
</tr>
<tr>
<td>H_NewGroup</td>
<td>Creating a New Group</td>
</tr>
<tr>
<td>H_Opportunities_NavPane</td>
<td>Using the Opportunity Manager</td>
</tr>
<tr>
<td>H_OutlookIntegration</td>
<td>Outlook Integration</td>
</tr>
<tr>
<td>H_PredefinedDashboards</td>
<td>Predefined Dashboards</td>
</tr>
<tr>
<td>H_Projects_NavPane</td>
<td>Using the Project Manager</td>
</tr>
<tr>
<td>H_RecordTypes</td>
<td>Record Types</td>
</tr>
<tr>
<td>H_RecordTypesAdminCntr</td>
<td>Using the Record Types Administration Center</td>
</tr>
<tr>
<td>H_RetrievingEmail</td>
<td>Retrieving E-mail</td>
</tr>
<tr>
<td>H_SchedActBusyFree</td>
<td>Scheduling Based on Contact's Free/Busy Times</td>
</tr>
<tr>
<td>H_SchedForcastSales</td>
<td>Scheduling Forecasted Sales</td>
</tr>
<tr>
<td>H_SchedMtgRequests</td>
<td>Scheduling from Meeting Requests</td>
</tr>
<tr>
<td>H_SchedRecurAct</td>
<td>Scheduling Recurring Activities</td>
</tr>
<tr>
<td>H_SendEmailMulti</td>
<td>Sending E-mail to Multiple Recipients</td>
</tr>
<tr>
<td>H_Service_NavPane</td>
<td>Service Center</td>
</tr>
<tr>
<td>H_SlctResourceToAddDialog</td>
<td>Select a Resource to Add Dialog Box in My GoldMine</td>
</tr>
</tbody>
</table>
### Text Box Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Data</strong></td>
<td></td>
</tr>
<tr>
<td>+ DataBinding</td>
<td>Data binding information for the Dashboard Part</td>
</tr>
<tr>
<td>+ Exclusive Data</td>
<td>Data from selected data source will be exclusive (private) for this part or not.</td>
</tr>
<tr>
<td>+ Data Category</td>
<td>Bound category of the data source</td>
</tr>
<tr>
<td>+ Data Source</td>
<td>Bound data source based on Data Category</td>
</tr>
<tr>
<td>+ Text field</td>
<td>Field the Dashboard Part displays</td>
</tr>
<tr>
<td>+ Value field</td>
<td>Value the Dashboard Part stores</td>
</tr>
<tr>
<td>+ Row</td>
<td>Row the Dashboard Part shows</td>
</tr>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>+ Multiline</td>
<td>The editbox it multiline (true/false)</td>
</tr>
<tr>
<td>+ Name</td>
<td>Name of the Dashboard Part</td>
</tr>
<tr>
<td>+ Tab order</td>
<td>Order of the Button tabs</td>
</tr>
<tr>
<td>+ Text</td>
<td>Dashboard Part Text label</td>
</tr>
<tr>
<td>+ Value</td>
<td>Dashboard Part value</td>
</tr>
<tr>
<td><strong>Layout</strong></td>
<td></td>
</tr>
<tr>
<td>+ Anchors</td>
<td>Edge definitions that bound the Dashboard Part.</td>
</tr>
</tbody>
</table>
### Drop-down list Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data</td>
<td></td>
</tr>
<tr>
<td>DataBinding</td>
<td>Data binding information for the Dashboard Part</td>
</tr>
<tr>
<td>- Exclusive Data</td>
<td>Data from selected data source will be exclusive (private) for this part or not.</td>
</tr>
<tr>
<td>- Data Category</td>
<td>Bound category of the data source</td>
</tr>
<tr>
<td>- Data Source</td>
<td>Bound data source based on Data Category</td>
</tr>
<tr>
<td>- Text field</td>
<td>Field the Dashboard Part displays</td>
</tr>
<tr>
<td>- Value field</td>
<td>Value the Dashboard Part stores</td>
</tr>
<tr>
<td>- Row</td>
<td>Row the Dashboard Part shows</td>
</tr>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>- Name</td>
<td>Name of the Dashboard Part</td>
</tr>
<tr>
<td>- Tab order</td>
<td>Order of the Button tabs</td>
</tr>
<tr>
<td>Layout</td>
<td></td>
</tr>
<tr>
<td>- Anchors</td>
<td>Edge definitions that bound the Dashboard Part.</td>
</tr>
</tbody>
</table>

### Web View Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data</td>
<td></td>
</tr>
<tr>
<td>DataBinding</td>
<td>Data binding information for the Dashboard Part</td>
</tr>
<tr>
<td>- Exclusive Data</td>
<td>Data from selected data source will be exclusive (private) for this part or not.</td>
</tr>
<tr>
<td>- Data Category</td>
<td>Bound category of the data source</td>
</tr>
<tr>
<td>- Data Source</td>
<td>Bound data source based on Data Category</td>
</tr>
<tr>
<td>- Text field</td>
<td>Field the Dashboard Part displays</td>
</tr>
<tr>
<td>- Value field</td>
<td>Value the Dashboard Part stores</td>
</tr>
<tr>
<td>- Row</td>
<td>Row the Dashboard Part shows</td>
</tr>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>- Name</td>
<td>Name of the Dashboard Part</td>
</tr>
<tr>
<td>- URL</td>
<td>URL address</td>
</tr>
<tr>
<td>Layout</td>
<td></td>
</tr>
<tr>
<td>- Anchors</td>
<td>Edge definitions that bound the Dashboard Part.</td>
</tr>
</tbody>
</table>
### Chart Properties

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Appearance</strong></td>
<td></td>
</tr>
<tr>
<td>• 3D Depth</td>
<td>Depth of the chart image in 3D</td>
</tr>
<tr>
<td>• 3D Mode</td>
<td>3D view setting of the chart</td>
</tr>
<tr>
<td>• Back Color</td>
<td>Background color</td>
</tr>
<tr>
<td>• Color Scheme</td>
<td>Color scheme for the chart</td>
</tr>
<tr>
<td>• Colored Values</td>
<td>Fill values for multiple colors</td>
</tr>
<tr>
<td>• Gridlines</td>
<td>Gridline display</td>
</tr>
<tr>
<td>• Inside Color</td>
<td>Chart image area color</td>
</tr>
<tr>
<td>• Key Axis Title</td>
<td>Title of the Keys Axis</td>
</tr>
<tr>
<td>• Stacked</td>
<td>Display chart values stacked</td>
</tr>
<tr>
<td>• Title</td>
<td>Chart Title text</td>
</tr>
<tr>
<td>• Values Axis Title</td>
<td>Title of the Values Axis</td>
</tr>
<tr>
<td>• View Mode</td>
<td>Type of chart display</td>
</tr>
<tr>
<td><strong>Data</strong></td>
<td></td>
</tr>
<tr>
<td>• DataBinding</td>
<td>Data binding of the chart</td>
</tr>
<tr>
<td>• Retain Source Order</td>
<td>Resorting of data order option</td>
</tr>
<tr>
<td><strong>Format</strong></td>
<td></td>
</tr>
<tr>
<td>• Keys</td>
<td>Key values formatting</td>
</tr>
<tr>
<td>• Keys Decimals</td>
<td>Key values decimal accuracy</td>
</tr>
<tr>
<td>• Values</td>
<td>Value formatting</td>
</tr>
<tr>
<td>• Values Decimals</td>
<td>Value decimal accuracy</td>
</tr>
<tr>
<td><strong>General</strong></td>
<td></td>
</tr>
<tr>
<td>• Name</td>
<td>Name of the Dashboard Part</td>
</tr>
<tr>
<td><strong>Layout</strong></td>
<td></td>
</tr>
<tr>
<td>• Anchors</td>
<td>Edge definitions that bound the Dashboard Part.</td>
</tr>
</tbody>
</table>
### Table View

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Appearance</td>
<td></td>
</tr>
<tr>
<td>• Back Color</td>
<td>Background color</td>
</tr>
<tr>
<td>• Flat</td>
<td>Flat appearance of grid</td>
</tr>
<tr>
<td>• Font</td>
<td>Label font style</td>
</tr>
<tr>
<td>• Line Color</td>
<td>Color of lines between columns and rows</td>
</tr>
<tr>
<td>• Text Color</td>
<td>Color of the table text</td>
</tr>
<tr>
<td>Data</td>
<td></td>
</tr>
<tr>
<td>• DataBinding</td>
<td>Data binding of the Table</td>
</tr>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>• Name</td>
<td>Name of the Dashboard Part</td>
</tr>
<tr>
<td>Layout</td>
<td></td>
</tr>
<tr>
<td>• Anchors</td>
<td>Edge definitions that bound the Dashboard Part.</td>
</tr>
</tbody>
</table>

### Date Picker

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data</td>
<td></td>
</tr>
<tr>
<td>• DataBinding</td>
<td>Data binding information for the Dashboard Part</td>
</tr>
<tr>
<td>• Exclusive Data</td>
<td>Data from selected data source will be exclusive (private) for this part or not.</td>
</tr>
<tr>
<td>• Data Category</td>
<td>Bound category of the data source</td>
</tr>
<tr>
<td>• Data Source</td>
<td>Bound data source based on Data Category</td>
</tr>
<tr>
<td>• Text field</td>
<td>Field the Dashboard Part displays</td>
</tr>
<tr>
<td>• Row</td>
<td>Row the Dashboard Part shows</td>
</tr>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>• Name</td>
<td>Name of the Dashboard Part</td>
</tr>
<tr>
<td>Layout</td>
<td></td>
</tr>
<tr>
<td>• Anchors</td>
<td>Edge definitions that bound the Dashboard Part.</td>
</tr>
</tbody>
</table>
Types of Charts

When defining the properties for the chart-type Dashboard Parts, you have the option to also determine the visual type of chart to display. Below are examples of the various types of charts that are available under the drop-down menu for the View Mode chart property.

Each Chart can have a slightly different appearance based on the data being reported and the properties defined for the chart (see "Chart Properties" on page 157).

<table>
<thead>
<tr>
<th>Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lines</td>
<td><img src="chart_lines.png" alt="Lines Chart" /></td>
</tr>
<tr>
<td>Bar</td>
<td><img src="chart_bar.png" alt="Bar Chart" /></td>
</tr>
<tr>
<td>Curve</td>
<td><img src="chart_curve.png" alt="Curve Chart" /></td>
</tr>
<tr>
<td>Scatter</td>
<td><img src="chart_scatter.png" alt="Scatter Chart" /></td>
</tr>
<tr>
<td>Name</td>
<td>Example</td>
</tr>
<tr>
<td>---------</td>
<td>---------</td>
</tr>
<tr>
<td>Pie</td>
<td><img src="image1.png" alt="Pie Chart Example" /></td>
</tr>
<tr>
<td>Area</td>
<td><img src="image2.png" alt="Area Chart Example" /></td>
</tr>
<tr>
<td>Pareto</td>
<td><img src="image3.png" alt="Pareto Chart Example" /></td>
</tr>
<tr>
<td>Step</td>
<td><img src="image4.png" alt="Step Chart Example" /></td>
</tr>
<tr>
<td>Surface</td>
<td><img src="image5.png" alt="Surface Chart Example" /></td>
</tr>
<tr>
<td>Name</td>
<td>Example</td>
</tr>
<tr>
<td>---------</td>
<td>---------</td>
</tr>
<tr>
<td>Radar</td>
<td><img src="image" alt="Radar Chart" /></td>
</tr>
<tr>
<td>Cube</td>
<td><img src="image" alt="Cube Chart" /></td>
</tr>
<tr>
<td>Doughnut</td>
<td><img src="image" alt="Doughnut Chart" /></td>
</tr>
<tr>
<td>Pyramid</td>
<td><img src="image" alt="Pyramid Chart" /></td>
</tr>
<tr>
<td>Bubble</td>
<td><img src="image" alt="Bubble Chart" /></td>
</tr>
<tr>
<td>Name</td>
<td>Example</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Contour</td>
<td><img src="image1" alt="Contour Example" /></td>
</tr>
<tr>
<td>CurveArea</td>
<td><img src="image2" alt="CurveArea Example" /></td>
</tr>
<tr>
<td>Gantt</td>
<td><img src="image3" alt="Gantt Example" /></td>
</tr>
<tr>
<td>HiLowClose</td>
<td><img src="image4" alt="HiLowClose Example" /></td>
</tr>
</tbody>
</table>
Data Source Management

A data source is a SQL template that used as a data feeder for a Dashboard control. GoldMine comes with many predefined data sources that you can use to bind your data to a Dashboard Part. You can use these data sources as they are, or you can modify them to meet your needs. You can also create new data sources by using the New Data Source wizard.

Managing Data Sources

The Data Source Manager is only accessible while in Design mode on the Dashboards. To open the Data Source Manager, click the Data sources manager link located below the Objects tree in the pane to the left immediately above the Navigation buttons.

Using the buttons on the Data Source Manager, you can:

- **Add** a new Data Source using the New Data Source wizard (see "To Create a New Data Source" on page 164)
- **Edit** the selected Data Source in the Edit Data Source dialog box (see "To Edit a Data Source" on page 165).
- **Delete** the selected Data Source from the list of available data sources (see "To Delete a Data Source" on page 165).
Export the selected Data Source and save it as a Datasources (*.ds.xml) file (see "To Export a Data Source" on page 165).

**To Create a New Data Source**

1. On the Data Source Manager, click the Add button to start the New Data Source wizard.
2. Select the Type of Data and Creation Method.

   **NOTE:** The Manually Typed data source type refers to one in which the database is not a GoldMine database. You must be familiar with this database in order to enter the SQL query manually.

3. the Name and optional Description, and then click Next.
4. Select the Security Level from the drop-down list.
   - None
   - Show ‘n/a’
   - Hide
5. Select the Owner.
6. Select the Output type: (Table or Matrix) and then click Next.
7. Specify the Columns to bind to a Dashboard control.
8. Add fields to the list or modify existing fields using the following options.
   - Select the maximum number of records to include from the drop-down list.
   - Click Add to add a new entry.
   - Click Edit to modify an existing selected entry.
   - Click Delete to remove a selected entry.
   - Click Up or Down to move the selected entry on the list.
9. Specify the search criteria for the data source.
   - Click Add to add a new entry.
   - Click Edit to modify an existing selected entry.
   - Click Delete to remove a selected entry.
10. Specify the runtime search criteria for the data source by clicking Add and entering the following information, then click Next.
   - Enter the Name and choose whether or not to Interpret as String.
   - Choose Field Based or Custom for the search string.
   - The Default Value option activates the string entered in the associated text box.

11. Specify how to group and sort the data and then click Next.
   - Open the Group by drop-down list and select an item. Then use the buttons to add, arrange, or delete the list items.
   - Open the Sort by drop-down list and select an item. Then use the buttons to add, arrange, or delete the list items.

12. Review the SQL template.
   - Click the Check button to perform an automated inspection of the SQL query code.
   - Click the Query button to run a preview of the SQL query.
   If you want to edit the template manually, check the Edit manually option and then modify the text in the box below.

13. Click Finish to save the SQL template.

To Edit a Data Source
1. On the Data Source Manager, select the data source on the list to modify.
2. Click the Edit button to open the Edit Data Source dialog box.
3. Click the appropriate tab and make your modifications as needed.
4. Click the Query tab and Inspect the changes.
   - Click the Check button to perform an automated inspection of the SQL query code.
   - Click the Query button to run a preview of the SQL query.
5. Click Apply to save your changes and OK to close the dialog box.

To Delete a Data Source
   **NOTE:** If you think you might want to use this data source again in the future, you can Export the data source and use it at a later date to create a new data source (see "To Export a Data Source" on page 165).

1. On the Data Source Manager, select the data source on the list to delete.
2. Click the Delete button to remove the selected data source.
3. Click OK the delete the data source.

To Export a Data Source
1. On the Data Source Manager, select the data source on the list to Export.
2. Click the Export button open the Save As dialog box.
3. Browse to the desired location to save the file.
4. Enter a name for the file and then click Save.
   **NOTE:** An exported Data Source can be used during the creation of a new Data Source by checking the Import datasource definition from a file option on the first screen of the New Data Source wizard (see "To Create a New Data Source" on page 164).
Dashboard Macros

Below is a list of supported Macros that can be used when creating SQL query statements for a New Data Source.

**Date Macros**

This group can be used only with date/datetime fields (OnDate, CREATED, etc.)

<table>
<thead>
<tr>
<th>Macro</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;&lt;~CURRENT_YEAR&gt;&gt;</code></td>
<td>current year</td>
</tr>
<tr>
<td><code>&lt;&lt;~CURRENT_MONTH&gt;&gt;</code></td>
<td>current month</td>
</tr>
<tr>
<td><code>&lt;&lt;~CURRENT_QUARTER&gt;&gt;</code></td>
<td>current quarter</td>
</tr>
<tr>
<td><code>&lt;&lt;~CURRENT_DAY&gt;&gt;</code></td>
<td>current day</td>
</tr>
</tbody>
</table>

This group can be used only with date/datetime fields (OnDate, MODIFIED, etc.)

<table>
<thead>
<tr>
<th>Macro</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;&lt;~LAST_YEAR&gt;&gt;</code></td>
<td>last (previous) year</td>
</tr>
<tr>
<td><code>&lt;&lt;~LAST_MONTH&gt;&gt;</code></td>
<td>last month</td>
</tr>
<tr>
<td><code>&lt;&lt;~LAST_QUARTER&gt;&gt;</code></td>
<td>last quarter</td>
</tr>
<tr>
<td><code>&lt;&lt;~LAST_DAY&gt;&gt;</code></td>
<td>last day</td>
</tr>
<tr>
<td><code>&lt;&lt;~CURRENT_DATE&gt;&gt;</code></td>
<td>current date</td>
</tr>
<tr>
<td><code>&lt;&lt;~FY_END&gt;&gt;</code></td>
<td>when fiscal year ends (month)</td>
</tr>
</tbody>
</table>

**User Macros**

<table>
<thead>
<tr>
<th>Macro</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;&lt;~CURRENT_USER&gt;&gt;</code></td>
<td>logged/current user</td>
</tr>
<tr>
<td><code>&lt;&lt;~IS_CURRENT_USER_MASTER&gt;&gt;</code></td>
<td>replaced by</td>
</tr>
<tr>
<td><code>&lt;&lt;~USER_GROUP_MEMBERS&gt;&gt;</code></td>
<td>user group's name, replaced by group's members list (&quot;&quot;, 'USER1', 'USER2')</td>
</tr>
</tbody>
</table>

**Contact Macros**

<table>
<thead>
<tr>
<th>Macro</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;&lt;~CONTACT_FILTER&gt;&gt;</code></td>
<td>contact filter</td>
</tr>
<tr>
<td><code>&lt;&lt;~CONTACT_GROUP&gt;&gt;</code></td>
<td>contact group</td>
</tr>
</tbody>
</table>

**Runtime Filters**

<table>
<thead>
<tr>
<th>Macro</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;&lt;~INACTIVE_STATE~&gt;</code></td>
<td>ignore runtime filter (by default value will be placed)</td>
</tr>
<tr>
<td><code>&lt;&lt;~IGNORE_STATE~&gt;</code></td>
<td>ignore runtime filter and its default value</td>
</tr>
<tr>
<td><code>&lt;&lt;~VALUE~&gt;</code></td>
<td>shows place where value from part will be replaced</td>
</tr>
<tr>
<td><code>&lt;&lt;~VALUES~&gt;</code></td>
<td>the same as <code>&lt;&lt;~VALUE~&gt;</code> , but several values can be replaced (our grid supports multi selection)</td>
</tr>
</tbody>
</table>
Dashboard Tables

Dashboard Tables display a variety of data. You can customize how the data is displayed (adding/removing columns) and how it functions, such as linking to other data. The follow procedures will assist you in designing a table the meets your required needs.

- Adding a Column to an Existing Table (see page 167)
- Removing a Column from an Existing Table (see page 167)
- Changing the Column Label Displayed in the Dashboard (see page 168)
- Creating Table Cell Hyperlinks (see page 168)

Adding a Column to an Existing Table

There are two parts to adding a column to an existing table: Update the SQL Query and Edit the Data Binding Properties.

**To Update the SQL Query**

1. Click the New Data Source link at the bottom of the Dashboards Objects panel.
2. On the Data Source Manager, select the data source on the list to modify.
3. Click the Edit button to open the Edit Data Source dialog box.
4. Click the Select tab.
5. Click the Add button to add a field.
6. Click OK to save your changes.

**NOTE:** If you have a Manually Typed data source, you might need to manually edit the SQL Query. However, if you have a states that contains code such as “Select*”, then it will already query for all the columns in the table.

**Edit the Data Binding Properties**

1. Select the Table on the Dashboard.
2. In the Properties area, locate the Data > Data Binding field.
3. Click the ellipses button (...) to open the Table View Data Binding dialog box.
4. There are two list boxes:
   - Unbound fields (columns) contains columns that are not available for display in the table.
   - Bound fields contains columns that can be displayed in the table.
5. Select an item from the Unbound fields list and then use the Right Arrow button (or double-click the field name) to move it to the Bound Fields.
6. Click OK to save your changes.

Removing a Column from an Existing Table

Removing a column from a table does not actually remove any data from your database table. It only hides the column from view in the Dashboard Table part.

**To Remove a Column from a Table**

1. Select the column name from the Bound fields list box.
2. Click the Left Arrow button to move it to the Unbound list box.
   
   You can also select the column name in the Bound Fields list box and the uncheck the Visible box under the Column Properties area.
3. Click OK to save your changes.
Changing the Column Label Displayed in the Dashboard

By default, the column label on the table used that label from your database table for that column. If you want the column to have a different name on your Dashboard Table, you can change the display name using the procedure below.

To Change the Name of the Column

1. Select the Table on the Dashboard.
2. In the Properties area, locate the Data > Data Binding field.
3. Click the ellipses button (…) to open the Table View Data Binding dialog box.
4. Select the column from the Bound fields list box.
5. In the Column Properties area, change the text in the Caption text box as desired.
6. Click OK to save your changes.

Creating Table Cell Hyperlinks

The process of hyperlinking a cell shown in a dashboard Table View is set up within the Data Binding for the Dashboard Part. In the case of a Table, the column must be linked to the record the GoldMine will use for the destination.

To Create Linked Table Cells

1. Select the Table on the Dashboard.
2. In the Properties area, locate the Data > Data Binding field.
3. Click the ellipses button (…) to open the Table View Data Binding dialog box.
4. Select a Bound field that you want to be a hyperlink.
5. Uncheck the Visible option under Column Properties.
   Normally, you will want to make this field invisible because it does not contain readable data.
6. Check Enable as hyperlink option.
7. Select Primary Destination (see "About Dashboard Link Data Destinations" on page 152).
8. Select Field that identifies <x> record
9. Click OK to save your changes.

Dashboard Management

Managing your Dashboards involves adding/removing parts from a Dashboard and manipulating the size and location of parts, as well as creating copies of a Dashboard and deleting an unwanted Dashboard.

IMPORTANT: You cannot modify any of the predefined Dashboards. Dashboards that can be modified are based on those of your own design or from a copy of a predefined Dashboard (see “Predefined Dashboards” in the User Guide or Online Help.)

- Removing a Part from a Dashboard
- Repositioning and Relocating a Dashboard Part
- Creating a Copy of a Dashboard
- Deleting a Dashboard
Removing a Part from a Dashboard

If there is a part or parts that you no longer need on a Dashboard, you can remove them following the procedure below. Before you make any permanent changes to the current Dashboard, you might want to create a copy (see "Creating a Copy of a Dashboard" on page 169) or back up of the Dashboard (see "Exporting a Dashboard XML File" on page 174).

**To Remove a Dashboard Part**

1. Select the Dashboard from the list of Available Dashboards.
2. Click the Design button to start the Dashboard Designer.
3. Select the Dashboard Part on the canvas, then right-click the Dashboard Part and select **Delete control** from the context menu, or press the **Delete** key on the keyboard.
4. Click the **Save** button on the Dashboard toolbar to save your changes.
5. Click the **View** button to view the new Dashboard.

Repositioning and Relocating a Dashboard Part

If you have a Dashboard Part that is either not where you want it or is not the desired size/shape, you can easily move to resize it to fit your needs.

**NOTE:** You can use the canvas’ grid points to help align the various components on the Canvas.

**To Move a Dashboard Part**

1. Click Dashboard Part to select it.
2. Use the **Arrow** keys on the keyboard to move the Dashboard, or place the cursor on the part and then click and drag the part to refine the location.
3. Click the **View** button to view your changes.

**To Resize a Dashboard Part**

1. Click Dashboard Part to select it.
2. Adjust the shape by placing the cursor over any of the resize points around the active Dashboard Part, then click and drag the resize point to the desired shape and size.
3. Click the **View** button to view your changes.

Creating a Copy of a Dashboard

When you create a copy of the Dashboard, you create an exact duplicate of the currently active Dashboard. By default, the copy is placed under the same Category as the current Dashboard, but the phrase “*Copy_from_*” is prepended to the current Dashboard name.

**To Create a Copy of a Dashboard**

1. Click the **Dashboards** button on the Navigation Pane.
2. Expand the **Available Dashboards** tree to locate the desired Dashboard.
3. Select the Dashboard from the tree to view the Dashboard.
4. Right-click and select Copy from the context menu. A message box displays with the following question:

- Yes creates new instances (which allows for editing of the data sources).
- No uses the existing data source (which might not allow for editing of the data sources if they are based on those of a predefined Dashboard).

5. The screen switches to the Dashboard Designer.
6. Change the Name and Category properties for the Dashboard as desired.
7. Add, remove, or edit the Dashboard Parts as desired.
8. Click the Save button on the Dashboard toolbar to save your changes.
9. Click the View button to view the new Dashboard.

   **NOTE:** You can also use the Copy button in the Dashboard Designer tool bar to create a copy of the current Dashboard.

### Deleting a Dashboard

Any Dashboard on the list of Available Dashboards can be deleted. If you want to backup the Dashboard before you delete it, you can use the Export command to save a copy of the Dashboard. This allows you to add it back to GoldMine at a later date using the Import command. For more information, see "Import and Export Dashboards" on page 174.

   **NOTE:** A user must be defined as a Master user to delete an existing Dashboard (see "Using the User QuickStart Wizard" in the User Guide or Online Help).

### To Delete a Dashboard

1. Click the Dashboards button on the Navigation Pane.
2. Expand the Available Dashboards tree to locate the desired Dashboard.
3. Select the Dashboard from the tree to view the Dashboard.
4. Click the Design button to switch to the Dashboard Designer.
5. Click the Delete button on the Dashboard toolbar.
6. Click Yes to delete the current Dashboard, or No to cancel.
Events and Actions

Events and Actions can be added to any Dashboard Part while in Design mode. The Event is what occurs with the Dashboard Part, such as clicking a Button or making a selection from a Drop-down list. The Action is what happens as a result of the Event.

For example: you might have a Dashboard Part that is a Refresh button. When you click this button, all the data on the Dashboard is updated to display the latest information. Another example is used in the Sample Dashboard Tutorial (see page 133). In that example, a Drop-down list is assigned the Event and Action that results in a Chart being updated based on the user’s selection in the Drop-down List.

There are many uses of Events and Actions that you can use within the Dashboard.

Viewing the Events and Actions Dialog Box

The Events and Actions Dialog box is only accessible from within the Dashboard Design mode. To view the Events and Actions dialog box, add an Dashboard Part or select and existing part and then click the Events button on the Dashboard toolbar.

To Add an Event and Action

1. Select the Dashboard Part and then click the Events button on the Dashboard tool bar.
2. On the Events and Actions dialog box select the area affected: Main View or Dashboard Part.
   
   **NOTE:** The Main View option automatically adds the Refresh entire dashboard Action to the List of Actions.

3. Select the Event from the drop-down list.
4. Click the Add button to view the Action's properties dialog box.
5. Select the type of Action:
   - **Refresh entire dashboard** updates all data on the Dashboard
   - **Focus on a dashboard part** changes focus to the specified Dashboard part
   - **Refresh a dashboard part** refreshed the data of the specified Dashboard part
   - **Refresh a dashboard part based on user selection** refreshed the data of the specified Dashboard part by data source, runtime parameter, and set values.
   - **Set runtime parameter for a dashboard part without refreshing** updates a Dashboard part based on data source, runtime parameter, and set values without refreshing the selected Dashboard part.
   - **Drill down** moves further into the details.

6. Make selections for each section from the drop-down lists for the selected Action type.
   The properties that display vary depending on the type of Action selected. For more information, see "Set Action Properties" on page 173.

7. Click **OK** and add the Action to the List of Actions on the Events and Actions dialog box.
   To add another Action, click the **Add** button again and repeat the process.

8. Click **OK** to save the action and close the dialog box.
   
   **NOTE:** If you click **Cancel**, the Action is not saved nor added to the list of actions for the Dashboard Part.

**To Edit an Event and Action**

1. Select the Dashboard Part and then click the **Events** button on the Dashboard toolbar.
2. Select either the **Main View** or **Dashboard Part** as desired.
3. Select the **Event** from the drop-down list as desired.
4. Select an Action from the List of Actions and the click the **Edit** button.
5. Select the type of **Action** (see “To Add an Event and Action” above for Action details).
6. Make selections for each section from the drop-down lists for the selected Action type.
   The properties that display after your Action type selection vary depending on the type of Action selected.
7. Click **OK** to return to the Events and Actions dialog box.
   
   **TIP:** To add another Action, click the **Add** button and repeat the process.
8. Click **OK** to save the action and close the dialog box.
   
   **NOTE:** If you click **Cancel**, the Action changes will not be saved.

**To Delete an Action from an Event**

1. Select the Dashboard Part and then click the **Events** button on the Dashboard toolbar.
2. Select an Action from the List of Actions and the click the **Delete** button.
3. Click **OK** to save the Action deletion and close the dialog box.
   
   **NOTE:** If you click **Cancel**, the Action will not be deleted.
Set Action Properties
The following tables list the available options depending on the type of Action selected from the Action drop-down list when you click the Add button on the Events and Actions dialog box (see "Viewing the Events and Actions Dialog Box" on page 171).

- Focus on a dashboard part
- Refresh a dashboard part

| Dashboard part | The name of the affected Dashboard part |

- Refresh a dashboard part based on user selection
- Set runtime parameter for a dashboard part without refreshing

| Update dashboard part | The name of the affected Dashboard part |
| Data source | The name of the Data source linked to the Dashboard part |
| Runtime Parameter |
| - Predefined value |
| - Runtime (from part) |
| - Field | Key |
| | Value |
| | Series |

Drill down

| Update dashboard part | The name of the affected Dashboard part |
| Data source | The name of the Data source linked to the Dashboard part |
| Runtime Parameter 1 |
| - Predefined value |
| - Runtime (from part) |
| - Field | Key |
| | Value |
| | Series |

| Runtime Parameter 2 |
| - Predefined value |
| - Runtime (from part) |
| - Field | Key |
| | Value |
| | Series |
Import and Export Dashboards

The Dashboards of GoldMine are created using the XML file format. Any Dashboard that you export creates an XML file containing all the required components to recreate the Dashboard, including the Category and Name. Likewise, any Dashboard you import must be in the XML format.

Importing a Dashboard XML File
1. Click the **Dashboards** button on the Navigation Pane, or select **Go To > Dashboards** from the menu.
2. Click the **Design** button on the Dashboard toolbar.
3. Enter a **Category** and **Name** for the imported Dashboard.
4. Click **OK** to view the blank Dashboard canvas.
5. Click the **Import** button on the Dashboard toolbar.
6. Browse to the location of the XML file that you want to import.
7. Select the file from the list and then click the **Open** button.
   
   **NOTE:** If the name of the Dashboard contained in the XML file matches a Dashboard you already have, a warning message displays. Click **Yes** to overwrite the existing Dashboard or **No** to cancel the import.
8. Click the **Save** button on the Dashboard toolbar.
9. Click the **View** button on the Dashboard toolbar to view the Dashboard.

Exporting a Dashboard XML File
1. Click the **Dashboards** button on the Navigation Pane, or select **Go To > Dashboards** from the menu.
2. Click the **Design** button on the Dashboard toolbar.
3. Enter a **Category** and **Name** for the new Dashboard.
4. Click **OK** to view the blank Dashboard canvas.
5. Click the **Export** button on the Dashboard toolbar.
6. Browse to the location where you want to save the file.
7. Enter a name for the file and then click the **Save** button on the Dashboard toolbar.
Web Import

Overview

Set up Internet Web sites to collect contact information from interested visitors. Use the data in GoldMine by creating a Web form (see "Creating Web Forms" on page 177) that includes instructions for handling the data.

After information is submitted, a Web server script (see "Creating Server Scripts" on page 180) can format the data into an Internet e-mail message which can then be sent to a designated recipient. When retrieving the e-mail message (see "Importing Contacts with Web Import" on page 186), GoldMine recognizes the import instructions and creates a Contact Record with data captured from the Web page. Or, if a Web Import contact duplicates an existing contact, update selected fields (see "Updating GoldMine Fields with Web Import Data" on page 187).

Combining the Web Import feature with GoldMine’s Automated Processes (see "Formatting Web Import Files" on page 183) can automate capturing and responding to leads. Initiate Automated Processes automatically and send e-mail messages to GoldMine users alerting them of the incoming contact data.

An advanced knowledge of gateway scripts is not needed to implement the GoldMine Web Import feature. Begin by contacting your Web administrator and providing him or her with the sample HTML and Perl script. Writing and modifying scripts requires some programming expertise not covered in this material. Many sources for getting started with Common Gateway Interface (CGI) scripts are available on the Internet and in bookstores.

**NOTE:** FrontRange Solutions’ technical support cannot provide support for creating or maintaining HTML code or CGI scripts.

Using the Web Import Wizard

The Web Import Wizard creates the HTML form and script to process the contact information input by visitors on a Web site. You do not need to type the code and can create the forms in PERL, ASP, and PHP. Because all activities are driven off the Web server, Internet access is necessary.

The Web form captures the data, and the script formats it into an Internet e-mail message which can then be sent to a designated recipient. When retrieving the e-mail message, GoldMine recognizes the import instructions and creates a Contact Record with all the data captured from the Web page or updates selected fields if a Web Import contact is a duplicate of an existing contact.

Attach an Automated Process to a new or duplicate contact. Automated Processes can be initiated automatically, and e-mail messages sent to GoldMine users alerting them of the incoming contact data.

Once the form and script are e-mailed to the designated recipient, the Web administrator can place the HTML form page and the script source code on the Web Import server(s).

**To Start the Web Import Wizard**

1. Select **Go To > Campaigns**
2. Click the Campaigns button in the Navigation Pane, then click **Configure WebImport** on the toolbar.

**TIP:** You can also start the wizard by selecting **Web > Setup Web Import** and then click **New**.
3. Enter or set the Web Import authorization password (see "Requiring Passwords on Web Import Files" on page 186).
4. Create, edit, rename, and delete Web Import Profiles in the Web Import Profiles dialog box.

Using Web Import Profiles

After creating a Web Import form and script using the Web Import Wizard, edit, rename, and delete Web Import profiles with these options on the Web Import Profiles dialog box:

- **New**: Create a new import form and script.
- **Edit**: Edit an existing import form and script.
- **Rename**: Type a new name for the campaign.
- **Delete**: Removes the selected Web Import profile.
- **More>>**: Users with Master rights have these settings available:
  - **Optional Web Import authorization password**: Protect the Web Import process with passwords so only authorized incoming instruction files can be imported. This prevents unauthorized persons from sending e-mail messages and inundating a GoldMine system with unwanted data.
  - **Fields to be Updated by WebImport**: Type “I Want To Allow Fields To Be Updated By WebImport” in the text box to let visitors to your Web site update their information in your GoldMine database.
  - **Fields that can be updated**: Select the fields to be updated by the Web Import.
Creating Web Forms

The Web form is an HTML document for collecting information. Users type text and make choices from check boxes, radio buttons, and selection lists. Design forms meeting customer requirements by combining these input types; use or modify the sample HTML form below. The name of fields in your form must be identical to the names in your GoldMine databases.

How Forms Work

A Web form works with a script on a server to process submitted information. When a person fills out a form and clicks Submit, the browser sends (or posts) information in the form to the script or application running on the server for processing. The script processes the information passed from the browser to the server. The processed information can be sent back to the server, or, as with GoldMine's Web Import feature, sent by e-mail to a designated recipient.

Example of an HTML file using a form:

```html
<!----The following is an example of an HTML file using a form----->
<html>
<head><title>FrontRange Solutions Inc. - Online Registration</title></head>
<body bgcolor="#008080" text="#FFFFFF" link="#000000" vlink="#FF8900">
  <basefont size=3>
  <!----This is where the table layout begins----->
  <table border=3>
    <tr>
      <td><font size=+3>FrontRange Solutions Inc.</font></td>
    </tr>
    <tr>
      <td><font size=+2>Online Registration Form</font></td>
    </tr>
  </table>
  <!----This is where the table layout ends----->
  <p>
    <b>
      <center>To register your copy of GoldMine, please fill out the following form.</center>
      <center>Your registration number is located on the registration card.</center>
    </b>
  </p>
  <hr>
  <!-----This is where the form layout begins----->
  <form method=post action=http://www.frontrange.com/cgi/webimp.pl>
    <!----The line below references the PERL script----->
    <input type="hidden" name="cs1_Rectype" value="P">
    <input type="hidden" name="cs1_ContSupRef" type="text" size="15" maxlength="15">
  </form>
</body>
</html>
```
<br><dt>Number of Licenses<br>
<select name="Key1">
     <option value="Gold 01/Single user">Single user</option>
     <option value="Gold 05 Net">5 user Network</option>
     <option value="Gold 10 Net">10 user Network</option>
     <option value="Gold 10-25 Net">10 - 25 user Network</option>
     <option value="Gold 25-50 Net">25 - 50 user Network</option>
     <option value="Gold 51+ Net">51+ user Network</option>
     <option value="Gold Net Unknown">Not Sure</option>
     <option selected>Choose One</option>
</select><br>
<p>
<dt>Date of Purchase<br>
<input name="cs1_Country" type="text" size="35" maxlength="35" value="MM/DD/YY">
<p>
<dt>Place of Purchase<br>
<input name="cs2_Rectype" type="hidden" value="P">
<input name="cs2_Contact" type="hidden" value="Place of Purchase">
<input name="cs2_ContSupRef" type="text" size="35" maxlength="35" value="">
<hr>
Ms. <input type="radio" name="Dear" value="Ms.">
Mr. <input type="radio" name="Dear" value="Mr.">
<dt>Name<br>
<dd><input size="40" maxlength="40" name="CONTACT">
<dt>Title<br>
<dd><input size="30" maxlength="30" name="TITLE">
<dt>Company Name<br>
<dd><input size="40" maxlength="40" name="COMPANY">
<dt>E-Mail Address<br>
<dd><input name="cs3_Rectype" type="hidden" value="P">
<input name="cs3_Contact" type="hidden" value="Internet Address">
<input name="cs3_ContSupRef" type="text" size="30" maxlength="30">
Fax Number (WITH AREA CODE)

Contact Manager/PIM, if any, prior to purchasing GoldMine

Computer Type:

Network Operating System

Primary Business at your company:
Creating Server Scripts

The Common Gateway Interface (CGI) is the specified standard for communication between HTTP servers (Web servers) and server-side gateway programs. The CGI specifications define how data passes from the server to gateway programs, and vice versa.

Gateway programs can be compiled programs written in languages such as C, C++ or Pascal, or they can be executable scripts written in languages such as Perl, TCL, ASP, and other various shell programs. Most gateway programs are Perl scripts; they are easy to write and modify and are transportable between computers.
Sample PERL Gateway Script for GoldMine Web Import

```perl
#!/usr/local/bin/perl

# check for the POST method
if ($ENV{'REQUEST_METHOD'} eq 'POST')
{
  # How many bytes are we supposed to receive?
  read(STDIN, $buffer, $ENV{'CONTENT_LENGTH'});
  # make a list of keyword/value pairs
  @pairs = split(/&/, $buffer);
  # cycle through each pair and decipher the values
  foreach $pair (@pairs)
  {
    # get the name/value pair strings
    ($name, $value) = split(/=/, $pair);
    # translate "+" to a space
    $value =~ tr/+// ;
    # decipher ASCIhexidecimal escaped characters, if any
    $value =~ s/%([a-fA-F0-9][a-fA-F0-9])/(chr(hex($1)))/eg;
    # find profile/contsupp field names that begin with cs*
    if ($name =~ /cs\d_/)
      #add the profile/contsupp pair to a list keyed on the name of the variable
      @{$csarray}{$name} = $value;
    else {
      #add the basic field data pair to a list keyed on the name of the variable
      $contents{$name} = $value
    }
  }

  ($mon,$day,$year) = split(m/>/>>/,'/bin/date +%B/%e/%Y');
  $date = "$mon $day, $year";
  $to = $contents{email_to} ;
  &mailto;
  #thankyou;
  # subroutines from here on down!
  sub thankyou {
    print "Location: http://www.frontrange.com/thankyou.htm\\n\\n";
    exit;
  }
  sub mailto {
    open (MAIL, ">>/usr/lib/sendmail -t") >>>>die "can't open pipe to sendmail \n"
    print MAIL "Content-Type: application/x-gm-impdata\\n"
    print MAIL "To: $to\\n"
    print MAIL "From: $csarray{cs2_ContSupRef}\\n"
    print MAIL "Subject: datafromgoldform.pl\\n"
    print MAIL "\\n\\n";
  }
}
```

print MAIL "{\[Instructions\]}\n";
print MAIL "SaveThis=Web Import File\n";
print MAIL "DupCheck1=Contact\n";
print MAIL "\n";
print MAIL "OnNewSendEmail=Bart,NEW,Prospect requesting information \n";
print MAIL "OnDupSendEmail=Natalie,,Duplicate Record \n";
print MAIL "\n";
print MAIL "OnNewAttachTrack=WEBLead\n";
print MAIL "\n";
# The following is an example of testing a field for a value
#ifprint MAIL "Below a message will be printed if the CITY is Torrance\n"
if ($contents{CITY}eq "Torrance") {
print MAIL "OnAnySendEmail=John,WCC,This one is from Torrance\n"
}
print MAIL "\n";
# print MAIL "Run=c:\goldmine\webimp.exe\n";
print MAIL "\n";
print MAIL "\n";
print MAIL "{\[Data\]}\n";
# print out general fields and values
foreach $name (sort keys %contents) {
next if $contents{$name} eq "";
print MAIL "$name = $contents{$name}\n";
}
print MAIL "\n";
print MAIL "{\[ContSupp\]}\n";
# print out profile/contsupp fields and values
foreach $name (sort keys %csarry) {
next if $csarry{$name} eq "";
print MAIL "$name = $csarry{$name}\n";
}
print MAIL "\n";
print MAIL "\n";
print MAIL "\n";
print MAIL "\n";
close (MAIL);
}
### Formatting Web Import Files

The incoming import file contains contact data and instructions. It must conform to a specific format, similar to .ini files. Three major import file sections:

- **[Instructions]**: Define import instructions. These instructions allow duplicate checking, sending e-mail messages to GoldMine users, attaching Automated Processes, and running external applications to further process the incoming contact data. GoldMine can check if the contact already exists by considering the DupCheck#= instructions. The first duplicate checking instruction usually must be based on one of the indexed fields, Contact, Company, Phone1, City, State, Country, Zip, AccountNo, Key1, Key2, Key3, Key4, or Key5. Additional DupCheck#= instructions can be specified to test more than one field to determine if the incoming contact data is a duplicate.

  **Example:**
  
  DupCheck1=Contact
  DupCheck2=Company

- **[Data]**: Defines contact data. Format each entry as fieldname=value; for example, City=Long Beach. The filename should be the actual field name in the Contact1 or Contact2 files. A special email=field can be used to insert the contact’s e-mail address.

- **[ContSupp]**: Allows addition of detail records. The fields of each record must have a prefix of cs#_, and must appear consecutively. For example, the fields of the first ContSupp record would have the prefix cs1_, while the fields of a second record would have a prefix of cs2_. Add a maximum of 8 ContSupp records.

### Checking for Duplicate ContSupp Data

GoldMine can check for duplicate records based on ContSupp data by specifying the ContSupp record prefix; for example, CS1. When GoldMine identifies a duplicate record, but notices the contact name does not match the existing name, an additional contact is created with the incoming data under the existing Contact record. GoldMine also adds ContSupp records that do not already exist.

### Checking for Duplicate E-Mail Addresses

Configure GoldMine to check for duplicate records based on an e-mail address. Run this check without including a check based on indexed fields. To check for duplicate e-mail addresses, include the statement:

- DupCheck=Email

### Using Commands to Automatically Perform Operations

#### E-Mail

Send e-mail messages to GoldMine users alerting them of newly created contact records. Send a separate e-mail message based on whether the contact is new [OnNewSendGMEmail=], or already exists on file [OnDupSendGMEmail=]. Designate a user as the message recipient, followed by an optional activity code, then an optional reference. Send multiple e-mail messages by appending consecutive numbers to the send e-mail instructions; for example, OnNewSendGMEmail1=, OnNewSendGMEmail2=, and so on.
Automated Processes

Attach Automated Processes to the contact to initiate an automated response. Initiate letters, faxes, e-mail, and other activities to automate responding to the captured leads. Attach a separate Automated Process based on whether the contact is new [OnNewAttachTrack=], or already exists on file [OnDupAttachTrack=]. You must specify the track name, followed by an optional attaching user. For faster processing, also specify the internal track number instead of the track name. Attach multiple Automated Processes by appending consecutive numbers to the attach track instruction; for example, OnNewAttachTrack1=, OnNewAttachTrack2=, and so on.

Launch an External Application

To launch an external application for further processing of the incoming data, use the Run=<exefile> instruction. This command allows flexibility, since custom programs can be written to perform a variety of tasks. GoldMine saves import instructions to a file, and passes that file name as a parameter to the launched application.

Extracting Import Instructions and Data

Since the import instructions are similar to .ini files, use Windows API GetPrivateProfileString to extract the import instructions and data. The ImportData=0 instruction prevents GoldMine from importing any new data, and lets the custom application append the data.

The SaveThis=<reference> instruction saves the instruction file to the notes of a new history record. Specify any history reference; for example, SaveThis=Web import file.

Protect the Web Import process with passwords to allow importation of only authorized incoming instruction files.

GoldMine can also process an import instruction file by sending a DDE command. Using a DDE command lets other applications create Contact records in GoldMine. To start processing an instruction file through DDE, send the ExecInImp (<filename>) command; for example, ExecInImp(i:\GoldMine\imp.ini)]).

NOTE: Also require a password on your WebImport Files (see "Requiring Passwords on Web Import Files" on page 186).

Example 1:

Since GoldMine stores Web site addresses as detail records (called Web Site), import these addresses using the following syntax:

[ContSupp]
 cs1_RecType=P
 cs1_Contact=Web Site
 cs1_ConSupRef=http://www.web.site.com
 cs_Address1=notes (optional)

Example 2 (correct format for an import instruction file):

[Instructions]
 DupCheck1=Contact
 OnNewSendGMEmail=JOHN, NEW, Prospect requesting information
 [Data]
 Company=GlobalCorp.
 Contact=John Doe
 Phone1=555/333-1234
 email=jdoe@global.com
 [ContSupp]
 cs1_RecType=P
 cs1_Contact=Serial Number
 cs1_ConSupRef=10000002
 cs_Address1=This is a test....
The following example shows a short instruction file containing the password “Doodle”:

[Instructions]
Password=Doodle
DupCheck1=Contact
OnNewSendGMEmail=JOHN, NEW, Prospect requesting information
[Data]
Company=GlobalCorp.
Contact=John Doe
Phone1=555/333-1234
email=jdoe@global.com

Example 3 (an import instruction file containing all possible instructions:)

[Instructions]
DupCheck1=Contact
DupCheck2=userDef05
DupCheck3=cs1
OnNewSendGMEmail=JOHN, NEW, Prospect requesting information
OnDupSendGMEmail=AMI,,Repeated request...
OnNewAttachTrack=Web Lead
OnDupAttachTrack=100067,JOHN
Run=c:\goldmine\webimp.exe
SaveThis=Web import file
;ImportData=0
Password=Verify
[Data]
Company=GlobalCorp.
Contact=John Doe
Phone1=555/333-1234
Address1=1401 West Baker Street
City=Garden Grove
State=CA
Zip=90220
Source=Web Page
email=jdoe@global.com
[ContSupp]
cs1_RecType=P
cs1_Contact=Serial Number
cs1_ContSupRef=10001001
cs1_Address1=This is a test...
cs2_RecType=C
cs2_Contact=Jane Adams
cs2_Title=Beta Program Manager
Importing Contacts with Web Import

GoldMine's Internet e-mail reader identifies data retrieved from the Web Import Gateway. GoldMine looks at the header of every e-mail message for handling instructions.

**Example of Special Header Information**

```
Content-Type: application/x-gm-impdata
```

When an e-mail message containing Web Import information is retrieved, GoldMine handles the message. Alternatively, an incoming message can trigger the Web Import with this To: line entry:

```
{$GM-WEBIMPORT$}
```

**TIP:** For more information, see "Formatting Web Import Files" on page 183.

Requiring Passwords on Web Import Files

Web Import processes are protected with passwords to allow importation of only authorized incoming instruction files. This prevents unauthorized persons from sending e-mail messages and inundating a GoldMine system with unwanted data. A password is always required to use Web Import. The incoming instruction file will not be processed if it does not contain a password or if it contains an invalid password.

The Web Import authorization password is set at the top of the Web Import Profiles dialog box.

**NOTE:** A password must be set before the Web Import functions are made available.
Updating GoldMine Fields with Web Import Data

If a contact already in your database fills out a Web form, set the Web Import to update specified Contact1 and Contact2 fields instead of creating duplicate records. Also enable Web Import to update e-mail addresses and append Notes. With these settings, GoldMine updates only the specified fields and discards changes to fields not included in the list. The e-mail address is added only if it differs from the existing addresses. It is added as the new primary address and the others save as alternative addresses.

Important Information About WebImport Overrides

⚠️ IMPORTANT: Accepting changes from a Web Import can cause data integrity problems.

It is recommended that you follow these additional security precautions when enabling Web Import overrides:

- Do not accept Web Import e-mails from an unknown e-mail address.
- Limit access to the Web Import e-mail account to one user, the GoldMine administrator with Master Rights.
- Protect your Web Import files with a password and monitor the Web Import passwords regularly for changes.

TIP: It is recommended that you back up GoldMine data daily when performing daily Web Imports.

Enabling Field Updates with Web Importing

1. Using a text editor, such as Windows Notepad, open the GM.ini.
2. Add this section and lines:
   
   ```
   [WebImportOverwrite]
   IAgree=I Want To Allow Fields To Be Updated By WebImport
   Fields=<list the contact1 and contact2 fields that can be updated, separated by a comma>
   
   Example: Fields=Key1,Fax,UData
   ```
3. Select File > Save and close the text editor.

   NOTE: The Accountno or Recid fields can never be overwritten using the GoldMine Web Import.
Customizing GoldMine

Overview

GoldMine provides extensive customization opportunities. You can configure your calendar, and customize record types, field views, and fields and screens.

Two files store user-related information: username.ini and username.tbi. The username is the GoldMine login name. For example, JohnB.ini and the JohnB.tbi are files in the GoldMine directory.

Calendar Options

GoldMine provides extensive customization opportunities. You can configure your calendar, and customize record types, field views, and fields and screens.

Two files store user-related information: username.ini and username.tbi. The username is the GoldMine login name. For example, JohnB.ini and the JohnB.tbi are files in the GoldMine directory.

- **Holidays**: Holiday categories and holidays to display.
  (see "To Configure the Calendar Options Holidays Settings" on page 30)

- **Activity Details**: How scheduled and completed activities display.
  (see "To Configure the Calendar Options Activity Details Settings" on page 31)

- **Publishing**: iCalendar and Web publishing options.
  (see "Calendar Options Dialog Box, Publishing Tab" on page 74)

- **Free/Busy**: How your scheduled busy times display.
  (see "Calendar Options Dialog Box, Free/Busy Tab" on page 74)

Record Types

Record types are customized combinations of Primary Fields Views, Custom Screens, and GM+Views. Linked and applied based on user-defined rules, record types determine what users see when working in GoldMine. The full record type combination (Primary Field View, Custom Screens and GM+View) is an entity. Manage record types in the Record Types Administration Center.

Effective use of the Record Types Administration Center depends on a workflow.
The Workflow: Creating Primary Fields Views, Custom Screens, and GM+Views

1. Defining Primary Fields Views (see "Primary Field Views" on page 196)
   - Creating Primary Fields Views (see "Creating Primary Field Views" on page 197)
   - Editing fields (see "Editing Field Properties" on page 201)
   - Using Field Typing (see "Customizing Field Typing" on page 208)

2. Creating Custom Screens
   - Creating Custom Screens (see "Creating Custom Screens" on page 200)
   - Adding Fields to Screens (see "Adding Fields to Screens" on page 210)
   - Editing fields (see "Editing Field Properties" on page 201)
   - Using Field Typing (see "Customizing Field Typing" on page 208)
   - Customizing Labels (see "Customizing Field Typing" on page 208)

3. Creating GM+Views (see "Creating GM+View Templates" on page 215)

Using the Record Types Administration Center

The Record Types Administration Center allows you to create and manage Contact Record customizations. Record typing is powerful and dynamic, letting you customize the type of Contact Record GoldMine users see and combine, within one database, what might appear to be disparate types of Contact Records.

To access the Record Types Administration Center, select **Tools > Configure > Record Types**.

Users can perform searches for record types instead of field names which allows them to find information without identifying a field name. Logical pick lists display field names for the record type.
Use the Record Types Administration Center to create Record Types based on combinations of different Primary Field Views, Custom Screens, and GM+Views, and apply them in GoldMine based on your user-defined Record Type Rules. The full record type combination (Primary Field View, Custom Screens, and GM+View) is an entity.

**Examples:**
- A manufacturing company uses GoldMine to track suppliers and customers. They use record typing to create a Supplier record type and a Customer record type.
- Realtors use GoldMine to maintain information about properties, sellers, buyers, and real estate financing sources. They use record typing to create customized record types for each category they work with.

Part of the Record Typing is determining New Record Creation Options to specify fields displayed to a user who is creating a record based on a record type. Available fields are limited to fields included in the selected record type and are only available when the field value-based record type rules are activated.

**NOTE:** The New Record Creation Options, once configured, let you create new records based on record types. Select File > New > New Default Record Type. A customized dialog box appears.

Also create and apply Record Type Rules to govern what record type displays based on a field value-based or dBase expression-based rule, or to disable the rules. Rules can be as simple as when the value in the Acct. Type field is Property display the Property record type; when the value is Buyer, display the Buyer record type; or when the value is Seller, display the Seller Record type.

### Creating Record Types

After creating the appropriate Primary Fields Views, Custom Screens, and GM+Views, create new Record Types. A record type consists of a unique name and is composed of a combination of Primary Fields, Custom Screens, and GM+Views. The combination of these components creates an record type entity.

1. Select Tools > Configure > Record Types. The Record Types Administration Center opens.
2. In the Record Types Details pane, right-click and select New Record Type or click the New Record Type button on the toolbar. The Record Type Settings dialog box opens.
3. Specify:
   - Record Type Name: A unique name for the record type.
   - Relationship Tree Section Name: The name assigned to the relationship tree.
   - Primary Fields drop-down list: The Primary Fields View to associate with this record type.
   - Custom Screens drop-down list: The Custom Screen to associate with this record type.
   - GM+View drop-down list: The GM+View to associate with this record type.
4. To specify a different field layout for the New Default Record Type dialog, check New record dialog uses different field layout and then select a layout from the New Record Layout pull-down menu.
5. Set as Default Record Type uses the current record type as default when record type rules are not met.
   - The default record type could be a generic view or the record type used by the largest number of users. Only one record type can be the default at one time. Selecting this option on a different record type makes it the default. Bold type in the Record Types Details pane identifies the default record type.
6. Click OK to close the Record Type Settings dialog box.
7. Click the Apply Changes button.
Editing Record Types

1. Open the Tools menu and select Configure > Record Types. The Record Types Administration Center appears.

2. Expand the Record Types Details tree and expand Record Types. Select the Record Types to edit. The associated Custom Screen, GM+View, and Primary Fields display in the upper right pane. The lower right pane displays the fields (for Custom Screens and Primary Views) and the HTML template (for the GM+View) when the object is selected in the upper right pane.

3. To edit change the Record Type Name, reconfigure new record selection options, or select new Primary Fields, Custom Screens, or GM+Views, right-click and select Edit. The Record Type Settings dialog box appears. Make necessary changes.

4. Edit Primary Fields and Custom Screen fields by right-clicking on the field when it displays in the lower right pane and select Edit. The Field Properties dialog box appears.

5. Edit GM+View templates by right-clicking on the GM+View in the upper right pane and select Edit. The Edit <template name> GM+View dialog box appears.

6. Click the Apply Changes button to apply the changes to GoldMine records.

Configuring Record Type Rules

Record type rules are key to effective use of record types. They govern which record types display when the conditions of the rules are met.

Select one of three rules to apply to the record types: use text boxes and drop-down lists, use dBASE expressions, or disable rules. If no rules are configured, users can manually select Primary Fields Views, Custom Screens, and GM+Views as they work in GoldMine. Apply only one set of rules at a time when working with record types.

1. Select Tools > Configure > Record Types.

   The Record Types Administration Center opens.

2. In the Record Types Details pane, right-click on Record Type Rules and select Edit. The Rule Definition for Record Type dialog box appears.

3. Select a rule type:
   - Field value-based: Evaluates the field for the specified values and displays the record type you select.
   - dBase Expression result-based: Evaluates an expression that returns a string the name of a record type.
   - Inactive (disable rules): Turns off the record type rules. When the rules are inactive, manually change the primary field view, custom screen, or GM+View.

4. Click the Apply Changes button to apply the changes to your GoldMine records.

   NOTE: If the rules are not met, GoldMine displays your default record type.

   NOTE: Field value-based rules are limited to 32. If you have 33 or more, no rules are evaluated.
Creating Record Type Rules Based on dBASE Expressions

Use Record Type Rules to determine the displaying record type. Define rules by field values and dBASE expressions, or make them inactive.

dBASE expressions are for advanced users. If you activate the dBASE expression rules, you cannot create new records based on record types. Activate field value rules to create new records based on record types.

1. Select **dBase Expression result-based** on the Rule Definition for Record Type dialog box. The dialog box displays an Expression text box.
2. In the text box, type or copy and paste the expression you are creating.
3. As you type or modify the expression, use the **Insert Record type from List** button to select a record type from the list and guarantee data consistency.
4. After creating your expression, click **OK** and then **Apply Changes** on the Record Types Administration toolbar.
5. To verify your record type selection is based on rules, right-click in the primary fields and select **Select Primary Fields**. On the expanded local menu, **Rules-Based selection** should have a check mark next to it; otherwise, select Rules-Based selection.

### Expressions Using Values Corresponding to Record Type Names

When the string value in the field being evaluated corresponds to the name of the record type, use these expressions:

#### Simple Expression

Assuming Key1 can have Supplier, Customer, or Equipment as a value and assuming you have record types named Supplier, Customer, and Equipment, use this expression:

\[ \text{trim(contact1->key1)} \]

Results: Each record where the key1 field value equals Supplier, the Supplier record type displays. Each record where the key1 field value equals Customer, the Customer record type displays. Each record where the key1 field value equals Equipment, the Equipment record type displays.

#### Sum of Two Fields Expression

Assuming Key1 can contain the value Supplier or Customer and Key2 can contain Insured or Uninsured and assuming four record types are named Supplier Insured, Supplier Uninsured, Customer Insured, Customer Uninsured, use this expression:

\[ \text{trim(contact1->key1)} + ' ' + \text{trim(contact1->key2)} \]

Results: The expression returns <Key1string><space><Key2string>. If the value in Key1 is Supplier and the value in Key2 is Uninsured, then the Supplier Uninsured record type display for the record. When moving to another record where the value of Key1 is Customer and the value in Key2 is Insured, then the Customer Insured record type display for the record.

#### If...Then...Else Expressions

An even more effective expression is the dBASE IIF statement. The structure of the iif statement, for example, `iif(trim(contact1->key1)=="Supplier"),"Supplier","Customer")` reads as: If the statement is true (contact1-key1)="Supplier", then display the Supplier record type, else (if statement is not true) display the Customer record type.

#### Simple IIF Expression

Assuming Key1 can have Supplier or Customer as a value and assuming record types are named Supplier and Customer, use this expression:

\[ \text{iif(trim(contact1->key1)=="Supplier"),"Supplier","Customer")} \]

Results: For each record where the Key1 field value equals Supplier, the Supplier record type displays; otherwise the Customer record type displays.
Complex IIF with \texttt{.AND.} Expression

Assuming Key1 can contain the value Supplier or Customer and Key2 can contain Insured or Uninsured and assuming four record types are named Supplier Insured, Supplier Uninsured, Customer Insured, Customer Uninsured, use this expression:

\[
iif((\text{trim(contact1->key1)}=\text{"Supplier"}).\text{and.}(\text{trim(contact1->key2)}=\text{"Insured"}),\text{"Supplier Insured"},\text{"Supplier Uninsured"})
\]

Results: If the value in Key1 is Supplier and the value in Key2 is Insured, then the Supplier Insured record type display for the record. When moving to another record where the value of Key1 is Supplier and the value in Key2 is Pending, the Supplier Uninsured record type displays for the record.

Complex Multiple IIF Expression

Assuming Key1 can have Supplier, Customer, or Equipment as a value and assuming record types are named Supplier, Customer, Equipment, and Standard, use this expression:

\[
iif(\text{contact1->key1}=\text{"Supplier"},\text{"Supplier"},iif(\text{contact1->key1}=\text{"Customer"},\text{"Customer"},iif(\text{contact1->key1}=\text{"Equipment"},\text{"Equipment"},\text{"Standard"})))
\]

Results: If the value in Key1 is Supplier, display the Supplier record type. If the value is not Supplier, evaluate whether Key1 is Customer. If the value is Customer, display the Customer record type; otherwise, evaluate whether Key1 is Equipment. If it is Equipment, display the Equipment record; otherwise, display the Standard record type.

Creating Record Type Rules Based on Field Values

Use Record Type Rules to determine the record type that displays. Define the rules by field values, dBASE expressions, or make them inactive.

Field value-based rules are the easiest to use and are required for creating new records based on record types.

To create field value rule, select Field value-based on the Rule Definition for Record Type dialog box. Field value-based rules evaluate the value in only one field at a time, but can trigger the display of different record types depending on the value in the field.

The dialog box displays field names, values, and record types.

1. Click New to add a new value/record type rule to the list.
2. Select a field in the Field Name drop-down list.

\hspace{1em} \text{**NOTE:** Although you can have several field value-based rules configured on fields, the field displayed in the Field Name text box is the only field evaluated by the rules. To evaluate from a different field, select the field in the drop-down list. Rules configured on the newly selected field go into effect when you apply changes.}

3. In the Field Value text box, type or select a value in the F2 Lookup list.
4. Select a Rec. Type in the drop-down list.
5. To remove a rule, highlight the rule and click Delete.
6. When finished, click OK.
7. Click the Apply Changes button.
8. To verify your record type selection is based on rules, right-click in the primary fields and select Select Primary Fields. On the expanded local menu, Rules-Based selection should have a check mark next to it; otherwise, select Rules-Based selection.
Configuring New Record Creation Options

Specify fields to display for update when creating a new default record type.

1. When creating or editing a new record type, click **New Record Creation Options**. The Record Type: New Record Creation Options dialog box appears.

2. Select **Use a type specific new record dialog** to activate the fields and begin configuration.

3. Beginning with **Field1**, select the field in the drop-down list to display in the New Default Record Type dialog.

4. Select **Duplicate checking** for the field to be a duplicate checking field when adding new records. Select a maximum of 4 fields to use for duplicate checking.

5. Continue adding fields, Field2, Field3, and so on as needed. Configure up to 10 fields.

   **NOTE:** If you have a field(s) as a trigger field for your Record Type Rules, select the field(s) as part of your New Record Creation Options. This helps you create records that work with the record type rules.

Primary Fields Views

1. Open the **Tools** menu and select **Configure > Record Types**. The Record Types Administration Center appears.

2. Expand the **Record Types Details** tree and expand **Primary Fields Views**. Select the Primary Fields View to edit. The fields appear in the upper-right pane.

3. To change the name or the access to the view, right-click the view name and select **Edit**. The Main View Profile dialog box appears. Make necessary changes.

4. To edit field properties (for example, to make a field a required field), right-click on the field in the upper-right pane and select **Edit**. The Fields Properties dialog box appears. Make necessary changes.

5. Click the **Apply Changes** button to apply the changes to GoldMine records.

Editing Custom Screens

1. Open the **Tools** menu and select **Configure > Record Types**. The Record Types Administration Center appears.

2. Expand the **Record Types Details** tree and expand **Custom Screens**. Select the Custom Screen to edit. The fields appear in the upper-right pane.

3. To change the name, the tab, or the access to the view, right-click the view name and select **Edit**. The Custom Screen Profile dialog box appears. Make necessary changes.

4. To edit field properties (for example, to make a field a required field), right-click the field in the upper-right pane and select **Edit**. The Fields Properties dialog box appears. Make necessary changes.

5. Click the **Apply Changes** button to apply the changes to GoldMine records.

Editing GM+Views

1. Open the **Tools** menu and select **Configure > Record Types**. The Record Types Administration Center appears.

2. Expand the **Record Types Details** tree and expand **GM+Views**. Select the GM+Views to edit. The template name appears in the upper-right pane and the view of the template displays in the lower right pane.

3. To change the name and edit the template, right-click on the view name and select **Edit**. The Edit <template name> GM+View dialog box appears. Make necessary changes.

4. Click the **Apply Changes** button to apply the changes to GoldMine records.
Viewing the Master List of Fields

The Master Field List provide you with a quick way to look up the field name in the database corresponding to a field you see in the user interface (UI).

The Master Field List is the last object on the Record Types Details tree on the Record Types Administration Center (Tools > Configure > Record Types). The list contains all field properties (both custom and default) and allows you to view and manage the fields by selecting the field and clicking the Edit Selected button or double-clicking the field.

With the Master Field List you can quickly look up the database name for all fields without having to manually open each one and check its properties. This makes it easier to map fields during import or export when using the Import/Export Wizard.

Primary Field Views

Primary field views are customized views of primary fields. Primary fields are in the upper pane of a Contact Record and are Contact1 fields.

GoldMine now allows you to move fields around the screen as your needs dictate. The customizations can include changing the displayed label or color for a field or hiding a field. Apply many changes to many fields, creating a unique view for a type of record you are creating, and save the combination of customization as a primary fields view.

Create as many primary field views as needed. The only set limit to the number of views in GoldMine is the amount of available computer memory.

Creating a primary field view relies primarily on the field typing. Use field typing to customize the look of the fields and the values displayed in GoldMine's primary and user-defined fields.

Primary field views are a key component of record typing in the Record Types Administration Center. For more information, see "About the Record Types Administration Center" on page 220.
Use Primary Fields Views To:

- Create Primary Fields Views (see "Creating Primary Field Views" on page 197)
- Customize Primary Fields (see "Editing Field Properties" on page 201)
- Edit Primary Fields Views (see "Editing Field Properties (Profile Tab)" on page 202)
- Add to Record Type (see "Record Types and Contact Records" on page 220)
- Delete Primary Fields Views (see "Deleting Primary Field Views" on page 198)
- Manually Change Primary Fields Views (see "Manually Changing Primary Field Views" on page 198)

Customizing Primary Fields

Primary fields appear in the upper pane of the contact record. Many fields are indexed fields. You can modify the field labels and data display with colors or other expressions using the fields properties to create custom field typing.

**NOTE:** Whenever a form of DDE is used, the external application extracts data based on the hard-coded Field Name regardless of the field label.

After you make the modifications to the primary fields, save as primary fields views. The Contact1 table stores primary field data.

1. Right-click on the field and select **Properties**. The Field Properties dialog box appears.
2. Modify field properties using the Field Properties dialog box.

Creating Primary Field Views

Primary field views are customized modifications to the primary fields saved as views. They are in the upper pane of a Contact record.

The GM+View template is chosen automatically. It is driven by the record type, but can be over-ridden under **Web > Setup GM+View > Rules** (see "Creating GM+View Rules" on page 218). Manually changing the Primary Fields View does not change the GM+View.

**NOTE:** When creating your first primary field views, create a named view based on your current view before modifying the fields to create your new view.

**TIP:** If you already have several primary field views, to create a new one, select the view that most closely resembles the view you are creating; create a new named view based on that view before modifying the fields to create your new view.

**To Create a Primary Field View**

1. Before modifying the fields, right-click in the primary fields (top) pane and select **Select Primary Fields**.
2. Select a view from the menu.
   - The primary fields update to the selected view.
3. Right-click in the primary fields panes and select Screen Design.
   - The Screen Design toolbar appears and the contact record displays with a grid-like series of lines.
Select one of the following from the toolbar and then click **OK**:

- **New.** To add a new field to the view, click **New** and then select the field from the **Place Field** drop-down box.

  To add a new field to the list, click **New Field** and do the following:
  - At the **New Field** field type a unique name for the new field.
  - At the **Description** field type a brief description of the new field.
  - At the **Field Type** field select the type of the new field and then add the number of characters in the **Len** (length) and/or **Date** fields.

- **Save As.** Save the screen as a new Primary Fields View.
- **Load.** Load the new Primary Fields View.
- **Rebuild.** Rebuild the database and add the fields to the Contact2 table. Review details on rebuilding before proceeding at "About Maintaining Databases" on page 87.
- **Exit.** Exit the Screen Designer.

4. Click the **Save as a Primary Field** button.

   The Main View Profile dialog box appears. Use this dialog box to name and set access on Primary Fields Views. Complete the following fields and then click **OK**:

   - **Name.** Type a descriptive name in the field.
   - **User Access.** Select the user or user group to have access to this new group in the User Access. Select (public) for all users to have access this view.

   The new view appears in screen design mode and ready for modification.

5. To modify the fields in the view, see Customizing Primary Fields.

### Manually Changing Primary Field Views

Primary Fields Views are typically determined by the record types and record type rules configured in the Record Types Administration Center. However, with permissions, manually change the displayed primary field view.

**To Manually Change the Primary Field Views**

Right-click in the primary fields of a record and select **Select Primary Fields.** The sub-menu includes Rule-Based selection and a list of primary fields views. Then, on the menu, select the view to apply to the displayed record. The record updates to selected primary fields view.

### Deleting Primary Field Views

Deleting Primary Fields Views does not remove field data from the database.

1. Open the **Tools** menu and select **Configure > Record Types.** The Record Types Administration Center appears.
2. Expand the **Record Types Details** tree and expand **Primary Fields Views.**
3. Select the view to delete, right-click and select **Delete.** The view is removed from GoldMine.

### Custom Fields and Screens

Apply several levels of customization to Contact records. When creating custom screens and fields, you have greater flexibility in the information stored in GoldMine.

Customize GoldMine by:

- Creating custom screens (see "Creating Custom Screens" on page 200)
- Creating custom fields (see "Creating Custom Fields" on page 200)
- Changing field labels (see "Editing Field Properties (Profile Tab)" on page 202)
- Customized field typing (see "Customizing Field Typing" on page 208)
Custom Screens

Custom screens let you group related custom fields together. Create up to 20 custom screens, each with up to 250 fields. Custom screen information is stored in the Fields5 table.

Custom Fields

Custom fields, also called user-defined fields, make GoldMine an adaptable program, able to meet the needs of a broad range of businesses. Information about user-defined fields are stored in the Contact2, ContuDef, and Fields5 table. For more information about Fields and Details, see "User-Defined Fields vs. Details" on page 199.

GoldMine on an SQL database can store 1024 fields. For additional information, consult the knowledge base at support frontrange.com.

The system administrator determines each field's type. Fields can store the following:

- **Character field type**: Alphanumeric data. A character field can also contain a dBASE expression that calculates field values or displays text.
- **Numeric field type**: Numeric data; required for the field to calculate values related to other numeric fields.
- **Date field type**: Contains dates.

When creating user-defined fields, plan your implementation: what is the field type, what data is going into the field, will it be a calculating field, and will it be associated with other fields in a custom screen?

To create a field, select Tools > Configure > Custom Fields. The list of 10 user-defined fields and other user-defined fields appear. The mechanism is the same for creating one field as for creating many fields; it makes the repeated creation of fields easier by not returning to the screen designer after the one field is created.

Field Labels

Field properties determine the field’s label in GoldMine. When changing labels on fields (whether primary fields or user-defined fields) you have a limit of 15 characters for the label. To change the label, right-click its name and select Properties. The Field Properties dialog box appears.

Field Typing

Use field typing to customize the look of field labels and values. The customization can include changing the label or data color in a field based on the value in that field or in another field, hide labels and values, assign a generic field use name to a field that can have different labels and values.

User-Defined Fields vs. Details

The GoldMine administrator must decide what type of field (user-defined or detail) is most appropriate for the information being recorded.

When setting up a field as a Detail or user-defined field, consider:

- Details allow unlimited multiple entries without the need for the repetitive creation of fields and Lookup Tables.
- Unlike creating a new user-defined field, adding a new Detail does not allocate field space to every record in the database; therefore, less time is required to perform system maintenance.
- All Details are indexed for fast searching and browsing.
- User-defined fields can be updated using the Lookup.ini.
- User-defined fields can be date, numeric, or character and allow for complex filtering.
- Filters can be built on user-defined fields only.
- Groups can be built on Detail.
Creating Custom Screens

Custom screens are user-defined areas that appear under the **Fields** tab or as an individual tab. Use these screens to logically group user-defined fields.

You can create up to 20 screens, each one with a maximum of 250 fields.

Custom screens are a key component of the record typing in the Record Type Administration Center.

1. Select **Tools > Configure > Custom Screens**.
2. At the **Custom Screens Setup** dialog box, click **New**.
   The **Custom Screen Profile** dialog box opens. See "Custom Screen Profile Dialog Box" on page 200.
3. After configuring the **Custom Screen Profile** dialog box, click **OK**.
   The **Custom Screens Setup** dialog box reopens.
4. Click **Close**.
   You can now add fields to your new custom screen.

Custom Screen Profile Dialog Box

1. In the **Screen Name** field, type the name (up to 20 characters) you want to appear in the **Fields** tab local menu and on the configuration dialog boxes.
2. In the **Tab Name** field, type the name for the tab.
   Leave this box blank for the screen to not display as an individual tab.
   View Tab Name tips.
   - Due to viewing limitations, a tab name should not exceed eight characters, and it should not contain spaces.
   - GoldMine alphabetizes tabs. To reorder tabs, place a number at the beginning of the tab name. The number does not appear on the tab, but determines the position of the title within the bank. For example, for the Reseller View tab to appear before the Mgt View tab, type 1Reseller in the Tab Name field.
   - To create a blank tab with no name on it, type two asterisks (**) in this field. The tab label remains blank.
3. Leave the **User Access as (public)** to let users view the screen, or select a user or user group from the drop-down list.
4. Select **This screen is available** in the current **Contact Set** to let users see the screen listed in the Fields tab local menu.
   When this option is cleared, the screen is unavailable in the current contact set. If you have three contact sets, disable the screen in only two of the databases, log on to each contact set and disable the option.
5. When finished, click **OK**.

Creating Custom Fields

GoldMine’s flexibility meets a range of business information needs. The ability to create user-defined custom fields goes beyond the variety of options in GoldMine and better tailors the contact record to meet your company’s needs.

Plan custom field implementation by considering the following:

- What is the field-type: numeric, alpha, or both?
- What type of data will the field contain?
- Will the field calculate?

**NOTE:** When adding user-defined fields, create a custom screen (see "Custom Screen Profile Dialog Box" on page 200) to display the related fields. Always back up your databases before creating user-defined fields.

**TIP:** Create telephone number fields that format numbers like other phone fields. Create a field named **UPHONE{n}**, where **n** is a user-defined number.
To Create a Custom Field

1. Select **Tools > Configure > Custom Fields.**
2. At the **User Defined Fields** dialog box, select **New.**
   The **User Defined Field Profile** dialog box opens.
3. Type a unique name, beginning with *U*, in the **Field Name** field (it can be up to nine alphanumeric characters in length, including the U).
   The field name should not contain spaces or special characters, such as asterisks (*), an underscore (_) immediately following the U, or percent signs (%).

   **NOTE:** The Field Name appears when inserting fields into Microsoft Word; therefore, make the field name user-friendly and identifiable.

   **WARNING:** User-defined field names must not use an underscore (_ ) immediately following the U (example: **U_fieldname**). Fields named in this way will not synchronize and will result in data loss.

4. In the **Description** field, type the field label to appear in the contact record.
5. At the **Field Type** options select one of the following:
   - **Character.** Formats data as a text string.
   - **Numeric.** Formats data as numbers to run mathematical functions against.
   - **Date.** Formats data as a date, month/day/year.
6. In the **Len** field, type or select a field data length.
   The maximum length for a character field is 256; numeric is 16.
7. The **Dec** field is available when creating a numeric field.
   It sets the number of decimal places within the field. GoldMine assigns one character place to the decimal point in determining field length. For example, create a field that can accept hold values up to 9.99 by assigning a **Len** value of 4 and a **Dec** value of 2. This field applies to numeric data types.
8. Click **OK.**

   The **User Defined Fields** dialog box reopens with your new field added to the list. Next, add the field to your custom screen (see "Adding Fields to Screens" on page 210).

   After fields are created, GoldMine rebuilds the database for the fields to be physically placed in the Contact2 table. Review help topics regarding maintaining your SQL database. See the support site for information on rebuilding.

---

### Editing Field Properties

Field Properties determine the field type, label and data appearance, field location, label and data field size, and field security.

Use the following procedure to edit the field properties.

1. Right-click on the field label and select **Properties.**
   The Field Properties dialog box appears.
2. Configure the settings on these tabs and then click **OK:**
   - **Profile.** Field labels and field data options. For more information on editing these properties, see "Editing Field Properties (Profile Tab)" on page 202.
   - **Color.** Colors on the Contact record for the field label and field data. For more information on editing these properties, see "Editing Field Properties (Color Tab)" on page 204.
   - **Layout.** Field size, position, and tab order. For more information on editing these properties, see "Editing Field Properties (Layout Tab)" on page 205.
- **Security.** Fields requiring data, users having read and update rights to the field, and options to update the log on the History tab. For more information on editing these properties, see "Editing Field Properties (Security Tab)" on page 205.

3. Click OK after configuring the Field Properties.

### Editing Field Properties (Profile Tab)

1. Select the **Profile** tab. In the **Field Label area**, select **Global Label** and type the field label in the associated field. The Global Label applies to all GoldMine databases.

   - **Global Labels:**
     - Display in all databases unless there is a Local Label.
     - Have a length limit of 15 characters, but are limited by the field label size.
     - Are stored in the Contudef and Fields5 table in the database.

2. Type the field label in the **Local Label** field if the local label differs from the Global Label. The Local Label applies only to the current database.

   - **Local Labels:**
     - Display in the current database.
     - Have a length limit of 15 characters, but are limited by the field label size.
     - Are stored in the Contudef table in the database.
     - Take precedence over the Global Label.
     - Are always applied when the field is displayed within the corresponding contact set database, regardless of Record Type or Primary Fields View being used.

3. Select **Expression** if editing an expression field.

   See "Adding Expression Fields to Screens" on page 207 for details about the Expression option and the Label Reference.

   - **NOTE:** Use expressions to create complex field typing (see "Customizing Field Typing" on page 208) related to displaying and hiding the field label and data.

   Remember these general rules for Label Types in the following table.

<table>
<thead>
<tr>
<th>Label (Type)</th>
<th>Priority (Versus Other Label Types)</th>
<th>Stored with Contact Set (Different for each Contact Set)</th>
<th>Stored with Field View (Different for other Record Types or view types)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Global</td>
<td>3 - Base level</td>
<td>No</td>
<td>Yes</td>
</tr>
<tr>
<td>Expression</td>
<td>2 - Overrides Global Label Types</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Local</td>
<td>1 - Overrides both Global and Expression Label Types</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

4. In the **Field Data area**, select **Name in Database**.

   The field name displays in the field. The **All Fields** button is active for user-defined fields, not primary contact fields.

5. Select **All Fields** to change the data field.

   The **User Defined Fields** dialog box opens.

   Select the new field data to display in the field. After selecting a new field, the Global Label remains the same; however, the Local Label changes to reflect new data.

6. Select **Expression** if editing the data expression.

   See "Adding Expression Fields to Screens" on page 207 for details about the Expression option.
7. Configure the **Color** tab, **Layout** tab, and **Security** tab.
Editing Field Properties (Color Tab)

1. Right-click the field label and select Properties.
2. At the Field Properties dialog box, select the Color tab.
3. In the Label Color area, select Fixed Color and click Colors.
   The Color dialog box opens.
4. Select the color from the palette to use as the label color.
   - Select Define Custom Colors to create custom colors.
   - Click Use default label color to reset the color to black.
5. Select Expression if you know the system number for the color.
6. Type the number in the field.
   NOTE: Use expressions to create more complex field typing, related to changing the color of field labels and field data.
   Examples:
   - Use expressions to create a variable color based on a more complex expression. For example, to display a red label on Key1 if the field is empty and a black label if it not empty, use this expression: if((len(trim(contact1->Key1))==0),255,0). In the example 255 is the Windows color profile for red and 0 is the profile for black.
   - Use field label expressions with predefined color (see "Predefined dBASE Colors" on page 205). For example, to flag companies with a credit limit of $1000 or higher with a red field label and a green label for less than $1000, use this expression: color(if(contact2->u_credit>1000, "RED","GREEN")) where u_credit is the user-defined numeric field storing the credit limit value.
   - If a user-defined field is empty, change the color on the Company field label to red; otherwise, it displays black. The expression to add to the Company field is:
     if(contact2->u_userdefinedfield=" ",color("RED"),color("BLACK"))
   - In the last two examples, the expressions are configured differently — Either is valid.
   - Use expressions to create more complex field typing, related to displaying and hiding the field label and field data.
7. In the Data Color area, select Fixed Color and click Colors.
   The Color dialog box opens.
8. Select the color from the palette to use as the data color.
   - Select Define Custom Colors to create custom colors.
   - Click Use default data color to reset the color to dark blue.
9. Select Expression if you know the system number for the color.
   Type the number in the field.
10. Configure the Profile tab, the Layout tab, and the Security tab.
Predefined dBASE Colors
The GoldMine color() function includes these predefined colors:

- Black
- Gray
- White
- DarkGray
- Invisible
- Yellow
- Red
- BrightYellow
- BrightRed
- Purple
- Blue
- BrightPurple
- BrightBlue
- Orange
- Green
- BrightCyan
- BrightYellow
- BrightGreen
- Default

Sample Expressions

color(iif(contact2->u_numericfield>1000, "RED","GREEN"))
iif(contact2->u_userdefinedfield=" ",color("RED"),color("BLACK"))

Editing Field Properties (Layout Tab)

1. Right-click the field label and select Properties.
2. At the Field Properties dialog box, select the Layout tab to configure field size and position and to select field tab order.
3. In the Field Size & Position area, configure these by typing in numbers or increasing or decreasing the values with the up and down arrows for each field:
   - Field Label Size. Sets the size of the field label (up to 15 characters).
   - Data Size. Sets the size of the data field to display. To increase the actual size of a field, select File > Configure > Custom Fields (see "Creating Custom Fields" on page 200).
   - (: Row (y): and Column (x). Sets the placement of the field based on a grid of rows and columns. Refine field placement after dragging and dropping.
4. In the Field Order area, Position field, type or select the numbered tab order for the field.
   - NOTE: Increase data entry efficiency by setting the field tabs in the order the data should be entered.
5. Click Screen Fields to view field order on the active Field Screen.
6. Configure the Profile tab, the Color tab, and the Security tab.

Editing Field Properties (Security Tab)

1. Right-click the field label and select Properties.
2. In the Field Properties dialog box, select the Security tab to configure the Field Data Entry Requirement, configure Field Access, and turn on Field Auditing.
3. In the Field Data Entry Requirement area, select Required Data Entry to force users to fill in the field.
   - A required field displays on the contact record with a red box around it.
   - If the Required Data Entry flag is set, but the record was not modified in any way, no alert is displayed when the user navigates to a different contact record.
   - If the record was modified and there is a required field that was left empty, the Required Field(s)s Alert dialog box appears reminding the user to complete the field before navigating to a different record.

The Required Fields Alert dialog box appears when saving or leaving a Contact Record with one or more fields requiring data.
When the Required Fields Alert dialog box appears, select either:

→ **OK** to close the dialog box, allowing you to add data to the fields.

→ **Skip Required Entry** to expand the dialog box allowing you specify the reason and authorize the override.

  - In the **Reason** text box, type the reason for not updating the field or select the reason from the F2 Lookup list.
  - In the **Authorizing user** drop-down list, select the user with permission to override the entry.
  - Type the user’s **Password** and then click **Authorized**. Save the Contact Record without the required data; an Override activity is added to the **History** tab of the record.

After the record modifications are complete and the user navigates to another record, the record is saved.

- If a required field is overridden, an Override activity is added to the associated **History** tab with a Result code of OVR. The record is not removed when the field is updated and can only be deleted by a user with **Master rights**.

4. In the **Field Access** area, leave the **Read Rights as (public)** to allow users to view field data.
   - To limit user access to fields, select a user or user group from the drop-down list.
   - If **Required Data Entry** is selected, the field must have (public) read and update rights.

   **NOTE:** This setting does not override record ownership and record curtaining. If record ownership is assigned and record curtaining is activated, only the owning user or user group sees the field.

5. To set **Update** rights, select the user or user group from the drop-down list.
   - Only the selected user or user group can update field data. To let users update the field, leave as (public).

   **NOTE:** This setting does not override record ownership. If record ownership as been assigned, only the owning user or user group can update the field.

6. In the **Field Audit** area, select Log changes in history to record changes made to the field data.

   **NOTE:** The record is kept on the **History** tab with an Activity code of Other and a Result code of LOG.

7. Configure the **Profile** tab, the **Color** tab, and the **Layout** tab.
Adding Expression Fields to Screens

Use expressions to create titles or text messages on screen or to create calculated fields (fields that contain a mathematical expression rather than data). Calculated fields have no value; they only display a value, so reporting or filtering cannot take place on the field. If filtering or reporting is required, create a field and use the Lookup.ini to calculate its value. The Lookup.ini returns a value.

Use the following procedure to add an expression field to a screen.

1. Select the Fields tab and right-click in the area under the tab. Select the screen to which you are adding the field.
   
   The selected custom screen becomes active under the Fields tab.

2. Right-click and select Screen Design.
   
   The GoldMine Screen Designer Toolbar toolbar appears with a grid-like background in the Contact record (see "Adding Fields to Screens" on page 210).

3. Click New on the design toolbar.
   
   The Place Field dialog box opens.

4. At the Field drop-down list; select -- dBASE Expression --.

5. Click OK.
   
   The field box appears in the upper left corner of the Fields tab. Drag and drop the field in the desired location on the Field Screen.

6. Double-click the field.
   
   The Field Properties dialog box opens.

7. In the Field Label area on the Type tab, select either:
   
   ☐ Global Label. Designate the Global Label that applies to all databases. With Expression fields, the Local Label is not an option.

   ☐ Expression. Type text in quotes or type a field expression.

   Examples:
   
   → To create a text expression label, type Total: in the Field Label area Expression box. GoldMine displays Total: as the field label.

   → To create a field expression label, type Contact1->Company in the Expression box. GoldMine displays the first 15 characters of the company name as the field label.

8. If you use Expression as a field label, type the Label Reference label for the expression field.

9. In the Field Data area, select Expression and type the expression that displays the field value.

   Example:

   For two numeric fields, called USUM1 and USUM2, create a calculation expression to add them together. For example, Contact2->USUM1+Contact2->USUM2. Remember, you cannot report on the total value. If you create a complex expression, test it using the dBASE Expression Tester.
Customizing Field Typing

Use field typing to customize the look of field labels and values, including changing the label or data color in a field based on the value in that field or another field, hide labels and values, assign a generic field use name to a field that can have different labels and values. Create custom views for different users or user groups, or let users switch between customized views. Field typing is the first level of customization you can add to primary field views and record types.

Use the following procedure to customize a field type

1. Right-click on the field label and select Properties.
2. At the Field Properties dialog box, select the Profile or Color tab as needed.
   - The Profile tab holds the settings for the field label and data.
   - The Color tab holds settings for the label color and field data color.

Examples:

- **Field Type**
  
  Change the text of the label depending on the value in that field or in another field. The following example displays the field label as all capital letters if the field is blank and as initial capital if it contains a value. This expression is added to the Field Label Expression box on the Profile tab for the Key1 field.

  \[
  \text{iff}(\text{len}((\text{trim(contact1->key1)}=0), \text{"ACCT TYPE:"}, \text{"Acct Type:"})
  \]

  Change the label depending on the value in another field. In the following example the country field is evaluated to determine what is displayed as the Zip field label. This expression is added to the Field Label Expression field on the Profile tab for the Zip field.

  \[
  \text{iff((upper(contact1->country)="U.S.A.").or.((len((\text{trim(contact1->country))=0), \text{"Zip:"}, \text{"Post Code:"})
  \]

- **Field Color**

  GoldMine provides several predefined color choices or you can specify the Windows profile color number. Add the expressions to the Label Color Expression field to affect the label or to the Data Color Expression field to affect the data color.

  \[
  \text{Using Predefined Colors}
  \text{iff(contact1->key1=" ", color("red"), color("black")}
  \]

  \[
  \text{Using Windows Color Profile Codes}
  \text{iff((len((\text{trim(contact1->key1)}=0), 255, 0)}
  \]

3. After customizing field typing (saved to your current view), save the customizations as a new Primary Fields View.

Inserting Labels in Reports

1. Right-click the report template and select Insert > Label.
   
   An edit box opens. Drag the edit box to the desired location and click to place.

2. The box shows the word Label, Double-click the label box and the Text Field Parameters dialog box opens.
   
   **NOTE:** Labels appear on the report regardless of whether the field contains data.

3. the Text field, type the words to appear in the label.

4. In the Text Position area, select the Horizontal and Vertical placement of the text within the label box.

5. Click Outline to create an outline of the text field and set the Line Properties.

6. Click Background to create a background color and type within the label box.

7. Click Font to select the text font.

8. Click OK to save and close the text parameters.
Hiding Field Labels and Values

Hide the label and the value based on the value in the field or in another field using the **Label Color Expression** and the **Data Color Expression** fields.

In the following example, the label and data for the **Source** field are hidden if the Key1 field value is Employee.

**Example**

To hide both the label and the data, add the expression to the **Label Color Expression** field and the **Data Color Expression** field in the Field Properties of the **Source** field.

```
iif((Contact1->key1)="Employee",-2,-1)
```

**NOTE:** In this example the expression looks for an exact match with Employee. If the Key1 field data is entered as employee, the expression fails and the Source field and data remain visible. Force valid data with F2 Lookup lists to keep data entry consistent.

Combining Hiding and Color

To effectively use color and hiding, add expressions in several Field Property areas. Add this data to the Field Properties of the **Source** field:

Use the following procedure to combine hiding and color.

1. **Right-click on the Source field and select Properties.**
   The **Field Properties** dialog box opens.
2. **On the Profile tab, select Expression in the Field Label area.**
3. **Copy this into the Expression field:**
   ```
iif((len(trim(contact1->source))=0).and.trim(contact1->key1)<>"Employee"),"SOURCE:","Source:")
```
4. **Select the Color tab.**
5. **Select Expression in the Label Color area.**
6. **Copy this into the Expression text field:**
   ```
iif((len(trim(contact1->source))=0).and.trim(contact1->key1)<>"Employee",255,iif(contact1->key1="Employee",-2,-1))
```
7. **Select Expression in the Data Color area and copy the following:**
   ```
iif((len(trim(contact1->source))=0).and.trim(contact1->key1)<>"Employee",255,iif(contact1->key1="Employee",-2,-1))
```
8. **Click OK to save the changes.**
   **Results:** If the Key1 field contains the value Employee, the Source field label and value are hidden. If the Key1 field does not contain Employee, and the Source field is empty, the Source field label displays SOURCE:; if there is a value, the field label displays Source: in the default color.
Adding Fields to Screens

After you have created the fields and screens, place these types of fields on the screens:

- **Fields.** Hold data.
- **Expression fields.** Display titles, messages, or mathematical calculations based on other fields.

Use the Screen Designer to place the fields on screens. Only users with Master Rights can access the Screen Designer. The Screen Designer lets you click and drag fields in the display. Only unindexed fields can be dragged from the upper panes to the Fields tab area.

**NOTE:** If asked to rebuild the database, review Help topics regarding rebuilding and maintaining SQL.

Use the following procedure to add fields to a screen.

1. At the Screen Designer, select the **Fields** tab and right-click in the area under the tab.
2. Select the screen to which you are adding the field.
   - The selected custom screen becomes active under the Fields tab.
3. Right-click and select **Screen Design.**
   - The GoldMine **Screen Designer Toolbar** appears with a grid-like background in the contact record.
   **NOTE:** Changing the field order position of Company, Contact, Phone1, or any of the Key 1–5 fields can cause problems—especially with synchronization and querying the database.
   - The Screen Design Toolbar appears when designing primary fields or **Fields** tab screens.
   - Right-click in the field area of the **Fields** tab and select **Screen Design.** The Screen Design Toolbar appears and the Contact Record displays a grid-like series of lines.

   - **New:** Create a field.
   - **Save As:** Save the screen as a new Primary Fields View.
   - **Load:** Load the selected Primary Fields View.
   - **Rebuild:** Rebuild the database and add the fields to the Contact2 table. Review details on rebuilding before proceeding.
   - **Exit:** Exit the screen designer.
4. Click **New** on the design toolbar. The **Place Field dialog box** opens.
5. From the **Field** drop-down list, select the field to place on the screen.
   **TIP:** Click **New Field** to create a new field without accessing **Tools > Configure > Custom Fields.**
6. Click **OK.** The field appears in the upper left corner of the Fields tab. Drag and drop the field in the desired location on the Field Screen.
   **NOTE:** When working with Row and Column entries, do not delete indexed fields from the primary Contact Record display or move indexed fields to custom user screens. Moving or deleting indexed fields can reduce GoldMine’s ability to find records based on these fields when using search commands from the Lookup menu.
7. Click the field. The **Field Properties dialog box** opens.
8. Make changes to the Profile, Color, Layout, and Security tabs and click **OK.**
   - The field is placed on the screen with an **n/a** in the data area.
9. Log out and back into GoldMine to see the field.
10. Select **File > Exit** and then relaunch GoldMine.
About the GM+View Tab

Create a customizable information page using HTML capabilities. Display images, linked documents, or inserted GoldMine fields. Create several templates, set default templates, and then create rules controlling what template displays for contacts meeting the rules.

The tab uses Internet Explorer 6, 7, or 8; the local menu and HTML design options are IE-based. Settings in the IE menu (View > Text Size) control font size.

Information in the tab stores in the Mailbox table and synchronizes to remote users. Users with Master Rights can create or edit a template by selecting Web > Setup GM+Browser. The GM+Browser Tab Settings dialog box opens.

Views on this tab are a key component of the record-typing used in the Record Type Administration Center. If record type rules are activated, right-click in the tab area and select another view; or, to reactivate the rules, right-click in the tab area and select Rules-Based Selection.
About the GM+Browser

This floating window allows you to have important GM+View and other Web pages at your fingertips from within GoldMine, regardless of what contact is displayed.

From the menu bar, select **Web > GM+Browser**. GM+Browser appears. Your Microsoft Internet Explorer home page is displayed in the Browser.

Configuring GM+Browser

1. In the **GM+Browser** tab bar, click the **GM+Browser Setup** button.
   
The setup page appears.

2. From the **Available** list, highlight an available GM+View (such as, Property, from the demo data).
   
   **NOTE:** This list is autofilled based on all available GM+View templates.

3. Click the [>>] move button.
   
The Property view moves to the **Selected** list.

4. To make all views available, click **Add All**.
   
   All Available views move to the Selected list.
5. To create a placeholder for other Web pages in GM+Browser, in the **Add _ Browser Tabs** field, type 2.

6. Click **Save**. A tab for the **Property** and **Car** views and an extra **Browser** tab now appear in the **GM+Browser** tab bar.

7. Click the unassigned **Browser** tab. It loads the default Web page until changed.

8. In the address bar, type the appropriate Web address of a different Web page to assign to this tab and click **Go** (alternatively, you can navigate to the appropriate page through the default page). The tab title changes to the assigned page.
NOTE: When the tab bar exceeds the size of the GM+Browser window, forward and back buttons appear on the right side of the bar. Use these buttons to navigate to additional tabs. Or, resize the window.

- As you work in GoldMine, minimize GM+Browser or leave it open.
- If you click a Contact record, GM+Browser moves behind the record.
- When you close this instance of GM+Browser, it retains all settings except the additional Browser tab addresses.
- The Browser tabs always display ahead of the GM+View tabs in the tab bar.

Working with GM+View Templates

Create a customizable information page using HTML capabilities. Display images, linked documents, or inserted GoldMine fields. Create several templates, set default templates, and then create rules controlling what template displays for contacts meeting the rules.

The tab uses Internet Explorer 6, 7, 8, or 9; the local menu and HTML design options are IE-based. Settings in the IE menu (View > Text Size) control font size.

Information in the tab stores in the Mailbox table and synchronizes to remote users. Users with Master Rights can create or edit a template by selecting Web > Setup GM+View. The GM+View Tab Settings dialog box appears.

Views on this tab are a key component of the record-typing used in the Record Type Administration Center. If record type rules are activated, right-click in the tab area and select another view; or, to reactivate the rules, right-click in the tab area and select Rules-Based Selection.

NOTE: The Microsoft Internet Explorer embedded in the GM+View does not support the Framesets tags. To use iframes, enable the Internet Explorer security settings for IFrame.
Creating GM+View Templates

Use the following procedure to create a GM+View template.

1. Select **Web > Setup GM+View**.
   The **GM+View Tab Settings** dialog box opens.

2. In the **Template List** area, click **New**.
   The **Edit GM+View** dialog box opens.

   **NOTE:** Select **Edit** to change an existing template, or **Rules** to set the display rules.

3. Type a name in the **Template Name** field.

4. Click in the design box to activate the template design toolbar.

5. Design using these toolbar options (or right-click and Select):
   - **Font.** Formats fonts.
   - **Paragraph.** Sets alignment and check spelling.
   - **Style.** Selects from Normal, Formatted, Address, Heading.
   - **Picture.** Inserts images stored in shared directories. See "To Insert Pictures in GM+View Templates" on page 216.
   - **Insert HyperLink.** Inserts a hyperlink to a Web site.
   - **Insert Fields.** Inserts GoldMine fields (user name and contact information), linked images, or linked documents.
   - **Insert Background Image.** Browses to the location of the image file.
   - **Remove Background Image.** Deletes the background.
   - **Spell check.** Checks spelling.
   - **Save as file.** Saves to a location.
   - **Print.** Prints.
   - **Edit HTML Source.** Edits the template directly in the HTML code.

**Examples:**

**Hyperlink in Template**

To insert a fixed hyperlink, type the following in the HTML code:

```
<A href="http://www.frontrange.com">FRS</A>
```

This inserts a hyperlink to the FrontRange Solutions Web site with FRS as the label.

**Display Full Web Page**

This code example configures a GM+View template to display the FrontRange Solutions Web site as a GM+View template:

```
<!DOCTYPE HTML PUBLIC "-/W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<STYLE type=text/css> P, UL, OL, DL, DIR, MENU, PRE { margin: 0 auto;}</STYLE>
<META content="MSHTML 6.00.2800.1264" name=GENERATOR></HEAD>
<BODY leftMargin=1 topMargin=1 rightMargin=1><FONT face="MS Sans Serif" color=#ff0000 size=4>
<DIV>Please wait while the FrontRange Solutions Web Site loads.......</DIV>
<SCRIPT>
window.location.href = "http://www.frontrange.com/
</SCRIPT>
</FONT></BODY></HTML>
```

6. Right-click in the design box and select **Save**.
Editing GM+View Templates

After creating templates, edit them as needed. There are several ways to access the Edit <template name> GM+View dialog box. The dialog box is used when you are creating a new template and when you are editing an existing template.

1. Open the Edit <template name> GM+View dialog box.
   - Select Web > Setup GM+View. The GM+View Tab Settings dialog box appears. Click Edit. The Edit <template name> GM+View dialog box appears.
   - Select Tools > Configure > Record Types. The Record Types Administration Center appears. Expand GM+Views. Right-click the GM+View name and select Edit. The Edit <template name> GM+View dialog box appears.

2. In the Template Name text box, change the template name.

3. Click in the design box to activate the template design toolbar.

4. To edit the template, use the toolbar options:
   - Font: Formats fonts.
   - Paragraph: Set alignment and check spelling.
   - Style: Select from Normal, Formatted, Address, Heading.
   - Insert:
     → Picture: Inserts images stored in shared directories (see "To Insert Pictures in GM+View Templates" on page 216).
     → Link: Inserts a hyperlink to a Web site (see "To Insert Links in GM+View Templates" on page 217).
     → Fields: Inserts GoldMine fields (see "To Insert Fields in GM+View Templates" on page 217), linked images (see "To Insert Linked Images in GM+View Templates" on page 217), and linked documents (see "To Insert Linked Documents in GM+View Templates" on page 217).
     → Insert Background Image: Browses to the location of the image file.
     → Remove Background Image: Deletes the background.
   - Spell check: Checks spelling.
   - Save as file: Saves to a specific location.
   - Print: Prints.
   - Edit HTML Source: Edits the template directly in the HTML code.

   Example:
   To insert a fixed hyperlink by typing the following in the HTML code:
   
   ```html
   <A href="http://www.frontrange.com">FRS</A>
   ```
   This inserts a hyperlink to the FrontRange Solutions, Inc. Web site with FRS as the label.

5. Right-click in the design box and select Save.

To Insert Pictures in GM+View Templates

1. Place cursor in the design box where you want to insert the picture.
2. Right-click and select Insert > Insert Picture.
3. At the Picture dialog box, click Browse to select the Picture Source from a shared directory.
4. Type Alternative Text to describe the picture.
5. In the Layout area, select the Alignment from the drop-down list and type the number of pixels to use for the Border Thickness.
6. In the Spacing area, type the number of pixels to use as the Horizontal and Vertical spacing around the picture.
7. Click OK.
To Insert Links in GM+View Templates

1. Place cursor in the design box where you want to insert the link.
2. Right-click and select Insert > Insert Link.
3. At the Hyperlink dialog box, select hyperlink type from the Type drop-down list.
4. Type the appropriate Internet address in the URL field and then click OK.

To Insert Fields in GM+View Templates

1. Place cursor in the design box where you want to insert the field.
2. Right-click and select Insert > Insert Field.
3. At the Field local menu, select the field to insert.
   - The field macro is inserted in the template (use <<&company>> to insert the appropriate company name). The Contact Details expands to include more fields, including Linked Image and Linked Document File name.
4. Right-click and select Save.

To Insert Linked Images in GM+View Templates

1. At the GM+View design template dialog box, right-click and select Insert Field > Contact details > Linked Image.
   - The Linked Image Field Properties dialog box opens.
2. Type the Linked Image (Links tab Document Name).
   - The name must be the one that appears in the Links tab Document field.
3. Type a description for the linked image in the HTML Alt (Alternative Text) Attribute field.
4. Select the Linked Image’s Alignment from the drop-down list.
5. In the More HTML Attributes field, type the HTML code for the other formatting options.
6. Click OK.

To Insert Linked Documents in GM+View Templates

1. At the GM+View design template dialog box, right-click and select Insert field > Contact details > Linked Document File name.
   - The statement <<LinkedImageFileName:?>> is inserted.
2. Replace the question mark (?) with the document name in the Document column of the Links tab (<<LinkedImageFileName:MyDocument>>).
3. Save and Exit.
   - The path to the linked document displays on the GM+View tab.

Setting GM+View Default Templates

Set a default GM+View template to display for Records not meeting template rules.

1. Select Web > Setup GM+View. The GM+View Tab Settings dialog box appears.
2. In the Set Default GM+View area, select the default template.
3. Click OK.
   - NOTE: To see the new template, users on other workstations must log out and back in.
Creating GM+View Rules

Apply templates to particular contact records by creating rules. GoldMine evaluates a rule and if a Record meets the
criteria, the specified template is displayed. Create templates prior to creating rules.

Use the following procedure to create a GM+ View rule.

1. Select File > Configure > GM+View tab.

The **GM+View Tab Settings** dialog box opens.

2. In Template List, click Rules.

The **GM+View Tab Rules for Template Selection** dialog box opens.

The template rule selected becomes the primary set of rules that are applied to the GM+View templates:

- **Field Value.** See "Creating GM+View Rules for Field Values" on page 218.
- **dBase Expression.** See "Creating GM+View Rules for dBASE Expressions" on page 218.
- **User Selected.** See "Creating GM+View Rules for the User Selected Option" on page 219.

Creating GM+View Rules for Field Values

1. Select File > Configure > GM+View tab.

2. At the **GM+View Tab Settings** dialog box, click Rules.

3. At the **GM+View Tab Rules for Template Selection** dialog box, select Field Value.

4. Select a Field Name.

   This is the field for which you will select the Field Value.

5. Click New.

   The **Field Value and Corresponding Template** dialog box opens.

6. In the Field Value field, type the value to be the trigger for the rule.

   If the values in the field are determined by F2 Lookup list, the right arrow on the Field Value text box will display the F2
   Lookup value for the field.

7. Select a Template.

   This is the template that displays when the Field Value is triggered.

8. Click OK.

   The **GM+View Tab Rules for Template Selection** dialog box reopens.

Creating GM+View Rules for dBASE Expressions

1. Select File > Configure > GM+View tab.

2. At the **GM+View Tab Settings** dialog box, Click Rules.

3. At the **GM+View Tab Rules for Template Selection** dialog box, select dBase Expression.

4. Type the dBASE expression in the Expression field.

**Examples:**

The expression used must return a string, and the string must be the name of one of the templates. One option is *iif*, which
functions as an *if ... else* statement:

\[
iif(contact2->uacctbal<500,"GM+View1","GM+View2")
\]

In the above statement, GM+View1 and GM+View2 are defined templates. If the amount in the Account Balance field is
less than 500, the GM+View1 template displays. If the amount is over 500, the GM+View2 template displays.

\[
iif(trim(CONTACT1->KEY1)="test","GM+View1","GM+View2")
\]

If the Key1 field is "test," then the GM+View1 template displays. If the value of Key1 is not equal to "test," then the
GM+View2 template displays. Take note of the double equal signs (==) in the above statement.
Creating GM+View Rules for the User Selected Option

1. Select File > Configure > GM+View tab.
2. At the GM+View Tab Settings dialog box, click Rules.
3. At the GM+View Tab Rules for Template Selection dialog box, select User Selected.
4. Right-click the GM+View tab and select a template to display for the current contact.

Online Searching

The Search Online command located on the Web menu opens the Internet Search window. On this window, you can access web links for searching the internet. The search engines that display are determined by the iSearch.ini file. This file can be modified to display the search engines that you want.

Searching the Internet for Contact Record Information

1. Select Web > Search Online.
2. At the Internet Search dialog box, select one of the available search engines.
3. In the toolbar, click the Search now button.
4. Your default browser opens to the search engine’s results page for the currently active company contact.

   NOTE: The default configuration searches only for contacts that have a Company name listed in the Contact Record.

Modifying the iSearch.ini File

1. Select Web > Search Online.
2. At the Internet Search dialog box, click the iSearch.ini properties button.
   The iSearch.ini file opens in Notepad.
3. Select the display location where you want to add/remove a search engine.
4. Press Return to give yourself a line of space.
5. Modify the file accordingly.

   Example: Insert Bing as a new corporate search engine.

   [Section: Corporate Search: <<Company>>]
   Icon= 1

   [Google]
   URL1= http://www.google.com/search
   Data= ?p=<<Company>>>
   Icon= 5

   [Bing]
   URL1=http://www.bing.com/search
   Data= ?q=<<Company>>>
   Icon=5

   [Yahoo]
   URL1= http://search.yahoo.com/bin/search
NOTE: Determine the structure of the entry (unique to each search engine) by testing a search and determining where the search begins.

In this example, the test search returned the following results in the Internet Explorer Address text box:

```
http://www.bing.com/search?q=FrontRange%20Solutions%20Inc
```

Notice the search command for Bing, &q, and the company name, FrontRange Solutions Inc, at the end. In the `iSearch.ini` entry, this is replaced by the company macro, `<<Company>>`. The macro allows the search to remain interactive with the current contact record.


When launching the Internet Search, the new entry appears in the dialog box.

About the Record Types Administration Center

The Record Types Administration Center manages record types.
- Creating Record Types. See "Creating Record Types" on page 191.
- Configuring Record Type Rules

Record Types and Contact Records

After creating record types and configuring the in the Record Types Administration Center, the record type (entity) displaying in GoldMine is based on how the record meets the rules criteria.

With the Field value-based rules activated, the File > New menu expands to include record types with the New Record Creation Options configured. The New Default Record Type option provides you with an efficient data entry option.

You are not always restricted to the views determined by the record types and rules. With sufficient GoldMine permissions, manually change the primary field view, custom screen, or GM+View.

Customizing the Opportunity and Project Managers Properties

Opportunity and Project share the same table, fields, and user-defined fields. Modify the field labels or reorder and hide tabs of an opportunity listed in the Manager.

Use the following procedure to customize the opportunity and project properties or contact your administrator.

1. Select Go To > Opportunities, or click Opportunities on the Navigation Pane.

   The Opportunities window opens.
   - To customize Project Manager, select Go To > Projects, or click Projects on the Navigation Pane.

   The Projects Manager window opens.

2. Select a listed opportunity or project. and click Customize.
3. At the **Opportunity Manager Customization Properties** dialog box, click the **Fields** tab and select from these options:

- **New.** Creates a new user-defined field on the Opportunity/Project Properties dialog box.

  ![WARNING: User-defined field names must not use an underscore (_) immediately following the U (example: U_fieldname). Fields named this way will not synchronize and will result in data loss.]

  Click **New.** At the **User Defined Field Profile** dialog box enter the Field Name, Description and select a field type.

  - **Character.** A character field. Select the length of the field in the **Len.** drop-down list.
  - **Numeric.** A numeric field. Select the number of decimals in the **Dec.** drop-down list.
  - **Date.** A date field.

- **Edit.** Edits a user-defined field.

  Click **Edit.** At the **User Defined Field Profile** dialog box enter the Field Name, Description and select a field type.

  - **Character.** A character field. Select the length of the field in the **Len.** drop-down list.
  - **Numeric.** A numeric field. Select the number of decimals in the **Dec.** drop-down list.
  - **Date.** A date field.

- **Delete.** Deletes a user-defined field. Click **Delete** and click **Yes** at the message.

- **Move Up.** Reposition the selected field above other fields. Select a field and click **Move Up.** The field moves up one position.

- **Move Down.** Reposition the selected field below other fields. Select a field and click **Move Down.** The field moves down one position.

4. Click the **Labels** tab. Allows you to change the name of a label.

- In the **Default Label** list, find the label name you want to change. Click once next to the field (under the **New Label** list). A text box opens.

- Type in the new label name and click **OK.**

- At the message click **Yes.**

5. Click the **Tabs** tab. Select from the following options:

  **NOTE:** For each tab title listed, clear the associated check box to hide tab from view.

  - **Move Up.** Repositions the tab. Select a tab and click **Move Up.** The tab moves up one position.

  - **Move Down.** Repositions the tab. Select a tab and click **Move Down.** The tab moves down one position.

  - **Customize tab labels globally.** Applies changes to all users. Select the check box if you want changes to apply to all users.

  - **Rename.** Renames the tab. Select a tab and click **Rename.** At the **Edit Tab label** dialog box, type in the new tab label and click **OK.** The new tab name appears.

  - **Reset.** Return the tabs to default order.

6. Click the **Options** tab and select the **When adding a New Opportunity/Project, prompt the user to use either the wizard or the manual method** check box and then click **OK.**
Mobile Settings

Overview

GoldMine Premium Edition allows users to access Goldmine’s e-mail folders and to auto-retrieve (download) and auto-link their email. Auto-linking allows a user to save email messages in contact history and only works for messages related to GoldMine contacts. A user must be logged in to GoldMine Mobile for both auto-retrieval and auto-linking to work. See Configuring Mobile Settings for information on how to set auto-retrieval and auto-linking for a user.

Configuring Mobile Settings

For a user to view email on a mobile device you must enable the email account for auto-retrieval and auto-linking. You can use GoldMine Premium Edition to manage both types of settings. Auto-linking only applies to messages which are related to the contacts that a user has set up within GoldMine.

A Master user (Admin) can set up more than one user at a time, but each user must be set up sequentially.

Set Up User accounts from GoldMine Premium Edition

1. Log into GoldMine Premium Edition as a Master user (Admin).
2. Go to Tools > Users’ Settings... and select a user.
3. Click the Preferences button, select the Email tab then click the Accounts... button.
4. Ensure that the user name is highlighted and click Edit...
5. Select the Auto-retrieve checkbox then click OK for Email Account Properties, Email Options, and <username> Options dialogs.
6. If you have finished editing users click the Close button or
   Select another user account and repeat the procedure.
7. When you are finished click the Close button.

Set Auto-retrieval and Auto-linking for GoldMine Mobile Edition

1. Log in as a Master User (Admin) into GoldMine Premium Edition.
2. Go to Tools > Configure > GoldMine Mobile.
3. Ensure that the user’s name appears in the Assigned users: window and is highlighted.
   If it does not, double-click the user name in the Unassigned Users: pane to move it into the Assigned users: pane.
4. Select the Automatically retrieve and link e-mail messages when user is logged in to GoldMine Mobile checkbox.
5. Enter a Retrieve interval (in minutes) setting.
   The setting determines how often the e-mails are retrieved when a user is logged in to GoldMine Mobile. You can select between 3 to 999 minutes. The default setting is 15 minutes.
6. For IMAP, outgoing connections can be linked by entering the Sent Items folder name. For example:
   - For Gmail: [Gmail]/Sent Mail
   - For Microsoft Exchange Server: Sent Items
     
     **NOTE:** If IMAP is selected, email auto-retrieval and auto-linking become available only after you enable the features for the account.

7. If you are setting up more than one user at this time, select (highlight) the next users name and make the selections as desired.

8. Click OK to save the settings for all the users you edited, and to exit the window.

### User Customization Procedures

Users have the rights to turn auto-retrieve on or off for their own account by using the following procedure:

2. Go to **Tools > Options**.
3. Select the **Email** tab then click the **Accounts** button.
4. Ensure that the email account is selected and click **Edit...**
5. Select or de-select the **Auto-retrieve** and **Auto-delete** checkboxes then click **OK** at the **Email Account Properties**, **Email Options**, and **<username> Options** dialogs to save the changes and exit.

### Troubleshooting GoldMine Mobile

When troubleshooting GoldMine Mobile Edition you must allow a user to **Modify** the GoldMine Mobile Program folder. This setting is not enabled by default. When enabled, it creates a **Logs** directory and a debug file for the device. Once the issue is resolved and a debug file or log is no longer needed, we recommend changing permissions back to the default.

Use the following procedure to create a debug file:

1. From the users computer, log in as Admin and navigate to **Program Files > GoldMine Mobile**.
2. Right-click the folder and select **Properties** then select the **Security** tab.
3. In the **Group or user names:** pane, select the user name to check if the user has permissions to **Modify**. If not, click **Edit...**
4. Ensure that the user name is highlighted (selected) and under the **Allow** column click **Modify**.

   ![Permission Settings](image.png)

   This enables the user to create a debug file when using their mobile device.

5. Click **Apply** then click **OK**.
6. Click **OK** to exit the GoldMine Mobile Properties dialog.
Plug-Ins

Overview

GoldMine contains a mechanism to support ActiveX controls and HTML-based integrations as if they were part of GoldMine. The structures allow for rapid integration, ease-of-use, and security.

To begin, create an Active X control (see "ActiveX Controls" on page 225) or an HTML file/web site (see "HTML Integrations" on page 225) for integration, then set up security (see "Plug-in Security" on page 229).

ActiveX Controls

ActiveX structure provides the most control and can be created with these programming languages: C++, Delphi, Visual Basic, and .NET. When used with other GoldMine APIs, ActiveX is powerful.

Within the ActiveX support, 4 methods can be implemented in your control for stronger interaction with GoldMine. These functions are not necessary to implement:

<table>
<thead>
<tr>
<th>Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>public void GMOnStart(long hWnd)T</code></td>
<td>This is the only function that passes a parameter. The parameter is the HWND</td>
</tr>
<tr>
<td></td>
<td>(window handle) of the container window in GoldMine. Use the Windows API</td>
</tr>
<tr>
<td></td>
<td>SendMessage() call to control what happens to the container (for implementing</td>
</tr>
<tr>
<td></td>
<td>a Close button—since the control is late bound in GoldMine, and cannot</td>
</tr>
<tr>
<td></td>
<td>expose events).</td>
</tr>
<tr>
<td><code>public void GMOnActivate()</code></td>
<td>This function tells you when the user has given your control’s container focus</td>
</tr>
<tr>
<td></td>
<td>in GoldMine.</td>
</tr>
<tr>
<td><code>public void GMLostFocus()</code></td>
<td>This function is called whenever the user gives focus to another object when</td>
</tr>
<tr>
<td></td>
<td>your control had focus.</td>
</tr>
<tr>
<td><code>public void GMOnDestruct()</code></td>
<td>This function is called when the window is just about to close; it provides</td>
</tr>
<tr>
<td></td>
<td>the opportunity to clean up.</td>
</tr>
</tbody>
</table>

For more information, see "Plug-in Description File" on page 226.

HTML Integrations

The HTML attempts to call a JavaScript or VBScript function named like the last 3 ActiveX methods, meaning exactly the same thing. The GMOnStart() function is not supported in HTML:

```javascript
function GMOnActivate();
function GMLostFocus();
function GMOnDestruct();
```
Plug-in Description File

The plug-in description file is a well-formed XML file describing the plug-in. The extension for the file is .GME (GoldMine Extension).

HTML

Structure for the HTML plug-in

```xml
<PlugInDefs>
  <PlugInDef>
    <URL>http://gmail.google.com/gmail</URL>
    <QueryString>q=&lt;&amp;Address1&gt;&gt;, &lt;&lt;&amp;City&gt;&gt;, &lt;&lt;&amp;State&gt;&gt;,
    &lt;&lt;&amp;Zip&gt;&gt;</QueryString>
    <Description>
      <Language Locale="1033" IsDefault="1">
        <Name>G-Mail</Name>
        <Publisher>Google</Publisher>
        <Description>Launches Google's Gmail Service</Description>
        <Menu>Launch GMAIL</Menu>
      </Language>
      <Language Locale="4000">
        <Name>eegay ale-</Name>
        <Publisher>oogle-Gay</Publisher>
        <Description>Launches Lay oogle-Gay's eegay ale- Urvice-Say</Description>
        <Menu>aunch-Lay eegay ale-</Menu>
      </Language>
    </Description>
    <OnDemand>1</OnDemand>
    <Startup>1</Startup>
    <MultipleInstance>0</MultipleInstance>
    <Modal>0</Modal>
    <DefaultPos>
      <top>50</top>
      <left>50</left>
    </DefaultPos>
    <DefaultSize>
      <width>800</width>
      <height>600</height>
    </DefaultSize>
    <Visible>1</Visible>
  </PlugInDef>
</PlugInDefs>
```
**HTML plug-in details**

The root node must be PlugInDefs and as the name implies, multiple plug-ins can be installed under one definition file. For each plug-in, there is a PlugInDef. The child nodes for PlugInDef are:

- **URL**: The URL for the HTML file or Web site must be http://, https://, or file://.
- **QueryString**: The querystring to be tacked on to the end of the URL. Can contain GoldMine field macros that will be evaluated on launch of the plug-in. The macro wrapping structure is <<field>>, like <<&Contact>> or <<Contact1->AccountNo>>.

  **NOTE**: You must XMLEncode the macros as shown in the structure above.

- **Description**: The values here describe the item to the user and can contain multiple languages to describe the file, using the locale code associated with the target language. One language structure must be marked as IsDefault and is used in case the target language is not supported by the plug-in. Use XML entities in place of extended characters. For example, Ñ would be Ñ.

  - **Name**: Dialog name used for security.
  - **Publisher**: Your company name. Creates a sub menu under the Plug-ins menu.
  - **Description**: Used in the Help > About Plug-ins button.
  - **Menu**: The text the user sees for a menu item.

- **OnDemand**: Determines if the plug-in is added to the plug-ins menu. 1 = True, 0 = False. If false, the item is started up with GoldMine.

- **StartUp**: Determines if the item is started up with GoldMine. This is for situations where you want it to start, but if the user closes the window you want them to be able to access the plug-in via a menu. 1 = startup with GoldMine, 0= don’t start with GoldMine.

- **MultipleInstance**: Determines if multiple instances of the plug-in are allowed. 1 = allow multiple instances, 0 = false. When false, if the user chooses the menu item for that plug-in, GoldMine will bring that window to the front and give it focus. non-OnDemand, Modal, and non-visible plug-ins are automatically single instance.

- **Modal**: Determines if any action can occur outside of the window in GoldMine. 1= Modal, 0 = Modeless. Startup/non-OnDemand items cannot be modal. Modal items are strictly single instance.

- **DefaultPos**: The coordinates where your dialog first appears. This is only used the first time the plug-in is run and is ignored for Modal plug-ins, which automatically center in relation to the GoldMine window.

- **DefaultSize**: Describes the height and width of the dialog box for first time use or for modal windows, which cannot be resized.

- **Visible**: Determines if the user can see the window. Not recommended for HTML-based plug-ins.
ActiveX

*Structure for the ActiveX plug-in*

```xml
<PlugInDefs>
  <PlugInDef>
    <ProgID>myApp.ClassInstance</ProgID>
    <Installer>myAppInstaller.exe</Installer>
    <Description>
      <Language Locale="1033" IsDefault="1">
        <Name>G-Mail</Name>
        <Publisher>Google</Publisher>
        <Description>Launches Google's Gmail Service</Description>
        <Menu>Launch GMAIL</Menu>
      </Language>
      <Language Locale="4000">
        <Name>eegay ale-</Name>
        <Publisher>oogle-Gay</Publisher>
        <Description>aunches-Lay oogle-Gay's eegay ale- Urvice-Say</Description>
        <Menu>aunch-Lay eegay ale-</Menu>
      </Language>
    </Description>
    <OnDemand>1</OnDemand>
    <Startup>1</Startup>
    <MultipleInstance>0</MultipleInstance>
    <Modal>0</Modal>
    <DefaultPos>
      <top>50</top>
      <left>50</left>
    </DefaultPos>
    <DefaultSize>
      <width>800</width>
      <height>600</height>
    </DefaultSize>
    <Visible>1</Visible>
  </PlugInDef>
</PlugInDefs>

*ActiveX plug-in details*

Although it is very similar to the HTML plug-in description, there are 2 primary differences, the ProgID and Installer nodes instead of the URL and QueryString nodes.

The ProgID is the ProgID for your ActiveX control and the Installer is the installer name for the application. The Installer should be sitting in a folder named Installers under the plug-in directory.
Plug-in Security

Using GM.ini or the User.ini, a user or administrator can block the use of plug-ins altogether, block individual plug-ins, and add user-specific directory for more plug-ins (see "Adding a Local Plug-in Directory" on page 229).

GM.INI has precedence over the user INI file. Two methods are available:

- **Optimistic**:
  
  ```ini
  [PlugIns]
  allow_by_default=1
  ```

- **Pessimistic**:
  
  ```ini
  [PlugIns]
  deny_by_default=1
  ```

`allow_by_default=0` is the same as `deny_by_default=1` and vice versa. If the keys are missing, the method is assumed to be Optimistic.

If Optimistic, you only need to add blocked plug-ins to the INI files. If Pessimistic, you must give a plug-in permission to run.

**To Block with Optimistic**

```ini
[PlugIns]
allow_by_default=1 or deny_by_default=0
EVIL_PLUGIN=0
```

**To Allow a Plug-In with Pessimistic**

```ini
[PlugIns]
deny_by_default=1 or allow_by_default=0
GOOD_PLUGIN=1
```

Adding a Local Plug-in Directory

By default, the plug-in directory is under /SysDir/Plug-ins. For server installs, this means that all users have the plug-ins under that folder. If users want to add their own local plug-in directory, they could add it to the user INI:

```ini
[PlugIns]
LocalPath=c:\personal\GMPlugIns
```

The user still gets the global level programs (assuming they are not blocked) so ensure there is no duplication.

Security

The ShowActvForCurtained setting in [GoldMine] section of the GM.ini file lets you specify whether or not the calendar shows activities linked to completely curtained contacts. Set this field to 1 if you want the calendar to show activities linked to completely curtained contacts. For example:

```
[GoldMine]
ShowActvForCurtained=1
```

⚠️ **WARNING:** Storing this setting in GM.ini means that GM.ini must be read-only for all except administrators/masters. This weakens GoldMine security.
Reporting

Overview

GoldMine provides analysis reports for reviewing metrics. For example, you can calculate statistics based on activities scheduled and completed by GoldMine users.

Select from over 200 standard GoldMine reports or design a custom report tailored to meet your organization's needs.

**NOTE:** After installing Microsoft SQL Server Reporting Services and configured on the network, you must add a section to the gm.ini file (typically located in Program Files/GoldMine/). This tells GoldMine where the Reporting Services is hosted. For more information, see "To Configure the GM.INI File For Reporting Services" on page 46.

About Reports

A report can include data from these database tables:

- **Contact1.** Main area of the Contact Record and the **Summary** and **Notes** tabs.
- **Contact2.** Fields tab and user-defined fields.
- **ContSupp.** Contacts, Details, Referrals, and Links.
- **Cal.** Calendar tab
- **ContHist.** History tab
- **OpMgr.** Opportunity Manager.
- **Cases.** Service Center

Special fields can include:

- **Dialog.** Prompts users to input data used within the report.
- **Calculations.** Calculates the total or performs other mathematical operations.
- **Macros.** Places multiple fields in the report. Macros are like those used within GoldMine/Microsoft Word templates. For a list of available report Macros, see "GoldMine Report Macros" on page 61.
About the Reports Center

The Reports Center provides easy visual access to several reporting options available within GoldMine.

To access the Reports Center, select Go To > Reports > Reports Center or click the Reports button in the Global Toolbar. The Reports Center appears and offers easy-management features:

- **Report Center Toolbar (see page 232)**
- A tree-view pane listing the selected user’s reports (see "Using the Reports Center" on page 234)
- A description of the selected report
- A .jpg preview of the selected GoldMine Report (see "Adding JPG Previews to the Reports Center" on page 233)

**NOTE:** System reports do not have .jpg previews.

Report Center Toolbar

<table>
<thead>
<tr>
<th>User: [public]</th>
<th>Select the owner (public, user groups, or individual users) of the report you are accessing in the drop-down list.</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Report Center Toolbar" /></td>
<td>Launch the Report Properties dialog box to begin a new report (see &quot;Creating Reports&quot; on page 237).</td>
</tr>
<tr>
<td><img src="image" alt="Report Center Toolbar" /></td>
<td>Create a copy of the report (see &quot;Cloning Reports&quot; on page 240). (recommended for creating new reports)</td>
</tr>
<tr>
<td><img src="image" alt="Report Center Toolbar" /></td>
<td>Delete the report.</td>
</tr>
</tbody>
</table>
Adding .JPG Previews to the Reports Center

Add your own .jpg previews to the Reports Center for reports you create.

1. Open the report with data.
2. Take a screen capture and save the file with the exact same file name as the user-created report but with a .jpg extension.
3. Place a copy of the .jpg in the Reports folder where the matching .fp report is saved.
4. In the Reports Center, the report now has a .jpg preview in the lower right pane.

Report Types

GoldMine Reports

Generate reports from the data in your databases. Using the report generator, select data from your contact database and then present the information in an easy-to-read format for printing or displaying on screen. Approximately 200 reports are included when GoldMine is installed. Use GoldMine reports to generate reports (see "Using the Reports Center" on page 234), clone reports (see "Cloning Reports" on page 240), edit reports (see "Editing Report Layouts" on page 241), and create reports (see "Creating Reports" on page 237).

The easy to run standard reports, which cover most aspects of the database, are organized in the following categories and access only the listed tables:

- **Contact Reports**: Contact1, Contact2, ContHist, ContSupp, Cal, OpMgr, OpMgrFld.
- **Calendar Printouts**: Cal, Contact1, Contact2, ContHist, Cal, OpMgr, OpMgrFld.
- **Service Reports**: Users, Contact1, ContHist, ContSupp, CASES, CaseAttachment, CaseContactsLink, CaseInfoLink, CaseTeamLink
- **Analysis Reports**: Contact1, Contact2, ContHist, Cal, OpMgr, OpMgrFld.
- **Labels and Envelopes**: Contact1, Contact2, ContHist, ContSupp, Cal, OpMgr, OpMgrFld.
- **Other Reports**: Users, Lookup, Filters, Reports, PerPhone, Forms, ScriptsW, OpMgr, OpMgrFld, Mailbox.

System Reports

The GoldMine Output to printer reports are available from the various GoldMine local menus. The System Reports list is only available on the tree view when the selected user is (public).
Using the Reports Center

GoldMine’s report generator organizes data from your contact databases into a report and sends the report to an on-screen display or a selected printer. Select from approximately 200 standard templates provided by GoldMine to meet reporting and printing needs. For special reports, a developer can use GoldMine’s form designer to create custom report templates.

1. Select Go To > Reports > Report Center. The Reports Center appears.
2. From the User drop-down list, select (public) to see the standard reports. Select a user if the user created a custom report.
3. The Report Type tree contains the following report types:
   - **GoldMine Reports:** GoldMine Reports.
   - **System Reports:** GoldMine "Output to printer" reports available from GoldMine local menus.
4. Expand the report type to see a list of reports and sub-categories.
5. When you expand GoldMine Reports category, the following subcategories display:
   - **Contact Reports** displays Contact Listing reports.
   - **Calendar Printouts** displays Activity List reports.
   - **Service Reports** displays Case and Service reports.
   - **Analysis Reports** displays analytical reports.
   - **Labels and Envelopes** displays templates that print data on special paper sizes.
   - **Other Reports** displays six special report templates.
6. Select the report to generate.

   **NOTE:** Depending on the selections made in the Reports Categories area, reports available in the Report Description list vary. Access a local menu for each report. Highlight the report and right-click to view the Reports Center local menu. (Also use the Reports Center toolbar.)

Within the Reports Center, you can work with reports using the following functions:

- Setting Report Properties (see page 234)
- Creating Reports (see page 237)
- Cloning Reports (see page 240)
- Editing Report Layouts (see page 241)
- Previewing GoldMine Reports (see page 259)
- Printing Reports (see page 260)
- Viewing Saved Reports (see page 261)

Setting Report Properties

Use the Report Properties dialog box to specify description and file names, select sorting fields and levels, and set data and date options. The Sorting and Options information can be altered before running or printing a report and will change the information in the report based on changes made on these tabs.

Click the Report Properties button on the Reports Center toolbar for these tabs:

- **Profile.** Report’s name, owner, notes, file name, and printer (see Setting Report Properties, Profile Tab).
- **Sorting.** Report’s sort levels and fields (see Setting Report Properties, Sort Tab).
- **Options.** Report’s data and date inclusion options (see Setting Report Properties, Options Tab).
Setting Report Properties, Profile Tab

Use the Report Properties Profile tab to display or configure report description, filename, and owner. The dialog box appears when clicking Properties on the Reports Center toolbar or when selecting New from the Reports local menu.

1. At the Report Center, select a report and click Report Properties on the Reports Center toolbar.

2. At the Reports Properties dialog box, click the Profile tab.
   - Type (or edit) the name of the report in the Report description field.
   - Select the owner of the report in the Owner drop-down list.
   - Type in extra details about the report and variables in the Notes field.
   - Type or select the name of the report file name in the Reports Filename field.
     Reports store in the Reports folder of the main GoldMine directory. Report templates end with the extension .fp; for example, MyReport.fp.
   - Select a printer.
     → Selected Printer. The printer designated in the Output to section of the Reports Menu.
     → Layout Printer. The printer selected in GoldMine’s layout mode.

Setting Report Properties, Sort Tab

The Report Sorts tab of the Report Properties dialog box allows you to assign up to three sorting levels to a report. For example, you can sort a report by Company, City, and finally Contact.

1. At the Report Center, select a report and click Report Properties on the Reports Center toolbar.

2. At the Reports Properties dialog box, click the Sort tab.
   You can also select the Sort button on the Report Center toolbar.

3. Select a sort level.
   - Primary Sort. This sort specifies the first set of parameters for ordering records.
     NOTE: Every GoldMine report must have at least a Primary Sort defined to operate properly, even if no sorting is required. To preclude sorting, set Sort Database to (none). If Primary Sort is defined as (none), the Data Preparation browse window entry dims, indicating GoldMine sorts records by the natural order of record entry.
     To complete the sort definition, select the database Sort Database and Field Name GoldMine uses to order records in the report. To specify a range of records, set a Start at and an End at value.
   
   - Secondary Sort. This sort specifies a second set of parameters for ordering records.
   
     To complete the sort definition, select the Sort Database and the Field Name by which GoldMine sorts records. To specify a range of records, set a Start at and an End at value.
     NOTE: Define a first-level sort before defining a second-level sort. For a report with only one sort level, define the first level sort only.
   
   - Tertiary Sort. Specifies the third set of parameters for ordering records. To complete the sort definition, select the Sort Database and the Field Name by which GoldMine sorts records. To specify a range of records, set a Start at and an End at value. Define a second level sort before defining a third level sort. For a report with only two sort levels, define the first and second sort levels only.

4. In the Sort Database drop-down list, select the contact table containing the field on which the records are sorted for the selected sort level (Primary, Secondary, or Tertiary). The selected database appears to the right of the sort level.

5. In the Field Name drop-down list, select the field on which records sort for the selected sort level (Primary, Secondary, or Tertiary). Available fields are determined by the table selected from the Sort Database list. The selected field appears to the right of the sort level and the contact database name.

6. As needed, at the Start at field, type the beginning value of a range of ordered records.
If the Start at field and End at field are blank, (all) appears to the right of the sort level database and field, and all records sort in ascending order.

7. At the **End at** field type the ending value of a range of ordered records.

   **NOTE:** The Start/End range constraints are character-to-character comparisons. For example, if you constrain your start and end range to *FrontRange*, the sort will return all contacts for *FrontRange* but none for *FrontRange Solutions* or *FrontRange Solutions, Inc.* *FrontRange* is within the start/end range, but *FrontRange<space>* is outside the end range. Also, searching for *FrontRange* would not return any results for *Frontrange*, because *r* is greater than *R* and therefore outside the end range of the sort. Finally, note that the range criteria is limited to 20 characters, so *FrontRange Solutions, Inc.* would show up in none of the above-described sorts, as it is outside the character limit.

**Setting Report Properties, Options Tab**

The Options tab determines what type of information displays in the report, similar to a filter applied internally to the report. Available options depend on the selected report category. Contacts, Analysis, and Labels and Envelopes display one set of Options, while the Calendar displays another.

1. At the Report Center, select a report and click **Report Properties** on the Reports Center toolbar.

2. At the Reports Properties dialog box, click the **Options** tab.

   You can also select the **Options** button on the Report Center toolbar.

3. In the **History Data** area, select the activity types to be included in the report and complete these fields:
   - **User.** At the drop-down list, select (all) or select the individual user of the report.
   - **Date.** Type or click the drop-down arrow and select the beginning date from the F2 Graphical Calendar. This is the first date you want the report data to reflect.
   - **To.** Type or click the drop-down arrow and select the end date from the F2 Graphical Calendar. This is the last date you want the report data to reflect.
   - **Actv.** Type the Activity Code assigned to the completed activities.
   - **Result.** Type the Result Code assigned to the completed activities. This is a completion code to categorize the outcome of activities. You can use result codes to analyze specific completed activities.

4. In the **Calendar Data** area, select the activity types to be included in the report and complete these fields:
   - **User.** At the drop-down list, select (all) or select the individual user of the report.
   - **Date.** Type or click the drop-down arrow and select the beginning date from the F2 Graphical Calendar. This is the first date you want the report data to reflect.
   - **To.** Type or click the drop-down arrow and select the end date from the F2 Graphical Calendar. This is the last date you want the report data to reflect.
   - **Actv.** Type the Activity Code assigned to the completed activities.

5. In the **Linked Data** area, select the linked data to be included in the report. The selections are: Other Contacts, Document Links, Details, Referrals, and Organizations.
Creating Reports

Reports can be created by either creating a report from a blank template or by cloning a report and then editing to match your desired results.

**NOTE:** Creating a report from a blank template is not recommended for beginners. It is recommended that beginners clone and then edit the report template to first become familiar with the process before attempting to create a new report with a blank template. For more information, refer to "Cloning Reports" on page 240 and "Editing Report Layouts" on page 241.

**To Create a New Report**

1. Select Go To > Reports > Report Center.
2. At the Reports Center click the **New Report** button or right-click inside the report name tree-view pane and select **New**. The Report Properties dialog box opens.
3. When creating a report, click the **Profile** tab:
   - **Report Description:** The name to display in the Report Center.
   - **Owner:** Select the report owner in the drop-down list.
   - **Notes:** Type extra details about the report and report variables.
   - **Report Filename:** Type or select the file name of the report template. The reports store in the Reports folder of the main GoldMine directory. Report templates should end with the extension .fp. For example, MyReport.fp.
4. Click **OK** on the **Profile** tab to return to the **Reports Center**. The new report is now listed in the report list.
5. Highlight the new report and click the **Layout** button or right-click and select **Layout**. A blank template opens.

**IMPORTANT:** If you do not give the report a unique file name at this stage of the process, it does not save.

- **Default Printer:** Select a printer:
- **Selected Printer:** The device designated in the Output to section of the Reports Menu
- **Layout Printer:** The special printer selected in GoldMine’s layout mode

6. Use the **Reports Layout Local Menu** (see page 238) and **Report Center Toolbar** (see page 232) to format your GoldMine Report. For more information, see "Editing Report Layouts" on page 241.
Reports Layout Local Menu

To access the local menu, right-click within the report editing window. The reports local menu has the following options:

- **Save**: Save the report to the file name specified when the report was created or cloned, or save alterations to an existing report.
- **Edit**: Edit items placed on the report including copying, pasting, text formatting, and editing expressions.
- **Insert**: Insert labels, sections, data fields, expressions, graphics, and pictures.
- **Arrange**: Alter the alignment and spacing of report items.
- **Center**: Position the selected field box in the center of the report page.
- **Named Font**: Add, edit, and delete a named font.
- **Font Expression**: Add, edit, delete, and rename a font expression.
- **Grid Settings**: Switch the Snap to Grid option on to position new items consistently. Edit the grid thickness for smaller, finer grids.
- **Printer Setup**: Access the Printer Setup dialog box.
- **Report Settings**: Access a submenu with these options:
  - **Options**: Alter margins, display or hide the ruler, and set the date format.
  - **Filter**: Base the report on an embedded filter so, when run, it applies only to records matching the filter. An alternative is to activate a filter in GoldMine and run a global report on just those records.
- **Dialog Fields Table**: Create, edit, and delete report dialog fields (fields that can be inserted into a report for user input).

Reports Layout Toolbars

The GoldMine Reports layout mode has four toolbars helping you design and edit reports. To edit Layout toolbar options, right-click in the toolbar area and select the toolbars to display. Select Options to change how button information displays, and select Insert items to add toolbar buttons. Also find toolbar options in the Layout local menu.

**Layout Toolbar**

Use the Layout toolbar to perform basic functions, such as opening and closing report templates or switching to an on-screen preview mode.

- **Open**: Returns to the Report Menu.
- **Close**: Closes Reports.
- **Save**: Saves changes to the template.
- **Preview**: Previews the template with data from the database.
- **Printer**: Sends the report to the printer.
- **Settings**: Defines Report Parameters.
- **Filter**: Creates Record Selection Criteria.
**Insert Toolbar**

Use the **Insert** toolbar to insert fields, labels, and graphics, into the template.

- Field: Inserts a field.
- Label: Inserts a text label.
- Section: Starts a new Section.
- Picture: Inserts a `.bmp` graphic file.
- Line: Inserts a line.
- Formula: Inserts a calculation formula.
- System: Inserts a system field.
- Dialog: Inserts a dialog field.

**Style Toolbar**

Use the **Style** toolbar to apply formatting effects.

- Fonts: Selects a font.
- Outline: Places a border around a field or section.
- Background: Selects a fill color for the background of a field or section.
- Position: Set the horizontal and vertical positioning for characters within a field or section.
- Left: Left justifies the text.
- Center: Centers the text within an object.
- Right: Right justifies the text.
- Bold: Makes selected characters bold.
- Italics: Makes selected characters italics.
- Underline: Underlines selected characters.

**Align Toolbar**

Use the **Align** toolbar to justify multiple selected items. To select the items to align, hold down the left mouse button and drag the mouse over the items. A red-bordered box appears. Any item touched by the box is aligned.

- Align Left: Aligns items to the left.
- Align Vert. Center: Aligns items vertically along a center point.
- Align Right: Aligns items to the right.
- Align Top: Aligns items to the top.
- Align Horiz. Center: Aligns items horizontally along a center point.
- Align Bottom: Aligns items along the bottom.
- Even Width: Makes items the same width.
- Even Height: Makes items the same height.
- Even Vert. Spacing: Aligns items with equal vertical spacing.
- Even Horiz. Spacing: Aligns items with equal horizontal spacing.
Cloning Reports

Identifying an existing report that is closest to meeting your needs and then cloning it is the most efficient way to create new GoldMine reports. We recommend you clone existing reports before modifying them so you always have a clean copy available for future edits.

1. Select Go To > Reports > Report Center. The Reports Center opens.
2. Select the user whose report you are cloning in the User drop-down list. Select (public) if the report is publicly owned.
3. Select the report to clone and click the Clone Report button or right-click the report name tree-view pane and select Clone.
4. At the Report Properties dialog box, select the Profile tab and configure:
   - Report Description: When cloning a report, the description defaults to Copy of <report name>. Type a new and unique name for the report to replace the default.
   - Owner: Select the report owner in the drop-down list.
   - Notes: Type extra details about the report and the report variables.
   - Report Filename: Type a new, unique name for the report template. Reports store in the Reports folder of the main GoldMine directory. Report templates should end with the extension .fp.

   **IMPORTANT:** If you do not give the report a unique file name at this stage of the process, it does not save.

   - Default Printer: Select a printer:
     - Selected Printer: The device designated in the Output to section of the Reports Menu
     - Layout Printer: The special printer selected in GoldMine’s layout mode.
5. Click OK on the Profile tab to return to the Reports Center. The new report is now listed in the report list.
6. Highlight the new report and click the Layout button or right-click and select Layout. The report layout appears.

7. Use the Reports Layout Local Menu (see page 238) and Report Center Toolbar (see page 232) to format your GoldMine Report.
Editing Report Layouts

The reports layout window displays a report's existing labels, fields, and sections for editing. Edit the report parameters, pages, filters, and break fields. Within the report layout, add, remove, or change parts of the report.

**NOTE:** Before changing standard GoldMine reports, clone the report to preserve original settings.

1. To edit a field, label, or section, right-click on it and select **Edit**.
   
   Available options depend on the type of item you are editing.

   **TIP:** When editing, the default report layout displays XXXX instead of field names. To display the field names and facilitate editing, right-click and select **Edit > Show Field Names**. The fields names display in the layout window.

2. To quickly edit Reports, use the GoldMine Reports Shortcut Keys and the Layout local menu or the Layout toolbar.

3. Customize the GoldMine Reports by:
   - **Cloning a Template** (see "Cloning Reports" on page 240)
   - **Creating a New Template** (see "Creating Reports" on page 237)

4. Refine the reports by:
   - **Editing Report Parameters** (see "Editing Report Parameters" on page 242)
   - **Editing Report Pages**
   - **Inserting Sections** (see "Inserting Sections in Reports" on page 242)
   - **Inserting Fields** (see "Inserting Report Fields" on page 245)
   - **Editing Fields** (see "Editing Report Fields" on page 246)

   These settings also determine the information and the order it displays in the report:

   - **Filters.** Determines the information included in the report; apply filters on a global level or to a report section (see "About Report Filters" on page 256)
   - **Break Fields.** Manages the grouping of report information (see "Report Break Fields" on page 241)

Report Break Fields

Break fields manage the grouping of information, determining how multiple entry information such as Details, Calendar, and History, displays in a report template. The break field ensures details or calendar entries group together before moving to the next Contact Record.

**NOTE:** Break fields can only be used in Sort Headers.

Most reports use one of two main break fields to determine the format of the report, with other break fields determining content.

- **AccountNo:** The unique number tying details relating to one Contact Record together. It appears in all of the data holding tables and can be used from any of them. The choice of database is dependent upon the type of information displayed in the report. If a mix of Contact1 and ContSupp information displays, two AccountNo fields that be used as break fields:
  - **Contact1->AccountNo:** Groups together the information regarding the company, listing all the company’s profiles together.
  - **ContSupp->AccountNo:** ContSupp->AccountNo tries to center the information on the detail, attempting to display the contact details every time and therefore not collate detail information together.
• **UserID**: The unique ID for users is generally used when displaying calendar information sorted by the user. UserID groups together all of a user’s activities before moving to the next user. It is also the preferred break field when reporting on history activity.

A report without break fields displays the assigned information for every Contact record whether that information appears in sort headers, footers, or detail sections. Once break fields are implemented, each sort header with a break field is dealt with one at a time, but detail sections always display. In this situation, include both filters and break fields to stop non-relevant information from displaying under the sort header details.

The break field for Sort 1Header is nearly always set to Contact1->AccountNo or Cal->UserID depending on the type of information in the report. Other break fields are used in the other sort headers, including macros. For more information, see "Editing Break Field in Reports" on page 243.

**Editing Report Parameters**

Set report margins, rulers, date format, and print defaults with the report parameters.

1. Right-click on the report template and select **Report Settings > Options**.
   
   At the Report Parameters dialog box opens.

2. In the **Margins** area, type the **Left**, **Right**, **Top**, and **Bottom** margins in inches.

3. In the **Ruler Selection** area, determine if a ruler displays and whether it appears in inches or centimeters:
   - **Hide**. No ruler displays on the template window.
   - **Inches**. Each section displays a ruler calibrated in inches.
   - **Centimeters**. Each section displays a ruler calibrated in centimeters.

4. In the **Default Date Format** area, select **MM/DD/YY** to display dates as month/day/year, or **DD/MM/YY** to display day/month/year.

5. Select **Print trial records when output to printer** prior to running a report.
   
   Use this option to run a test printing and adjust paper feed through the printer before sending the records.

6. Select **Print report header before the page header** to print report headers added before printing the page header.

7. Click **OK**.

**Inserting Sections in Reports**

1. Right-click the report template and select **Insert > Section**.
   
   The New Section window opens. The window displays sections available for inclusion. Detail and Sort sections are numbered from 1 to 9 and are only available for inclusion in numeric order.

2. Select the section to insert in the **Section Name** area and then click **OK**.


**Editing Report Sections**

1. Click on the header, detail, or footer section. An editing box appears around the section.

2. Right-click and select **Edit**:
   - **Delete**. Deletes the section.
   - **Outlines**. Accesses the Line Properties dialog box. Select lines that outline the section, line size, and color.
   - **Background**. Accesses the Item Background dialog box. Select the color and type of section background.
   - **Filter**. Accesses the Section Selection Criteria dialog box. Create a filter to specify section contents.
   - **Show Field Names**. Toggles the template display from XXXX to field names.
3. To edit using the Sort # Header or Detail # Section dialog boxes, double-click the section title. Select from:
   - **Compress Space Before the First Item.** Compresses space between the beginning of the section and the object at the top of the section.
   - **Compress Space After the Last Item.** Removes space after the last object of the section to allow for large word-wrapped fields.
   - **Advance Page Before Printing the Section.** Advances to the next page before the beginning of the section.
   - **Advance Page After Printing the Section.** Advances to the next page after printing the section.
   - **Reprint Titles on Every Page.** Prints titles on every page (available for sort sections only).
   - **Number of Records Across the Page.** Specifies the number of records that can be placed across the report template. This option is useful for printing labels and is available for Detail Sections only.
   - **Filter.** Accesses the Section Selection Criteria dialog box. Create a filter to specify section contents.
   - **Outlines.** Accesses the Line Properties dialog box. Select the lines that outline the section, line size, and color.
   - **Break Field.** Accesses the Break Field for Section dialog box. Edit a break field to manage the grouping of multiple entries (available for Sort Header sections).
   - **Background.** Accesses the Item Background dialog box. Select the color and type of section background.

**Editing Break Field in Reports**

1. Double-click the Sort Header section title. The Sort # Header dialog box appears.
2. Click Break Fields. The Break Field Section dialog box appears.
3. Click Data Field; the Select a Field dialog box appears. You can construct a simple break field. For example, Contact1-&gt;AccountNo (see "Report Break Fields" on page 241) and can also use macros for break fields, for example, &Sort2&Suppfile="csp" to define the break field for Sort 2 Header.

---

**&Suppfile Chart:**

<table>
<thead>
<tr>
<th>TABLE</th>
<th>CHARACTERS 1 AND</th>
<th>CHARACTER 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calendar -- ca</td>
<td>&amp;suppfile=&quot;cax&quot;</td>
<td>Where x =</td>
</tr>
<tr>
<td></td>
<td></td>
<td>a : appointment</td>
</tr>
<tr>
<td></td>
<td></td>
<td>c : call back</td>
</tr>
<tr>
<td></td>
<td></td>
<td>t : next action</td>
</tr>
<tr>
<td></td>
<td></td>
<td>d : to-dos</td>
</tr>
<tr>
<td></td>
<td></td>
<td>m : E-mail</td>
</tr>
<tr>
<td></td>
<td></td>
<td>s : forecasted sale</td>
</tr>
<tr>
<td></td>
<td></td>
<td>o : other action</td>
</tr>
<tr>
<td>ContSupp -- cs</td>
<td>&amp;suppfile=&quot;csx&quot;</td>
<td>Where x =</td>
</tr>
<tr>
<td></td>
<td></td>
<td>c : additional contacts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>p : details</td>
</tr>
<tr>
<td></td>
<td></td>
<td>r : referrals</td>
</tr>
<tr>
<td></td>
<td></td>
<td>l : linked documents</td>
</tr>
<tr>
<td></td>
<td></td>
<td>o : organizational chart</td>
</tr>
</tbody>
</table>
NOTE: Generally, only data fields from the database file specified by the macro are used within that section of the report.

Example of Break Fields in a Report:
Select the contact report Contact Profile (Detailed) and display the layout. By double-clicking each section title in turn and clicking the Break Field button, it is possible to see the break field of each section.

Many of these sections cannot utilize a break field; others use the &suppfile macro.

- **Page Header**: No break field available.
- **Sort 1 Header**: Contact1 and contact2 information. Break field: Contact1->AccountNo. This is the primary break field—it groups together all information for one Contact record on a report before moving onto a report for the next Contact record.
- **Sort 2 Header**: Labels and header information—no data fields. Break field: &sort2&suppfile="csc". This break field first groups together everything alphabetically according to the contents of the &sort2 field and then groups together all additional contacts for the current Contact record.
- **Sort 3 Header**: Labels and header information—no data fields. Break field: &sort3&suppfile="csp". This break field first groups together everything alphabetically according to the contents of the &sort3 field and then groups together all details for the current Contact record.
- **Sort 4 Header**: Labels and header information—no data fields. Break field: &sort4&suppfile="csr". This break field first groups together everything alphabetically according to the contents of the &sort4 field even though this is not defined and then groups together all referrals for the current Contact record.
- **Sort 5 Header**: Labels and header information—no data fields. Break field: &sort5&suppfile="ca". This break field first groups together everything alphabetically according to the contents of the &sort5 field even though this is not defined and then groups together all scheduled activities for the current Contact record.
- **Sort 6 Header**: Labels and header information—no data fields. Break field: &sort6&suppfile="ch". This break field first groups together everything alphabetically according to the contents of the &sort6 field even though this is not defined, and then groups together all completed activities for the current Contact record.
- **Sort 7 Header**: Labels and header information—no data fields. Break field: &sort7&suppfile="csl". This break field first groups together everything alphabetically according to the contents of the &sort7 field even though this is not defined and then groups together all linked documents for the current Contact record.
- **Detail 1-6 Section**: No break fields available.
- **Sort 1 Footer**: No break field available.
- **Page Footer**: No break field available.

If break fields did not appear in the sort headers for multiple information sections, only the first piece of information for that category would be included. Multiple instances of the same type of information such as details would be omitted, as the report would move to the next section and/or Contact record.
4. Click **Calculation Field** and the Comp_XXX dialog box appears. A section break field can be a calculated field that lets you generate complex sort breaks. The expression dialog box contains these options:
   - **System Field**: Inserts a system field in the expression.
   - **Dialog Field**: Inserts a dialog field in the expression.
   - **Data Field**: Launches the Select a Field dialog box where you select a field or macro to insert in the expression.
   - **Operator**: Launches the Select an Operator dialog box where you select an operator such as <, >, =, .AND., etc.
   - **Function**: Launches the Select a Function dialog box. Select a predefined argument that returns a value of a predefined type.
   - **Calc Field**: Inserts a predefined calculation field in the expression.

**Inserting Report Fields**

Insert several types of fields into a GoldMine report. After inserting, edit the fields.

1. Right-click on the report template.
2. At the layout local menu, select **Insert**.
3. Insert the following field types as needed:
   - **Label**: A text field to act as a field label.
   - **Section**: A section in the report.
   - **Data Field**: A macro field or a field from the database.
   - **Expression Field**: A calculation field in the report.
   - **System Field**: A predefined system field, such as a record count.
   - **Dialog Field**: An interactive field in the report that requires a response from the user.
   - **Line**: A line into the report.
   - **Picture from Clipboard**: The .bmp that is in the clipboard.
   - **Picture from Disk File**: A .bmp from a saved location.

**Creating Dialog Fields for Reports**

When a report launches, it can prompt the user for parameters to include in the report. For example, create a dialog box to prompt the user for the first and last dates for a calendar report.

Before inserting Dialog Fields into a report, create them.

1. Right-click on the report template and select **Dialog Fields Table > Create**. The Create Dialog Field dialog box appears.
2. In the **Field Name** text box, type a field name.
   - **TIP**: You cannot use spaces. To separate words, use the underscore (_).
3. In the **Field Type** area, select one:
   - **Text**: Any alpha-numeric characters
   - **Numeric**: Any numeric value
   - **Double**: Any float value
   - **Logical**: Logical True and False indicators; defaults are Y for true and N for false
   - **Date**: Value must be in a date format (MM/DD/YY)
   - **NOTE**: After created, the field type cannot be modified.
4. **OK**.
5. The **Field Name** appears as a prompt on the Report Prompt dialog box. To make the prompt more user friendly, right-click the report template and select **Dialog Fields Table > Modify**. The field name dialog box appears.

6. In the **User Prompt** text box, type the text the user will see and respond to. For example, you may have a Dialog Field name of Start_Date but you want the users to respond to the text "Type the starting date."

7. In the **Prompt Order** field, you can change the number to reflect the order multiple questions are asked in.

8. In the **Field Width** text box, type the number of characters you want available in the dialog box.

9. After the Dialog Field is created, insert it in your report for the response to appear on your report (see "To Insert Dialog Fields in Reports" on page 252.)

### Editing Report Fields

Format fields inserted (see "Editing Report Fields" on page 246) into a report.

1. Click on the field. The editing box appears around the field.

2. Right-click the field and select **Edit**. Select an editing option:
   - **Cut**: Cuts the selected field from the template.
   - **Copy**: Copies the selected field to the clipboard.
   - **Paste**: Places a copied field on the template where the cursor is located.
   - **Delete**: Deletes the field.
   - **Position Text**: Accesses the Text Position within Outlines dialog box. Position the text Horizontally and Vertically within the field box (see "To Set Text Position" on page 248).
   - **Outlines**: Accesses the Line Properties dialog box. Select the lines that outline the field box. Also select the line size and color (see "To Set Outline Properties" on page 249).
   - **Background**: Accesses the Item Background dialog box. Select the color and type of field background (see "To Set the Background" on page 250).
   - **Default Item Font**: Accesses the Font dialog box. Select font style, size, and color (see "To Edit the Fonts in Report Fields" on page 250).
   - **Field Expression**: The dialog box that appears varies, depending on the type of field you are editing:
     - **Data Fields** (see "To Insert Data Fields in Reports" on page 251)
     - **Expression Fields** (see "To Insert Expression Fields in Reports" on page 252)
     - **System Fields** (see "To Insert System Fields in Reports" on page 252)
     - **Dialog Fields** (see "To Insert Dialog Fields in Reports" on page 252)
   - **Show Field Names**: Toggles the template display from XXXX to field names.
   - **Properties**: Depending on the field type, one of these Field Properties dialog boxes appears:
     - **Basic Field Properties** (see "To Edit Field Properties in Reports" on page 253)
     - **Date Field Properties** (see "To Edit Date Field Properties in Reports" on page 254)
     - **Numeric Field Properties** (see "To Edit Numeric Field Properties in Reports" on page 255)
Examples of Formatting Sections

The Contact Profile (Detailed) report example shows a report template divided into 17 sections, each one holding different information. By default, the information displays as rows of Xs, plain text labels, and dates.

To display the field names instead of the Xs, right-click and select **Edit > Show Field Names**.

- **Page Header.** Company and Contact Name fields from the Contact1 database. Also displays a line dividing the header from following sections.
- **Sort 1 Header.** Contact name, address details, and telephone numbers as macros. It also displays the five key fields and the first 10 user-defined fields along with the local label names. The final information shown is that drawn from the Summary tab.
- **Sort 2 Header.** Title bar information for displaying additional contacts within the report. If additional contacts exist, this section defines where they are displayed.
- **Sort 3 Header.** Sort 2 Header, but displays Details.
- **Sort 4 Header.** Sort 2 Header, but displays Referrals.
- **Sort 5 Header.** Sort 2 Header, but displays Pending Activities.
- **Sort 6 Header.** Sort 2 Header, but displays History Activities.
- **Sort 7 Header.** Sort 2 Header, but displays Linked Documents.
- **Detail 1 Section.** Information defined in Sort 2 Header listing all additional contacts.
- **Detail 2 Section.** Information defined in Sort 3 Header listing all profiles.
- **Detail 3 Section.** Information defined in Sort 4 Header listing all referrals.
- **Detail 4 Section.** Information defined in Sort 5 Header listing all pending calendar activities.
- **Detail 5 Section.** Information defined in Sort 6 Header listing completed history activities.
- **Sort 5 Header.** Sort 2 Header, but displays Pending Activities.
- **Sort 6 Header.** Sort 2 Header, but displays History Activities.
- **Sort 7 Header.** Sort 2 Header, but displays Linked Documents.
• **Detail 1 Section.** Information defined in Sort 2 Header listing all additional contacts.
• **Detail 2 Section.** Information defined in Sort 3 Header listing all profiles.
• **Detail 3 Section.** Information defined in Sort 4 Header listing all referrals.
• **Detail 4 Section.** Information defined in Sort 5 Header listing all pending calendar activities.
• **Detail 5 Section.** Information defined in Sort 6 Header listing completed history activities.
• **Detail 6 Section.** Information defined in Sort 7 Header listing all linked documents.
• **Sort 1 Footer.** Section for notes from the Notes tab. With no criteria for determining whether notes exist, this section prints in every report.
• **Page Footer.** System information such as the date the report was printed, by which user, and the page number.

When running this report, the page header and footer and Sort 1 Header and Footer have no filter and therefore always display. The other sections use filters. If the data for the section exists, the section displays in the report. Title bars for the optional sections display in sort headers while the actual information displays in detail sections.

### Modifying the Appearance of Report Fields

- **To Set Text Position (see page 248)**
- **To Set Outline Properties (see page 249)**
- **To Set the Background (see page 250)**
- **To Edit the Fonts in Report Fields (see page 250)**

#### To Set Text Position

1. Click on the field in the template. The editing box appears around the field.

![Text Position within Outlines dialog box](image)

2. Right-click the field and select **Edit > Text Position**. The Text Position within Outlines dialog box appears.
3. In the **Horizontal** area, select Left, Center, or Right placement of the data within the field.
4. In the **Vertical** area, select the Top, Center, or Right placement of the data within the field.
5. Click **OK** to save and close the dialog box.
To Set Outline Properties

1. In the **Draw on Sides** area, select the sides the lines should appear.

![Line Properties](image)

2. In the **Line Style** area, select the style of outline to appear around the item.

3. The choices in the **Label** area vary depending on the kind of field you are outlining. Invisible masks the item on the report.

4. Type the **Line Width** in millimeters.

5. Click **Line Color** to select an outline color. The effectiveness of choosing color over greyscale depends upon whether you are printing on a color printer.

6. Click **OK**.
To Set the Background

1. Select a field on the report template. The editing box appears around the field.

2. Right-click and select Edit > Background. The Item Background dialog box appears.

3. To add a background, select Paint Item Background and select Paintbrush Color. The Color dialog box appears. Select the color and click OK. You return to the Item Background dialog box.

4. Select Paintbrush Type and one option.

5. Click OK.

To Edit the Fonts in Report Fields

The default font for Reports is Arial or MS Sans Serif. Change to font on the fields on the report to better suite your publication.

1. Click once on the field to edit. The editing box appears around the field.
2. Right-click and select **Edit > Default** Item Font. The Font dialog box appears.

3. In the **Font** list, select a typeface from those installed on your computer.

4. Select a **Font style**: Regular, *Italic*, **Bold**, or **Bold Italic**.

5. Select the font point **Size**.

6. In the **Effects** area, select **Strikeout** to strike out the characters in the field.

7. **Underline** characters in the field.

8. Select the **Color** in the drop-down list.

9. Select the **Script** in the drop-down list.

   **NOTE:** Selections you make on the Fonts dialog box are previewed in the **Sample** area, above the Script option.

**Fields in Reports**

*To Insert Data Fields in Reports*

1. Right-click on the report template and select **Insert > Data Field**. The Select a Field dialog box appears.

2. From the **Database Name** drop-down list, select one:
   - **Macros**: Composite fields similar to those used when setting up a GoldMine/Word template. These fields include blank line suppression.
   - **Contact1**: A list of available fields from the Contact1 database showing fields from the primary contact area of GoldMine.
   - **Contact2**: A list of available fields from the Contact2 database including information from the Summary tab and all user-defined fields.
   - **ContHist**: Information available from the ContHist table containing details shown on the History tab of a Contact Record.
   - **ContSupp**: Information available from the ContSupp table holding the contents of the Contacts, Details, Referrals, and Links tabs.
   - **Cal**: Information available from the Cal table containing the calendar details shown on the Pending tab.
   - **OpMgr**: Fields available from the Opportunity Manager database OpMgr.
   - **OpMgrFld**: Additional fields available from the Opportunity Manager database applicable to New Opportunity templates.

3. After selecting a table, select the field from the **Field Name** drop-down list. Fields available in the Field Name list are determined by the selected Database Name.

4. Click **OK**. The field appears as a movable box in the report template. Use the mouse to drag the box to the desired location and left-click to place it.

5. Double-click the field to edit Field Properties (see "To Edit Field Properties in Reports" on page 253).
**To Insert Expression Fields in Reports**

Use expression fields to insert calculations in reports. Expressions can perform mathematical functions or derive statistical information from numeric fields, such as averages, percentages, or the number of days between two dates. Calculation fields are usually found in analysis and calendar reports, but they can be added to any type of report.

1. Right-click a report template and select **Insert > Expression Field**. The Enter Field Name dialog box appears.
2. Type a descriptive name for the field. Do not use spaces.
3. Click **OK**. The **CALC->FieldName** expression dialog box appears.
4. In the **Expression** text box, type the calculation expression, including the tables you are drawing from. For example, `Contact2->Usum1+Contact2->Usum2` adds the sum of Usum1 and Usum2 to the report.

Use the buttons to add expression elements:
- **System Field**: Inserts a system field in the expression.
- **Dialog Field**: Inserts a dialog field in the expression.
- **Data Field**: Launches the Select a Field dialog box to select a field or macro to insert in the expression.
- **Operator**: Launches the Select an Operator dialog box to select an operator such as `<`, `>`, `=`, `AND`, etc.
- **Function**: Launches the Select a Function dialog box. Select a predefined arguments that returns a predefined type value.
- **Calc Field**: Inserts a predefined calculation field in the expression.
5. Click **OK**.

**To Insert System Fields in Reports**

1. Right-click the report template and select **Insert > System Field**. The System Field Selection dialog box appears.
2. Select the field to insert.
3. Click **OK**. The field appears as a movable box in the report template. Drag the box to the desired location and left-click to place it. System Fields are usually placed in the report Header or Footer.

**To Insert Dialog Fields in Reports**

**NOTE:** You must create dialog fields (see "Creating Dialog Fields for Reports" on page 245) before inserting them into your report.

1. Right-click the report template and select **Insert > Dialog Field**. The Select Dialog Field dialog box appears.
2. Select the field to insert.
3. Click **OK**. The field appears as a movable box in the report template. Use the mouse to drag the box to the desired location and left-click to place it.
4. Double-click the field box to change the parameters. For instance, change the True and False indicators on a Logical dialog box.
Working with Field Properties in Reports

To Edit Field Properties in Reports

This dialog box shows settings for a basic data field. Separate dialog boxes exist for date fields and numeric fields.

1. Double-click the field in the report template. The Field Properties dialog box appears with the field name in the title bar.

2. In the Wrap area, select:
   - Wrap Text: Wraps text from one line to the next within the designated field box.
   - Word Wrap Text: Wraps text from one line to the next without breaking words.
   - Variable Number of Lines: Lets data display outside the field box.

   **NOTE:** Without this option selected, information in a long field displays in one continuous line, with the information disappearing outside the report boundaries.

   - Trim Extra Spaces: Removes extra spaces in the field.

3. In the Text Position area, select the Horizontal and Vertical placement of the text within the field box.

4. In the Capitalization area, select:
   - Capitalize: Capitalizes data in the field, no matter how it is entered in the database.
   - Capitalize First Letter: Capitalizes the first letter of each word.
   - Print in Lower Case: Prints words in lowercase.

5. Click Outline to configure the outline of fields in the Line Properties dialog box.

6. Click Background to create a background color and type within the label box.

7. Click Font to select the font for the field.

8. Click OK to save the settings and close the dialog box.
To Edit Date Field Properties in Reports

This dialog box covers the basic settings for a date field. There are separate dialog boxes for basic data fields and numeric fields.

1. Double-click the field in the report template. The Field Properties dialog box appears with the field name in the title bar.
2. In the Date Format area, select the month, date, and year format to apply to the field.
3. Select the Date Delimiter character that separates month, date, and year. The default is /.
4. Select Suppress Zero Date to display nothing if there are only zeroes in the dates.
5. In the Text Position area, select the Horizontal and Vertical placement of the date within the field space.
6. In the Footer Fields area, click Summarization Type: Value to specify the summarized values you are using in the footer field. This option is available only if you are working in a footer. The footer can include any of these types:
   - Value: Field value.
   - Total: Cumulative field value of all records in the section.
   - Average: Cumulative field value of all records in the section divided by the number of records in the section.
   - Count: Generates the total number of records in a section
   - Max: Computes the maximum value of all records in a section.
   - Min: Computes the minimum value of all records in a section.
7. Select Retain Value After Printing to print running totals instead of clearing the internal accumulator after printing. This option applies only to numeric fields or float fields used in a footer.
8. Click Outline to set the Line Properties around the field box.
9. Click Background to set the color and background type in the field box.
10. Click Font to change the font used in the field.
11. Click OK to save and close.
To Edit Numeric Field Properties in Reports

This dialog box shows basic settings for a numeric field. Separate dialog boxes exist for basic data fields and date fields.

1. Double-click on the field in the report template. The Field Properties dialog box appears with the field name in the title bar.
2. In the Numeric Format area, type the Negative Sign Prefix (defaults to -).
3. Type a Negative Sign Suffix as needed.

   **NOTE:** If using just a negative sign (-) to indicate a negative value, you do not need to type any value in the suffix box. To use parentheses around a value to indicate a negative amount, type the left parentheses (“(“ in the prefix box and the right parentheses “)” in the suffix box.

4. Type a Positive Sign Prefix and a Positive Sign Suffix as needed.
5. Type the # of Decimal Places. This number specifies the number of digits that can be entered to the right of the decimal point.
6. Type the Currency Symbol to be used, such as $, £, or ¥.
7. Select Suppress Zero Values to not print a value in the field if the value is zero.
8. Select Pad with Zeros to pad decimal values with trailing zeroes.
9. Select Use Comma Format to separate thousands with commas. For example, 12345 appears as 12,345.
10. In the Text Position area, select the Horizontal and Vertical placement of the data within the field box.
11. In the Footer Fields area, click Summarization Type: Total to specify the summarized values you are using in the footer field. This option is available only if you are working in a footer. The footer can include these types:
   - Value: The field value.
   - Total: The cumulative field value of records in the section.
   - Average: The cumulative field value of records in the section divided by the number of records in the section.
   - Count: The total number of records in a section.
   - Max: The computed maximum value of records in a section.
12. Min: The computed minimum value of records in a section.
13. Select Retain Value After Printing to print running totals instead of clearing the internal accumulator after printing. This option applies to numeric fields or float fields used in a footer.
14. Click Outline to set the Line Properties around the field box.
15. Click Background to set the color and type of background in the field box.
16. Click Font to change the font used in the field.
17. Click OK to save and close.

---

**About Report Filters**

Report filters determine what information to include when the report is run. Report filters are composed with the same notation as other filters in GoldMine.

There are three ways filters can be applied to reports:
- **Active GoldMine filters or groups** (see "Activating and Releasing Filters and Groups" on page 199)
- **Global Report filters** (see "Editing Global Report Filters" on page 256)
- **Section filters** (see "Editing Section Filters in Reports" on page 257)

GoldMine filters and Global filters to determine which Contact Records are included in a report. Section filters specify what information is in the section the filter applies to. Different sections of reports can have different filters, including macro filters.

**Editing Global Report Filters**

Use global report filters to include only Contact records meeting filter criteria.

**NOTE:** GoldMine Reports are not optimized for SQL Server and may cause slow performance.

1. Right-click the template and select **Report Settings > Filters**. The Record Selection Criteria dialog box appears.
2. In the **Expression** text box, type the filter expression to build, including the tables you are drawing from. For example, `Contact1->State="CO"` include records where the state is Colorado.

**NOTE:** For a Global Report filter like the one above, it is more efficient to create and activate a GoldMine filter or group than use it as a global filter.

3. Construct your filter with these options:
   - **System Field**: Inserts a system field in the expression.
   - **Dialog Field**: Inserts a dialog field in the expression.
   - **Data Field**: Launches the Select A Field dialog box to select a field or macro to insert in the expression.
   - **Operator**: Launches the Select An Operator dialog box to select an operator such as <, >, =, .AND., etc.
   - **Function**: Launches the Select A Function dialog box. Select a predefined arguments that returns a predefined type value.
   - **Calc Field**: Inserts a predefined calculation field in the expression.
4. Click **OK** to save the filter and close the dialog box.
Editing Section Filters in Reports

Section Filters limit information displaying in the report sections. Each section can have its own filter.

1. Click the section header you are editing. The editing box appears around the section.
2. Right-click and select Edit > Filters. The Section Selection Criteria dialog box appears.
3. In the Expression text box, type the filter expression, including the tables from which you are drawing. For example, Contsupp->Rectype="R" displays only the records with referrals in the section.
4. Use these buttons to construct your filter:
   - **System Field**: Inserts a system field in the expression.
   - **Dialog Field**: Inserts a dialog field in the filter.
   - **Data Field**: Launches the Select a Field dialog box to select a field or macro to insert in the expression.
   - **Operator**: Launches the Select an Operator dialog box to select an operator such as <, >, =, .AND., etc.
   - **Function**: Launches the Select a Function dialog box. Select a predefined argument that returns a predefined type value.
   - **Calc Field**: Inserts a predefined calculation field.
5. Click OK to save the filter and close the dialog box.

Editing Macros in Filters

1. To edit a Section Filter with a macro, click in the section. The editing box appears around the section.
2. Right-click in the section and select Edit > Filters. The Section Selection Criteria dialog box appears.
3. Edit the filter in the Expression box or click Data Field to access the Select a Field dialog box.
4. Select Macros from the Database Name drop-down list. Two types of macros are available:
   - **&Sort**: &sort1, &sort2, and &sort3 hold the primary, secondary, and tertiary sorts that can be specified for the report. Click the Sorts button in the Report Menu dialog box. These macros let the data within a generic report be sorted by a user when selecting the report. Contact records are included in a report if they contain specified report sort order criteria. These three special macros become more useful when used as Break Fields.
   - **&suppfile**: When used within section or report filters, this macro determines which area of the GoldMine database to report on. For example, if the section deals with Referrals, this filter can be added: &suppfile="csc". The first two letters reference the table; the second two reference the Rectype.

   **NOTE**: The &suppfile macro cannot be selected from a list of variables and must be typed manually.

   Responses for &suppfile must be a minimum of two letters and a maximum of three. See the "&Suppfile Chart" on page 259.

Example of Macro Filters in a Report

Select the Contact Report Contact Profile (Detailed) and display the layout. By selecting each of the report sections in turn, right-clicking, and selecting Edit > Filter, you see whether each section is filtered.

Many sections use the &suppfile macro. Each section:

- **Page Header**: No filter—this information displays in every report.
- **Sort 1 Header**: No filter—this information displays in every report.
- **Sort 2 Header**: Title bar for additional contacts section. Filter: &suppfile="csc". This section displays if additional contacts exist on the record.
- **Sort 3 Header**: Title bar for profiles section. Filter: &suppfile="csp". This section displays if details exist on the record.
- **Sort 4 Header**: Title bar for referrals section. Filter: &suppfile="csr". Displays if referrals exist on the record.
- **Sort 5 Header**: Title bar for pending activities section. Filter: &suppfile="ca". Displays if pending activities of any type exist on the record.
- **Sort 6 Header**: Title bar for history activities section. Filter: &suppfile="ch". Displays if historical activities of any type exist on the record.
Sort 7 Header: Title bar for linked documents section. Filter: &supppfile="csl". Displays if documents have been linked to the record.

Detail 1 Section: Detail section for additional contacts. Filter: &supppfile="csc". Displays if additional contacts exist on the record.

Detail 2 Section: Detail section for details. Filter: &supppfile="csp". Displays if details exist on the record.

Detail 3 Section: Detail section for referrals. Filter: &supppfile="csr". Displays if referrals exist on the record.

Detail 4 Section: Detail section for pending activities. Filter: &supppfile="ca". Displays if pending activities of any type exist on the record.

Detail 5 Section: Detail section for history activities. Filter: &supppfile="ch". Displays if historical activities of any type exist on the record.

Detail 6 Section: Detail section for linked documents. Filter: &supppfile="csl". Displays if documents are linked to the record.

Sort 1 Footer: No filter—this information displays in every report.

Page Footer: No filter—this information displays in every report.

If filters are not added to the Detail sections, information displaying there displays under every sort header. Detail sections 1 through 6 display under each sort header (2 through 7) but are only shown when filter criteria are met. Adding a third letter to the &supppfile macro in the pending and history activity section filters narrows the information included to only the type of activity specified.

5. Click OK to save and close the dialog box.
Previewing GoldMine Reports

Previewing a GoldMine Report to check report results before printing or to view information without printing the entire report.

1. Use one of these methods:
   1. In the Reports Center, configure the Report Properties to return the desired results and click the Print button on the Reports Center toolbar. The Print Report dialog box opens.
      Configure the dialog box and select Print Report Output to Window. The Preview window appears with the data in the report.

   2. When working in the GoldMine Report layout, click the Preview button on the toolbar. The Preview window appears with data in the report.
2. To print the report, right-click and select **Print**. The **Print Pages** dialog box appears. Type the first and last pages to print and click **OK**.

3. To save a report with the previewed data, click **Save**.

---

### Printing Reports

Select and print an existing report by one of the following ways:

- Selecting **File > Print a Report**. The **Print Report** dialog box appears.
- Selecting **Go To > Reports > Report Center**. The **Reports Center** dialog box appears. Select the report to print and click **Print** on the **Reports Center** toolbar. The **Print Report** dialog box appears.
- From the **Calendar**, click **Print** on the **Calendar** toolbar. The **Print Report** dialog box appears.

1. In the **Print Report** dialog box, select the report **Type** in the drop-down list. Select **GoldMine**.

2. In the **Category** drop-down list, select the report category to select from:
   - Contact Reports
   - Calendar Reports
   - Service Reports
   - Analysis Reports
   - Labels and Envelopes
   - Other Reports

3. In the **User** drop-down list, select the owning user of the report to print. If it is a public report, select (public) in the drop-down list.

4. In the **Report** drop-down list, select the report name.

5. Determine the contacts against which the report is run:
   - **Current Contact Only**: Prints the report based on the active Contact Record.
   - **All contacts in the following filter or group**: Selects ALL Contact Records to generate the report for the entire database (this can be time consuming), or select a predefined filter or group.

6. In the **Print Report Output To** area, select from:
   - **Window**: Generates the report and displays data in a report Preview window.
   - **Printer**: Generates the report and sends it to your designated printer.

7. Click **OK** to generate the report.
Saving Reports with Data

After previewing a report with specified Report Properties, save report results as a file and access the information later.

1. In the Report Center, configure the Report Properties and preview the report.
2. Click Save. The Save the Report to a Disk File dialog box appears.
3. Select the location. and then type a File name.
4. Select Native Format (*.FRC) in the Save as type drop-down list.
5. Click OK. The report saves to that location.

Viewing Saved Reports

1. In the Reports Center, click View saved report. The Open dialog box appears.
2. Browse to the location of the *.frc file you are viewing.

Sorting Report Data

Present data in order of selected field(s). GoldMine provides 3 levels of sorting for each report. For example, if you select Company as the first sort field, GoldMine orders all the records in the report alphabetically by company name. However, if you select Zip as the first sort field, GoldMine lists records by ZIP code.

GoldMine queries the database in the most efficient way available. If you set up a multilevel sort, or a single-level sort on a field not already indexed, GoldMine builds a report sort table. This additional step lets other users access GoldMine data while the report is printing and also speeds the printing process.

NOTE: The Sorts option is only available for Contact Reports, Analysis Reports, and Other Reports.

1. the Reports Menu dialog box, highlight the report, then click Report Sorts.
3. Select a second level of sorting for those records having the same primary sort field. For example, if you select Company for the Primary Sort, and the Secondary Sort is Contact, GoldMine first orders records by company name. When 2 records have the same company name, GoldMine sorts them alphabetically by contact name.
4. Select a Tertiary Sort field to order records by the third sort field when the first and second level sort fields are identical. For example, if the first and second-level sorts are State and City, and the third level sort is Zip, GoldMine orders records by Zip entries only when 2 or more records have the same City and State values.

   NOTE: Without a second- or third-level sort, GoldMine orders records with the same first-level sort values by the records’ creation date and time. Listing records by entry order is known as the natural order of records.

5. the Start at field, specify the beginning value of a range defining record order within the selected sort level.
6. In the End at field, specify the end of the range.

   If Start at and End at are blank, (all) appears to the right of the sort level database and field, and GoldMine sorts all records in ascending order.

   Example:

   Primary Sort: Contact1->Lastname (all): The first level sort is ordering all records by the Lastname field of the Contact1 database in alphabetical order. When selecting a Start at value and an End at value, GoldMine displays (range) to the right of the sort level database and field.

7. Click OK.
### Reporting Services Integration

Use the **Report Scheduling** feature to run reports at scheduled times from within GoldMine. It works in conjunction with Microsoft’s **SQL Server Reporting Services** and **Microsoft Visual Studio**. These programs must be installed and operating successfully for Scheduled Reports to function. Reporting Services must be configured for E-Mail Delivery.

**NOTE:** This feature only works with **SQL Server Standard Edition** or higher.

The menu bar, select **Go To > Reports > Report Scheduling**. If the feature has not been configured, a message appears.

If the feature has been configured, the **Scheduled Reports** dialog box appears.

See Using Scheduled Reports.
To Schedule Reports

1. From the menu bar, select Go To > Reports > Report Scheduling.

The Scheduled Reports dialog box opens.

This dialog box is blank until you have scheduled a report and it is pending.

2. Click New. The Schedule a Report dialog box opens.

   NOTE: If Microsoft .NET 1.1 has not been installed, an error message appears explaining the RepServicesBridge.dll has not been registered. Ask your system administrator to register this DLL file.
3. Click the Detail tab.

4. From the Report drop-down list, select one of the reports contained in Microsoft Reporting Services.

5. From the Schedule area, select a Start Date and Start Time.

6. From the Delivery area, select By e-mail or Shared directory.

   E-mail is sent by MSSQL Reporting Services, not from within GoldMine.

7. From the Render format area, select Excel, HTML, PDF, or XML. The report is delivered in this format. The formats mimic those available in Microsoft Reporting Services.

8. If you have selected Shared directory, click the Delivery tab.

   **NOTE:** If you selected Shared directory and do not configure the Delivery settings, an error is logged in the GoldMine Process Monitor and the report is not delivered.
9. If you selected Shared directory on the Detail tab, configure the path here.
10. In the **File name** text box, type the folder name of the shared directory.
11. In the **Path (UNC)** text box, type the UNC path to this folder.
12. Select **Add a file extension** when the file is created check box.
13. In the **File Share Credentials**, type a Username and Password for this folder. If the folder has an existing username and password, type these.
14. In the **Overwrite** area, select Do not overwrite, Overwrite with newer file, or Increment file name.
15. Click **OK**.
16. The **Scheduled Reports > Active tab** reopens.

The report you just scheduled should be listed.

**Report Notes**

- After the report runs based on the scheduled time in Scheduled Reports, that report is automatically removed from the Active tab and then logged in the Completed tab.
- If you want a report to run immediately, select the report and click Complete.
- To make changes to the settings in the Schedule a Report – Detail or Delivery tabs, click Edit in the Scheduled Reports dialog box.
- To delete a report from the schedule, select it in the Active tab, and click Delete.
- To delete a report from the Completed tab, select it and click Purge. Select Purge All to delete all reports.
- There is no recurrence with this feature. You must manually schedule a report to run each time.
Configuring for E-Mail Delivery

Reporting Services includes an e-mail delivery extension so that you can distribute reports through an existing e-mail server. Before it can be used, you must configure the report server to make e-mail delivery available to your users. Report server e-mail delivery is implemented on Collaboration Data Objects (CDO), and requires a Simple Mail Transport Protocol (SMTP) server. The e-mail delivery extension does not provide support for digitally signing or encrypting outgoing mail messages.

The configuration file is an XML document called rsreportserver.config. Below is a snip of how it should be set for the e-mail delivery:

```xml
<RSEmailDPConfiguration>
  <SMTPServer>mail.frontrange.com</SMTPServer>
  <SMTPServerPort>25</SMTPServerPort>
  <SMTPAccountName>cosmin</SMTPAccountName>
  <SMTPConnectionTimeout>30</SMTPConnectionTimeout>
  <SMTPUseSSL></SMTPUseSSL>
  <SendUsing>2</SendUsing>
  <SMTPAuthenticate>0</SMTPAuthenticate>
  <From>cosmin@frontrange.com</From>
  <EmbeddedRenderFormats>
    <RenderingExtension>MHTML</RenderingExtension>
  </EmbeddedRenderFormats>
  <组织领导UserRenderFormats></组织领导UserRenderFormats>
  <ExcludedRenderFormats>
    <RenderingExtension>HTMLOWC</RenderingExtension>
    <RenderingExtension>NULL</RenderingExtension>
  </ExcludedRenderFormats>
  <SendEmailToUserAlias>True</SendEmailToUserAlias>
  <DefaultHostName></DefaultHostName>
  <PermittedHosts></PermittedHosts>
</RSEmailDPConfiguration>
```

See the article Configuring a Report Server for E-Mail Delivery at http://msdn.microsoft.com/.
Configuring the INI File

After you have Microsoft SQL Server Reporting Services installed and configured on your network, the system administrator must add a section to the gm.ini file typically located in Program Files/GoldMine/. This addition tells GoldMine where the Reporting Services is hosted.

1. Close GoldMine and open the gm.ini file using Notepad.
2. Type the following as shown below (where localhost is the IP address, machine name, or domain name of your Microsoft SQL Reporting Server).

```plaintext
```
3. Click Save and close Notepad.
4. Open GoldMine and navigate to Go To > Reports > Report Scheduling. If the INI file was successfully revised, the Scheduled Reports dialog box opens.
Automated Processes

Overview

You can automate routine tasks by setting up a series of predefined actions to perform the tasks on Contacts in the database. These tasks include:

- Administrative and tracking duties
- Generating direct mail
- Validating data

For example, print introductory letters to new contacts whenever a Contact Record is created. After printing the letter, the Automated Process can schedule a follow-up activity (such as a call back) on the calendar of a GoldMine user.

Automated Processes Components

The following is a list of the automated process components.

- **Processes.** This is a sequence of two or more events used as the step-by-step instructions GoldMine evaluates to perform a defined series of activities. Also known as an automated process. You can link several events to form a process.

- **Events.** An automated process consists of a sequence of one or more events. An event refers to the step-by-step instructions contained in an Automated Process or process GoldMine evaluates to perform a series of activities. An event consists of a trigger and an action. Events within each process perform an action when triggered by a condition.

- **Action.** Each Automated Process event has a triggered action. The trigger is evaluated and if the criteria is met, the event’s action is performed.

- **Trigger.** Each Automated Process event is processed based on a trigger. The trigger evaluates and, if the criteria is met, performs the event’s action and the processing continues to the next event.

Use the Automated Processes Center to create and edit processes and events and to execute processes. Manage processes attached to contacts on each record with the Processes tab. Use the available menu options to Execute Processes and Manage Processes.

Designing Automated Processes

When an event is created, it is assigned a preemptive or sequential number. GoldMine evaluates preemptive events first and then sequential events.

When creating preemptive events you generally set the condition to eliminate the scanned record rather than confirm this process is appropriate. For example, a sales rep and territory is designated in the Sales Rep and Territory fields, then remove this process from the record; otherwise populate these two fields with the defined criteria.

Preemptive events are numbered from 0 to 99. GoldMine processes all of the preemptive events of a process first before moving on to sequential events. If the Preemptive event if statements is:

- **True.** Perform the action and go to the next event.
Preemptive events should be numbered 5, 10, 15, and so on. Keep space between the events to insert additional events. **Sequential** events perform actions such as printing a letter, sending an e-mail, or scheduling a call. They are numbered from 100 to 999. Sequential events should be numbered 100, 110, 120, and so on to add other events between existing events. After completing all preemptive events, GoldMine runs the first sequential event and processes sequential events. If the statement is:

- **False.** Do not perform the action but still go to the next event.
- **True.** Perform the action and go to the next sequential event.
- **False.** Do not perform the action and do not proceed to the next sequential event.

After GoldMine completes the sequential events, it processes the next process for the Contact, or if there is no process to process, GoldMine goes to the next Contact.

When creating an automated process, define the process, then allocate the events, triggers, and actions to the process. Example of the planning to do:

**New Prospect Welcome**
- 1x per Contact
- Immediately Execute
- Anyone can Attach

**Update Territory/Rep Field**
- Preemptive
- Condition
- Update Field

**Sold - Attach Customer Welcome Track**
- Preemptive
- History will trigger
- Attach Track

**Send Auto E-mail**
- Sequential
- Immediate

**Print ‘Thank You for Interest’ Letter**
- Sequential
- Immediate
- Print

**Schedule TeleSales Rep Call**
- Sequential
- 5 Days
- Schedule

**Send Literature**
- Sequential
- History
- Schedule
Automated Processes Center Components

Toolbar

The Automated Processes Center toolbar has the following buttons:

- **New Automated Process.** Creates a new automated process.
- **New Event.** Creates a new event.
- **Clone New Process.** Clones an automated process.
- **Delete.** Deletes the Automated Process
- **Properties.**
- **Move Event Up.** Moves the event up the list.
- **Move Event Down.** Moves the event down the list.
- **Execute Automated Process.** Executes the automated process.

Event Local Menu

The Event Local Menu contains the following commands:

- **Refresh.** Updates the selected Automated Process or event display.
- **Refresh All.** Updates the display of all Automated Processes and events for the selected User.
- **Expand.** Displays all items contained under the selected Automated Process.
- **Move Up.** Moves the selected event up by one line.
- **Move Down.** Moves the selected event down by one line.
- **New...**
- **Delete...**
- **Properties...**

- **Refresh.** Updates the selected Automated Process or event display.
- **Refresh All.** Updates the display of all Automated Processes and events for the selected User.
- **Expand.** Displays all items contained under the selected Automated Process.
- **Move Up.** Moves the selected event up by one line.
- **Move Down.** Moves the selected event down by one line.
- **New.** Displays the GoldMine Automated Process Event Wizard, from which you can create an event.
- **Delete.** Deletes the selected event.
- **Properties.** Displays the GoldMine Automated Process Event Wizard, from which you can make changes to the selected event.
Process Local Menu

- **Refresh.** Updates the selected Automated Process or event display.
- **Refresh All.** Updates the display of all Automated Processes and events for the selected user.
- **Expand.** Displays all items contained under the selected Automated Process.
- **New.** Displays the GoldMine Automated Processes Wizard. Use to create a process.
- **Clone.** Displays the GoldMine Automated Processes Wizard. Use to create a copy of the selected Automated Process.
- **Delete.** Deletes the selected process.
- **Properties.** Displays the GoldMine Automated Processes Wizard to enable you to edit the process.

Process Options Update

The Process Options allows you to determine when and how processes attach and execute.

- **Allow only one attachment of this process per contact.** Prevents multiple attachments of the one process to a contact’s record.
- **Execute this process immediately upon attachment.** Starts processing the process as soon as a user attaches the process to one or more contact records.
- **Execute this process only when scanning for processes.** Prevents GoldMine from executing a process attached to a single contact record. Use to restrict process execution to a specific system.
- **For example, if a print action requires a special printer that is connected to one workstation, selecting this option and Execute this process immediately upon attachment prevents the printing process from running a different workstation.**
- **Restart this process each time that it ends.** Reattaches the process when processing for the process completes.
- **Allow users to attach this process.** Lets other users attach the process.
- **Attach this process to all new contact records.** Attaches the process to each new contact record. Apply to only one Automated Process.

Creating Automated Processes

Create new automated processes using the Automated Process Wizard.

1. Select **Tools > Automated Processes > Manage Processes.**
   - Click OK at the Welcome message. The Automated Processes Center opens.
2. Right-click on **Automated Processes** and select **New.**
   - The **Automated Processes Wizard** opens.
3. Type in a name, then select a process code and then click Next.

4. Select from the following options and click Next.
   - **Allow only one attachment of this process per contact.** Prevents multiple attachments of the one process to a contact's record.
   - **Execute this process immediately upon attachment.** Starts processing the process as soon as a user attaches the process to one or more contact records.
   - **Execute this process only when scanning for processes.** Prevents GoldMine from executing a process attached to a single contact record. Use to restrict process execution to a specific system. For example, if a print action requires a special printer that is connected to one workstation, selecting this option and Execute this process immediately upon attachment prevents the printing process from running a different workstation.
   - **Restart this process each time that it ends.** Reattaches the process when processing for the process completes.
   - **Allow users to attach this process.** Lets other users attach the process.
   - **Attach this process to all new contact records.** Attaches the process to each new contact record. Apply to only one Automated Process.
5. Click New.

The Event Properties dialog box opens.

6. In the Event area, type a description of the event in the Event Description field. At the radio buttons, select either:
   - **Sequential.** Numbered between 100 - 999, these events evaluate one at a time, starting with the lowest numbered event. The next event is not processed unless the previous event’s trigger evaluates as True.
     
     For example, if you create a process with multiple sequential events, where each event is numbered 100, 110, and 120, GoldMine evaluates event 100 but does not evaluate event 110 until the trigger for event 100 is fulfilled.
   
   - **Preemptive.** Numbered 00 - 99, these events are evaluated individually. The next preemptive event is processed, whether or not the first event is True.
     
     At the Sequence drop-down box, type or select the Sequence number (between 100 - 999 for Sequential; 00 - 99 for Preemptive).

7. In the Trigger area, at the Trigger On drop-down box, select a trigger.

   Depending on the trigger you select, a series of configuration options open.
8. In the **Action** area, at the **Perform Action** box, select an action. Click **Options** to configure the selected action.
9. Click **Next** and then click **Finish**.

The new automated process appears in the Automated Processes Center.

10. Click **Next**.

The Automated Process Event Wizard: Additional Trigger dialog box appears. Configure using:

- **Attempt the trigger only once.** If the current event is triggered, it executes the corresponding action, then continues to the trigger of the next event. However, if the event is not triggered, it skips the event and continues to the trigger of the next event. Example: a process includes 2 events (send a gift to contacts purchasing >$30 and print a thank-you to a contact making any purchase). Select this option to just print the thank-you letter.

**NOTE:** Trigger only once events function like a loop and are dependant on having an event that can escape from the loop. Therefore, make your trigger only once events preemptive; the process will be attached and when the Automatic Process is processed, the preemptive events are also processed.

- **Filter.** Select and then click Filter. The Expression Builder dialog box appears, which lets you specify a dBASE expression.

12. Click **Next** and click **Finish**.

---

**Working with Automated Processes**

Manage processes using these options:

- **Creating Processes.** See "Creating Processes" on page 275
- **Creating Events.** See "Creating Events" on page 277
- **Editing Processes.** See "Editing Processes" on page 276
- **Editing Events.** See "Using the Automated Processes Center" on page 277
- **Attaching Processes.** See "Attaching Processes to a Contact" on page 285
- **Executing Processes.** See "Executing Processes" on page 286
- **Deleting Processes or Events.** See "Removing Attached Automated Processes" on page 286

---

**Creating Processes**

Create, clone, or modify Automated Process **processes** with the GoldMine Automated Processes Wizard.

**NOTE:** Planning is key. Take time to determine what you want to accomplish, how the triggers and actions work together for each preemptive or sequential event, and how the series of events, the process, will fit together.

1. Select **Tools > Automated Processes > Manage Processes.** The **Automated Processes Center** appears.
2. From the drop-down list, select the **User** who owns this Automated Process.
3. Right-click **Automated Processes** in the left pane and select **New**, or click the **New Automated Process** button. The **Welcome to the Automated Process Wizard** dialog box appears.
4. In the **Process Name** text box, type a descriptive name.
5. Type or select the **Process Code** from the F2 Lookup list.
6. Select the **Owner.** By default, the user name selected in the Automated Process Center displays.
7. Click **Next**. The **GoldMine Automated Process Wizard: Options** dialog box appears.
Select one of the following options:

- **Allow only one attachment of this process per contact:** Prevents multiple attachment of the same process to a contact’s record.

  **Note:** If two duplicate contact records are merged that already have automated processes attached, both processes will be attached to the merged contact record, regardless of whether the above check box was selected.

- **This process immediately upon attachment:** Starts processing the process as soon as a user attaches the process to one or more contact records.

- **Execute this process only when scanning a group of contacts:** Prevents GoldMine from executing a process attached to a single contact record. This option is useful to restrict process execution to a specific system. Example: if a print action requires a designated workstation printer, selecting this option and **Execute this process immediately upon attachment** prevents the printing process from running from any other workstation.

- **Restart this process each time that it ends:** Reattaches the process as soon as the processing of the process completes.

- **Allow users to attach this process:** Permits other users to select and attach the process.

- **Attach this process to all new contact records:** Automatically attaches the process to each new contact record. Apply only to one Automated Process (can only be applied to one Automated Process).

9. Click **Next**. The **GoldMine Automated Process Wizard: Events** dialog box appears. The dialog box displays the following:

- **Seq (Sequence):** Sequence ordered number for each event in an Automated Process. The sequence number begins with is either P for a Preemptive event or S for a Sequential event. Each event is processed in order based on the sequence number.

- **Event:** Step-by-step instructions contained in an Automated Process, or track, that GoldMine must evaluate to perform a specified series of activities. An event consists of an action and a trigger. An Automated Process consists of a sequence of two or more events.

- **Trigger:** A predefined condition in an Automated Process event that, when the condition is true, causes GoldMine to execute an action.

- **Action:** The Automated Process action is the activity performed when triggered) for each event. While creating a new track, the display is empty.

10. Select from the following:

- **New.** A blank Event Properties dialog box appears. Lets you create an event.

- **Delete.** Deletes the selected.

- **Edit.** The Event Properties dialog box displays the selected event’s settings. Edit and save.


12. Click **New** to add another event, or when you finish adding events, click **Next**. The Finish dialog box opens.

13. Click **Finish**. For the Automated Process to work, attach the process and process the process.

### Editing Processes

1. In the Automated Processes Center, highlight the process you are editing and right-click.

2. Select **Properties** from the local menu. The Automated Process Wizard opens.


4. Click **Finish**.
Creating Events

Events are the triggered actions that take place in a specific order. Each Automated Process or process, can have up to 900 sequential events and 100 preemptive events. Create or edit events using:

- **Automated Process Event Wizard.** Available when right-clicking and select New.
- **Event Properties dialog box.** Available while creating or editing an Automated Process.

Using the Automated Processes Center

2. Create or modify processes using tool and menu options:
   - **Toolbar**
   - **Process Local Menu**
   - **Events Local Menu**

   **NOTE:** For information on the toolbar and local menus see "Automated Processes Center Components" on page 271.
   - **Process Options Update.** See "Process Options Update" on page 272.
3. Manage processes using these options:
   - **Creating Processes.** See "Creating Processes" on page 275
   - **Creating Events.** See "Creating Events" on page 277
   - **Editing Processes.** See "Editing Processes" on page 276
   - **Editing Events.** See "Editing Events" on page 278
   - **Attaching Processes.** See "Attaching Processes to a Contact" on page 285
   - **Executing Processes.** See "Executing Processes" on page 286
   - **Deleting Processes or Events.** See "Removing Attached Automated Processes" on page 286

Event Properties Dialog Box

When you are using the Automated Process Wizard to create a process and add events, the Event Properties dialog box opens when selecting **New** (or **Edit** on the GoldMine Automated Process Wizard: Events dialog box.

1. In the **Event** area, type the **Event Description**.
2. Select one of the following:
   - **Sequential:** Numbered between 100 - 999, these events evaluate one at a time, starting with the lowest numbered event. The next event is not processed unless the previous event’s trigger evaluates as true.
     
     **Example:** If you create a process with multiple sequential events, where each event is numbered 100, 110, and 120, GoldMine evaluates event 100 but does not evaluate event 110 until the trigger for event 100 is fulfilled.
   - **Preemptive:** Numbered 00 - 99, these events are evaluated individually. The next preemptive event is processed, regardless whether the first event is true.

3. Type or select the Sequence number (between 100 - 999 for Sequential; 00 - 99 for Preemptive).
4. Select a **Trigger.** Configuration options vary depending on the Trigger on option selected.
5. Select an **Action.** Click Options to configure the select action.
6. Click **OK.**
Editing Events

After an event has been created, you can edit the events within a track. Follow the procedure below to edit the even.

1. In the Automated Process Center, double-click on an event or right-click on an event and select Properties. The Welcome to the AP Events Wizard appears.
2. Use the Automated Process Event Wizard to edit.
3. Click Finish.

Creating Triggers

Each Automated Process event is processed based on a trigger. The trigger evaluates and, if the criteria is met, the event's action is performed and processing continues to the next event. Select one of these from the drop-down list and configure the associated settings:

Elapsed Days

Specify the number of days that must pass before the action is executed. GoldMine begins counting days as soon as the event immediately prior to the current event is triggered. If an event is the first event of the track, GoldMine begins counting days as soon as the event is attached to a Contact Record. You can also select Trigger Filter and click Filter. The Expression Builder dialog box appears.

Immediate

Sets GoldMine to immediately execute the action associated with the event. This allows you to set up a sequence of actions based on a single trigger. You can also select Trigger Filter and click Filter. The Expression Builder dialog box appears.

Detail Record

Specifies that the processing of an event’s action cannot be executed until a specified detail record, document link, other contact, or referral has been added to the Contact Record. Configure the following settings:

- Click Options to configure the Detail Trigger dialog box.
- Select Attempt trigger only once to branch to the next event whether or not the current event is triggered. If the current event is triggered, GoldMine executes the corresponding action, then continues to the trigger of the next event. However, if the event is not triggered, GoldMine skips the event, and continues to the trigger of the next event. For example, a track might include two events: Send a gift to contacts who make purchases over a specified dollar amount and print a thank-you letter to a contact who makes any purchase. Selecting Attempt to trigger only once enables GoldMine to print the thank-you letter for all purchases, regardless of the dollar amount.
- Select Trigger Filter and then click Filter. The Expression Builder dialog box appears, allowing you to specify additional conditions based on a dBASE expression.
History Activity

Specifies that the processing of the event’s action cannot be executed until a specified history record has been saved for the Contact Record. Configure the following settings:

- Click **Options** to configure the History Trigger dialog box.
- Select **Attempt trigger only once** to branch to the next event whether or not the current event is triggered. If the current event is triggered, GoldMine executes the corresponding action, then continues to the trigger of the next event. However, if the event is not triggered, GoldMine skips the event, and continues to the trigger of the next event. For example, a track might include two events: Send a gift to contacts who make purchases over a specified dollar amount and print a thank-you letter to a contact who makes any purchase. Selecting **Attempt to trigger only once** enables GoldMine to print the thank-you letter for all purchases, regardless of the dollar amount.
  - Select **Trigger Filter** and then click **Filter**. The Expression Builder dialog box appears, allowing you to specify additional conditions based on a dBASE expression.

Scheduled Activity

Specifies that the processing of an event’s action cannot be executed until a selected activity type has been scheduled for the contact. Configure the following settings:

- Click **Options** to configure the Schedule Activity dialog box.
- Select **Attempt trigger only once** to branch to the next event whether or not the current event is triggered. If the current event is triggered, GoldMine executes the corresponding action, then continues to the trigger of the next event. However, if the event is not triggered, GoldMine skips the event, and continues to the trigger of the next event. For example, a track might include two events: Send a gift to contacts who make purchases over a specified dollar amount and print a thank-you letter to a contact who makes any purchase. Selecting **Attempt to trigger only once** enables GoldMine to print the thank-you letter for all purchases, regardless of the dollar amount.
  - Select **Trigger Filter** and then click **Filter**. The Expression Builder dialog box appears, allowing you to specify additional conditions based on a dBASE expression.

Opportunity

Specifies that the processing of the event’s action cannot be executed until a specified opportunity record has been recorded for the Contact Record. Configure the following settings:

- Click **Options** to configure the Opportunity Trigger dialog box.
- Select **Attempt trigger only once** to branch to the next event whether or not the current event is triggered. If the current event is triggered, GoldMine executes the corresponding action, then continues to the trigger of the next event. However, if the event is not triggered, GoldMine skips the event, and continues to the trigger of the next event. For example, a track might include two events: Send a gift to contacts who make purchases over a specified dollar amount and print a thank-you letter to a contact who makes any purchase. Selecting **Attempt to trigger only once** enables GoldMine to print the thank-you letter for all purchases, regardless of the dollar amount.
  - Select **Trigger Filter** and then click **Filter**. The Expression Builder dialog box appears, allowing you to specify additional conditions based on a dBASE expression.
Project

Specifies that the processing of the event’s action cannot be executed until a specified project record has been recorded for the Contact Record. Configure the following settings:

- Click **Options** to configure the Project Trigger dialog box.
- Select **Attempt trigger only once** to branch to the next event whether or not the current event is triggered. If the current event is triggered, GoldMine executes the corresponding action, then continues to the trigger of the next event. However, if the event is not triggered, GoldMine skips the event, and continues to the trigger of the next event. For example, a track might include two events: Send a gift to contacts who make purchases over a specified dollar amount and print a thank-you letter to a contact who makes any purchase. Selecting **Attempt to trigger only once** enables GoldMine to print the thank-you letter for all purchases, regardless of the dollar amount.
- Select **Trigger Filter** and then click **Filter**. The Expression Builder dialog box appears, allowing you to specify additional conditions based on a dBASE expression.

**dBase Condition**

Specifies that the event’s action can be executed only after a specified dBASE expression is evaluated as true. To access the Expression Builder dialog box, from which you can select an existing expression or create an expression, select Options. Configure the following settings:

- Click **Options** to configure the dBASE Expression Builder dialog box.
- Select **Attempt trigger only once** to branch to the next event whether or not the current event is triggered. If the current event is triggered, GoldMine executes the corresponding action, then continues to the trigger of the next event. However, if the event is not triggered, GoldMine skips the event, and continues to the trigger of the next event. For example, a track might include two events: Send a gift to contacts who make purchases over a specified dollar amount and print a thank-you letter to a contact who makes any purchase. Selecting **Attempt to trigger only once** enables GoldMine to print the thank-you letter for all purchases, regardless of the dollar amount.
- Select **Trigger Filter** and then click **Filter**. The Expression Builder dialog box appears, allowing you to specify additional conditions based on a dBASE expression.

**Disabled**

Turns off the trigger condition setting for the selected event.

**Creating or Editing Filters and dBASE Expressions**

1. On the Expression Builder dialog box, select the user from the **Owner** drop-down list.
2. Select the filters owned by the selected user in the **Filters** drop-down list. The filter expression appears in the text box below. Click **OK** to accept, or continue with more options.
3. Select the **Field name**. Only **Contact1** and **Contact2** are available when creating a filter.
4. Select the **Operator** (see "Filter Expression Operators" on page 190).
5. Type a **Value** in the text box or select a value from the F2 Lookup list.
6. Click Insert Condition. The expression is inserted in the text box.
7. Click **AND** or **OR** to insert a **Boolean Operator** (see "Boolean Operators" on page 191) and then construct the additional expression using Field, Operator, and Value, as well as the left and right parentheses.
8. Click **Insert Condition** to add the new expression to the existing expression.
9. When finished, click **OK**. The dialog box closes and the Event Properties dialog box or the Automated Process Event Wizard reappear.
Creating Actions

Each Automated Process event has a triggered action. The trigger is evaluated and if the criteria is met, the event's action is performed. Select one of these actions from the drop-down list, then click Options to configure the associated settings:

- Print Form (see page 281)
- E-mail Message (see page 282)
- Print Report (see page 282)
- Schedule Activity (see page 283)
- Create History (see page 283)
- Create Detail (see page 283)
- Add to Group (see page 284)
- Update Field (see page 284)
- Remove Process (see page 284)
- Add a New Process (see page 284)
- Branch to Event (see page 284)
- Run Application (see page 284)
- Create Case (see page 285)

Print Form

1. Select the Document Type.
   
   NOTE: Spreadsheet templates with link fields do not print with Automated Processes, because it does not allow proper update of the linked fields; Use only when the file has static data.

2. Select the User who owns the template you want to print.

3. Select a Template. The list is limited to the templates in the Document Management Center owned by the selected user and of the selected document type.

4. In the Printing Schedule area, select:
   - Print immediately: The form is printed immediately upon execution.
   - Queue for immediate printing: The form is queued and is printed on the queued printing schedule.
   - Queue for printing in x days: Queues the form until the specified number of days is reached. Type the number of days in the text box.

5. In the User area, select a user the activity is recorded for:
   - Record Owner: Owner of the Contact record, if record ownership was set.
   - Assigned User: User specified in the Activity Details.
   - Attaching User: User attaching the Track to the record.
   - Logged User: User currently logged into the workstation executing the Automated Process.

6. In the Output method area, select Print or Fax.

7. Click OK.

   NOTE: When a Print Form action is executed, 2 records are added to the History tab. One records the history of the action and the other records the successful printing of the form.
E-mail Message

Chose a template to print as an E-mail message action in an Automated Process.

1. In the Template tab, configure:
   - **User**: Select the user who owns the e-mail template to be sent.
   - **Template**: Templates displayed are limited to those owned by the selected user and configured in the Document Management Center.
   - **Merge for**: Select the user to be listed in the From field of the e-mail message.
   - **User**: Select Merge for > Selected User > User, then select a particular user.

2. On the Recipient tab, configure:
   - **Contact Section**: Select Primary Address to send the message to the primary e-mail address or All addresses linked to this record to send the message to other e-mail addresses associated with the Contact Record.
   - Select All addresses linked to this record and configure specific settings.
     - **Primary**: Sends to the primary e-mail address on the Contact Record.
     - **Additional**: Sends to additional contacts with e-mail addresses.
     - **Other**: Sends to a different e-mail address of the primary contact.
     - **Limit to E-mail merge code**: Sends to contacts with the same e-mail merge code.
   - **Delivery Options**: Specify delivery options for all recipients. Select an option from the list.

3. On the File in History tab, configure:
   - **Create a history record**: Select to create a sent e-mail message record on the contact's History tab.
   - **Save the template in history**: Select to create a complete record of the message sent.
   - **Reference**: Type or select a descriptive reference line to display on the history record.
   - **Activity**: Type or select an activity code for the message.
   - **Result**: Type or select a result code for the message.

4. Click OK.

Print Report

1. From the User drop-down list, select (public) to see the standard reports, or select a particular user if a user has created a custom report you wish to use.

2. Select the Type:
   - **GoldMine**: The GoldMine Reports.

3. From the Reports Categories List, display:
   - **Contact Reports**: Contact Listing reports.
   - **Calendar Printouts**: Activity List reports.
   - **Analysis Reports**: Analytical reports.
   - **Labels and Envelopes**: Special templates that print data on special paper sizes.
   - **Other Reports**: Six special report templates.

4. Select a report to generate from the Report Description list.
   - **NOTE**: The reports available in the Report Description list vary depending on selections made in the Reports Categories area.

5. In the Contacts area, select:
   - **All**: Report includes all contact records.
   - **Current**: Report includes only the currently displayed contact record.
   - **Filter or Group**: Report includes only the contact records that meet the filter criteria or are in an activated group.
   - **NOTE**: GoldMine saves your selection with the report profile.

6. Click OK.
**Schedule Activity**

1. In the **Schedule Activity** area, select the activity type.

2. In the **User** area, select the user the activity is assigned to based on the following options:
   - **Record Owner**: Owner of the Contact record, if record ownership was set.
   - **Assigned User**: User specified in the Activity Details.
   - **Attaching User**: User attaching the Track to the record.
   - **Logged User**: User currently logged into the workstation executing the Automated Process.
   - **User from Field**: A user can be selected from a Contact1 or Contact2 field, if the fields are configured accordingly. Example: a Sales Rep field.

3. Click **Activity Details**. The related Scheduling dialog box appears. Use it to specify information about the scheduled activity.
   
   **NOTE**: Automated Processes do not allow you to schedule and send iCalendar meeting requests as you schedule an action.

4. Specify how many days out to schedule the activity in the **Schedule x days into the future** text box.

5. Select one:
   - **From Today**: Starts counting days from the current date.
   - **From Trigger Date**: Starts counting days from the date the event is triggered.

6. Select **Skip Weekends** to not include weekend days in the total.

7. Click **OK**.

**Create History**

Choose the history activity as your **Create History** action in an Automated Process.

1. Select the **Activity Type**.

2. Select the **User** the activity is assigned to:
   - **Record Owner**: Owner of the Contact record, if record ownership was set.
   - **Assigned User**: User specified in the Activity Details.
   - **Attaching User**: User that attached the Track to the record.
   - **Logged User**: User currently logged into the workstation executing the Automated Process.
   - **User from Field**: A user can be selected from a Contact1 or Contact2 field, if the fields are configured accordingly.

3. Click **Activities Details**. The Complete an activity dialog box appears. Use it to create a specific completed activity record to file in History.

4. Click **OK**.

**Create Detail**

Choose the detail to use as your **Create Detail** action in an Automated Process.

1. Select the **Detail** from the F2 Lookup list.

2. Type or select the relevant **Reference** information from the F2 Lookup list.

3. Add **Notes**, as needed.

4. Select the **Info** tab to access additional fields.

5. Click **OK**.
Add to Group
Add the contacts as group members to your Add to Group action in an Automated Process.

1. Select the owner of the group from the User drop-down list.
2. Select the Group to which you are adding the contacts.
3. Type or select the Membership Reference from the F2 Lookup list.
4. Select the Sort field from the drop-down list.
5. Click OK.

Update Field
1. From the drop-down list, select the field to update.
2. Select Look-up a replacement value in the Lookup.ini if you have an existing subsection in the Lookup.ini that updates this field.
3. Select Update with dBASE Expression and type a dBASE expression in the text box.
   Example, "Updated 5/15/2011".
4. Click OK.

Remove Process
Terminate and remove the track at any point during the processing phase, assuming the trigger is true. Does not require the setting of additional options.

Add a New Process
Appears under two different scenarios: when building a process and when manually attaching a process on the Processes tab (see "Attaching Processes to a Contact" on page 285. To add an existing track to your current track as your Add a New Track action in an Automated Process:

1. Select the process to add from the Code and Process Name list.
2. To execute the attached process immediately, select Process immediately.
3. Click OK.

Branch to Event
Use to jump to another event as your Branch to Event action in an Automated Process.
Example: The Branch to Event acts as a go to statement. If, after processing sequential event 110, the Branch to Event is set to go to 200, all the "skipped" unprocessed sequential events are ignored.

1. Select the event from the Branch to Event drop-down list.
2. Click OK.

Run Application
Launch an external application or execute a Dynamic Database Exchange (DDE) command.

To Run an Application

1. Select Run Application.
2. Browse to the location of the Application executable file that launches the outside application.
3. Add Command line parameters (or dBASE expression) to the launch command.
4. Select Run minimized to run the application in the background and place a button for the application in the Windows Task bar.
5. Click OK.
To Send DDE Commands

1. Select **Execute a DDE Command**.
2. Select a **DDE Service**.
3. Select a **Topic**.
4. Select or type a **DDE Client Command**.

   **NOTE:** Each product application uses a unique format for DDE requests. Consult that product's documentation for details.

5. Click **OK**.

Create Case

For the Automated Process, you can either create a new case based on an existing Service Template (if available) or create an empty case.

1. Select **Create Case** from the **Perform Action** drop-down list. The Automated Process - Create Case dialog box appears.
2. Select one of the options:
   - Use **Existing Case Template** and then select from the list of available templates.
   - Create an **empty case** if you want to start with a blank case.

   **NOTE:** If you want to create a new Case Template, click the **Create A New Case Template** button. The Edit Template dialog box opens. Complete the fields as desired and then click **Save**.

3. Click **OK**.

Attaching Processes to a Contact

Before an Automated Process can be executed, the process must be attached to selected Contact Records. One record can have multiple processes assigned to it. GoldMine stores the attached processes on the **Processes** tab. Build your processes in the Automated Processes Center, then manually attach a process to a record.

To Attach Processes to a Single Contact Record

1. Right-click in the **Processes** tab and select **Attach a Process**. The Attach an Automated Process dialog box appears.
2. Select the process to add from the **Code** and **Process Name** list.
3. Select **Attaching User** from the drop-down list.
4. Click **OK** to attach the process and continue.

To Attach Processes to Multiple Contact Records

1. Select **Tools > Automated Processes > Execute Processes**.
   The Automated Processes Execution dialog box opens.
2. Select one of the following:
   - **Scan current contact**. GoldMine processes only the active contact, then returns to an idle mode.
   - **Scan a group of contact**. Select **ALL Contact Records!** or a filter or group as the basis for selecting contacts. GoldMine processes the contacts in the filter or group, then returns to idle mode.
3. GoldMine scans to evaluate and execute attached processes. In the **Scan Method** area, select from the following:
   - **Scan once**. Executes the process as you attach it.
   - **Scan continuously**. Scans the database continuously as configured in the Server Agents Administrator.
   - **Do not scan**. Attaches the process, but does not evaluate it for execution (available only when selecting **Attach Process to selected contacts**).
4. Select **Attach Process to selected contacts** to select the process to be attached from the drop-down list.
5. Click **Process**. The **Process Monitor** opens, processing the attachments and the events triggered.
Executing Processes

Execute a process for a single contact, a group of records based on a filter or group, or for all contacts. Execute a track manually whenever necessary, or set GoldMine to scan the database continuously, or use the Automated Process Server Agent.

1. Select **Tools > Automated Processes > Execute Processes.**
   The Automated Processes Execution dialog box appears.

2. Select one of the following:
   - **Scan current contact.** GoldMine processes only the active contact, then returns to an idle mode.
   - **Scan a group of contacts.** Select ALL Contact Records, or select a filter or group from the drop-down list.

3. In the **Scan Method** area, select one:
   - **Scan once.** GoldMine scans the contact database, or the contacts selected by a filter or group, and processes all processes. When complete, it returns to an idle mode, unless you have the Automated Processes Server Agent running. If running, the Automated Process scans again in the time frame designated.
   - **Scan continuously.** GoldMine scans the contact database and processes all processes, then repeats the process continuously. This allows you to set up a workstation on the network that continuously scans for triggered events and immediately performs the event actions. It can be interrupted by selecting Stop in the GoldMine Process Monitor dialog box.

   **NOTE:** The option **Do not scan** is available only when you select Attach Process to selected contacts, which lets you attach processes without scanning the database for processes to execute.

4. In the **Options** area, configure:
   - **Max Events.** Maximum number of events (up to 99,999) to be processed during this scan.
   - **Max Contact.** Maximum number of contact records (up to 99,999) evaluated.

   **TIP:** To control the number of letters printed at one time, set the Max Contact to process only 25 records per day, or queue the print job to print manually or in off hours using the Print/Fax Server Agent.

   - **Time.** Sets a time to start processing the track. Use this option to take advantage of periods of lower demand to run the process. To set the time using the graphical clock, press **F2**.

5. Select **Attach Process to selected contacts** to select the process to be attached from the drop-down list.

6. Click **Process.** The Process Monitor appears, displaying the number of contacts scanned and triggered.

Removing Attached Automated Processes

After attaching a track to an individual or many Contact Records, you might need to remove the attached track.

1. Select the **Processes** tab.
2. Right-click the process to be removed and select **Remove Process.**
3. Click **Yes.**
Trigger Dialog Boxes

Opportunity Trigger Dialog Box

Automated Process events can be triggered based on the opportunity information selected. Trigger based on a single opportunity setting or a combination.

1. In the Options area, configure:
   - Max Age: Select the age of the project (in days).
   - Manager: Select the manager.
   - Opportunity: Select the opportunity name.
   - Stage: Select the stage of the opportunity.

2. In the Status area, select either Open or Closed.

3. Click OK.

Project Trigger Dialog Box

Automated Process events can be triggered based on the project information you select in the Project Trigger dialog box. You can trigger on a single project setting or a combination of settings.
1. In the **Options** area, select or configure one or more of the following:
   - **Max Age**: Select the age of the project (in days).
   - **Manager**: Select the manager.
   - **Project**: Select the project name.
   - **Stage**: Select the stage of the project.

2. In the **Status** area, select either **Open** or **Closed**.

3. Click **OK**.

### Schedule Action Dialog Box

1. In the **Schedule Activity** area, select the activity type.

2. In the **User** area, select the user the activity is assigned to based on the following options:
   - **Record Owner**: Owner of the Contact record, if record ownership was set.
   - **Assigned User**: User specified in the Activity Details.
   - **Attaching User**: User attaching the Track to the record.
   - **Logged User**: User currently logged into the workstation executing the Automated Process.
   - **User from Field**: A user can be selected from a Contact1 or Contact2 field, if the fields are configured accordingly. Example: a Sales Rep field.

3. Click **Activity Details**.

   The related Scheduling dialog box appears. Use to specify information about the scheduled activity.

   **NOTE**: Automated Processes do not allow you to schedule and send iCalendar meeting requests as you schedule an action.

4. Specify how many days out to schedule the activity in the **Schedule x days into the future** text box.

5. Select one:
   - **From Today**: Starts counting days from the current date.
   - **From Trigger Date**: Starts counting days from the date the event is triggered.

6. Select **Skip Weekends** if you do not want to include weekend days in the total.

   **NOTE**: The weekends are skipped only if the process occurs on a weekend day. For example, you schedule an activity on 02.15 for nine days later on 02.24, which happens to be a Sunday. GoldMine will actually schedule it for 02.25, the following Monday. If you scheduled an activity for eight days which would be a Saturday, then GoldMine schedules for Monday as well. However if you schedule an activity for seven days later, GoldMine will schedule for Friday.

7. Click **OK**.
Synchronization

Overview

Synchronization is a process where one GoldMine system exchanges information with another GoldMine system through a Local Area Network (LAN), Wide Area Network (WAN), or the Internet. It is useful for organizations with employees in distant offices and in the field who can link their GoldMine systems to communicate effectively and remain dynamically connected.

Synchronization is also used when exchanging data between a GoldMine system and Microsoft Outlook.

To synchronize, each GoldMine system must have a unique license number (see "Licensing" on page 375). However, a GoldMine Administrator working on a GoldMine network can create a GoldMine sublicense to work on an undocked basis.

It is required that you run the same version and build of GoldMine on all systems. To maintain the current version on all systems, users can update their copies via Net-Update or unattended installation (for undocked users). For more information, see “Unattended Installation” in the GoldMine Installation Guide.

Transfer Sets

Synchronization involves the creation, distribution, and retrieval of transfer sets:

- **Stage 1.** The transfer set is created based on changes to the data since the specified date.
- **Stage 2.** The systems connect and exchange data.
- **Stage 3.** The retrieving system incorporates the updates into the databases.

For more information see "About Transfer Sets" on page 291.

During remote synchronization, GoldMine creates a transfer set that is a database of all the changes made to a GoldMine database from the beginning date/time until the present time frame. The receiving GoldMine system uses data in the transfer set to update the resident GoldMine system’s database and retains only data from the transfer set that is newer than the information in its own GoldMine database.

**NOTE:** The transfer set does not contain every change ever made to a GoldMine database. Records go back only far enough to include changes made to the database since a specified cut-off date.
The transfer set contains only records from the originating GoldMine system’s database modified within a specified time frame, only those changed records are updated on the GoldMine system that retrieves the transfer set.

GoldSync uses a system of unique record identifiers and time stamps to track when a record was created, when it was last successfully synchronized, and which update is the most current. During synchronization, GoldSync:

- Evaluates the database to determine what records to include in the transfer set based on Send Options and the cutoff date.
- Sends the transfer set.
- Evaluates the contents of the transfer set to determine what data to retrieve based on the Retrieve Options.
- Compares the date and time stamp of a field in the transfer set with the date and time stamp of the same field in the database to determine which record is more recent and will overwrite the older data.

Tlogs

GoldSync uses Tlogs to keep track of changes to each field in the database and to track new records. (Tlogs is the general name for the two types of logs: ContTlog and GMTlog. They track date and time stamps for changes to fields and the synchronization of the data.) For more information on GoldSync, see “About GoldSync” on page 300.

Changes you make to your GoldMine data are tracked to the millisecond and stored in the Tlogs. This ensures that if two users update the same field on a record, the most recent change saves.

**IMPORTANT:** When creating a new remote site, do not copy tables from one system to another since this causes inconsistent data with synchronization. Remote sites should be set up with a fresh installation of GoldMine, and the data should be synchronized with the main GoldMine site.

Configure specialized settings in the Synchronization Settings (see "Configuring Synchronization Settings" on page 306).

Uses

Use synchronization in these ways:

- **One-button Sync with GoldSync Server.** See "Synchronizing Using One-Button Synchronization" on page 319.
- **Synchronization Wizard.** See "Using the Synchronization Wizard" on page 297.
- **GoldSync Administration Center.** See "Using the GoldSync Administration Center" on page 308.
- **Synchronization with Outlook.** See "About Synchronizing with Microsoft Outlook" on page 292.
- **Copy/Move Records.** See "Using Copy/Move Records" on page 295.
About Transfer Sets

Transfer sets are the containers that transport data between systems. They contain the contact and user-related information that is specified by record type, record filters, and specified date ranges.

As a transfer set is built, GoldMine follows a basic protocol. It evaluates the synctstamp (Contains the time and date when the record was last successfully retrieved during synchronization.) if a particular record falls between the cutoff date and the current date and time when the transfer set is being created. If it falls within that range, the record is included in the transfer set (as long as it is not excluded by other criteria, including security settings determining whether a remote site can update the server, the server can update the site, or both update each other). If the cutoff date is older than the oldest Logstamp (Contains the time and date the record was last changed.) in the TLogs (The general name for the two types of logs: ContTlog and GMTlog. They track date and time stamps for changes to fields and the synchronization of the data.), GoldSync uses the ReclID method to evaluate whether a record in the database was created after the cutoff date. With the ReclID method, GoldSync evaluates the first seven characters of the ReclID for the date and time the record was created. There is a Cut-off date, which can be set to include all records that have a date on or after that date. If the record data is newer than the cutoff date, the then record is included in the transfer set.

**NOTE:** When a previously synchronized Contact Record’s ownership changes, for example from (public) to a specific user, and there has been no further synchronization, the Contact Record can still be updated by a “non-Master Rights” user on the remote system. The remote user’s ability to modify the record is not restricted until after the next synchronization; record ownership is updated during synchronization.

When the transfer set is created, it contains the data to transfer and the transfer set Tlogs. When GoldSync retrieves a transfer set, it compare the Logstamp of the records in the transfer set with the Logstamp of the records on the retrieval site. If the sending Logstamp is newer than the Logstamp for a record in the retrieval site, the record is retrieved.

**Synchronization Scenario**

ABC Company is a medium-sized manufacturer employing about 100 people. It has departments handling sales, order processing, customer service, and support. Ideally, these departments collaborate to accomplish ABC’s goals.

Whenever a prospect calls to inquire about ABC’s products, the inside sales representative adds the prospect to the database, including name, address, telephone, how the prospect heard about ABC Company, and the products in which the prospect is interested.

The literature fulfillment department uses this information to send the requested product information to the prospect. They inform the outside sales representative of the date the information was sent.

The outside representative assigned to the prospect’s territory follows up with a call to the customer a week or so after the product information was sent from the home office. Several subsequent, qualifying sales calls are made to secure the sale of an ABC product. During this period, the salesperson is responsible for updating ABC’s sales management on sales activity including related calls and forecasts.

After a sale is completed, the accounting department generates an invoice the shipping department uses to fill the customer’s order. If the customer fails to pay the invoice, the collections department sends a delinquent letter to the customer to indicate payment is due for the ABC product.

Meanwhile, the customer service department records the date the merchandise was received by the customer and initiates the warranty period. Then, when the customer requires support, the customer service department determines and notes the nature of the problem for future reference. If necessary, a follow-up support call is scheduled at the customer’s location.

ABC Company’s field technicians handle support calls. A field technician uses the customer information gathered by sales and customer service to locate a customer’s office and to determine the nature of the problem. When the problem has been corrected, the technician creates a support record for future reference, then prepares an invoice based on whether the product is within its warranty period.
In this scenario, several employees access the same customer information at the same time, and, in some cases, these individuals work in locations that do not allow direct access to the office. The remote staff, such as the outside sales representatives and field technicians, need access to the same information available to inside ABC Company staff.

To share critical account information, they must be able to transfer this contact data between the office staff and the mobile staff. With synchronization, ABC Company transfers sales leads to outside salespeople, sends support requests to service technicians, and collects follow-up reports from staff in the field. Without remote synchronization, this information would probably have to be printed, sent by facsimile to the remote location, and re-entered into GoldMine by the salesperson or service technician. Synchronization automatically sends updated information to ensure timely, accurate communications for organizations with mobile or distributed personnel.

About Synchronizing with Microsoft Outlook

Synchronize data between GoldMine and these applications or devices:

- **Microsoft Outlook**. See "Configuring Synchronization with Microsoft Outlook" on page 292

  **NOTE:** Outlook must be installed on the GoldMine workstation you are synchronizing.

Synchronize to and from GoldMine and the other applications or devices, or transfer data in one direction. Configure the synchronization process for each option using synchronization wizards.

Configuring Synchronization with Microsoft Outlook


After creating at least one synchronization profile, configure the Server Agents Administrator to automatically synchronize GoldMine and Outlook regularly.

---

**IMPORTANT:** Some Outlook synchronization settings must be defined at the local workstation.

---

**NOTE:** Outlook must be installed on the synchronizing workstation.

Select Tools > Synchronize > Synchronize with Outlook. The Outlook Synchronization dialog box opens.

**Automatic Synchronization**

If you want synchronization to occur automatically with GoldMine, check the Automatically synchronize with Outlook box.

**Manual Synchronization**

Select from the following options:

- If you want synchronization to occur automatically with GoldMine, check the Automatically synchronize with Outlook box.
- If you want to use the setting from the Outlook integration, select the Use the settings for the Outlook Integration option.
- If you want to select what to synchronize, select the Choose what to synchronize, using the Outlook Sync Wizard and then click Synchronize now (see "To Manually Synchronize Now with Outlook" on page 292).

**To Manually Synchronize Now with Outlook**

1. Open the Tools menu and select Synchronize > Synchronize with Outlook. The Outlook Synchronization dialog box opens.

2. Select the Choose what to synchronize, using the Outlook Sync Wizard option.

3. Click the Synchronize now button. The GoldMine Outlook Synchronization Wizard opens.

4. Select from the following options:
   - Start a new session. Configure settings for a new synchronization session.
If you selected **Start a new session**, click **Next** and continue to the Outlook Synchronization Options dialog box.

- **Sync using the setting of the following Profile.** Select a saved profile from the drop-down list.

If you select **Sync using the settings of the following Profile**, select **Finish**. The GoldMine Process Monitor shows the status of the process. Edit settings by clicking **Next**. The Outlook Synchronization Options dialog box appears.

5. On the Outlook Synchronization Options dialog box, select a send and retrieve options:

- **Send and retrieve: To/From Outlook**: Sends and retrieves data between GoldMine and Outlook.
- **Send Only: To Outlook from GoldMine**: Sends data from GoldMine to Outlook, but does not retrieve data from Outlook to GoldMine.
- **Retrieve only: To GoldMine from Outlook**: Retrieves data from Outlook to GoldMine, but does not send data from GoldMine to Outlook.

6. Select **Synchronize Contact Items** to send or retrieve contact information.

7. Select **Synchronize Calendar Items** to send or retrieve calendar information.

8. Click the **Advanced** button to define the Advanced Options for synchronization.

The Advanced Options dialog box opens. Click the following tabs to set options for the following areas:

- **General** defines the telephone extension separator, record modification tolerance, duplicate activity checking by Outlook ID number, synchronizing RSVP, and using categories for activities in Outlook.

  **NOTE:** You can change the information displayed in the Outlook activity Subject line of a retrieved GoldMine activity by editing the `GoldSync.ini` file (see "Adding Macros to the GoldSync.ini File" on page 318).

- **Deletions** defines how deletions synchronize between GoldMine and Outlook.

- **Field Mapping** defines mapped fields so GoldMine can place data in the corresponding Outlook fields.

---

**IMPORTANT:** If you choose to use a different folder than the default option in the Folder selection area on the Contacts, Calendar, or Task tabs, it is required to define that custom folder path at the system where the profile will be used.

**NOTE:** The synchronization of **Notes** is not supported between GoldMine and Outlook.

- **Contacts** specifies the location of the Outlook folder in which GoldMine sends and retrieves contact information.
- **Calendar** specifies the Outlook folder in which GoldMine sends and retrieves activity information.
- **Task** specifies the Outlook folder in which GoldMine sends and retrieves.

9. After configuring advanced options, click **OK** and you return to the Outlook Synchronization Options dialog box.

10. Click **Next**.

The dialog box that appears depends on the option you selected:

- **Send and retrieve: To/From Outlook** (see "GoldMine Record Selection and User’s Calendars" on page 294)
- **Send Only: To Outlook from GoldMine** (see "GoldMine Record Selection and User’s Calendars" on page 294)
- **Retrieve only: To GoldMine from Outlook** (see "Outlook Record Selection Dialog Box" on page 295)
GoldMine Record Selection and User’s Calendars

The first two options on the Outlook Synchronization Options dialog box allow you to send-and-retrieve or send-only records to Outlook (see "To Manually Synchronize Now with Outlook" on page 292).

- **Send and retrieve: To/From Outlook**
- **Send Only: To Outlook from GoldMine**

Both of these options present the following scenario. However, the **Send and retrieve: To/From Outlook** option will proceed to the Outlook Record Selection Dialog Box (see page 295) when you complete the “send” portion of the wizard.

The first dialog box that appears after selecting either of these options and then clicking **Next** is the GoldMine Record Selection dialog box.

![Outlook Synchronization: GoldMine Record Selections](image)

On this dialog box, make selections to choose the Current contact record, cutoff date/time, filter, contact records and groups to include since cutoff. The **Also include contacts with calendar activities from** check box enables the start/finish date range boxes. You can also choose to Omit records previously retrieved from Outlook by checking the box.

After you complete the GoldMine Record Selection dialog box, click **Next** to go to the User’s Calendar Selection dialog box.

![Outlook Synchronization: User’s Calendar Selection](image)
Select the Calendar Records that you want to send to Outlook. The My Calendar option enables the list of other available calendars to send. Make your selections and then click Next to continue the wizard, or Finish to complete the wizard.

**Outlook Record Selection Dialog Box**

The third option on the Outlook Synchronization Options dialog box, Send and retrieve: To/From Outlook, allow you retrieve-only records to Outlook (see "To Manually Synchronize Now with Outlook" on page 292).

The dialog box that appears after selecting this option and then clicking Next is the Outlook Record Selections dialog box.

![Outlook Synchronization: Outlook Record Selections](image)

The Cutoff date/time allows you to specify a starting point for records with a modification date/time until the current date/time for all Outlook records. What that means is that any Outlook record that is newer than the specified date/time will be synchronized. You can also choose to Ignore last synchronized date when sending Outlook records to GoldMine. Make the desired selections and then click Next to continue the wizard, or Finish to complete the wizard.

**Using Copy/Move Records**

Move a single record or a group of contact records to a Contact Database. Copy/Move is a synchronization process. To copy or move only some of the records, build the appropriate filter or group first.

**IMPORTANT:** When copying or moving records that have cases linked to the records, they will not appear in the “Other” contact set.

**NOTE:** It is recommended that you back up your database before moving data.

For example, move contacts into an archive database, or copy records from a leads database to a customer database once the lead becomes a customer.

1. Select Tools > Data Management > Copy/Move Records. The Copy/Move Records Between Contact Sets dialog box appears.

2. From the Select Target Contact Set drop-down list, select the Contact Database. The records copy or move from the open database.

3. In the Record Selection area, select either:
   - Current Record. Copies or moves the active contact record.
   - Group of Contact Records. Copies or moves all records in the filter or group selected from the drop-down list.

4. In the Transfer Method area, select either:
- **Copy Records**: Creates a duplicate of the records in the target contact set. The duplicate records have the same account numbers as the original records, and all associated notes, history, additional contacts, detail, and referral records also copy.

- **Move Records**: Moves records from the current Contact Set to the target file. Records delete from the original file.

---

**IMPORTANT**: Shared data (such as Opportunities, Scheduled Activities, and Cases) must be carefully considered before deletion, because it will be deleted in both Contact Set database records as they are shared data. It is recommended that you use the copy feature only. Copy and verify the data in the new contact set, and delete the data in the originating data set.

---

**NOTE**: Scheduled Activities, Opportunities, and E-mails (shared data) MUST be completed (filed) in the correct Contact Set. Otherwise, the History information will go into the wrong Contact Set.

---

5. If you selected Move Records, select **Sync Deletions** to mark moved records as deleted. Selecting this option marks the Tlogs for the records as deleted and GoldMine does not recognize attempts by another GoldMine system to re-synchronize the records.

6. Click **Details** to read a description of the **Sync Deletions** option.

7. Click **Go**. The Copy/Move begins.
   
   The **Process Monitor** displays progress in the process.

---

### Using the Sync Spy

When synchronizing records you might need to use the **Sync Spy** to check the records updating in the sync logs. Use Sync Spy to view the sync stamp, log stamp, field name, and user.

- **NOTE**: With Sync Spy you determine if there is a sync stamp for the field and whether you set the cutoff date back far enough.

**Sync Spy** window contains an upper and lower pane. The upper pane is summary information for the active Contact Record. The lower pane reflects the information stored in the Contact file Tlogs (ContTlog). This log file holds synchronization information for the contact set. Each contact database has its own ContTlog file.

1. Select **Tools > Synchronize > Sync Spy**. The **Sync Spy** window opens.

2. On the Contact Record for which you are checking the updates, click the field in question.

   - **Database**: Name of the table you are currently evaluating.
   - **Sync Stamp**: The date and time when the field was synchronized from the remote site and the date and time the field was modified by a user local to this system.
     
     **NOTE**: On the transfer set creation side, the Sync Stamp is used with the cut-off date and time to determine if the field-level or record-level change should be included in the transfer set.
   - **Stamp**: The date and time when the field was modified by a user local to the system the Sync Spy is run on.
     
     **NOTE**: On the retrieval system, the Log Stamp is used to compare which system has the latest change.

   - **Field Name**: Field modified in the selected database.
     
     **NOTE**: Curtained fields are viewable in the Sync Spy. If this is a security concern for your organization, disable the Sync Spy option for non-Master Rights users you do not want viewing the fields. Select **Tools > User Settings**. Highlight the user and click Properties. Click the **Menu** tab and expand **Tools**. Disable the **Sync Spy** menu option for the user.

   - **User**: User who made the modification to the field. Also shows if the modification was made by a remote or local user.

3. To select a table for the Sync Spy to display if values for a certain area are stored in more than one table, you can select the table from the drop-down right from table. For example, the Fields tab information is stored in Contact2. Select Contact2 from the drop-down list to view the values.

4. To view field values stored in another table, click the tab containing the values to view.
For example: Browse to the Additional Contacts tab, highlight an additional contact, and then open Sync Spy.

5. To display data in the Sync Spy for another contact, click the Contact Record and scroll through the database.

6. Use the local menu to access Find and Output options.

**Sync Spy Local Menu**

Right-click in the upper pane or lower pane to display the Sync Spy local menu which contains:

- **Find.** Displays the Find dialog box where you search for contacts based on entered text.
- **Output to.** Sends the data to the printer, Word, Excel, or the clipboard.

---

**About the Synchronization Wizard**

Use the GoldMine Synchronization Wizard to synchronize with another remote GoldMine system using an IP/Network connection or Internet e-mail. GoldMine can initiate or accept a connection from a remote GoldMine system and perform the synchronization by transferring data across the selected carrier. Save settings in a profile for use in future synchronization sessions.

The wizard lets you specify the settings needed to synchronize with another site. Synchronize data in one direction to send new leads to a salesperson or synchronize bidirectionally to let a traveling salesperson exchange data with the home office.

To use the Synchronization Wizard, you must:

- Establish a TCP/IP connection between the server and remote machine. This is the default configuration.
- Have Internet e-mail configured in GoldMine if sending and retrieving transfer sets by e-mail.

**Using the Synchronization Wizard**

Define a variety of data and communication options to synchronize with a remote GoldMine or GoldSync system. Define the settings needed to create a transfer set or immediately start a synchronization session.

1. Select **Tools > Synchronize > Synchronization Wizard.** The **GoldMine Synchronization Wizard** dialog box appears.

2. Select one option:
   - **Start a new session.** Define settings for a synchronization session. Use these settings once or save for future use.
   - **Sync using the settings of a Sync Profile.** Synchronizes according to the settings already defined in a profile selected in the drop-down list.
   - **Sync using the settings of a GoldSync Site.** Synchronizes according to the previously defined settings for the site selected in the drop-down list. The site settings are defined in the GoldSync Administration Center. GoldMine uses only the send and retrieve options for the selected site configuration.
   - **Use the following profile/site settings.** Specifies the synchronization profile to use during the current session. This option is available only if you select Sync using the settings of a Sync Profile or Sync using the settings of a GoldSync Site.

   **NOTE:** You can delete a synchronization profile selected in the drop-down list by pressing the **Delete** key on the keyboard.
3. If you selected Sync using the settings of a Sync Profile or the settings of a GoldSync Site, click Finish to synchronize according to existing settings. The GoldMine Process Monitor appears.

**TIP:** The Process Monitor (see "Monitoring Processes" on page 118) can float anywhere on the GoldMine screen, or it can be docked to any of the four sides of the GoldMine screen. The window can also be resized to maximize available workspace. For best results, dock the Process Monitor to the bottom of the GoldMine screen.

4. To verify or change existing settings, click Next to continue to the Connection Method dialog box. (see "Configuring the Synchronization Connection Method" on page 298).

**Configuring the Synchronization Connection Method**

When configuring synchronization, select a connection method. Then, click Next to continue to the appropriate connection options.

- **Connection Method (IP to IP/Network):**
  - **Answer an incoming connection.** Sets GoldMine to wait for an incoming connection from another GoldMine or GoldSync system. When the outside system makes contact, GoldMine accepts the connection, establishes a conversation with the remote system, and begins transferring data. The Wait for Incoming Connection dialog box appears (see "To Configure the Wait for Incoming Connection Options" on page 298).
  - **Connect to remote.** Sets GoldMine to contact the remote GoldMine or GoldSync system via modem, direct Internet connection, or network. The Connect/Send E-mail to Remote dialog box appears (see "To Configure Connect/Send E-mail to Remote (Connect to Remote)" on page 299).

- **No connection with remote:**
  - **Send a transfer set to remote by E-mail.** Sets GoldMine to send a transfer set as an attachment to Internet e-mail. The Connect/Send E-mail to Remote dialog box appears (see "To Configure Connect/Send E-mail to Remote (Transfer Set by E-mail)" on page 299).
  - **Create a transfer set.** Displays the Create a Transfer Set dialog box where you specify the destination for the transfer set, and an optional password. GoldMine does not attempt to contact another GoldMine or GoldSync system (see "To Configure the Create a Transfer Set Options" on page 299).
  - **Retrieve a transfer set.** Displays the Retrieve a Transfer Set dialog box where you define the location where GoldMine can find the transfer set, options for unpacking and deleting the transfer set, and an optional password. GoldMine does not attempt to contact another GoldMine or GoldSync system ("To Configure the Retrieve a Transfer Set Options" on page 299).

**To Configure the Wait for Incoming Connection Options**

When selecting Answer an incoming connection from the Connection Method dialog box, (see "Configuring the Synchronization Connection Method" on page 298), the Wait for an Incoming Connection dialog box appears.

1. Select Send changed data to remote to send changed data from this site to the remote. By default, GoldMine waits for another GoldMine or GoldSync system to call. When the other system calls, GoldMine answers to establish a connection with the remote system and begins transferring data.
2. Select Retrieve changed date from remote to retrieve changed date from the remote to this site.
3. Select Wait continuously for an incoming connection so GoldMine resets after a synchronization cycle and waits for another connection.
4. Type the Optional connection password.
5. Type the TCP Port synchronization is using. The default TCP Port is 5993. Typically, do not change this entry; if you override the default port, you must select the same port as the remote system.
To Configure Connect/Send E-mail to Remote (Connect to Remote)

Set connection options when selecting **Connect to remote** on the Connection Method dialog box (see "Configuring the Synchronization Connection Method" on page 298).

1. Select **Send changed data to remote** to send changed data from this site to the remote.
2. Select **Retrieve changed data from remote** to retrieve changed data from the remote to this site.
3. In the **Remote's Internet IP Address** text box, type the Internet IP address you are connecting to. If creating a one-button synchronization profile, the remote in this case is the GoldSync server the undocked computer synchs to.
4. Type the **TCP Port**. The default TCP Port is “5993”. Typically, do not change this entry; if you override the default port, you must select the same port as the remote system.
5. Click **IP** to add or edit alternative IP addresses.
6. Type the **Optional connection password** in the text box.
7. Click **Next**. If you selected **Send changed data to remote**, the Send Options dialog box appears (see "Configuring Send Options" on page 324).

To Configure Connect/Send E-mail to Remote (Transfer Set by E-mail)

When selecting **Send transfer set to remote by E-mail** on the Connection Method dialog box, (see "Configuring the Synchronization Connection Method" on page 298), you can then set the e-mail options.

1. Type the **Remote's E-mail address** in the text box.
2. Type the **Optional connection password** in the text box.
3. Click **Next**. The Send Options dialog box appears ("Configuring Send Options" on page 324).

To Configure the Create a Transfer Set Options

If you select **Create a Transfer Set** on the Connection Method dialog box (see "Configuring the Synchronization Connection Method" on page 298), set the options in the Transfer Set Options dialog box.

1. Type or browse to the **Path for the transfer set to be placed** location. This specifies the destination for the transfer set upon creation.
2. Select **Update cutoff time if previous transfer set in the above path has been retrieved (deleted)** to prevent GoldMine from updating the cutoff time if a previously retrieved transfer set is detected in the directory designated for transfer set placement.
3. Type the **Optional transfer set password**. When a password is used, both the local and remote GoldMine systems must use the same password.
4. Click **Next**. The Send Options dialog box appears ("Configuring Send Options" on page 324).

To Configure the Retrieve a Transfer Set Options

If you select **Retrieve a transfer set** on the Connection Method dialog box (see "Configuring the Synchronization Connection Method" on page 298), set the options on the Retrieve a Transfer Set dialog box.

1. In the **Path for the transfer set to be retrieved** box, type or browse to the location to place the retrieved transfer set.
2. Select **Unpack transfer set only - do not retrieve records** to decompress the transfer set, and place the transfer set in the directory designated in Path for the transfer set. GoldMine also decrypts the transfer set (with a password value if entered in Optional transfer set password below). GoldMine will not retrieve the data into a Contact Set.
   
   **NOTE:** Beginning with GoldMine 7.0, an unpacked transfer set is no longer a .dbf file, but an EBML file instead. This is a binary format similar to text-based XML, but with much better performance. FrontRange Support has tools to decode the EBML files into a text form, should troubleshooting become necessary.
3. Select **Delete transfer set after unpacking or retrieval** to delete the transfer set after unpacking or retrieving the records into the designated Contact Set.
4. Type the **Optional transfer set password** to specify a password and protect the system from unauthorized connection attempts. When a password is used, both the local and remote systems must use the same password.
5. Click **Next**. The Retrieve Options dialog box appears ("Configuring the Retrieve Options" on page 312).
About GoldSync

GoldSync provides unattended and automated remote synchronization for 2 or more GoldMine systems. GoldSync remote synchronization includes multilevel security and administrative controls and enhanced flexibility over GoldMine's one-to-one remote synchronization.

GoldSync licenses are included with GoldMine Premium Edition. GoldSync can simultaneously update multiple GoldMine systems with added or changed information in other GoldMine systems. Updates can be sent to as many users as are configured for the synchronization.

Although most users are not responsible for configuring or maintaining GoldSync, they might be required to synchronize their GoldMine with a GoldSync server. If so, they can use the One-button Sync with GoldSync Sync to set up and run a GoldSync profile with settings provided by their GoldSync administrator.

GoldSync administrators choose connection methods, session intervals, and the sending/retrieving data options that work best for their remote-to-host scenarios.

Systems using GoldSync to synchronize enjoy the added convenience of One-button Sync with GoldSync Server synchronization. Users can employ click-and-go synchronization using a profile defined by the GoldSync administrator. In some cases, users can install GoldMine and the One-button synchronization profile in one operation.

Recommendations

- To maximize potential for success, a certified GoldSync administrator should perform administrative duties.
- It is recommended that only GoldSync administrators create sync profile.
- It is recommended, and set by default, that undocked Users are denied access the Synchronization Wizard.
GoldSync Key Terms and Concepts

**Host Site:** The GoldMine system accepting incoming connections from one or more remote sites. The site running GoldSync with the Master license typically is called as the host site.

**Remote Site.** A GoldMine system initiating a connection to the host site. A remote site typically is an undocked user or branch office with a sublicense.

**Site Group.** A group of remote sites sharing common configuration settings. These settings define which data synchronizes, who sends/receives the data, how often the data synchronizes, and the method of data transport.

**Site Group Members.** The individual sites belonging to a site group. While the site group members inherit properties of the site group, an individual site group member can also have its own unique settings.

**Site Code.** An identifier limiting connected and initiated processes and nonconnected processes to only those sites with matching site codes. The site code is assigned to both the process and the site(s).

**GoldSync Server.** Any network computer GoldMine is installed on and where synchronization processes run. More than one GoldSync Server on a network is allowed. A GoldSync Server is a host site or a remote site depending upon whether it accepts or initiates connections.

**Processes.** The synchronization tasks performed on a GoldSync Server. Processes pack, send, and retrieve the data. Each process can initiate multiple tasks.

**Transfer Set.** A file comprising all the changes made in a GoldMine database during a specified time frame, including new Contact records and updates to existing Contact Records. Transfer sets can include changes down to the field level for each type of information stored.

**NOTE:** The transfer set does not contain all historical changes made to a GoldMine database. It includes records starting with the most recent and spans only to include database changes since a specified cutoff date.

**Contact Set.** A database of Contact Records.

**File Code.** A unique identifier used to distinguish one Contact Set from another. File Codes are defined in the main GoldMine application. (Select Tools > Database > Open Database, then select the Contact File from the list and click the Properties button.) When using the Synchronization Wizard or Gold Sync, all available Contact Sets MUST have a File Code otherwise the specific Sync feature will not open. When the File Code is set, the Contact Set is available for selection in the Synchronization Wizard and the GoldSync Administration Center.

**NOTE:** It is strongly recommended that the remote system must have a matching File Code.

**RecID.** The unique identifier for every record in GoldMine. This value is always compared during synchronization to determine if there is a matching record in the respective databases.

**GoldSync Administration Center:** The command center where synchronization settings are configured. The GoldSync Administration Center lets you administer multiple sites and automate the processing of transfer sets and connection management.

After you configure GoldSync, no further operator intervention is required. the GoldSync Administration Center handles dialing, redialing, and information transfers for remote GoldMine sites.

**GoldSync Synchronization Wizard:** The tool used by remote sites to manually define configuration settings and initiate synchronization sessions with the host site.

**One-button Synchronization:** Lets remote users synchronize with GoldSync with a single click. The administrator sets up a one-button sync profile for the remote user in the GoldSync Administration Center.
GoldSync Implementation Considerations

To understand how to make synchronization part of your business process, analyze:

- The anticipated number of records in the database.
- The volume of changes you expect to make to the data.
- Whether the entire database or a filtered subset of data is to be synchronized with remote sites.
- The number of remote sites.
- Whether the sync model is dynamic (several synchronizes per site per day) or static (once per week for reporting and data archive purposes).
- The expected future growth of the overall implementation (additional records/databases, users, remote sites).
- To understand the technology issues, consider:
  - Bandwidth currently available between potential remote sites and all synchronization servers.
  - Future plans for enhancing bandwidth (for example, VPN, corporate WAN, and so on).
  - Firewall and network security limit synchronization options.
  - Personnel resources available to administer and maintain synchronization.

Planning a GoldSync System

Analyze information needs, resources, and challenges presented by geography, time zones, or other factors. GoldSync accommodates a variety of configurations.

First, map a diagram of the GoldSync setup to show requirements for accomplishing business goals and providing a reference during final implementation.

Determine individual needs of the different remote sites. In the sample diagram, the Chicago office creates three site licenses with the appropriate number of seats. Sydney and Johannesburg need at least one GoldSync license each to synchronize with Chicago. Los Angeles needs one GoldSync license for synchronizing with Chicago and two more GoldSync licenses to create two remote sites for Heidi and Bill, who synchronize with Los Angeles; and Los Angeles, Johannesburg, and Sydney synchronize with Chicago.
Planning Variables

The GoldSync administrator must identify variables to evaluate when installing GoldSync.

Because the amount of data and load an organization require of GoldSync varies, no simple way exists to determine if a computer’s configuration or network infrastructure effectively serves GoldSync’s processing requirements. GoldSync’s requirements change as variables change.

**IMPORTANT:** GoldSync service does not see mapped drives. If GoldMine was installed to an existing database, and the server path was defined as a mapped location (such as G:\GoldMine) you will receive an error message when starting GoldSync. To avoid this, use the UNC path or make corrections to the gm.ini as in the following example:

1. Open the gm.ini file for edit.
2. Locate the realini and sysdir entries
   - realini=G:\GoldMine
   - sysdir=G:\GoldMine
3. Replace with your UNC path
   - realini=\<yourhost>\<GMPATH>
   - sysdir=\<yourhost>\<GMPATH>
4. Save the file.

- **Operating System:** The GoldSync server performs a considerable amount of intensive processing, so the GoldSync administrator must ensure the system acting as the GoldSync server can consistently sustain the demands of heavy load processing. Select a system that is stable, reliable, and scalable. We strongly recommend administrators install and deploy GoldSync on Microsoft Windows Server 2003 SP2, Microsoft Windows Server 2008, or Microsoft Windows Server 2012.

  The key benefit of determining the differences is to understand how this variable affects planning for the SQL Server implementation with GoldSync. Also, different operating system versions offer varying levels of support for memory and processing capabilities.

- **Microsoft SQL Server:** Microsoft SQL Server 2005, Microsoft SQL Server 2008, and Microsoft SQL Server 2012 are the only SQL Servers currently supported by GoldMine Premium Edition. Understanding how SQL Server is configured and managed is critical to GoldSync’s successful deployment.

  The more memory available, the better caching capability SQL Server has for loading the database into memory, and for performing queries in memory.

  Operating systems can impose limits on the amount of memory any application can use. Administrators must know key differences between various versions and editions of the Windows NT-based systems to effectively determine what memory capabilities are available to SQL Server.

- **Memory Usage:** Microsoft SQL Server 2005/2008/2012 require more RAM than earlier versions because the redesigned query optimizer using hash and merge takes more in-memory processing.

- **Disk I/O Subsystem Performance Can Affect SQL Server’s Performance:** SQL Server tries to cache as much information as it can into memory; at some point, available RAM will likely be insufficient to hold all the information (especially when running queries on large databases). Consequently, virtual memory is used, which can result in decreased performance.

  I/O performance becomes critical in sustaining heavy read/write activities. The physical disk subsystem must provide the database server with sufficient I/O processing power for the database server to run without disk queuing.

- **SQL Server Profiler and SQL Server Performance Monitor:** Tools such as SQL Profiler and SQL Server Performance Monitor can help administrators with performance tuning. SQL Server Profiler provides detailed information about activity occurring on the database server. Its logs are useful when troubleshooting SQL error messages and symptoms with applications issuing queries on the databases hosted to SQL.
- **Resources, Data, and Load**: These variables can have a significant impact on GoldSync’s functionality and performance. They have an interdependent relationship, making it difficult to plan a GoldSync implementation without accounting for all three.

  **NOTE:** After determining the amount of data and load the GoldSync Server must process, determine the hardware requirements. Look at the organization’s infrastructure to determine the limitations it can impose on the overall GoldSync implementation.

- **Selecting a GoldSync System Server**: Depending upon the amount of data and load, the GoldSync server might need to perform intensive processing. We recommend a dedicated GoldSync Server.

  Systems serving as SQL Servers and acting as servers for other applications or systems running resource-intensive applications are not good candidates for GoldSync Servers.

  Although GoldSync functions on systems meeting minimum requirements, we recommend (especially when running multiple sites) administrators deploy GoldSync on systems using at least a Windows 2003 operating system with at least 256 MB of RAM and with a processing power of a Pentium II-350. A safe guideline is to install as much memory as the computer can hold, especially in the case of single-processor computers.

  The overall load the GoldSync server processes influences GoldSync’s performance. The more data GoldSync processes through concurrent tasks, the more processing power it requires from the computer it runs on.

  The location of the GoldMine executable GoldSync uses has no observed bearing on GoldSync’s performance. To simplify management and troubleshooting, we recommend administrators run the same executable for GoldSync while the main GoldMine server is running.

- **Setting Maximum Simultaneous Synchronization Sessions**: Hardware components such as processor speed, memory, and disk subsystem available, affect the number of simultaneous synchronization sessions the GoldSync server can handle.

  FrontRange recommends no more than 10 simultaneous synchronization sessions per GoldSync server. This applies to connected and nonconnected sync methods and can fluctuate due to dependency on variables such as the amount of data each site needs to process and the processing power of the GoldSync and SQL Servers.

- **Determining the Need to Use Multiple GoldSync Servers**: Process more than 10 sites concurrently by setting up multiple GoldSync Servers. This procedure is synonymous to load balancing, where application tasks are distributed to multiple systems to increase and leverage the computing power that cannot be realized through a single, dedicated GoldSync Server.

  You might not realize any potential load-balancing benefits if conflicting limitations from the SQL Server’s capability exist. The number of simultaneous GoldSync processes is always physically constrained by the SQL Server. See Microsoft’s SQL Server documentation on Performance Tuning.

- **Setting the Synchronization Period**: Schedule a time when the GoldSync server can handle processes. By assigning a time for sites to synchronize, the administrator is assured the server can handle the processing load without needing to physically monitor the system.

  Administrators can access GoldSync’s Process Properties to use the Sync Period setting on the group member’s properties.

- **Selecting a Synchronization Connection Method**: FrontRange recommends administrators implement the IP to IP/Network method because:

  - Configuration is simple. Administrators specify the address (numeric or name) of the GoldSync computer the remote is connecting to.
  - It works well with common network security options, especially firewalls. GoldSync uses 5993 as its default port where the network administrator can configure a port on its firewall to receive and send packets of data securely. This method offers the flexibility of assigning another port number to receive the GoldSync connection.
  - It is the most reliable transport method when using the TCP/IP protocol. The TCP/IP protocol guarantees the retransmission of dropped packets, typically due to network problems. Additionally, it ensures each packet received has the same content as when it was sent. (If a bit changes or drops for some reason, the protocol detects this and retransmits the packet.)
  - IP to IP/Network is easier to troubleshoot. A Telnet procedure is usually the only tool needed to confirm a problem with the IP to IP/Network method.
Example: With e-mail synchronization, there is no way to verify a transfer set was retrieved by a remote site with the e-mail sync method because e-mail synchronization is a nonconnected procedure. GoldSync updates the cutoff date for the next synchronization session after successfully creating a transfer set even if the remote site fails to retrieve that transfer set. This might leave gaps in the remote's data in a situation where a transfer set was not successfully retrieved due to a condition external to GoldSync/GoldMine.

- **Designing a Plan to Reduce Processing Time:** When using a connected method for synchronization, reduce processing time by:
  - Creating transfer sets in advance.
  - Using filters and groups to limit the amount of data in the transfer set.
  - Using multiprocessor systems. GoldSync takes advantage of the high-performance computing power Windows NT-based technology provides.

**GoldSync Sites Local Menu**

Use the Sites local menu to configure and manage Site Groups and Sites using:

<table>
<thead>
<tr>
<th>Date/Time Stamp Conversion…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Refresh</td>
</tr>
<tr>
<td>Refresh All</td>
</tr>
<tr>
<td>Expand</td>
</tr>
<tr>
<td>Enable</td>
</tr>
<tr>
<td>Disable</td>
</tr>
<tr>
<td>Generate Verification Code…</td>
</tr>
<tr>
<td>Create Installation File for One-button Sync…</td>
</tr>
<tr>
<td>New One-button Sync Profile…</td>
</tr>
<tr>
<td>Email One-button Sync Profile to Remote…</td>
</tr>
<tr>
<td>New…</td>
</tr>
<tr>
<td>Clone…</td>
</tr>
<tr>
<td>Delete…</td>
</tr>
<tr>
<td>Properties…</td>
</tr>
</tbody>
</table>

- **Date/Time Stamp Conversion:** Opens the Date/Time Stamp Conversion dialog box to convert the SyncStamp, LogStamp, and the first seven characters of the RecID to a standard date or convert a regular date to a time stamp. See "To Use the Date/Time Stamp Conversion Utility" on page 314.
- **Refresh:** Updates the item.
- **Refresh All:** Updates levels and items in the GoldSync Administration Center.
- **Expand:** Displays items under the selected item.
- **Enable:** Lets the selected site synchronize. GoldSync checks Allow this site to synchronize on the first page of the GoldSync Site Group Member Wizard.
- **Disable:** Prevents the site from synchronizing, but leaves it listed under the site group. When selecting this local menu command, GoldSync clears Allow this site to synchronize on the first page of the GoldSync Site Group Member Wizard.
- **Generate Verification Code:** Displays the Generate Verification Code dialog box. The site must use the code to synchronize with GoldSync. The code is only valid for the site until the remote user uses a different profile. See "Synchronization Verification Codes" on page 316.
- **Create Installation File for One-button Sync:** Creates a GoldMine installation file according to the specifications defined in the user’s synchronization profile. Create the synchronization profile for the user before running this command and creating the installation file. When selecting this command, the Create Undocked User(s)' Installation Files appears. See "Creating Installation Files for One-button Synchronization" on page 323.
- **One-button Sync Profile**: Displays the GoldSync Site One-button Synchronization Profile Wizard to create a synchronization profile for an undocked user. This profile enables the undocked user to synchronize via One-button Sync with GoldSync Server. See "Creating One-Button Synchronization Profiles" on page 320.

- **Email One-button Sync Profile to Remote**: Sends the remote synchronization profile as an e-mail attachment to the undocked user. See "E-mailing One-Button Synchronization Profile to Remote" on page 322.

- **New**: Creates a site group or site. See "Creating Site Groups" on page 311.

- **Clone**: Displays the New Site Group Member dialog box to create a site based on attributes of the selected site. See "Cloning Site Settings" on page 314.

- **Delete**: Removes the selected site group or site.

- **Properties**: Displays the Site Group Wizard to modify the selected site group or site.

### Configuring Synchronization Settings

The **Synchronization Settings** dialog box is available only to users with Master Rights. It allows you define the synchronization options for One-button Sync, retrieving linked documents, running GoldSync as a service, and the overrides to the default time-out settings.

1. Select **Tools > Synchronize > Synchronization Settings**. The **Synchronization Settings** dialog box appears.

2. Configure the tabs:

   **One-button Sync**
   
   **TIP**: For additional information, see "Retrieving One-Button Synchronization Profiles" on page 321.

   - This tab is available when you retrieve a one-button synchronization profile. The One-button Sync option is included in the profile.

   - If the **Check for a GoldSync connection every minute** option is selected, GoldMine checks for network connections 15 seconds after login and prompts the user to synchronize if a network connection and the specified IP address are reachable; however, the GoldSync server might not be listening.

   - In the Instant Sync Connection dialog box, you can synchronize, be prompted again in one minute, or turn off the prompt for the session duration.

   - Clear the **Check for a GoldSync connection every minute** checkbox if you do not want GoldMine to query you about synchronizing whenever it detects your GoldSync server.

**Linked Documents**

**NOTE**: If running GoldSync as a service, you must use UNC paths for the folder location. Mapped drives are not recognized properly by Windows Services.

- Configures how linked documents are handled in the synchronization process. Configure these options in the **Attempt to retrieve linked files** to drop-down list:

  - Select **File’s original drive and folder** for GoldSync to place the linked documents in the original drive or location. If not found there, GoldSync searches available alternate drives.

  Then specify **alternative drives** in the text box below, telling GoldMine where to retrieve linked documents. For multiple drive entries or shares, separate each drive or share entry by a semicolon (;).

  For example, `C:\SERVER\DOCS;D;F;`. If the linked documents are not found in the original or alternate drives, GoldSync retrieves the document into the default directory. If you did not assign a directory in **default drive and folder**, the default directory is the `x:\SYSDIR directory\TmpLinks`; typically, the SYSDIR directory is the GoldMine directory.
Select Specified default drive and folder for GoldMine to retrieve linked documents only to the default directory. If you did not assign a directory in the default drive and folder, the default directory is the $x:\SYSDIR directory\TmpLinks$; typically, the SYSDIR directory is the GoldMine directory.

**IMPORTANT:** The Search for the original folder name on the drives I've specified ONLY option is very important for undocked users who have a server share or mapped drive available. If this option in not checked, the document will remain on the original location and will not be available on the undocked user’s machine.

- Continue configuring the linked document settings by selecting Allow new linked documents to sync by default for new linked documents to automatically synchronize.
- Select Backup existing files prior to overwriting them during retrieval (As .BAK files) for GoldSync to place a document in a directory where there is already a file with the same name; this option instructs GoldSync to rename the existing file with an extension of .bak. After the old file is renamed, the new file is saved. This setting can be over-ridden by the sync settings for the Site.

**Timeouts**
- Configure the Internet timeout settings.
- Type or select the Handshake timeout (sec). The handshake setting (the electronic protocol exchanged between two systems when establishing a connection) determines the number of seconds GoldMine or GoldSync waits to complete a handshake routine before disconnecting. The default value is 20 seconds.
- Type or select the Connection timeout (sec). The connection setting determines the number of seconds GoldMine or GoldSync waits after an interruption in the transmission to continue receiving status data before disconnecting. The default value is 60 seconds.
- Click set Set Defaults to return all time-out settings to their original default settings.

**NOTE:** The Set Defaults setting can have a maximum of 600 (sec) for the Handshake timeout and 120 (sec) for the Connection timeout.

**GoldSync**
- This tab is available only when GoldSync is installed on your computer. Configures the notification settings if GoldSync appears to fail.
  - Send an E-mail if a synchronization error occurred. Activates the e-mail notification options.
  - E-mail error messages to this address. Type the e-mail address of the person to notify. Use your address or the address of the GoldSync administrator.

**GoldSync Service**
- When your GoldSync server is running on computer with a Windows 2003/2008/2012 Server, you can run GoldSync as a Service. A service is an application type that runs in the background.

  Running GoldSync as a service provides added security by eliminating the need to log onto the computer to start GoldSync. It also saves administrative time since the service can be configured to restart whenever the operating system on the computer starts, thus avoiding the task of manually starting GoldSync.

  Install, start, and configure the GoldSync Service from the GoldSync Administration Center toolbar, but use the GoldSync Service tab to manage the service without launching the GoldSync Administration Center.
  - Set up GoldSync as Service: Installs the service.
  - Uninstall GoldSync Service: Removes the service.
  - Configure GoldSync Service: Launches the GoldSync Services Settings dialog box where you start, stop, and automatically start the service.

**NOTE:** To use the GoldSync Service feature on Windows 8, Windows 7, or Vista you must launch GoldMine using the Run As Administrator option.

3. Click OK to save the Synchronization Settings.
Using the GoldSync Administration Center

To start the GoldSync Administration Center, you must have GoldMine installed, running, and licensed with the correct licenses (E-license, S- and Y-licenses). Systems with U-licenses do not have access to the GoldSync Administration Center. The GoldSync Administration Center is the point of access for the site groups, sites, servers, and processes servers perform as defined for each site group.

1. Select Tools > Synchronize > GoldSync Administration Center.
2. At the GoldSync Administration Center window, configure or edit these settings using the wizards:
   - **Site Group Wizard**: Creates a site group with the connection method and transfer set you select. See "Creating Site Groups" on page 311.
   - **Site Group Member Wizard**: Adds members to the newly created site group ("Creating Sites" on page 309).
   - **Server Wizard**: Adds servers synchronizing with remote sites ("Creating Servers" on page 313).
   - **Process Wizard**: Defines the processes performed for the site ("Creating Server Processes" on page 315).
3. After configuring various aspects of the GoldSync Administration Center, use the toolbar, the Site local menu, and the Servers local menu to manage and edit the functions.
4. For synchronization to work automatically, you must start the processes. Expand Servers, the server name, and the server process. Highlight the process to start, right-click, and select Start to initiate the selected process or AutoStart On for GoldSync to run automatically during the times designated in the Server Agents Administrator.

   **NOTE**: You must start the processes in the GoldSync Administration Center of the computer running the synchronization processes.

   **TIP**: GoldSync can be also be run as a service (see "Configuring GoldSync as a Service" on page 317).
Creating Sites

Sites are Site Group Members. They commonly have the same communication method and similar settings in the Site Group. Customize site send and retrieve options and filters.

There are two ways to create sites in the GoldSync Administration Center: after you create the Site Group or from the local menu.

1. In the **GoldSync Administration Center**, right-click a site group folder and select **New**.
2. At the **New Site Group Member** dialog box, select one of these options:
   - **Undocked User**: Select the undocked user from the drop-down list. The list includes undocked users created in the License Manager. If the undocked user does not exist, see "Creating Undocked User License" on page 380.
   - **Sub-License**: Select the site from the drop-down list. The list includes sites created in the License Manager. For more information see "About Sub-licenses" on page 378.
   - **Other License**: Type the license serial number in the text boxes.
3. Click **OK**.
4. At the **Welcome to the GoldSync Site Wizard** dialog box, type a name for the site.
5. Select **Allow this site to synchronize** to make the site active for synchronization after configuring it. and click **Next**.
6. To make the site belong to a different group, select the **Site Group** from the drop-down list. and click **Next**.
7. The **Cutoff Date/Time** dialog box appears.
8. Select **Ignore cutoff time (send all records)** to send records. This option is available if you selected **ALL changed contact records** on the Send Contact-related Options dialog box.
9. Select **ALL contact records' cutoff** date and time to include new and changed data from the cutoff date you type or select from the F2 Lookup graphical calendar and clock. This option is available if you select **ALL changed contact records** or **All filtered records and user-scheduled activities' records** on the Send Contact-related Options dialog box.
10. Select **Contact records linked to Activities cutoff** date and time to include new and changed data linked to activities scheduled from the cutoff date and time. This option is available if you select **Contact records linked to the 'Send users' calendar list** or **All filtered records and user-scheduled activities' records** on the **Send Contact-related Options** dialog box.
11. Select the **Deletion-Filter** from the drop-down list. This option applies the deletion filter for a single synchronization and then clears the filter selection.

   **NOTE**: When deleting a record on the remote site through a deletion filter, the deletion is not recorded as a change in the database. This prevents the deletion from synchronizing back to the host and lets the record synchronize back to the remote, if necessary.

12. Click **Next**. The Override Options dialog box opens, unless configuring a shared directory site (in this case, the Next Synchronization Options dialog box opens).

Configuring the GoldSync Site Group Override Options

Unless configured differently, each site group member synchronizes according to the settings entered for the GoldSync Site Group. However, you can modify settings for a site in the **GoldSync Override Options** dialog box of the **GoldSync Site Group Member** wizard.

The **Overrides Options** allows you to override the group settings for the current site. To configure special settings for a particular site, check the necessary options on the Override Options screen. For example, if you are creating a site where you want a number of retries before failing a sync session, at the Overrids Options window select the **Number of retries before failing the sync session** option. The wizard will move you to the appropriate window in which you can choose the number of retries needed.
To Navigate to the Override Options

1. At the GoldSync Administration window select a Site and click Properties.

2. Click Yes at the message. The GoldSync Site Wizard opens.

3. Navigate through the wizard to the Overrides Options window and select from the list of options.

- General Settings
  - Connection/transfer set password
  - Logging Options

- Sending transfer sets settings
  - Send changes to remote
  - Transfer set creation types
  - The selected contact sets to send to remote
  - Transfer set record type creation options
  - Filter used for transfer set creation

- Retreiving transfer set settings
  - Receive changes from remote
  - Default contact set to retrieve changes info
  - The selected contact sets to retrieve from remote
  - Transfer set record type retrieval options
Intervals and synchronization frequency
- Successful synchronization session interval
- Failed synchronization session interval
- Active period of this site
- Number of retries before failing the sync session

Depending on the choices you make, the wizard will move you to the appropriate window on which you can make the necessary selections.

4. Click Next and then select Finish to the GoldSync Administration Center.

Creating Site Groups

Use the Site Group Wizard to set up site groups (the first step in configuring GoldSync). Configuration options you set for the group are inherited by each group member you add to the group. Using the Site Group Wizard, set the connection method, synchronization method and intervals, and the method by which transfer set data communicates between the remote site and the server and vice versa.

1. Select Tools > Synchronize > GoldSync Administration. The GoldSync Administration Center appears.
2. Right-click on Site Groups and select New. The Welcome to the Site Group Wizard dialog box appears.
3. Type a descriptive name for the site group and click Next. The Synchronization Method dialog box appears.
4. Select either:
   - In the Connected Methods (IP to IP/Network) area, select an option:
     - Accept an incoming connection: The server accepts the initial request for data via modem, Internet direct, or network.
     - Initiate an outgoing connection at set intervals: The server transfers data at a specified time. The interval is set by the user.
   - In the Non-connected Methods (Internet: E-mail, Shared Directories) area, select an option. Data transfer occurs without an active connection between the GoldSync Administration Center and the remote sites, using an Internet e-mail account or shared directory to transfer information:
     - Send and retrieve transfer sets via E-mail: The transfer set creates in advance and transfers by e-mail.
     - Synchronize with another GoldSync server via shared directories: Uses defined paths to directories for depositing and retrieving transfer sets.
5. Click Next. The General Options dialog box opens.

Configuring the General Options (Site Groups)

In the General Options set the send and retrieve, password, and log information.

1. Select Send changed data to site group’s members to let GoldSync accept a request from a remote site to create a transfer set.
2. Select Retrieve changed data from site group’s members to let GoldSync retrieve a transfer set from the remote site.
3. Type an Optional connection password requiring remote users to enter a password when connecting to the server.
4. In the Log Options area, select from:
   - Log the details of each synchronization session. Records Process Monitor information in the GoldMine system logs.
   - Log the transfer set details for the records sent/retrieved. Records changes made to synchronized records.

   **NOTE:** If information is stored for every synchronization session, the log information storage file could grow very large. Unless you are troubleshooting a sync issue, we recommend disabling log options.
5. Click Next.
   - If you selected **Accept an incoming remote connection** and **Send changed data**, the Transfer Set Creation Method dialog box opens. See "Configuring the Transfer Set Creation Method" on page 312.
   - If you selected another synchronization methods, and selected **Send changed data**, the Send Options dialog box opens. See "Configuring Send Options" on page 324.
   - If you selected only **Retrieve changed data**, the Retrieve Options dialog box opens. See "Configuring the Retrieve Options" on page 312.

**Configuring the Transfer Set Creation Method**

Use the Transfer Set Creation Method dialog box to determine if the transfer set is created while the remote site is connected or to have the transfer set created in advance for the remote site to pick up.

1. Select an option:
   - **Generate transfer set while site group member waits online.** When the remote sites initiate synchronization, they wait online while the transfer set is built and sent to them.
   - **Generate transfer set in advance for site group member(s) to pick up.** Your system generates the transfer set in advance and stores it in a shared directory. When the remote sites initiate synchronization, they stay online long enough for to send the transfer to them.

2. Click Next. The Send Options dialog box appears. See "Configuring Send Options" on page 324.

**Configuring the Retrieve Options**

The Retrieve Options determine what is considered for addition to the database when retrieving a transfer set from another system.

If you select either **Retrieve a transfer set** from the second dialog box of the Synchronization Wizard or **Retrieve changed data from remote** from the Connect/Send E-mail to Remote or Wait for an Incoming Connection dialog boxes, GoldMine opens the Retrieve Options dialog box.

1. In the **Retrieve record types** area, select the record types to retrieve from a remote site. By default, all record types are selected (except when setting up goldsync).
   
   **NOTE:** If you want to synchronize Users to remote users, select the **Users** option. You will also need to set the Send Records Type for Users in the "Configuring Send Options" on page 324 to allow both retrieving and sending of data to the remote users.

   **NOTE:** If you are a main site, clear many of the customization types unless retrieving from a remote site responsible for GoldMine customization.

2. In the **Retrieve users' calendar** area, select one or more users whose calendar activities you want to retrieve. To retrieve calendar activities for all users, select (all).
   
   **TIP:** History items are treated as user calendar items, and are only synchronized between users when user calendars are synchronized.

3. Click Next. The Retrieve Contact Sets dialog box opens (see "To Configure the Retrieve Contact Set Options" on page 313).

**To Force the Override of Tlogs**

The **Force overwrite of values with missing t-logs** option in the Retrieve record types area is used to force an update for records that are included in a transfer set based on the RECID value. These are records for which the t-logs have been purged as a result of routine maintenance. This option ignores any existing t-logs and forces the record update.
NOTE: It is recommended that one computer be designated as the primary host; this option should be set only at the computers connecting to the primary host, and not on the primary host.

WARNING: This option can update recently entered data. For example, when a contact record that does not have t-logs is modified at the remote. Normally, this change would update the central host. However, if the cutoff date at the host has been back-dated to include the original contact record, the host contact would be updated with the remote changes and the remote contact would be updated to the original record.

To Configure the Retrieve Contact Set Options

Select which multiple contact sets to synchronize.

1. In the Please specify which contact sets you wish to retrieve from the remote site area, select the contact sets to retrieve.
2. In the Default Contact Set area, select the Contact Set in the drop-down list. This is the Contact Set to retrieve data into if there is no matching file code from the incoming transfer set.
3. Click Next. If you selected:
   - Answer an incoming connection on the connection method dialog box, the Ready to Synchronize dialog box opens.
   - Connect to remote, the Connect/Send E-mail to Remote dialog box opens.

To Synchronize a Record After Purging T-logs

Suppose you are synchronizing a record after you purged t-logs. You don’t have enough information to do a field level sync, you can only do a record level sync.

On the retrieving side you have two options:

- Assume that the copy of the record you have is the same or newer than the one that comes with transfer set and ignore the record from transfer set. This is the old and the default behavior.
- Assume that the copy of the record from transfer set is newer than yours and overwrite your copy with the version from transfer set. This is what is done with “Force overwrite” option. The main use case is when you are trying to bring an undocked computer to be in sync with the server. Your undocked computer might have been out of service for a few months and you no longer have all t-logs.

Creating Servers

A GoldSync Server is any computer handling the synchronization processes. It can be any computer on the network running a network copy of GoldMine.

For example, your main GoldMine Server might not have a modem. Rather than installing a modem, assign another computer on the network that does have a modem as the GoldSync Server. Each GoldSync Server assumes the computer name as the server name.

You can designate more than one computer on your network as a GoldSync Server. Have one server for IP/Network synchronization and one for e-mail synchronization.

NOTE: The GoldSync Server computers must have proper resources for the processes they are running.

TIP: Because GoldSync is resource-intensive, we recommend dedicating a server to executing GoldSync processes, especially when many users are synchronizing throughout the day. Creating transfers for multiple users and managing multiple connections uses a significant amount of the system’s memory, processor, and hard disk capacity.
To Create a Server

1. In the GoldSync Administration Center, right-click on Servers and select New. The Welcome to the Server Wizard dialog box appears.
2. Type or browse to the name of the server to make a GoldSync Server.
3. Click Next. The available processes dialog box appears.
4. Select the processes to assign to the server.
   - IP to IP/Network: Accepts incoming remote connections
   - IP to IP/Network: Initiates remote connections.
   - E-mail: Scans for incoming transfer sets.
   - E-mail: Sends outgoing transfer sets.
   - Shared Paths: Creates/retrieves transfer sets created in advance.
5. Click Next. The Finish dialog box appears.
6. Click Finish and the Welcome to the Process

Cloning Site Settings

Cloning site setting to create site group members with the same or similar settings.

1. In the GoldSync Administration Center, highlight the site you are using a baseline, right-click and select Clone. The New Site Group Member dialog box appears.
2. Select or create the new undocked user to whom you are assigning the cloned settings.
3. Click OK.
   The Welcome to the GoldSync Site Wizard dialog box opens. Wizard settings are based on the source site's configuration. Keep the defaults or make necessary changes using the Override options.

To Use the Date/Time Stamp Conversion Utility

You might need to view date and time stamps in a regular date format. The utility converts the seven-character SyncStamp, LogStamp, or the first seven digits of the RecID to a standard date and time format; or it converts a standard date format to a stamp format.

TIP: Use this utility while troubleshooting synchronization issues to verify the date and time in the Tlogs of unpacked transfer sets and compare the information to that in the database.

1. Select Tools > Synchronize > GoldSync Administration Center. The GoldSync Administration Center window appears.
2. Right-click the Site Group and Server area and select Date/Time Stamp Conversion.
   The Date/Time Stamp Conversion dialog box opens.
3. In the Conversion Method area, select one:
   - Date and Time > Sync Stamp: Converts the date you select from the F2 Lookup calendar and the time from the F2 Lookup graphical clock to a date stamp format.
   - Sync Stamp > Date and Time: Converts a date stamp to a standard date and time format.
4. After selecting the date and time or typing the sync stamp, click Convert. The conversion displays in the Results area with your initial input on the left and the conversion to the right of the arrow. The results box displays multiple results so you can track the time stamps you are researching.
5. Click Cancel to close the dialog box.
Creating Server Processes

Use the Process Wizard to configure processes you are running on the GoldSync Server.

1. In the GoldSync Administration Center, right-click on the server name and select New from the local menu. The New Process dialog box appears.

2. Select the Server and the Process Type from the drop-down lists.

3. Click OK. The Welcome to the Process Wizard dialog box appears.

4. The Welcome to the Process Wizard dialog box displays the Server Name and the Process Type you are configuring. (If you are continuing from the Server Wizard, you start on this dialog box.)

5. The Process Name displays the process you are configuring. Click Next.

   - If configuring IP to IP/Network or Shared Directories, the Number of Connections dialog box appears. See "Configuring the Number of Connections" on page 315.
   - If configuring E-mail: Scan for incoming transfer sets, the Incoming E-mail Settings dialog box opens. See "Configuring Incoming E-mail Settings" on page 315.
   - If configuring E-mail: Sends outgoing transfer sets, the Outgoing E-mail Settings dialog box appears. See "Configuring Outgoing E-mail Settings" on page 315.

Configuring the Number of Connections

The Number of Connections dialog box appears when configuring IP/Network and Shared Directories processes.

1. Select the maximum number of concurrent connections. This option controls the number of remote users who can connect at one time.

   **NOTE:** If you have the maximum number of concurrent connections set to 5, only 5 remote users can connect at one time. The next user is refused a connection until there is an open slot. This option prevents your server from running out of resources.

2. If necessary, type another port number in the Wait for incoming Internet connection at TCP port field.

3. Click Next. The Active Period dialog box appears.

Configuring Incoming E-mail Settings

1. In The Host name of the inbound (POP3) mail server field, type the name of the POP3 server.

2. Select The Frequency period to check for e-mailed transfer sets by clicking the browse button (...). The Synchronization Frequency dialog box appears. Select the days, hours, or minutes.

3. Type the User Name and Password for the e-mail account retrieving the transfer sets.

4. Click Next. The Active Period dialog box opens. See "Configuring the Active Periods for Synchronization" on page 316.

Configuring Outgoing E-mail Settings

1. Type The Host name of the outbound (SMTP) mail server in the text box.

2. Type The return E-mail address for the outgoing transfer set.

3. Click Next. The Active Period dialog box opens. See "Configuring the Active Periods for Synchronization" on page 316.
Configuring the Active Periods for Synchronization

The Active Periods dialog box defines the days and hours the process is active.

1. On the Active Period dialog box, select *Start this sync process automatically if the GoldSync Agent detects the current time...* to use the GoldSync Server Agent to start the process automatically.
2. Select the active days.
3. Select the active beginning and ending time using the F2 Lookup clock.
4. Click **Next**. The Finish dialog box opens.
5. If configuring an Accept incoming connection process, click **Finish** to complete the process construction. If configuring an Initiate remote connection process, type a Site Code in the text box. 
   
   **NOTE:** Assign multiple site codes to a process, separated by a space. A site can be assigned only one site code.
6. Click **Finish**. The process adds to the GoldSync Administration Center.

If you need to view date and time stamps in a regular date format, see "To Use the Date/Time Stamp Conversion Utility" on page 314.

Synchronization Verification Codes

Verification codes are a security measure ensuring remote users do not change their synchronization profile without the GoldSync administrator's knowledge. If the remote user receives a message that his or her Verification Code is invalid, the GoldSync Administrator must generate another and send it to the remote user.

1. In the **GoldSync Administration Center**, select the site needing a new Verification Code and right-click. Select Generate Verification Code. The Generate Verification Code dialog box appears.
   
   The Verification Code generates.
2. Copy the number and click **OK** to close.
3. Send the remote site the code.
   
   The remote site types in the new verification code (the code remains valid until the remote user tries using another profile).

Running GoldSync as a Service

When your GoldSync server is running on a computer with Windows 2012 Server, Windows 2008 Server, Windows 2003 Server or Windows XP Server operating system, run GoldSync as a Service. A service runs an application in the background. Running GoldSync as a service provides added security by eliminating the need to log on to the computer to start GoldSync. Saves administrative time by configuring the service restart whenever the operating system on the computer starts.

Use the GoldSync Administration Center toolbar options for installing, starting and configuring, and uninstalling the service.

Also configure GoldSync as a service in the Synchronization Settings dialog box.

**To Run GoldSync as a Service**

1. On the GoldSync Administration Center toolbar, click the **Set up GoldSync as a service** button.
2. A dialog box opens indicating the GoldSync Service was created successfully.

   **NOTE:** After installing GoldSync as a service, but before starting the service, change the GoldSync Service logon from Local System account to This account. In the Services management window, right-click GoldSync Service and select **Properties > Log On**. Select This account and configure the logon information using a Windows account with full access rights on the GoldSync computer and to the shared mapped or UNC locations where your linked documents are stored.
Configuring GoldSync as a Service

You can access GoldSync Services configurations using either of the following methods:

- On the GoldSync Administration Center toolbar, click the **Configure GoldSync Service** button.
  The GoldSync Services Settings dialog box opens.

- Select **Tools > Synchronize > Synchronization Settings**. The Synchronization Settings dialog box opens. Click the GoldSync Services tab and Configure GoldSync Service.
  The GoldSync Services Settings dialog box opens.

  **NOTE:** After installing GoldSync as a service, but before starting the service, change the GoldSync Service logon from Local System account to This account. In the Services management window, right-click GoldSync Service and select **Properties > Log On**. Select This account and configure logon information using a Windows account with full access rights on the GoldSync computer and to the UNC locations where linked documents are stored.

  **NOTE:** To use this feature on Windows 8, Windows 7, Vista, Windows 2012, or Windows 2008 you have to launch GoldMine using the **Run As Administrator** option.

### Important Consideration

GoldSync service does not see mapped drives. For example, if GoldMine was installed into the existing database and you defined the server path as a mapped location (e.g. `G:\Goldmine`), then GoldSync service is started with an error. GoldSync service will not find any linked documents or attachments written through mapped drives (e.g. `G:\GoldMine\picture.jpg`). So, the files will not be synchronized with GoldSync service.

Use UNC path instead of mapped, or you can edit the `gm.ini` file manually:

- Find ‘realini=’ and ‘sysdir=’ entries:
  ```ini
  realini=G:\GoldMine
  sysdir=G:\GoldMine
  ```

- Replace with your UNC path
  ```ini
  realini=\yourhost\GMPath
  sysdir=\yourhost\GMPath
  ```

### To Configure GoldSync as a Service

1. Select the server running GoldSync in the Server drop-down list.
2. Click **Start** or **Stop** to start or stop the service.
3. Select **Automatically start as a service** whenever this computer boots up to start the service.
   The Status box displays indicates whether the service is running.
4. Click **OK** to exit the dialog box.

### To Uninstall GoldSync as a Service

On the GoldSync Administration Center toolbar, click the **Uninstall GoldSync service** button.
A dialog box appears indicating the GoldSync Service was successfully uninstalled.
Adding the Users Table as an Option for Sync

1. On the Server, open the **Tools** menu and select **Synchronize > GoldSync Administration**.
2. On the GoldSync Admin Center, right-click on the sync site and select **Properties** from the local menu (see "GoldSync Sites Local Menu" on page 305).
   The Site Group Wizard opens.
3. Click **Next** 3 times until you reach the **Sync overrides** screen.
4. Select **Send undocked user’s securities and password** and then click **Next**.
5. Verify that the Undocked user’s information and corresponding securities and password check boxes are checked below in Send Options area.
6. Finish the wizard.

Adding Macros to the GoldSync.ini File

In the **GoldSync.ini** file, you can create and modify a section that contains a string of macros that run when GoldMine is synchronized with Outlook. These macros are used to control the formatting of the activity Subject.

The default string is:

```
<<&user>>, <<&contact>>, <<&company>>, <<&phone>>, <<&emailaddress>>, <<&fulladdress>>
```

Below is an example of the string used in the **GoldSync.ini** file

```
[OutlookSync]
CalSubjectPattern= contact=<<&contact>>, user=<<&user>>,, <<&company>>, <<&phone>>, <<&emailaddress>>, <<&fulladdress>>
```

**NOTE:** You can change the order or add your own words which will be stored and shown in the subject.

Regarding Multiple Contacts and Multiple Users

- If the activity has **multiple contacts**, the **CalSubjectPattern** is ignored and the text “multiple contacts” is inserted in its place.
- If the activity has **multiple users**, the settings for the user is ignored and the text “multiple users” is inserted in its place.

The following example demonstrates how the string of macros display in GoldMine:

```
Categories: Appointment (7 items)
 multiall [Regarding: Multiple users, Multiple contacts]
 multicontacts [Regarding: ALEX, Multiple contacts]
 multicontact [Regarding: user=ALEX, contact=AddContact, Super company national limited, 555-222-666-9897, PrimEm@
 primecont [Regarding: user=ALEX, contact=Primary cont, Super company national limited, 555-222-666-9897, PrimEm@S

User Macros

For the User, you can select from the following macros:

- **<<&user>>**
- **<<&userfullname>>**
Contact Macros

For a Contact, you can select from the following macros:

- `<<&Address1&2>>`
- `<<&CityStateZip>>`
- `<<&FullAddress>>`
- `<<&Name&Address>>`
- `<<&&Title&Address>>`
- `<<&&Company&Address>>`
- `<<&Phones>>`
- `<<&Phone>>`
- `<<&&FAX>>`
- `<<&Contact,Company>>`
- `<<&Company,Contact>>`
- `<<&Contact>>`
- `<<&Company>>`
- `<<&EMailAddress>>`

About One-Button Synchronization

When enabled on the remote GoldMine system, one-button synchronization gives the undocked, remote user a single-step synchronize process. Because the remote user cannot modify synchronization settings, the organization increases data security and enhances control of information access for each synchronizing remote system. One-button synchronization lets the GoldSync administrator:

- **Create one-button synchronization profiles** for each remote system running one-button synchronization. See "Creating One-Button Synchronization Profiles" on page 320.
- **E-mail the one-button synchronization profiles** to remote, undocked users. See "E-mailing One-Button Synchronization Profile to Remote" on page 322.
- **Create an undocked installer** to install GoldMine on the remote system with the one-button synchronization profile (new GoldMine user). See "Creating Installation Files for One-button Synchronization" on page 323.

After created and sent, the remote user can:

- **Retrieve the one-button synchronization profile**. See "Retrieving One-Button Synchronization Profiles" on page 321.
- **Retrieve the undocked installer file**. See "Retrieving One-Button Synchronization Installation Files" on page 323.
- **Synchronize using one-button synchronization**. See "Synchronizing Using One-Button Synchronization" on page 319.

Synchronizing Using One-Button Synchronization

The GoldSync administrator configures one-button synchronization profiles and sends them to remote users. Once installed, the profile streamlines the remote, undocked user synchronization process.

1. Select **Tools > Synchronize > One-button sync with GoldSync Server**. The **One-button Synchronization** dialog box opens, indicating the GoldSync administrator has configured your system for One-button Synchronization.
2. Click **Sync**. The **Process Monitor** opens, indicating synchronization status.
Creating One-Button Synchronization Profiles

Use the One-button Sync Profile Wizard option after creating site group members or from the GoldSync Administration Center Sites local menu. One-button synchronization profiles include the Instant Sync option (see "Configuring Synchronization Settings" on page 306) to remind undocked users to synchronize when it detects a network connection.

To Create a One-Button Synchronization Profile

1. In the GoldSync Administration Center, highlight the site, right-click and select New One-button Sync Profile. The Welcome to the GoldSync Site One-button Sync Profile Wizard dialog box appears.
2. Type the descriptive name of the profile in the text box. Click Next.
3. Enter the remote site’s E-mail address.
   To restrict synchronization access to the One-button sync profile, check the Disable remote site’s access to the ‘Synchronization Wizard’ option.
5. Select a synchronization connection method:
   - Connect to remote using IP to IP/Network method.
   - Send a transfer set to remote by E-mail.
   For more information, see "Retrieving One-Button Synchronization Profiles" on page 321.
6. Click Next. The Connect/Send E-mail to Remote dialog box opens.
   - Check the desired send and retrieve options.
   - Enter the Remote’s Internet IP address and port assignment or E-mail address
   - Enter an optional password.
   For more information, see "To Configure Connect/Send E-mail to Remote (Connect to Remote)" on page 321 and "To Configure Connect/Send E-mail to Remote (Transfer Set by E-mail)" on page 321.
7. Click Next. The Send Options dialog box opens.
   - Check the desired Send Record Types and Send user’s calendar options.
8. Click Next. The Send Contact-related Options dialog box opens.
   - Specify the type of Contact Records to send to the remote site.
   - Specify the Contact Sets to send to the remote site.
9. Click Next. The Send Filter Options dialog box opens.
   - Select one of the Filters from the drop-down list.
   - To you want to exclude filtered records previously stored in the last synchronization session with the current transfer set for this remote site, check the Reset Auto-Territory Realignment feature option.
10. Click Next. The Cutoff Date/Time dialog box opens.
   - If you want to ignore cutoff time, check the Ignore cutoff time (send all records) option.
   - If you want to use a cutoff time, enter a cutoff date and time.
11. Click Next. The Retrieve Options dialog box opens.
   - Check the desired Retrieve Record Types and Retrieve user’s calendar options.
12. Click Next. The Retrieve Contact Sets dialog box opens.
   - Specify the type of Contact Set to retrieve from the remote site.
   - Specify the default Contact Sets when the set is not specified.
13. Click Next. The Ready to Synchronize dialog box opens.
14. Check the desired Logging Options and then click Finish to save the profile settings.
To Configure Connect/Send E-mail to Remote (Connect to Remote)

Set connection options when selecting Connect to remote on the connection method dialog box.

1. Select **Send changed data to remote** to send changed data from this site to the remote.
2. Select **Retrieve changed date from remote** to retrieve changed date from the remote to this site.
3. In the **Remote's Internet IP Address** text box, type the Internet IP address you are connecting to. If creating a one-button synchronization profile, the remote in this case is the GoldSync server the undocked computer is synchronizing with.
4. Type the **TCP Port**. The default TCP Port is 5993. Typically, do not change this entry; if you override the default port, you must select the same port as the remote system.
5. Click the **IP** button to add or edit alternative IP addresses.
6. Type the **Optional connection password** in the text box.
7. Click **Next**. If you selected Send changed data to remote, the Send Options dialog box appears.

To Configure Connect/Send E-mail to Remote (Transfer Set by E-mail)

When selecting Send transfer set to remote by E-mail on the connection method dialog box, you can then send the e-mail options.

1. Type the Remote's E-mail address in the text box.
2. Type the **Optional connection password** in the text box.
3. Click **Next**. The Send Options dialog box appears. See "Configuring Send Options" on page 324.

Retrieving One-Button Synchronization Profiles

When the GoldSync administrator creates or makes changes to your One-Button Synchronization Profile, they can e-mail you the profile. One-button synchronization profiles include the **One-button Sync** option (see "Configuring Synchronization Settings" on page 306) to remind undocked users to synchronize when it detects a network connection.

To Retrieve One-Button Synchronization Profiles in the GoldMine E-mail Center

1. In the GoldMine E-mail Center, double-click on the e-mail message with the subject line of **One-button Sync Profile**.
2. A GoldMine message box appears, indicating the message has a sync profile attached. Click **Yes**.
3. The profile installs. The **One-button Sync with GoldSync Server** menu option becomes active. Use One-button Sync with the GoldSync Server.
To Retrieve One-Button Synchronization Profiles From Another E-mail Client

If an undocked user is using another e-mail client (such as Outlook), the One-Button Synchronization Profile appears as an attachment. The attachment can be saved to the hard drive and retrieved through the Synchronization Settings dialog.

1. Save the One-Button Synchronization Profile attachment to your hard drive (for example: create a \Profile directory in the \GoldMine directory).
2. In GoldMine, open the Tools menu and select Synchronize > Synchronization Settings.

   ![Synchronization Settings dialog](image)

3. On the One-Button Sync tab, enter the location or browse to the location of the saved One-Button Synchronization Profile transfer set file.
4. Click Update to retrieve the transfer set.

   The sync profile includes the date and time of its creation. If an undocked user tries to retrieve an earlier profile the following error message displays:

   “A newer One-button Sync Profile has been found. To change your Profile settings contact the GoldSync administrator.”

E-mailing One-Button Synchronization Profile to Remote

The GoldSync administrator can create or change a site’s One-Button Synchronization Profile and e-mail it to the remote user.

1. In the GoldSync Administration Center, highlight the site, and right-click. Select E-mail One-button Sync Profile to Remote from the local menu.
2. A confirmation dialog box opens. Click Yes to e-mail the profile to the remote.

   The profile is e-mailed to the e-mail address in the One-button Synchronization Profile.
Creating Installation Files for One-button Synchronization

With One-button Synchronization Profile, create an installation file containing fields and data for a new remote user.

**NOTE:** To use this feature on Windows 8, Windows 7, Vista, Windows 2012, or Windows 2008 you have to launch GoldMine using the **Run As Administrator** option.

**NOTE:** Create a synchronization profile for the user before creating an installation file.

1. Highlight the site in the GoldSync Administration Center and select **Create Installation File for One-button Synchronization**.
   The Create Undocked User(s’) Installation Files dialog box opens.

2. Select the user or users for whom you are creating the installation files.
   **NOTE:** Process up to five undocked sites simultaneously. If more than five sites must be processed, GoldSync queues the additional sites until resources are available.

3. Click **OK**.
   - If the **gmsetup.exe** is not in the default location, browse to the correct location. If you cannot locate the .exe in the GoldMine directory, copy the file from the installation CD-ROM.
   - If the **gmsetup.exe** file is in the default location of \GoldMine\Setup\GoldMine then the Process Monitor displays the status of the creation process. GoldSync creates installation files and initial transfer sets based on the profile settings.
   **NOTE:** Creation of the initial transfer set can be time consuming. GoldSync ignores the cutoff date defined in the user’s synchronization profile for these tables and includes all records. The tables are: **Fields, ContUdef, Lookup, Users, InfoCenter, and Resources**.

4. The installation file is placed in the GoldMine directory, \GoldMine\Setup\Remotes\.

5. As the GoldSync administrator, distribute the file to the remote site using these methods:
   - Zip disk
   - CD-ROM
   - FTP
   - E-mail via file attachment

6. The file must be retrieved on the remote computer.
   It installs GoldMine based on the undocked user license for the site, copies the data, and installs the One-button Synchronization Profile.

Retrieving One-Button Synchronization Installation Files

As a remote user, when you receive the Undocked Installer package, install GoldMine by running the installer, named **username.exe** for the remote/undocked user.

The Undocked Installer package installs GoldMine using the undocked user license for your site, copies the data and files selected by the GoldSync administrator, and sets up the configured synchronization profile.

1. Locate the file sent to you on a zip disk or CD-ROM, using FTP, or e-mailed as an attachment. The file is named **username.exe**, where username is your GoldMine user name.

2. Open the file. It extracts the necessary files to the folder defined by the system’s Windows Temp variable, usually C:\Windows\Temp.

3. After files are extracted, the Undocked Installer installs GoldMine and imports the data.
Configuring Send Options

1. Use the **Send Options** dialog box to determine what data to include in the transfer set (a database of all changes made to GoldMine contact records during a specified time frame that is sent to other GoldMine locations and retrieved, updating that database with the new information).

2. In the **Send Record Types** area, specify record types to include in the transfer set.
   
   **NOTE:** Selecting a record type in the send options includes it in the transfer set; however, this does not guarantee the data will be retrieved at the retrieving site.

   **TIP:** If a User is added, deleted, or modified on the server, checking the **Users** option under **Customization** will propagate these changes to a remote undocked site. This option is only available for U and S Licenses. Also be sure that the remote users have retrieval rights by checking the **Users** option in the **Retrieve Options** on the Synchronization Wizard for the remote site (see "Configuring the Retrieve Options" on page 312).

3. In the **Send users' calendar** area, select one or more users whose calendar activities should be included in the transfer set. To include the calendar activities of all users, select **(all)**.
   
   **NOTE:** For the user name(s) to be made available in the drop-down list of the remote's calendar, the user names(s) must be synchronized with the Users database. Add user names in the Users Master File. History items are treated as user calendar items, and are only synchronized between users when user calendars are synchronized.

4. Select your **Encryption level** in the drop-down list. All transfer sets are encrypted at 128 or 32 bits.

5. Click **Next**. The Send Contact-related Options dialog box opens (see "To Configure Send Contact-Related Options" on page 324).

To Configure Send Contact-Related Options

After configuring the Send Options (see "Configuring Send Options" on page 324), use the Send Contact-related Options dialog box to evaluate records and send all new or changed contact records, send records based on whether they are linked to the names in the Send Users' calendars area of the Send Options dialog box, or all filtered records and records linked to selected users' activities.

1. In the upper drop-down list select one option:
   
   - **Only the current contact record**: (Available only in the Synchronization Wizard - see "About the Synchronization Wizard" on page 297). Includes all the data, without regard to a cutoff date, for the active Contact Record only.
   
   - **All changed contact records**: Includes all new or changed records since the cutoff date in the transfer set.
   
   - **Contact records linked to the 'Send user's calendar' list**: Includes all new or changed records linked to the users selected in the users' calendar send options and then evaluates those records for changes since the cutoff date.
   
   - **All filtered records and user scheduled activity records**: Includes records that meet your filter criteria and those that do not fit the filter but have scheduled appointments linked to users selected in the Send users' calendar list.

2. In the **Please select contact sets you wish to send to the remote site** area, select the Contact Set or sets to include in the transfer set.
   
   **NOTE:** When synchronizing multiple databases, they should have file codes. The database codes should be same on the remote and on the main site.

3. Click **Next**. If you selected:
   
   - **Only the current contact record**, the Retrieve Options dialog box appears.
   
   - **All changed contact records, Contact records linked to the 'Send user's calendar' list, or All filtered records and user scheduled activity records**, the Send Filter Options dialog box appears (see "To Configure the Send Filter Options" on page 325).
To Configure the Send Filter Options

Use the **Send Filter** to limit the number of records included in a transfer set the same way a filter limits the number of Contact Records you are working with in GoldMine. The filter must already exist in the Filters and Groups dialog box before you can apply it to the synchronization process.

1. Click the drop-down list to select **All Contact Records** or select records based on a filter owned by the user.
2. To select a different user, click `<Filters of: username>`. The Select a User dialog box appears. Select the user in the drop-down list and click **OK**. Once a different user is selected, the user's filters and the public filters display.
3. Select **Reset Auto-Territory Realignment** to send both records selected by your old filter and records selected by your new filter. This enables GoldMine to hold old records for one last synchronization; then you can send a deletion filter to remove unwanted records.
4. Click **OK** to return to the Send Filter dialog box.
5. Click **Next**. If you are:
   - Using Synchronization Wizard, the Cutoff Date/Time dialog box appears (see "GoldMine Record Selection and User’s Calendars" on page 294).
   - Configuring GoldSync Site Groups, the Retrieve Options dialog box appears (see "Configuring the Retrieve Options" on page 312).
Server Agents

Overview

Use the Server Agents Administrator to process these operations on a recurring basis:

- Sending and retrieving e-mail from the Internet through GoldMine
- Synchronizing with GoldSync
- Synchronizing with Microsoft Outlook
- Printing and faxing correspondence
- Running Automated Processes
- Publishing Calendar information

IMPORTANT: Server Agents are configured around a user or user group, active time periods, and frequency. They work with other configurable parts of GoldMine and must be started for the processes to work.

Starting the Server Agents

Start the Server Agents for the settings you configured in the Server Agents Administrator to take effect.

1. Select Tools > Services > Start Server Agents.
NOTE: To stop an agent, select the agent and then click the Stop Processes button.

Configuring the Sending and Retrieving of E-mail

Use the Server Agents Administrator to send queued e-mail and retrieved e-mail from the e-mail server on the days and times specified.

2. Click the Send/Retrieve E-mails tab.
3. If allowing only one user to send and retrieve e-mail using the Server Agent, select the user in the drop-down list in the User’s Settings area.
4. To allow other users to use the Server Agent capability, select Apply to other users to enable the Select Users button. Click Select Users to select one or more users or user groups.
5. In the Active Period area, select the days of the week the agent will be active.
6. Type or select the active time period for each day from the F2 graphical clock.
   
   Times are set on a daily basis, the earliest time is 12:00 A.M. and the latest is 11:59 P.M. The latest time cannot be 12:00 A.M. When setting the times, consider the full range of Server Agents you are running and what activities can take place after regular business hours. In some cases, you need to select one scenario over another. For example, you do not want to send queued e-mail until after hours, but you do want to retrieve e-mail throughout the day
7. In the Frequency area, type or select the number of day(s), hour(s), minute(s) GoldMine waits before initiating the operation.
   
   The minimum amount of time is 5 minutes.
8. Click OK.

   NOTE: You must start the Server Agents to begin processing (see "Starting the Server Agents" on page 327).
Configuring GoldSync

Use the Server Agents Administrator to process GoldSync sites on the days and times specified.

1. Select **Tools > Services > Manage Server Agents**. The Server Agents Administrator dialog box appears.
2. Click the **GoldSync** tab.
3. If allowing only one user to publish his or her calendar using the Server Agent, select the user in the drop-down list in the User's Settings area.
4. To allow other users to use the Server Agent capability, select Apply to other users to enable the Select Users button. Click **Select Users** to select one or more users or user groups.
5. In the **Active Period** area, select the days of the week the agent will be active.
6. Type or select the active time period for each day using the right-facing arrows to access a list of times in thirty minute increments.
   Times are set on a daily basis, the earliest time is 12:00 A.M. and the latest is 11:59 P.M. The latest time cannot be 12:00 A.M. When setting the times, consider the full range of Server Agents you are running and what activities can take place after regular business hours. For example, GoldSync can draw upon many network resources and configure GoldSync to run after regular business hours to keep other processes running smoothly.
7. Click **OK**.
   **NOTE:** You must start the Server Agents to begin processing (see "Starting the Server Agents" on page 327).

Configuring Outlook Sync

The Server Agents Administrator allows you to synchronize data between GoldMine and Outlook at the frequency specified.

1. Select **Tools > Services > Manage Server Agents**. The Server Agents Administrator dialog box appears.
2. Click the **Outlook Sync** tab.
3. In the **User's Settings** area, select the user in the drop-down list.
   This is the user whose Outlook account you are synchronizing to GoldMine.
4. In the **Active Period** area, select the days of the week the agent will be active.
5. Type or select the active time period for each day from the F2 graphical clock.
   Times are set on a daily basis, the earliest time is 12:00 A.M. and the latest is 11:59 P.M. The latest time cannot be 12:00 A.M. When setting the times, consider the full range of Server Agents you are running and what activities can take place after regular business hours. For example, synchronize your Outlook with GoldMine several times during the business day.
6. Select the **Profile** in the drop-down list.
7. In the **Frequency** area, type or select the number of day(s), hour(s), minute(s) GoldMine waits before initiating the operation.
   The minimum amount of time is 5 minutes.
8. Click **OK**.
   **NOTE:** You must start the Server Agents to begin processing (see "Starting the Server Agents" on page 327).
Configuring Printing and Faxing

Use the Server Agents Administrator to send queued print and fax jobs on the days and times specified.

1. Select **Tools > Services > Manage Server Agents**. The Server Agents Administrator dialog box appears.
2. Click the **Print/Fax** tab.
3. If allowing only one user to print or fax queued jobs using the Server Agent, select the user in the drop-down list in the User's Settings area.
4. To allow other users to use the Server Agent capability, select **Apply to other users** to enable the Select Users button. Click Select Users to select one or more users or user groups.
5. In the Active Period area, select the days of the week the agent will be active.
6. Type or select the active time period for each day from the F2 graphical clock.
   Times are set on a daily basis, the earliest time is 12:00 A.M. and the latest is 11:59 P.M. The latest time cannot be 12:00 A.M. When setting the times, consider the full range of Server Agents you are running and what activities can take place after regular business hours. For example, printing large mailings during regular business hours could make the printer unavailable to regular daily users. Printing large jobs before or after business hours keeps the printer free.
7. In the **Frequency** area, type or select the number of day(s), hour(s), minute(s) GoldMine waits before initiating the operation.
   The minimum amount of time is 5 minutes.
8. Click **OK**.
   **NOTE:** You must start the Server Agents to begin processing (see "Starting the Server Agents" on page 327).
F2 Lookup Lists

Overview

Use F2 Lookup lists to standardize how users type information in some GoldMine fields. For example, limit entries in the Dear field to a few standard responses, such as Dr., Mr., Mrs., and so on. F2 Lookups also enable quick data entry into these fields. F2 Lookup values are stored in the Lookup table.

The F2 options for date and time fields offer a graphical interface.

F2 Lookup Benefits

Using the F2 Lookup lists helps:

- Force valid entry in a field.
- Set up field dependency between fields
- Enable the standardization of data entry by preventing similar entries, such as Finance Director, Director of Finance, and Financial Director.
- Let users unsure about field entry choose from a list.
- Speed up data entry
- Help prevent spelling errors.
- Simplify report writing and filtration. Set security access on the F2 Lookups to prevent users from altering contents or typing void data. Each F2 Lookup has its own settings; therefore, set the security on each list one-by-one.

A right-facing arrow at the end of the field box identifies fields with F2 Lookups. Access aspects of the F2 Lookups by:

- Clicking F2 or F4
- Clicking the right-facing arrow on the field
- Entering text and then selecting from the auto-fill menu that displays below the field.
Using the F2 Lookup

The F2 Lookup lists appear in a variety of locations throughout GoldMine. Some fields can be configured to only accept values from the lookup while other fields allow for “free-form” input. Still others are clocks or calendars.

You can open, set up, or edit your F2 values on the **Field Lookup** dialog box.

1. Click on a right-facing field arrow of a field or select **F2**.

   The **Field Lookup** dialog box opens.

2. Select one of the following options:
   - **New** opens the F2 Entry dialog box. Type in the new name and click **OK** (see "Creating F2 Lookup Entries" on page 333).
   - **Edit** allows you to edit a selected entry. First, highlight the value you want to edit and then click **Edit**. At the F2 Entry dialog box, type over the existing text and click **OK** (see "Editing F2 Lookup Entries" on page 337).
   - **Delete** removes an entry. First highlight the value you want to delete and then click **Delete**. At the prompt, click **Yes**.
   - **Setup** opens the F2 Field Setup dialog box (see "Configuring F2 Lookup List Security" on page 336) to configure settings for a field.
   - **Select** chooses an entry. Highlight the entry and then click **Select**. The value you selected appears in the field.

3. Click **Cancel** to close the Field Lookup dialog box.

Managing F2 Lookup Lists

You can manage F2 Lookup lists by:

- Creating F2 Lookup Entries (see page 333)
- Setting Dependency Between Lookup Lists (see page 334)
- Configuring F2 Lookup List Security (see page 336)
- Editing F2 Lookup Entries (see page 337)
Creating F2 Lookup Entries

The F2 Lookup lists appear in a variety of locations throughout GoldMine. Some fields can be configured to only accept values from the lookup while other fields can allow free-form input. In other cases, the lookup displays a clock or calendar. You can add other values to your F2 Lookup table. For example you can add contact names, addresses, and so on. You can even select which values will display.

Another lookup feature is the ability to set a limit on the types of values that can be added to a field by another field. For example, if you want to enter only cities (City field) in the state of California (State field) you can set up that limit on the Lookup lists.

**NOTE:** To place multiple entries in a field, with new entry after the existing entry, type a semi-colon (;) at the end of the entry. This appends the entry after existing data in the field, separated by a comma.

Be sure to set security options before or after creating the F2 Lookup tables (see "Configuring F2 Lookup List Security" on page 336).

1. Click on a right-facing field arrow of a field or select **F2**.
2. At the Field Lookup dialog box, click **New**. The **F2 Entry** dialog box opens.

3. Type the new entry.

   Use a method to designate special handling of field values:

   ☐ To place multiple entries in a field, with new entry after the existing entry, type a semi-colon (;) at the end of the entry. This appends the entry after existing data in the field, separated by a comma. This way, multiple entries can be placed in a field. When the entry does not end with a semi-colon, it overwrites data already appearing in the field.

   ☐ To place a coded entry that has descriptive information in the lookup list, type two slashes (//) after the entry, then the description. The entry for the field it is treated like a comment, and displays the text in the field.

   **Example:**

          0001//Shops & Retail
          0002//Shipping

   Selecting one of these places the numeric option into the field. To require multiple and coded entry, place these in this order: code, semicolon, forward slashes, and description:

          0001;//Shops & Retail
          0002;//Shipping

   ☐ To add the results of a dBASE expression to a field, type a ~ followed by the expression. For example, ~dtoc(date()) in the F2 Lookup list enters the current date in the field.

4. Click **OK**. The entry adds to the F2 Lookup list.
Setting Dependency Between Lookup Lists

You can set up lookup values that are dependent on values from other fields. Also, you can create, change, or delete necessary relationship.

For example, you set up the two fields State and City. This enhancement allows you to select only cities from a corresponding state. You can set up the City F2 lookup list to depend on the State field value, then change it to key1 (record type) field. The value from the City (that is, from the field which on the field city depends) field is named as Master Value.

To Set Up a Dependency

To set up a dependence, you must first configure the field setup.

1. Open a F2 Lookup dialog box and click Setup.

The Setup dialog box opens; this is where you change the dependency for F2 lookup values.

2. In the Field Name area, select values.

3. In the Context-dependent F2 lookup list area, click on the Lookup list depends on another field checkbox.

   NOTE: This checkbox must be selected. If left unchecked then the lookup values do not depend on any other fields.
4. Select the **Contact (CONTACT1)** button to select a master field from the Contact1 table.
   
   For example you can set an Activities result code which depends on the key 1 (record type) field in the corresponding contact. If you select this button, then the Contact1 fields appear in the Master field drop-down box. If you select other fields, fields from the corresponding table appear. For Activities it is the CAL table, for Cases it is the CASES or fields of cases.

   - Select **Go To > Service Center**
   - Click **New case** and create a new case
   - Navigate to **Subject** field and press **F2 > setup**.

   The **CASES** table is available for selection.

   **NOTE:** After changing this field all lookup values will not update. Manually edit each field in the list. See "To Manually Editing Dependencies" on page 335.

   For a list of dependency tables, see "Available Dependency Tables" on page 335.

**Available Dependency Tables**

The following table shows the available dependency tables.

<table>
<thead>
<tr>
<th>Fields</th>
<th>Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contact record fields</td>
<td>contact1 table</td>
</tr>
<tr>
<td>Use defined contact fields</td>
<td>contact1 and contact2</td>
</tr>
<tr>
<td>Pending activity fields</td>
<td>contact1 and cal tables</td>
</tr>
<tr>
<td>History activity fields</td>
<td>contact1 and conthist tables</td>
</tr>
<tr>
<td>Opportunities and Projects</td>
<td>contact1 and opmgr tables</td>
</tr>
<tr>
<td>Cases (Service Center)</td>
<td>contact1 and cases tables</td>
</tr>
</tbody>
</table>

**To Manually Editing Dependencies**

1. Open the F2 Lookup dialog box for the dependency field and select a value.
2. Click **Edit**.

   ![F2 Entry](image)

3. Click on the **Only valid when** checkbox.

   A **valid** value mean that master field has the appropriate value. In the example of city and state, the State value is CA (California) and when the **Only valid when** checkbox is checked, the City values returned are all cities in California.

4. At the drop-down box, select a value and then click **OK**.

   The F2 Lookup dialog box now have a **Show All** checkbox.
Select an Entry by Ignoring Dependency Settings

After setting up all the dependencies, you can select them from the F2 lookup lists.

1. Open an F2 Lookup dialog box.

2. Click the Show All checkbox.
   - This shows all values independent from the Master field value.
   - Unclick the Show All check box to show only valid values for the dependency.

Configuring F2 Lookup List Security

To ensure that data entries are consistent in a database, you must set security options for each F2 Lookup. Using these security options standardizes data field values. Set security options before or after you create (see "Creating F2 Lookup Entries" on page 333) or edit (see "Editing F2 Lookup Entries" on page 337) the lookup entries.

**NOTE:** To access the F2 Field Setup dialog box, you must have Master Rights.

1. Click on a right-facing field arrow of a field or select F2.
2. At the Field Lookup dialog box, click Setup.
   - The F2 Field Setup dialog box opens.
3. In the Field Name text box, type the name for the lookup list.
   - This can be the name of the field you are creating, its lookup, or a general name if you are planning to use the lookup list with more than one field. To use the lookup with more than one field if you will be importing the lookup entries, type a Field Name.
4. In the Field Settings area, select from the following:
   
   → **Allow blank input.** Keeps the data field blank. Selecting this option lets GoldMine skip the field when the value is unknown.
   
   **NOTE:** Selecting Allow blank input for a required field prevents you from determining whether the field was supposed to be empty. Retain more control over field entries by including a lookup value of N/A to indicate that no lookup value applies to the field.

   → **Force valid input.** Requires selection of an F2 Lookup list value to update the field. GoldMine allows only entries that appear in the lookup. If an invalid entry is attempted, GoldMine displays the lookup and highlights the item closest to the actual field entry.

   → **Insert closest match.** If an entry is typed in a field that does not match existing lookup entries, GoldMine inserts an entry that most closely matches the typed value. GoldMine changes the entry when the cursor is moved from the field. To enable this option, select Force valid input.

   Because GoldMine inserts the entry that appears to be the closest match, Insert closest match can place an incorrect value into a field.

   → **Capitalize first letter.** Capitalizes the first letter of the entry.

   → **Pop-up when selected.** Displays the corresponding F2 Lookup when the field is selected.

   → **List existing data.** Lets users look for the existing values.

   → For example, there are contacts with New York, Dublin, Moscow only. So, F2 Lookup will show these cities only. This option will disable new F2 Lookup navigation (by two fields).

   → **Allow adding.** Lets users add entries to the F2 Lookup.

   → **Allow editing.** Lets users edit the entries in the F2 Lookup.

   → **Allow deleting.** Lets users delete entries from the F2 Lookup.

   → **Auto Fill.** As the user types, GoldMine places the closest matching entry from the lookup in the field.

   → **Import lookup entries from another field.** Select this when importing an existing F2 Lookup list and then select the field name from the drop-down containing the information to use as entries in the lookup list. After selecting a field and closing the F2 Field Setup dialog box, entries corresponding to the selected field appear in the lookup.

   → **Lookup list depends on another field.** When this checkbox is selected the lookup value for a field depends on the value of another field called a master. For example, if you want all entries in the City field to be in the state of California, then you would check this box and in the Field name field, you would select State.

   If this box is not selected, all values can be added to the Lookup list.

   → **Contact radio button.** Allows the user to select a master field from the Contact1 table.

   → **Case (Opportunity, Calendar, Case and so on) radio button.** This radio button allows you to select a master field from the corresponding table.

5. When the form is completed click OK.

**Editing F2 Lookup Entries**

You can edit F2 Lookup entries to reflect changes or incorporate special symbols that designate values in a text-based lookup.

   **NOTE:** When editing a lookup entry, make sure you change the security options on the entire table (see "Configuring F2 Lookup List Security" on page 336).

1. Right-click on the field to open the Field Lookup dialog box.
2. Select the entry you want to edit and click **Edit**. The F2 Entry dialog box appears.

3. In the **Enter the value field**, type the new entry.

   Use the following methods to designate special handling of values in a field:
   - To place multiple entries in a field, with new entry *after* the existing entry, type a **semi-colon (;)** at the end of the entry. This appends the entry after existing data in the field, separated by a comma. This method allows multiple entries in a field. When the entry does not end with a semi-colon, the entry will overwrite any data that already appears in the field.
   - To place multiple entries in a field, with the new entry *before* the existing entry, type a **percent sign (%)** at the end of the entry. GoldMine does not insert a comma between entries.
   - To place a coded entry with descriptive information in the lookup list, type a pair of **forward slashes (//)** after the entry, followed by the description. The // symbol indicates breaks the string and treats text after it as informational and displays the text in the field. This is useful when working with coded values, for example industrial sector codes, where SIC Codes (for example) are 0 = Agricultural, Forestry and Fishing; 1 = Mining and Construction and so on. In GoldMine you can either enter all possible values as real values or you setup the lookup list with 0 // Agricultural, Forestry and Fishing 1 // Mining and Construction. When opening the lookup the user sees the description but in the field only the Code is entered means 0 or 1.
   - To add the results of a dBASE expression to a field, type a **tilde sign (~)** followed by the expression. For example, `~dtoc(date())` in the F2 Lookup list enters the current date in the field.

4. Click **OK** to add the updated entry to the F2 Lookup list.
My GoldMine

Overview

My GoldMine allows users to view current information from GoldMine and from the Internet in a customizable window. The My GoldMine desktop contains columns and sections you can personalize to display business-critical content from the Web or from within GoldMine. Personalize My GoldMine layout, content, and refresh rate. Users can:

- Add and remove content from My GoldMine to optimize efficiency and instantly access information such as stock quotes, e-mail, weather, pending activities, or other relevant information for planning and managing business.
- Add GoldMine information, including appointments, e-mail inbox, or the day's sales.
- Also add Internet sites supporting Rich Site Summary (RSS) which is a simple XML format designed for sharing Web headlines. Sites supporting RSS are usually offering “What’s New” information from their site. RSS versions 0.91-2.0 supported.

**NOTE:** The user’s system must be connected to the Internet to display and access Web sites. Set up the appearance, content, and refresh rate for My GoldMine to display the Web site content and GoldMine information.

Configuring My GoldMine

1. To access the My GoldMine configuration options, select `Web > My GoldMine`. The **My GoldMine** window appears.
2. Click the **Personalize Content** button at the top right of the window.
   
   The **Configure My GoldMine** dialog box opens.
3. On the **Layout** tab, select the **Page Style** in the drop-down list.
4. Select a 2 or 3 column style in the Column Scheme drop-down list.
   - Default
   - Windows
   - Newspaper
   - XP
5. For each column, select the Column Format in the drop-down list. Select **Tab**, which keeps the contents of the other items in the column hidden when not selected, or **Box**, which displays the information or hyperlink for all items.
   - Classic Three Columns
   - Even Three Columns
   - Even Two Columns
6. Click the **Contents** tab.
7. Select **Column 1, 2, or 3**. The information in the **Items** pane reflects the active resources for the selected column. To add a resource, click **Add**. The **Select Item to Add** dialog box appears.
8. To change the display order, select the item and click **Move Up** or **Move Down**.
9. Click **Remove** to delete the selected item.
10. Click the **Settings** tab.

11. Select **Refresh only on startup** prevents you from setting a refresh rate. My GoldMine does not refresh while it is open. If you do not select Refresh only on startup, type or select a time in the **Refresh My GoldMine Every x minutes** text box.

12. Click **OK** to save the settings and close.

---

**Using My GoldMine**

Use **My GoldMine** as a personalized resource for current information from selected GoldMine and Internet sources.

1. Select **Web > My GoldMine**. The **My GoldMine** window appears.

2. Depending upon the configuration you selected, My GoldMine displays with 2 or 3 columns, as tabs or boxes, and with default, Windows, newspaper, or XP page style.

   To change the setup, style, and content, select **Personalize Content**. The Configure My GoldMine dialog box opens.

3. To add to the content of each column, click **Add Item(s) to Columns**. The Select Item to Add dialog box appears.

4. To view the complete information where it is not displayed, clicking the hyperlink expands the view to include the detailed information.

   **NOTE:** If you selected the Tab format in the Configure My GoldMine dialog box, you need to scroll to the bottom of the column and double-click the resource’s title bar. Use the arrow to minimize the view on the tab format. The Box format keeps your resources actively displayed at the top of the column.

5. To copy information from the My GoldMine display, highlight the section and right-click.

   Select **Copy** from the local menu.

   Choose **Select All** to copy the entire My GoldMine display to the clipboard. Then paste the selected section or the entire section in your target application.

6. To refresh news feed sites manually rather than wait for the automatic refresh, click **Refresh**.

---

**Select a Resource to Add Dialog Box in My GoldMine**

Use the Select a Resource to Add dialog box to add, store, and remove resources. The dialog box appears if you click Add on the Content tab of the Configure My GoldMine dialog box or if you select Add Item(s) to Columns on the My GoldMine window.

1. If the GoldMine or Web-based resource is listed, select the item and click OK. The item is added to the selected column.

   **NOTE:** The Select a Resource to Add list displays only items not added to the My GoldMine display. The list is universal, not column specific. To move an item from one column to the next, you must remove it from the display by clicking the X in the title bar of the item in the My GoldMine window. The item is re-added to the Select Item to Add list and can be added to the column of your choice.

2. To add a resource to the item list, click **Add Resource**.

   The **Edit RSS Resource URL** dialog box appears.

3. After adding the RSS resource, it appears on the item list. Select the item and click OK. The item is added to the selected column.

4. To change the name or URL of an item, select the item and click **Edit Resource**.

   The **Edit RSS Resource URL** dialog box appears.

5. To remove an item from the list, select the item and click **Delete Resource**. The item is permanently deleted from the item list.

6. Click **OK** to add a highlighted item or Cancel to close the dialog box.
Knowledge Base

Overview

The Knowledge Base provides a resource for maintaining any type of information useful to an organization or an individual. It can provide easily accessible storage for graphics, multimedia files, and/or program applications. This information can then be linked to a Contact Record (displays the record whenever you access that topic).

The Knowledge Base consists of the **Knowledge Base**, and the **Personal Base**. Configure them to present newly added information to the user, control user reading and updating privileges, and search for specific entries based on user-defined criteria. Topic pages are arranged in outline format. Locate information by navigating through different sections, conducting a search, or opening a linked file.

**NOTE:** Users with Master Rights can set up user access to the Knowledge Base; each connected user can set up information in his or her Personal Base.

**TIP:** Knowledge Base material is stored in the InfoMine table.
Knowledge Base Toolbar

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Icon" /></td>
<td>Adds a book to the Knowledge tree.</td>
</tr>
<tr>
<td><img src="image2" alt="Icon" /></td>
<td>Adds a folder to the selected book.</td>
</tr>
<tr>
<td><img src="image3" alt="Icon" /></td>
<td>Adds a topic to the selected book or folder.</td>
</tr>
<tr>
<td><img src="image4" alt="Icon" /></td>
<td>Displays the Topic or Section Properties dialog box for the selected item.</td>
</tr>
<tr>
<td><img src="image5" alt="Icon" /></td>
<td>Displays the Attach File tab of the Topic or Section Properties dialog box.</td>
</tr>
<tr>
<td><img src="image6" alt="Icon" /></td>
<td>Deletes the selected item.</td>
</tr>
<tr>
<td><img src="image7" alt="Icon" /></td>
<td>Displays a Table of Contents in the lower right pane of the selected book.</td>
</tr>
<tr>
<td><img src="image8" alt="Icon" /></td>
<td>Displays the Search dialog box and allows you to enter search terms.</td>
</tr>
<tr>
<td><img src="image9" alt="Icon" /></td>
<td>Launches attachments, graphics, or other applications.</td>
</tr>
</tbody>
</table>

Accessing the Knowledge Base

Use the following steps to access the Knowledge Base.

1. Select **Go To>>Knowledge Base**, or select **Knowledge Base** from the main navigation pane. The **Knowledge Base** window opens.

2. Use the **Knowledge Base toolbar** to navigate and manage.

3. View information by selecting a tab:
   - **Knowledge Base.** Maintains information created by, for, and about an organization and available to multiple users.
     
     **NOTE:** Depending on rights, all users can potentially view all Knowledge Base topics. However, only users with Master Rights can add, edit, or delete Knowledge Base items.
   - **Personal Base.** Maintains information useful to an individual user that only the user can view and update.
     
     **NOTE:** The only way to access a Personal Base is to log in to GoldMine as the user who created the Personal Base.


5. Create and edit topic text and linked files. See "Adding HTML Text to Knowledge Base Topics" on page 344.

6. Click X to close.
Creating Knowledge Base Books, Folders, and Topics

Organize information in the either Knowledge Base or Personal Base by creating high level books, internal folders, and pages to address individual topics.

Use the following procedure to create or Knowledge Base material.

1. Select Go To>>Knowledge Base, or select Knowledge Base from the main navigation panel. The Knowledge Base window opens.

2. To create a Book, click the New Book toolbar icon. See "Knowledge Base Toolbar" on page 342.
   The <new book> appears in the left pane.

3. Type a name and press Enter.

4. Click in the right pane to add HTML text or click the Attach a file toolbar icon to add an attachment.
   TIP: Adding text or attachments at the book level is possible but will interfere with a book level Table of Contents. Adding a TOC replaces the text on the book, folder, or topic.

5. To add a Folder, highlight the book to add the folder to and click the New Folder toolbar icon. See "Knowledge Base Toolbar" on page 342.
   The <new folder> appears under the selected book.
   Type the name of the folder.
   Click in the right pane to add HTML text or click the Attach a file toolbar icon to add an attachment. See "Adding HTML Text to Knowledge Base Topics" on page 344.

6. To add a Topic Page, highlight the book or the folder to add the topic to, and click the New Topic Page toolbar icon. See "Knowledge Base Toolbar" on page 342.
   The <new page> appears under the selected book or folder.
   Type the name of the topic.
   Click in the right pane to add HTML text or click the Attach a file toolbar icon to add an attachment.

Editing Knowledge Base Books, Folders, and Topics

You can change the structure of the organizational tree, add keywords, attach files, and set security.

1. Select the book or folder to edit.

2. Right-click and select Edit.
   The Section Properties dialog box opens.

3. Click the Book, Attached File or Access tab.
   Book. Allows you to rename a book or add a subfolder.
   To rename a book, at the Book field, type the new name of the book.
   To add a folder, follow the directions on the screen.

   Attached File. Allows you to link existing files to your information.
   To attach a file, at the Attached file field, type in the file name or click the ellipse button and then select a file.
   To synchronize the file, check the Synchronize the file checkbox to include the attachment when the Knowledge Base information is synchronized to remote users.
   Note that the File Information area fields will change according to the file you enter.

   Access. Sets reading and updating security access on books, folders, and topics. See "Setting Security Access on Knowledge Base Topics" on page 344.
   To set the Read access, follow the directions on the screen.
4. To edit a topic, select the topic, right-click on it and then select Edit.

   The **Topic Properties** dialog box opens.
   - **Topic.** Allows you to use keywords to speed up searches and to create a tree structure of the book.
     - At the **Topic** field, select the topic.
     - At the **Keywords** field, type the keywords separating each word using commas (,). See "Adding Keywords to Knowledge Base Topics" on page 344.
     - At the **Folder** field, edit the tree structure of the book and folder by typing a new folder name after the book name, separated by semi-colons.

**Adding Keywords to Knowledge Base Topics**

At the topic level, add keywords (one or more words that succinctly describe a document’s contents.) to topics to facilitate organization. Assigning a keyword to related topics makes searching more efficient.

1. Select a topic, right-click, and select **Edit**.

   The **Topic Properties** dialog box opens.

2. In the **Keyword** text box, type a keyword or select a keyword from the F2 Lookup list.

   **NOTE:** To input multiple keywords, insert commas between words. When creating F2 Lookup terms, use semi-colons after each word. When selecting multiple entries, the words display with commas between them.

3. Click **OK**.

**Setting Security Access on Knowledge Base Topics**

Set reading and updating security access on books, folders, and topics.

1. Select a book, folder, or topic and right-click and select **Edit**. The Book, Section, or Topic Properties dialog box opens.

2. Select the **Access** tab.

3. At the **Read Access** drop-down list, select the user or user group to grant Read permission.
   - If you want everyone to have access, leave as (public).

4. In the **Update Access** drop-down list, select the user or user group to grant Update permission.
   - If you want everyone to have access, leave as (public).

5. Click **OK**.

**Adding HTML Text to Knowledge Base Topics**

Use the capabilities of HTML to create pages in the InfoCenter.

**NOTE:** The information provided here is specifically for the topic level, but is applicable at the Book and Folder levels.

1. In the Knowledge Base window, click the right pane. A blinking cursor and the HTML toolbar appear.

2. Type the information into the page, or copy and paste it in from other sources.

3. Right-click the text pane and use the local menu options to format your document and add features.
   - The HTML lets you format the text in a pleasing display and add Internet hyperlinks and graphics.

4. Click **Save**.
GoldMine Plus for Microsoft Office

Overview

GoldMine Plus for Microsoft Office is a powerful add-in for GoldMine that allows seamless integration between Microsoft Office and your GoldMine environment. Create dynamically merged documents such as letters, faxes, and e-mails using your GoldMine contact data, and then leverage the powerful features in the Microsoft Office suite to produce and distribute your work. Easily move data between GoldMine and Microsoft Excel. Tools embedded directly into Excel allow flexible generation of customized invoices, reports, and more, using your GoldMine contact data.

IMPORTANT: GoldMine support the use of more than one contact set. However, the integration link supports the use of only one contact set, and this must be the one in your primary SQL database that includes both Contact and GMBASE tables.

About GoldMine Plus for Microsoft Word

Installing GoldMine Plus for Microsoft Office adds the following features and enhancements to GoldMine and Microsoft Word:

- Complete integration between GoldMine and Microsoft Word
- A GoldMine menu in Microsoft Word
- Enhanced functionality for GoldMine’s document management features

Generate form letters, faxes, and e-mails with primary contact field information (Contact1) such as name, address, or primary phone number. Also include information from user-defined fields (Contact2). Create document templates for use with complex merges in GoldMine’s Document Management Center, and manage scheduled document production using Automated Processes. GoldMine fields used in templates remain dynamic, updating automatically to reflect changes in your database.

GoldMine Plus for Microsoft Office must be installed. After installed, a GoldMine menu option is added to the Word main menu, and you can merge templates with groups of contacts using:

- Document Management Center. See “About the Document Center” on page 78.
- Automated Processes. See “Automated Processes” on page 269

You can also customize the application (see “Customizing GoldMine Plus for Word” on page 348).

NOTE: Microsoft Word allows you to send e-mail messages through the program. However, when Microsoft Office Word 2003 and Outlook 2003 are integrated with GoldMine using the GoldMine Plus for Microsoft Office add-in, e-mail attachments can only be sent using Microsoft Outlook. To enable sending e-mail attachments using Microsoft Office Word 2003, you can either disable the GoldMine Plus for Microsoft Office add-in or upgrade to Microsoft Office 2007 or newer.
About GoldMine Plus for Microsoft Excel

GoldMine Plus for Microsoft Office installs a GoldMine menu in Excel for accessing integrated functions.

- **Insert GoldMine Fields.** Provides a list of GoldMine fields and a field macros to map to Excel cells. Field mappings remain dynamically linked to GoldMine fields, changing to reflect values in the active GoldMine Contact Record. For example, create a billing form in Excel, insert the appropriate name, address, and user-defined fields. Then use the integrated form to generate a printed bill for the current contact. See "Using GoldMine Fields in Microsoft Excel" on page 350.

- **Save as GoldMine Linked Document.** Save a workbook or worksheet that is linked automatically to a GoldMine contact.

- **Export Data to GoldMine.** GoldMine Plus now offers field mapping options for exporting Excel databases into GoldMine. Map Excel fields to GoldMine fields with a simple wizard-style interface, for the fastest, easiest method yet to bring data into GoldMine. "Exporting to GoldMine From Microsoft Excel" on page 351.

GoldMine Plus for Microsoft Office must be installed. After the application is installed, create individual spreadsheets with inserted GoldMine fields or create spreadsheet templates accessed through the Document Management Center (see "Adding Excel Templates" on page 352).

**NOTE:** If you do not see the GoldMine menu in Excel after installing GoldMine Plus for Microsoft Excel, open the Excel Help menu and select About Microsoft Office Excel. On the About Microsoft Excel dialog box, click the Disabled Items button and look for an item called GMPlusOffice. Re-enable this item to make the GoldMine menu available.

About GoldMine Plus for Microsoft Outlook

With this Integration link, the contact message-linking and history tracking features in GoldMine's E-mail Center are available to Microsoft Outlook users. The installation adds a GoldMine menu and toolbar to Outlook's main window and a GoldMine Link tab to its Options dialog box.

Depending on the options installed with the integration, you can:

- Manage Customer Contacts
- Schedule Activities
- Track Forecast Sales
- Track Cases
- Track Opportunities
- Linking Messages
- E-mail Templates
- E-mail Merge to GoldMine Group or Filter
- Schedule an Activity for a GoldMine Group or Filter

For detailed information about GoldMine Plus for Microsoft Outlook, see "Outlook Integration Administration" on page 353 and “Outlook Integration” in the GoldMine User Guide PDF or in the Online Help.

Installing GoldMine Plus for Microsoft Office

GoldMine Plus for Microsoft Office is usually installed during the GoldMine installation process, however, options during the GoldMine installation process allow you to install GoldMine Plus at a later point in time if desired.

Follow these steps to install GoldMine Plus after the main GoldMine installation.

1. From your desktop, go to: Start > Settings > Control Panel > Add or Remove Programs
2. Highlight GoldMine and then click the Change button.
3. The Welcome to the Installshield Wizard for GoldMine dialog box appears. Click Next.
4. Select the **Modify** radio button and then click **Next**. The **Custom Setup** dialog box opens.

5. Click the **GoldMine Plus!** icon to open the drop-down menu.

6. Select **This feature will be installed on local hard drive** and then click **Next**. The **Installing GoldMine** status screen opens.

7. When finished, the **GoldMine Installation Completed** dialog box appears. Click **Finish** to complete the installation process.

**NOTE:** To uninstall GoldMine Plus! components, repeat the steps listed above, but instead select **This feature will not be available** from the **GoldMine Plus!** icon drop-down menu. GoldMine Plus! will be uninstalled from your local hard drive.

---

**Setting Preferences in GoldMine Plus for Microsoft Office**

Use the GoldMine Plus Preferences for Microsoft Office dialog box to configure **automatic login**, **file location**, **fax method**, and **group merge** settings. GoldMine Plus preferences are accessed from within Microsoft Word.

1. Open **Microsoft Word**.
2. From the GoldMine menu, select **Setup**.
3. The **GoldMine Plus Preferences** dialog opens.

   ![GoldMine PLUS Preferences dialog box](image_url)
4. Set GoldMine Plus Preferences using the following options:

   **Automatic GoldMine Login:** To login to GoldMine automatically when Microsoft Word or Excel are started:
   - Check the box for **Please login to GoldMine with the following user data automatically in the future.**
   - Enter your GoldMine **User name** and **Password**.

   **File Location:** Select an option for a default file location where GoldMine Plus documents will be saved:
   - **Use GoldMine to determine location:** The default file location for GoldMine Plus documents will be determined from the GoldMine application.
   - **Use Word Default Path:** GoldMine Plus documents will automatically be saved to Microsoft Word’s default file location.
   - **Use (Browse to file location):** Manually browse to a default file location for GoldMine Plus documents.

   **Fax Method:**
   - **Provider:** Select your fax method in the drop-down list of fax applications:
     - (none)
     - OmniRush
     - WinFax
     - RightFax
     - DelFax
     - Zetafax
   - **Fax Macro:** Select the Fax Number Macro specified by your fax application in the drop-down list.
     - &DIALFAX: The fax number from the active contact record.
     - &FAX: The fax number as it should be sent to an auto-dialer for automatic fax transmission.

   - The **Show Send Screen** and **Use 'Fine' Resolution** options are available in different combinations, depending on the fax application.

   **Group Merge:** Select **Prompt for group merge destination** (print only) to have GoldMine generate a prompt before printing.

   **Field Automation:** Select the **Place GoldMine fields in a way that Word will not attempt to update automatically** option to all Microsoft Word to automatically update fields that you insert.

5. Click **Save** to exit the GoldMine Plus Preferences dialog.

---

**Customizing GoldMine Plus for Word**

### Adding Signature Files

Add a bitmap signature file to be included in the documents you print by adding a `SigDir=<drive: path>` entry in the `GM.ini` file under the `[GoldMine]` section where `<drive: path>` is the name of the directory containing the signature bitmap. All signature bitmap files must be named `<Username>.bmp` (example: `john.bmp`).

```
[GoldMine]
GoldDir=C:\GOLDMINE
CommonDir=C:\GOLDMINE\COMMON\n
SigDir=C:\GOLDMINE\SIG\n```

To insert a Signature bitmap into a template, in Word select **GoldMine > Insert GoldMine Field**. Select **&Signature**.

### Forcing Template Default and File Name

Force a file name and/or default save folder. The path for the template folder should be to the GoldMine root directory where users have their own folders. This option sets the default folder when merged documents, linked documents, and
Granting User Access to Templates

Many companies no longer allow local users access to certain functionality, such as access permissions on program installation folders. If the user has local administrator rights, then this is not an issue. However, if user rights are restricted within the network, access to the GoldMine templates are also restricted. Access to the GoldMine installation folder must be set by a Windows user that is designated as a local “Administration” to allow access to the templates.

The follow instructions use Windows XP for example. If you are using a different operating system, your steps might vary.

To Grant User Access using Word 2003

1. Login to Windows as an Administrator.
   - Open My Computer from the Windows Desktop, from the Start menu, or by pressing the Windows Logo key + E simultaneously on the keyboard.
   - Open the Tools menu and select Folder Options.
   - Click the View tab.
   - In the Advanced Settings section, clear the Use simple file sharing (Recommended) box.
   - Click OK.
3. Set the permissions on the GoldMine install directory.
   - Browse to the C:\Program Files\GoldMine\ folder.
   - Right-click the folder and select Properties.
   - Click the Security tab, select the Users group, and then check the Full Control check box under the Allow column to grant full permission on the folder (making sure to check to propagate to the sub-items and directories).

To Grant User Access using Excel 2003

This process must be performed for each existing and new user, with the exception of the user that installed GoldMine.

1. Start Excel.
2. Open the Tools menu and select Addins.
3. On the Add-Ins dialog box, click the Automation button.
4. On the Automation Servers dialog box, select GMPlusOffice2007.UserDefined Functions and then click OK.
5. A message box displays and asks if you want to replace the file. Click No to close this message.
6. Click OK to close the Add-Ins dialog box.
7. Restart Excel for the changes to take effect.

To Grant User Access using Excel 2007

This process must be performed for each existing and new user, with the exception of the user that installed GoldMine.

1. Start Excel.
2. Click the Office button.
3. Click Excel options.
4. Select Add-Ins.
5. On the Manage drop-down list, select Excel Add-ins and then click Go.
6. Click the Automation button.
7. Select GMPlusOffice2007.UserDefined Functions and then click OK.
8. A message box displays and asks if you want to replace the file. Click No to close this message.
9. Select OK.
10. Restart Excel for the changes to take effect.
Using GoldMine Fields in Microsoft Word

After GoldMine Plus for Microsoft Office is installed, you can add GoldMine fields to a Word document. The fields remain dynamic, meaning that when changes are made to the active GoldMine Contact Record, linked field data in Word changes as well.

**NOTE:** GoldMine linked fields that have changed in Microsoft Word documents will not update until the application’s cache is cleared. To do this, close, then reopen Microsoft Word.

Installing GoldMine Fields into a Word Document

**NOTE:** The steps below describe the process for Microsoft Office 2003. If you are using Microsoft Office 2007, all GoldMine menu items are accessed by selecting the GoldMine Tab from Word’s main menu.

1. **Launch GoldMine** and select a Contact Record as a data source.
2. **Open Microsoft Word.**
3. **Select GoldMine > Insert GoldMine Field(s).** The Insert GoldMine Fields floating toolbar appears. (To anchor the Insert GoldMine Fields toolbar, drag-and-drop the floating toolbar to the Word toolbar.)
   **NOTE:** In Microsoft Office 2007/2010, these fields are always located in the toolbar of the GoldMine Tab.
4. Place your cursor at the point in the document where you would like to insert the field.
5. Click the field drop-down list on the Insert GoldMine Fields toolbar, and select a field or macro.
   Fields are listed as TABLE->FIELDNAME (for example, CONTACT1->CONTACT). Macros are listed as &MacroName (for example, &UserFullName).
6. Continue adding desired fields to the document.
7. **Complete** the process by:
   - **Saving the document for later use:** Select File > Save as from the Word menu. Save the file as filename.doc. To reuse this file with dynamic fields, launch Word and open the saved .doc file. The dynamic fields display data from the active GoldMine Contact Record.
   - **Saving the document as a template:** Select File > Save as from the Word menu. Save the template as filename.dot. If you are using this file as a Word template in GoldMine, save it in the GoldMine Template folder.
   **NOTE:** If you are sending a mail merge to a group of contacts using GoldMine Plus for Microsoft Office and a required field is not populated in a contact record, an error message appear. Ensure all required fields are populated.

For information on setting preferences in GoldMine Plus for Microsoft Office, see "Setting Preferences in GoldMine Plus for Microsoft Office" on page 347.

Using GoldMine Fields in Microsoft Excel

After GoldMine Plus for Microsoft Office is installed, you add GoldMine fields to an Excel document. The fields remain dynamic, meaning that when changes are made to the active GoldMine Contact Record, linked field data in Excel changes as well.

**NOTE:** The steps below describe the process for Microsoft Office 2003. If you are using Microsoft Office 2007, all GoldMine menu items are accessed by selecting the GoldMine Tab from Excel’s main menu.

1. **Launch GoldMine** and select a Contact Record as a data source.
2. **Open Excel.**
3. **Select GoldMine > Insert GoldMine Field.** The GoldMine Fields floating toolbar appears. (To anchor the GoldMine Fields toolbar, drag-and-drop it in the Excel toolbar.)
   **NOTE:** In Microsoft Office 2007/2010, the fields toolbar is always available in the GoldMine Tab.
4. Select a target cell on the spreadsheet.
5. Click the field drop-down list on the floating GoldMine Fields toolbar and select a field or macro.

   Fields list as TABLE->FIELDNAME (for example, CONTACT1->CONTACT). Macros list as &MacroName (for example, &EmailAddress).

   **NOTE:** Excel does not support multiple lines per cell, therefore, multi-line macros cannot function in Excel.
6. Continue adding desired fields to cells.
7. Finish the process by:

   - **Saving the spreadsheet for later use:** Select File > Save as on the Excel menu. Save the file as filename.xls. To reuse the file with dynamic fields, launch Excel and open the saved .xls document. The dynamic fields display data from the active Contact Record.
   - **Saving the spreadsheet as a template:** Select File > Save as on the Excel menu. Save the file as filename.xlt. If using it in GoldMine, save the new template in the GoldMine Template folder. Then add the template to the Document Management Center (see "Creating Document Templates" on page 79).

   **NOTE:** When running Office 2007/2010 on Microsoft Vista, GoldMine must be running in order to access GoldMine fields in Excel. When Excel attempts to access a GoldMine linked field when GoldMine is not running, the following error message appears:

   Remote data not accessible... Start application ‘GOLDMINE.EXE’?

   - Select NO. If you select YES an additional error message displays. GoldMine must be running in order for Excel to access linked cells.

---

**Exporting to GoldMine From Microsoft Excel**

Once **GoldMine Plus for Microsoft Office** is installed, data can be exported from Microsoft Excel to your GoldMine database using new menu options in Excel.

GoldMine Plus for Office adds an export feature to the GoldMine menu in Excel. Use this menu option to map Excel columns to GoldMine fields and initiate the export process. Be sure to back up your database before beginning.

**NOTE:** Before proceeding with the export, verify that phone numbers are formatted consistently and make changes as needed. The format of the phone numbers in your Excel spreadsheet must be the same for the Excel ODBC to interpret the numbers correctly. If formats are inconsistent, the ODBC driver interprets all the values in the column as null and you lose phone number data during the export process. For example, you cannot have one phone number that is 1235557894 and another that is 777-555-1236. Before exporting to GoldMine, specify one format and update all phone numbers in your spreadsheet to match the selected format. When the phone number format is consistent, begin exporting to GoldMine.

**To Export from Excel to GoldMine**

1. Launch GoldMine.
2. Open the Excel spreadsheet you are exporting to GoldMine.
3. Select the cells you are exporting to GoldMine and specify the Named Range. In Excel, select Insert > Name > Define. The Define Name dialog box appears. See Excel Help for details.

   **NOTE:** To perform this function in Microsoft Office 2007/2010, select the cells to export to GoldMine, right-click on the selected cell range and select Name a Range from the drop-down menu. You also select the Formulas tab, then select Define Name > Define Name... from the Defined Names sub-menu.
4. In the Names text box, type the desired name of the range.

   **NOTE:** The first row of the selected range must contain only header data.
5. either Workbook or Sheet from the Scope drop-down menu.
8. Click Next.
   The field mapping dialog box appears.

9. To map columns to GoldMine fields, highlight the column in the Excel Fields list and then highlight the GoldMine field to map the column to. Click Add Mapping.
   Your selection is added to the Mapped Fields list (for example, Column1<=>C1.Company).

10. Continue to map desired fields. When finished, click Next. The GoldMine is now Ready to export your Excel data! dialog box appears.

11. Click Finish. When the import process completes, a dialog box appears, indicating the number of records imported into GoldMine.

---

Adding Excel Templates

A template is a spreadsheet created in Microsoft Excel and contains embedded GoldMine DDE link fields. The DDE fields link contact information to cells so the fields remain dynamic, displaying the data from the linked fields in the configured cells.

**NOTE:** Use the Document Management Center to link to a spreadsheet template and edit as needed; the template must exist as a file. The most common option for creating a spreadsheet document are using Microsoft Excel with GoldMine Plus for Microsoft Office installed.

**To Add Excel Templates**


2. Select the User from the drop-down list.


4. Type the Document Name in the format to appear in the Document Management Center and in the template drop-down list on the Merge Form dialog box.

5. Select the owning user from the Document User drop-down list.

6. In the Template Filename text box, type or browse to the location of the template.

   **NOTE:** To make changes to the spreadsheet, click the Edit button to open the spreadsheet, make any desired changes, then save the file.

7. In the Document Management area, select from the following options:
   - Save in Links Tab when merging for a single contact
   - Create History when merging

8. In the Document Type area, select Spreadsheet.

9. Click OK.
Outlook Integration Administration

Overview

GoldMine’s integration with Microsoft’s Outlook adds the contact message-linking and history tracking features in GoldMine’s E-mail Center to Microsoft Outlook users. The installation also adds a GoldMine menu and toolbar to Outlook’s main window and a GoldMine Navigation panel to the standard Outlook Navigation pane (see "Outlook Integration" on page 239).

**NOTE:** The GoldMine Outlook Integration must be configured before the integration is complete and ready to use. For more information, see "Setup GoldMine Outlook Integration" on page 353.

**NOTE:** Exactly 1 concurrent license is used if you have GoldMine open and/or are connected to GoldMine within Outlook.

Setup GoldMine Outlook Integration

GoldMine’s Outlook Integration is only available if you have included the GoldMine Plus! For Microsoft Outlook components during installation.

**TIP:** If GoldMine Plus! For Microsoft Outlook was not included during installation, it can be installed using the Add or Remove Programs control panel in Windows, and then selecting Change for the GoldMine entry on the list. For more information, refer to the GoldMine Installation Guide PDF.

When you open Microsoft Outlook after installing GoldMine and GoldMine Plus! For Microsoft Outlook, you must complete the configuration between the two programs.

- Setting Up GoldMine Plus for Microsoft Outlook (see page 354)
- Add the GoldMine Address Book to Outlook (see page 354)
- Set Outlook as Default E-mail Application for GoldMine (see page 356)

**NOTE:** If you have issues with performance or functionality after setup, refer to the Troubleshooting the GoldMine Integration topic.
Setting Up GoldMine Plus for Microsoft Outlook

The initial setup for GoldMine Plus! For Microsoft Outlook is a simple process of reading your GoldMine settings and applying those settings to the Outlook Add-in.

To Setup GoldMine Plus

1. Open the GoldMine menu and select Setup GoldMine Plus or click the button on the GoldMine toolbar in Outlook. The Setup GoldMine Plus for Microsoft Outlook dialog box displays.

2. Click the GoldMine Setup tab.

3. Click the Read GoldMine Settings button.

Check the other tabs to ensure that the settings were properly read and applied. Additional changes can also be made on the various tabs on the Setup GoldMine Plus for Microsoft Outlook dialog box.

   **NOTE:** If you want to restrict the current user from making changes to their settings, uncheck the Allow user to make changes to his/her settings option on the GoldMine Setup tab.

Add the GoldMine Address Book to Outlook

When sending a messages from Outlook, you can select Contacts and Contact groups from the GoldMine Address Book. You must add the GoldMine Address Book before you can use it in Outlook.

   **NOTE:** The address book uses the same information gathered by the Outlook link when the user clicked on the Read GoldMine Settings button. For more information, see "Setting Up GoldMine Plus for Microsoft Outlook" on page 354.

Note About VCards and GoldMine Contacts

A VCard (.vcf file) contains basic contact information similar to the entries made in your Personal tab or other information you enter outside of GoldMine. The details on the VCard originate from your registration information. If the receiving system has VCard capabilities, the system will decipher the .vcf file to import this information. If the recipient uses GoldMine to retrieve e-mail, GoldMine can use your VCard information to create a contact record if no existing contact record is detected.

The following fields are used in GoldMine when using address information for the VCard (.vcf file):

- Mailing Address = Address1 (street address) + Address2 (suite/room number)
- Home Street Address = Address1

For more information about these fields, refer to "Contact Management" in the GoldMine User Guide PDF or in the Online Help.

To Add the GoldMine Address Book to Outlook 2003

1. In Outlook, open the Tools menu and select E-mail Accounts. The E-mail Accounts wizard appears.

2. Under Directory, select Add a new directory or address book and then click Next. The Directory or Address Book Type dialog box appears.

3. Select Additional Address Books and then click Next. The Other Address Book Types dialog box appears.

4. Click Next (to verify changes are applied the next time Outlook is run).

5. Click OK (to save changes).

6. Exit and re-open Outlook.

   **NOTE:** For more information on how to switch to “Corporate or Workgroup” mode, refer to the Microsoft Outlook Help files installed with the product.
To Add the GoldMine Address Book to Outlook 2007

1. In Outlook, open the Tools menu and select Account Settings.
2. Select the Address Books tab.
3. Click the New icon from the toolbar. The Add New E-mail Account dialog appears.
4. Select Additional Address Books, and then click Next. The Other Address Book Types page appears.
5. Select GoldMine Address Book from the list and then click Next. The GoldMine Integration Services for Microsoft Outlook dialog appears.
   - Verify or enter the path to the GoldMine application on your hard drive.
   - Enter your User ID and Password.
   - Verify or Browse to select the Contact Set for Outlook to access.
6. When finished, click OK.
7. A message appears:
   "Any changes made will take effect next time Outlook is run."
8. Click OK to continue.
9. A message appears:
   "The E-mail Account you have just added will not start until you choose Exit from the File menu, and then restart Microsoft Office Outlook."
10. Click OK to continue.
11. A message appears:
    "Congratulations! You have successfully entered all the information required to setup your account. To close the wizard, click Finish."
12. Click Finish to close the Account Settings.

To Add the GoldMine Address Book to Outlook 2010

1. In Outlook, click the File tab.
2. Click Account Settings button and then select the Account Settings option.
3. On the Account Settings dialog box, click the Address Books tab.
4. Click the New button. The Add New Account dialog box opens.
5. Select the Additional Address Books option and then click Next.
6. Select GoldMine Address Book from the list and then click Next.
7. A message appears:
   "You must restart Outlook for these changes to take effect"
8. Click OK to close this message.
9. Click Finish to close the Account Settings and restart Outlook to apply your changes.
Set Outlook as Default E-mail Application for GoldMine

To fully integrate Outlook with GoldMine, you can set Outlook as the default e-mail application. After you make this change, any e-mail address link that you click will open Outlook to compose a new e-mail message.

**To Open Outlook when Clicking E-mail Address Links in GoldMine**

1. In GoldMine, open the **Tools** menu and select **Options**.
2. On the **<User’s>** Options dialog box, click the **E-mail** tab.
3. Under the **Getting Mail** area, check the **Use Outlook for linked E-mail Addresses** option.
4. Click **OK** to save the settings and close the dialog box.
5. Click any e-mail address link to ensure that the link now opens using Outlook.

   **NOTE:** If your e-mail account has an HTML Signature file, it will not display properly when sending e-mail from a GoldMine through Outlook to send linked emails from GoldMine.

Troubleshooting the GoldMine Integration

If necessary, Administrators can create log files that can help diagnose issues with application functionality or performance of GoldMine’s integration with Outlook. FrontRange Solutions Support Services might request that these files be created for troubleshooting purposes.

- **GMOutlookLog.txt** is a trace of the interactions between Outlook and GoldMine
- **GMOutlookSpeed.txt** shows the computing time of individual operations within the Outlook integration.

These files are not created by default. You must create each of these files manually in the **C:\ProgramData\GoldMine** directory. After creating these files, GoldMine will automatically populated the files; no user action is required.

   **NOTE:** If you have installed GoldMine to a different directory that the default **C:\**, you will need to create the **C:\ProgramData\GoldMine** and then create the **GMOutlookLog.txt** and **GMOutlookSpeed.txt** files within that directory.

   **IMPORTANT:** It is recommended that these files be deleted after the information for troubleshooting has been collected. Otherwise, Outlook integration performance could be negatively affected.

For more information, contact the FrontRange Support at [http://www.frontrange.com/support](http://www.frontrange.com/support).

Synchronization

The Synchronization ability in Outlook updates your Outlook Contacts, Calendar, and Tasks with information from GoldMine. You can set when the data from GoldMine is synchronized with Outlook or perform the synchronization manually (data synchronization from Outlook to GoldMine occurs immediately).

   **NOTE:** Outlook Integration does not support recurring or multiple-attendee Tasks created in Outlook when synchronizing with GoldMine. Only one instance of the task is created and linked to the Contact, but only if the Contact was selected in the Outlook Contacts field.

   **IMPORTANT:** Outlook synchronization works only with local folders.
Setting Up the GoldMine Outlook Synchronization

In Outlook, open the GoldMine menu and select Setup GoldMine Plus. Then, click the Synchronization tab to view the following options:

- **Set up Standard Configuration for Outlook Sync**
  (see "To Set Up Standard Configuration for Outlook Sync" on page 357)
- **Set up Outlook synchronization for <UserName>**
  (see "To Set Up Outlook Synchronization for a User" on page 361)
- **Start GoldMine Sync when starting Outlook option**
  (see "To Start GoldMine Sync When Starting Outlook" on page 363)

**To Set Up Standard Configuration for Outlook Sync**

1. On the Synchronization tab, click the Set up Standard Configuration for Outlook Sync.
   A message box appears.

2. Click Yes to start the Standard Configuration for Outlook Sync Wizard.

3. Enter a descriptive name for the Group and then click Next.
4. Select from the Synchronization options and Log Options.

   **NOTE:** Any un-timed (no start/finish time) activities in GoldMine are synchronized to the current time.

5. Click the **Advanced** button to modify **General**, **Deletions**, **Field Mapping**, **Contacts**, **Calendar**, and **Task** tab options (see "Configuring the Advanced Options" on page 360).
6. Click **OK** to close the Advanced Options dialog box.
7. Click **Next** to set the Synchronization Intervals.
- You can click the ellipse buttons (...) to set the **Sync Interval** and **Retry Interval** when synchronizing.

  **IMPORTANT:** Setting the Interval to a shorter rate might create performance issues on the workstation.

- Change the **Number of retries before skipping the session** value to set how many synchronization attempts are made before skipping the synchronization.
- Set the **Scan Outlook records once every [x] sessions** to determine after how many sessions data is synchronized from Outlook to GoldMine.
  
  For Example: If you synchronize data from GoldMine to Outlook every hour, a value of 10 would sync data from Outlook to GoldMine every 10 hours. This value is set to 10 by default as the scanning of Outlook is a lengthy operation and most activities go from GoldMine to Outlook.

8. Click **Next** and then **Finish** to complete the Standard Configuration for Outlook Sync Wizard.

  **NOTE:** If you have not setup any User Profiles, the Outlook Username Profile Wizard opens (see "To Set Up Outlook Synchronization for a User" on page 361).

### Configuring the Advanced Options

The Advanced Options dialog box displays when you click the **Advanced** button when configuring Outlook synchronization (see "To Set Up Standard Configuration for Outlook Sync" on page 357 and "To Set Up Outlook Synchronization for a User" on page 361).

The Advanced Options dialog box contains several tabs for individual configuration of the synchronization process:

- **General:** Define the telephone extension separator, record modification tolerance, duplicate activity checking by Outlook ID number, synchronizing RSVP, and using categories for activities in Outlook
  
  **NOTE:** You can change the information displayed in the Outlook activity Subject line of a retrieved GoldMine activity by editing the **GoldSync.ini** file (see "Adding Macros to the GoldSync.ini File" on page 318).

- **Deletions:** Define how deletions synchronize between GoldMine and Outlook.

- **Field Mapping:** Define mapped fields so GoldMine can place data in the corresponding Outlook fields.

  **IMPORTANT:** If you choose to use a different folder than the default option in the Folder selection area on the **Contacts**, **Calendar**, or **Task** tabs, it is required to define that custom folder path at the system where the profile will be used.

- **Contacts:** Specify the location of the Outlook folder in which GoldMine sends and retrieves contact information.

- **Calendar:** Specify the Outlook folder in which GoldMine sends and retrieves activity information.

- **Tasks:** Specify the Outlook folder in which GoldMine sends and retrieves.
To Set Up Outlook Synchronization for a User

1. On the **Synchronization** tab, click the **Set up Outlook synchronization for <UserName>** to start the Outlook Username Profile Wizard.

2. Enter a descriptive name for the user profile and select whether or not to allow this user to synchronize. Click **Next** to continue.
Selecting any of the **Synchronizations Options** check boxes will display the Synchronization Options dialog box (see "To Set Up Standard Configuration for Outlook Sync" on page 357).

- **Basic synchronization options** will enable options to sync contacts and/or calendar from GoldMine and/or Outlook to GoldMine and/or Outlook.
- **Advanced options** will enable the Advanced button on the Outlook Username Profile: Synchronization Options dialog box (see "Configuring the Advanced Options" on page 360).
- **Logging options** will enable the Logging Options check boxes on the Outlook Username Profile: Synchronization Options dialog box.

Selecting any of the **Intervals and synchronization frequency** options check boxes will display the Synchronization Intervals dialog box (see "To Set Up Standard Configuration for Outlook Sync" on page 357).

3. Outlook synchronization uses standard configuration. If you need to make changes, check the boxes for the areas that need changed for the current user, and then click **Next**.

4. Specify the GoldMine contact records and Outlook records to sync by cutoff date. Click **Next** to continue.
5. Select which calendars to synch with Outlook. Click **Next** to continue.

![Outlook Username Profile: Next Synchronization Options](image)

If necessary, the default date and time for the next scheduled synchronization for this profile may be changed.

Next sync time: 12/7/2009 @ 2:30 pm

![Outlook Username Profile](image)

Please click 'Finish' to save Outlook sync settings.

6. If needed, change the default date/time for the next scheduled sync, then click **Next**.

7. Click **Finish** to apply the changes and close the wizard.

---

**To Start GoldMine Sync When Starting Outlook**

The **Start GoldMine Sync when starting Outlook** option on the **Synchronization** tab allows you to set how Outlook synchronizes to GoldMine. By checking this option, Outlook will synchronize with GoldMine every time Outlook is launched. If this option is not checked, you must synchronize manually with GoldMine (see "Synchronizing Outlook and GoldMine Manually" on page 364).
Synchronizing Outlook and GoldMine Manually

By default, Outlook is set to synchronize automatically. However, if you’ve disabled this option (see "To Start GoldMine Sync When Starting Outlook" on page 363) or have made a change that hasn’t synchronized yet, you can start the synchronization process manually. Open the GoldMine menu and select Start/Stop Synchronization.

NOTE: GoldMine must be running to synchronize the database with Outlook.

Outlook Mail

Matching Outlook Contacts Automatically to GoldMine Contacts

By default, when a user selects a contact in Outlook, GoldMine Outlook Integration attempt to match the Outlook contact with a GoldMine contact. The contact matching is done by e-mail address (in order: email address #1, email address #2, and email address #3) until one or more matching contacts are found in GoldMine.

In the event that there are multiple matching contacts in GoldMine, GoldMine Outlook Integration displays a dialog in which the user can select the desired matching GoldMine contact to link to the Outlook contact. When there is only one match, this option causes the linking to automatically occur. When the option is not checked, the Outlook contacts are not linked to GoldMine contacts.

IMPORTANT: This option does not “link” the Outlook contact to the GoldMine contact (i.e., it does not save GoldMine data to the Outlook contact). Linking is achieved when the user clicks the Send data to GM button.

To Automatically Link Contacts

1. In Outlook, open the GoldMine menu and select Setup GoldMine Plus.
2. Click the Options tab.
3. In the General section, select the Link contact when the address matches single GM contact option.
4. Click Close to apply the changes and close the dialog box.

Auto-Linking Outlook Messages

Auto-linking links messages automatically from senders in your Outlook mailbox to Contacts in your GoldMine database. By default, messages are not set to link automatically to Contact records. If you want to set up auto-linking, follow the procedure below.

TIP: You can link multiple messages to a Contact by pressing the CTRL key on the keyboard and then selecting multiple messages.

To Setup Auto-Linking of Messages to Contact Records

1. In Outlook, open the GoldMine menu and select Setup GoldMine Plus.
2. Click the Options tab.
3. In the GoldMine Auto-Linking and Attachments section, use the following options to set up how you want the auto-linking feature to work.
   - Enable Auto-Linking when sending E-Mail enables the drop-down list for To Sender or To First Recipient.
     This option is for automatically linking of messages when the recipient/sender is one of your GoldMine Contacts. Checking this option enables the following options:
     - Prompt if E-mail address is not on file when Auto-Linking sent E-Mail.
     - Save a copy of outgoing attachments.
   - Enable Auto-Linking when receiving E-Mail enables the drop-down list for To Sender or To First Recipient.
This option is for automatically linking of messages when the sender/recipient is one of your GoldMine Contacts. Checking this option enables the following options:

- Enable auto-linking for messages previously read in other e-mail clients.
- Prompt if E-Mail address is not on file when Auto-Linking received E-Mail.
- Do not prompt me to handle file names that already exist.

This option allows you to send attachments with the same name without having to click OK on the overwrite warning dialog box for a file that already exists. This is especially useful for files such as a signature GIF or other files that are sent repetitively.

With this option checked, retrieved attachments are processed using the attachment handling settings configured in the user's GoldMine e-mail preferences. For more information, refer to "To Set E-mail Options on the Advanced Tab" in the GoldMine User Guide PDF or in the Online Help.

4. Click Close to apply the changes and close the dialog box.

To Set How the E-Mail is Linked to a Contact

1. In Outlook, open the GoldMine menu and select Setup GoldMine Plus.
2. Click the Options tab and, in the GoldMine E-Mail Center section, select one of the following options:
   - As a pending activity in the E-Mail inbox folder
   - As a completed activity in the filed E-Mail folder
3. Click Close to apply the changes.

To Setup Linking Exclusions

When linking multiple messages to GoldMine, there might be certain e-mail address that you do not want to include, such as anyone from your company or spam e-mail. You can add these e-mail addresses to the Linking Exclusions list, which prevents them from being linked to GoldMine. Manual linking of single messages can still be performed.

1. In Outlook, open the GoldMine menu and select Setup GoldMine Plus.
2. Click the Linking Exclusions tab.
3. Enter the e-mail address you want to exclude on the E-mail Address text box.
4. Click the Add to List button to add this address to the Linking Exclusions list.
   - The asterisk (*) can be used as a wild card; you can add whole domains by using the *@domain format, such as *@frontrange.com.
   - You can also add beginning of addresses by using the name*@ format, such as spam*@ or info@*.
5. Click the Save button to save the list.

You can update this list any time by adding more entries or removing entries that you no longer want to block.

Defining Outlook Folders for Auto-Linking

If you select the options for auto-linking of sending/receiving messages (see "Auto-Linking Outlook Messages" on page 364), GoldMine watches those folders in the Personal Folders area only. If you use an IMAP connection or have multiple inboxes that you want GoldMine to track for auto-linking, you can define those folders on the Outlook Folders tab.

**NOTE:** The folders selected are specific to the individual computer and must be set up individually for each computer using auto-linking.

To Define the Watched Folders for Auto-Linking

1. Open the GoldMine menu and select Setup GoldMine Plus or click the button on the GoldMine toolbar in Outlook.
   On the Setup GoldMine Plus for Microsoft Outlook dialog box displays, click the Outlook Folders tab.
2. Expand the e-mail account tree in the Your Outlook Folders area to view all folders.
3. Select the desired folder to watch.
4. Click the Add button to move it to the Folders Tracked for Auto-Linking area.
5. Repeat the previous step for additional folders to watch.
   
   **NOTE:** If the folder you want to watch has sub-folders that you also want to watch, you must select and add each sub-folder as well.

6. Click Close to save your changes.

Displaying the Linked Contact Details in Outlook

When a message is linked to a GoldMine Contact, the GoldMine Panel is populated with Contact Information and Items for the linked contact.

**To Modify the Display of Contact Information**

1. Click the **Setup GoldMine Plus** button.
2. Click the **Contact Pane** tab.

   The panel on the left shows the available contact fields that you can add to the Contact Information panel in Outlook.

   The panel on the right shows the layout of the contact information details as the display in the Contact Information panel in Outlook when viewing an E-mail or Contact. You can use the formatting tools at the top of this panel to adjust the color, alignment, and character styles of the display text.
3. Select the area where you want the field to be placed in the right panel.
   
   **NOTE:** Where ever the blinking cursor is in the right panel is where the new field will appear.

4. Click the field in the left panel, then click the **Arrow** button to add the field.

5. At the bottom of the **Contact Pane** tab, select the user that this change will affect. If this change should be for all users, select **All users** from the list.

6. When you are satisfied with the layout, click the **Save** button to save your changes.

### Setting the Contact/E-Mail Pane Display Options

By default, an e-mail message that is linked to a GoldMine Contact displays the following tabs below the Contact Information in the GoldMine Panel.

![Tabs](image)

Each tab has commands associated with selected tab, such as Create and Refresh.

**To Modify the Contact/E-Mail Panel Tabs**

If you want to hide any of these tabs on the GoldMine Panel, follow the steps below.

1. In Outlook, open the **GoldMine** menu and select **Setup GoldMine Plus**.
2. Click the **Options** tab.
3. Under the **Contact/E-Mail Pane** section, uncheck the box for any tab you want to hide.
4. Click **Close** to apply your changes.

### Outlook Calendar

#### Set the Calendar Display Options

The Outlook Calendar’s GoldMine Panel can display information related to the selected Item, as well as Pending Sales, Literature Requests, Contact Data, GoldMine Users and Resources, and GoldMine Preview for details for the appointment. You can determine which of these item is displayed in GoldMine panel by modifying the display options.

**To Modify the Display Options**

1. In Outlook, open the **GoldMine** menu and select **Setup GoldMine Plus**.
2. Click the **Options** tab.
3. In the **Calendar Pane** section, make selections from the following options to determine which items display in the GoldMine panel on the Calendar pane:
   - Show Forecasted Sales
   - Show Scheduled Literature Requests
   - Hyperlink to GoldMine Calendar
   - Hyperlink to GoldMine Activity List
4. Click **Close** to apply the changes.
Outlook Tasks

Displaying the Linked Task Details in Outlook

When a task is linked to a GoldMine task, the GoldMine Panel is populated with Task Information and Items for the linked task. You can select what information and how it is displayed by modifying the Task information display.

To Modify the Display of Task Information

1. Click the Setup GoldMine Plus button.
2. Click the Task Pane tab.

- The panel on the left shows the available fields that you can add to the Task Information panel in Outlook.
- The panel on the right shows the layout of the task information details as the display in the Task Information panel in Outlook when viewing a task. You can use the formatting tools at the top of this panel to adjust the color, alignment, and character styles of the display text.

3. Select the area that you want the field in the right panel.
   Note that wherever the blinking cursor is in the right panel is where the new field will appear.
4. Click the field in the left panel, then click the Arrow button to add the field.
5. At the bottom of the Task Pane tab, select the user that this change will affect. If this change should be for all users, select All users from the list.
6. When you are satisfied with the layout, click the Save button to save your changes.
Google Apps Integration Administration

Overview

GoldMine provides a way for companies using Google Apps to sync the GoldMine Calendar with Google Calendar. The 2-way synching allows a user with accounts on both GoldMine and Google Apps, to see appointments and events created in the GoldMine Calendar on the Google Calendar and vice versa. Google Apps must be configured through the Google Developer and Admin Consoles to enable synching.

- Google Apps Integration Set Up
- Synching the Calendar between Google and GoldMine
- Troubleshooting Google Apps Calendar Sync

Prerequisites for Google Apps

You need to have the following before you can set up and configure the synchronization:

- An authorized login for Google Apps to access the Google Developers and Google Admin consoles.
- At least one active Project in the Google Developers console so that you can access the APIs and other functionality necessary to set up the configuration.
- GoldMine Mobile Edition (GMME) installed on an IIS server in order to synchronize the Calendar with Google Apps.
- The IP address of the IIS server to access the GoldMine Configuration page if you are installing from another machine, (or use /localhost). Once GMME is installed you can access Google Apps and the GoldMine configuration page from any machine.

We recommend an installation of Chrome for ease of use with Google Apps products.

Set up involves logging in to the following pages:

- Google Developers Console Page,
- Google Admin Console
- GoldMine Configuration screen in Google Apps.

Once the synchronization is configured and enabled it will run until the GMGoogleSync service is manually stopped or fails. The service starts automatically when the server starts. We recommend performing the connection tests in order to ensure that your set up works.

**IMPORTANT:** Use the following process to generate and link the Email address, Domain, Certificates, and API scopes to a specific service account. Any mis-match between the items, or incorrect entries will result in errors and cause the connection tests to fail.
Google Apps Integration Set Up

**Google Apps Developers Console Tasks**

1. Log in to the Google Developers console  
   a. From a browser window go to: `cloud.google.com`  
   b. Sign in with your Google Apps credentials  
   c. Select Go to my console
2. From the Projects area select an existing project or create a new one.
3. Click on the project name to go to the Project page. In the left pane click the APIs & auth > APIs link to check that both the Admin SDK and Calendar API are enabled for the project. You should see a green ON button next to both.
4. Click on Credentials to create a Service Account that will be used to enable synching.
5. From the Credentials page click Create A New Client ID.
6. At the Create Client ID dialog select Service account and click Create Client ID.
   Once the Service Account is created a new Private key is generated. The Private Key is downloaded to your machine and is the only copy. Ensure that you know the download location.
   The dialog also displays a password that should not be changed or the sync process will not work. Remember this password since it will be used for the Certificate Password on the GoldMine Google Apps Configuration page.
   **NOTE:** You can generate a new Key at any time but the old Key information will no longer work and information for the Admin Console and GoldMine configuration must be updated to ensure that the key information is accurate.
7. When you have saved any needed information, click Okay, got it.
   The Service Account information now displays the ClientID, the Email Address, and the Public Key Fingerprints information.
8. Copy the ClientID and the E-mail address to a note, or keep the page active since you will need this information later.

**Google Apps Admin Console Tasks**

1. Log into the Google Admin Console using a new browser page,  
   a. From a browser window go to: `admin.google.com`  
   b. Sign in with your Google Apps credentials  
   c. Select Go to my console.
2. Click Security. If you cannot see the Security icon check the More Controls area.
3. Under API References, check the Enable API access box. It is not selected by default.
4. From the Security page click Advanced Settings.
5. In the Advanced Settings dialog under Authentication, click Manage OAuth Client access (Advanced Settings > Authentication:Manage OAuth Client access).
6. At the Manage API client access page under the Authorized API Clients section, you must provide a Client Name.
   This is the ClientID generated on the Developers Console. Copy and paste the string into the Authorized API Clients:Client Name field.
7. In the One or More API Scopes field enter the following domains separated by a comma (comma-delimited), to allow data access to the calendars:  
   `https://www.googleapis.com/auth/admin.directory.user`,  
   `https://www.googleapis.com/auth/calendar`
8. Then click Authorize.
   The information will display next to the Client ID. The Calendar scope must show (Read Write) privileges.
9. Return to the Admin Console by clicking the back arrow next to the Security icon.
   Click Google Apps, to ensure that Calendar has a Status of On for everyone.
GoldMine Configuration Tasks for Google Apps

1. Log in to the GoldMine Google Apps configuration page using an account with Master rights in GoldMine.
   Access the page using the IP address of your server for example:
   `<ip_address_of_GoldMine_Mobile_Server>/GoldMine/Configuration/`

2. In Integration Settings select Configure Google Apps.

3. Ensure that Integration is Enabled.

4. For the Service Account Email Address enter the Email Address created when you generated the Service Account key.
   The information is on the Google Developers Console page.

5. Click Select Certificate and browse for the Certificate that was downloaded to your machine. Most often this is in the
   Downloads directory.

6. For the Certificate Password, enter the Password that was generated when you created the Service Account.

7. When you see a check mark, click Save.
   The certificate is saved to the shared GoldMine data folder.

8. Optional but recommended: Click Test these Settings to ensure that the information you entered is accurate. From the
   Test Google Apps Settings dialog check that the @ field contains the email address of an authorized administrator and
   that the Google Apps Domain contains the correct domain information.
   a. Click Start Test.
   b. If all information was accurately entered, you will see a check mark indicating that the test was successfully able to
      connect to your Google Apps domain.
   c. You will also see a list of Users and an related OFF or ON symbol indicating whether or not the user can sync to the
      Calendar. If a GoldMine User has a Google Apps e-mail address for the configured Google Apps domain entered in
      the GoldMine Users' Settings, the account can access the users calendar and sync is turned ON for this user. If not,
      then sync will be turned OFF.

To Configure a Users GoldMine Email for Synching with Google Apps

1. Log into GoldMine with Master rights and select Tools > User’s Settings... to open the Users’ Master File dialog.
2. Double-click the user name, for example JSMITH, to open the Properties window.
3. In the Profile tab > E-mail address: field, enter the e-mail address. For example: j.smith@goldmine.com
4. Click OK, then click Close.
5. Return to the GoldMine Configuration page and click Test Again.
6. The email address you entered in GoldMine should display next to the user name in the Google Apps Configuration.

For synching to occur, ensure that e-mail addresses between Google Apps and GoldMine match as described in GoldMine
Configuration Tasks for Google Apps. Or enter e-mail address information in the GoldMine Properties > Profile tab > E-mail
address: field. If no match is found, synching will not occur and the user will be ‘skipped’.

To Monitor the Google Apps Sync

1. From Windows, open Event Viewer > Applications and Services Logs > GoldMine-GoogleSyncLog to track the activity.
2. Once started, the sync service remains active until it is cancelled.

Synching the Calendar between Google and GoldMine

The following table shows which fields are synched between the GoldMine and Google Apps Calendars:

<table>
<thead>
<tr>
<th>GoldMine Calendar</th>
<th>Google Calendar display</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference: Event title</td>
<td></td>
</tr>
<tr>
<td>Names entered in Contacts: Guests</td>
<td></td>
</tr>
<tr>
<td>GoldMine Events Google all day Events</td>
<td></td>
</tr>
</tbody>
</table>
Create an Appointment/Event from Google Calendar

1. From the Google Calendar page enter a name for the Event
2. For the Where: field enter a location such as a meeting room or webex link etc.
3. Add a Reminder time.
4. Mark as Private or Public. Information about Private events cannot be seen by other users.
5. Invite other contacts by entering an email address under Add guests then click Add.
   The event links to either Primary or secondary addresses entered in your GoldMine contacts. Primary and secondary email addresses are when you have a contact in GMPE with more than one email address. In this case no matter which email address is used, the appointment or event is still correctly linked with that contact.
6. Enter other information as needed the click Save. At the prompt click Send to send the invite.
   **NOTE:** Check the data mapping table Synching the Calendar between Google and GoldMine, to see which fields will update in GoldMine Calendar
7. The event will take a moment to sync to your GoldMine Calendar

Create an Appointment/Event from GoldMine Calendar

1. From the GoldMine Calendar page enter a title in Reference
2. Enter any descriptions under the Notes: field.
3. Add Start Date, Time, Duration, and Alarm information.
4. Mark as Private if needed. Information about Private events cannot be seen by other users.
5. Invite attendees by moving the name from the User List to the Selected Users pane then click OK.
6. Enter other information as needed then click Save. At the prompt click Send to send the invite.
   **NOTE:** Check the data mapping table Synching the Calendar between Google and GoldMine, to see which fields will update in GoldMine Calendar
7. The activity will take a moment to sync to your Google Apps Calendar

Troubleshooting Google Apps Calendar Sync

Here are some scenarios that explain why some invitees may not be listed, or some events may not be linked in GoldMine
From GoldMine
If you invite a person who does not have an email that person will not show as an attendee in the Google Calendar, since Google Calendar events require invitees to have an email address. If you later add an email in for this contact, you must Edit the Activity from the GoldMine Calendar before Google will sync the information and display the person as an Event participant within the Google Apps Calendar.

From Google Calendar
If the email entered for a Guest (Event participant) does not exist in GoldMine database, the activity appears on your GoldMine Calendar, but may appear as an [unlinked activity] since a corresponding email cannot be found.

Inviting someone in your domain (i.e. someone who works for the same company) who is not a GoldMine user or does not have a Google Apps email configured within GoldMine, will not appear as a participant in the GoldMine activity.

Once an Event is synched it will not re-sync unless a change is made to the invite on either platform.
Licensing

Overview

GoldMine has a fully-scalable licensing structure to meet the needs of individuals and organizations. As your business matures and GoldMine expands, your organization can change the licensing configurations.

About GoldMine Licenses

The single, distributed Master License serves as the authentication mechanism for secure synchronization across the entire organization, and the License Manager keeps track of your licensing configurations.

Most organizations generally buy one license—a Master License with X number of seats. These seats can then be parsed to users in various combinations of sub-licenses. For example, an organization can create Site sub-licenses for their remote office(s) and Undocked sub-licenses for individual remote (mobile) users. One seat should always be set aside for administrators.

**NOTE:** When using Outlook Integration with GoldMine, exactly 1 concurrent license is used if you have GoldMine open and/or are connected to GoldMine within Outlook.

License Types

**Master License.** This is the primary license (see "Master License" on page 377). It determines what database types are supported by the master site as well as its synchronization capabilities. It is a precursor to executing any sub-licenses which stem from it.

GoldSync licenses are issued concurrent with the E license.

The licensing serial number schema for Master licenses has been changed for the 7.0.4 release, but remains the same for sub-licenses. See "License Serial Number" on page 376.

**Sub-licenses.** To issue one of these, install GoldMine with a Master License on your organization’s primary network. This ensures all sub-licenses maintain security and are authenticated properly during synchronization.

The Undocked license (a special sub-license) is for remote users and can only be licensed for a single user. It can be sub-licensed from the main GoldMine system or from a Site sub-license.

**Increases:** Previous increases for Corporate Edition, Standard Edition, and GoldSync (J, R, and N), are now facilitated by obtaining a new E or G license (which account for the increase and the Master license count).
**License Serial Number**

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Product</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Master Licenses</strong></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
| E | GoldMine Corporate Edition  
| G | GoldSync License | GoldSync seat purchased separately and can be added to E-Licenses. |
| M | GoldMine Mobile License | Support for GoldMine Mobile users. |
| **Sublicenses** | | |
| U | Undocked License | Single sub-license for a remote GoldMine user. |
| S | Site License | Multiple-user sub-license for a remote office. |
| Y | GoldSync License | GoldSync sub-license for a remote office. |

- **License type**: Alpha-prefix denotes the type of Master license.
- **Number of users**: First 4 numbers indicate the license count or seats available in the license. The license count determines the number of users who can log on to GoldMine at one time but does not limit the total number of named users.
- **Version**: A 2-digit version number.
- **HDA number**: A unique 6-digit customer account number, also referred to as the Help Desk Authorization (HDA) Account.
- **Serial number**: 15-character (alphanumeric) serial number uniquely identifying the license for an organization. It is used for registration and support and identifies all sub-licenses as part of the same organization. Collected in 3 groups of 5 characters during licensing.
- **Key code**: 15-character (alphanumeric) key code is a computer-generated check used by GoldMine to verify the license’s validity. Collected in 3 groups of 5 characters during licensing.

**NOTE**: The key code is required during installation. Keep the license number and key code in a safe place in the event it becomes necessary to reinstall the software.

**License Manager**

Initial licensing information is collected during installation. Subsequent changes and related management functions are handled through the License Manager.

From the GoldMine **Tools** menu, select **Configure > License Manager**.

The central text box lists all installed licenses and any sub-licenses created from this location. Status is displayed along the right side. Buttons along the bottom allow you to add a New License, add a New Site, add an Undocked User, Remove License, or View License.

The database support of the Master License is inherited by the site sub-licenses distributed throughout the organization. GoldSync Synchronization capabilities can be distributed separately to sub-licenses.
NOTE: Licensing information is stored in the license file, Licensegm.bin, created at the time you register. This file must exist only in the GoldMine root directory of each GoldMine installation.

Master License

- A GoldMine Premium Edition 9 Master License begins with the alpha-prefix of E, G, or M (Example: E-0050xx where xx is the 2-digit GoldMine version number).
- The E-license is usually a multi-user license for a server installation of GoldMine but could be a single-user license for a stand-alone computer.
- An E-license includes a GoldSync license for each purchased GoldMine seat.
- Remote site sub-licenses (S- and Y-licenses) and Undocked sub-licenses (U-licenses) are created from the E-license.
- Type the E-license number and key code you received when you purchased the software.
- If you type an E-license serial number into the text boxes, the GoldSync text box area remains unavailable because GoldSync is included. Type your G-license information at that time, or later using License Manager. You do not need to type the G-License number to proceed with licensing GoldMine.

Using Net-Update

If you have an existing GoldMine license and have purchased an upgrade, or if you participate in the Upgrade Protection Program (UPP), use Net-Update to upgrade to the latest version.

NOTE: If multiple users synchronize with GoldMine, all GoldMine systems must run the same version and build of GoldMine.

Net-Update transmits your registration information to FrontRange Solutions, or log in frontrange.com to manually update this information.

1. Ensure your ISP is successfully connected.
2. Access Net-Update via:
   - Tools > Configure > License Manager (Net-Update Tab)
   - Help > Update GoldMine
   
   NOTE: If you are using License Manager, select the Update registration information check box to update with the information in the Registration tab if appropriate.
4. Use Net-Update to register GoldMine, update your version of GoldMine, or view options to upgrade your GoldMine system.

Using the License Manager

Purchase GoldMine with a Master License serial number to provide maximum flexibility for an organization in controlling the data integrity and security for each user.

Example:

Purchase a 50-user GoldMine license and a 50-user GoldSync license. Install once on the network. Then, create two 10-user sublicenses for the 2 branch offices from the Master License. Create GoldSync sublicenses for the 2 branch offices. Then, create undocked sublicenses for the notebook PCs of undocked users. Each license created from the Master License shares the same GoldMine serial number to provide authentication, ensuring secure remote synchronization throughout the organization.

Select Tools > Configure > License Manager. The GoldMine License Manager dialog box appears.
NOTE: Also display License Manager from the Undocked Users/Sites dialog box of the GoldSync Site Wizard. Select Undock Users/Create Sub-License.

License

- **Total users/dist**: Total available GoldMine E Licenses and the number of licenses distributed (S or U).
- **GoldSync Sites**: Total number of GoldSync G-Licenses and the number of licenses already distributed (Y).
- **Authentication**: The code randomly generated upon installation and used by GoldMine to verify sublicenses were created from the same Master License during synchronization. Reinstalling the Master License generates a new authentication number and renders all sublicenses incompatible.
- **Databases**: Database types supported by the current license (SQL Server).

Distributed Licenses

- **Undocked Users**: Number of Undocked license numbers created.
- **Remote Users/loc**: Remote users and total number of sites where these users are distributed.
- **GoldSync Sites/loc**: GoldSync sublicenses and the number of sites for these licenses.

NOTE: A maximum of 16 licenses can be combined within the License Manager.

Tasks Performed Using Licence Manager

<table>
<thead>
<tr>
<th>Task Description</th>
<th>Reference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create New Site sublicenses for branch offices (Master Rights required)</td>
<td>Creating Site Licenses (see page 379)</td>
</tr>
<tr>
<td>Create Undocked User licenses for remote users working offsite (Master Rights required)</td>
<td>Creating Undocked User License (see page 380)</td>
</tr>
<tr>
<td>Remove a license (Master Right required)</td>
<td>Removing Licenses (see page 382)</td>
</tr>
<tr>
<td>Upgrade your copy of GoldMine with the latest version using Net-Update.</td>
<td>Using Net-Update (see page 377)</td>
</tr>
<tr>
<td>Install GoldMine on Local Workstation</td>
<td>See “Running a Networked Workstation Installation” in the <em>GoldMine Installation Guide</em> PDF.</td>
</tr>
</tbody>
</table>

About Sub-licenses

With multiple offices and users, create sub-licenses for each site or user from the Master License. A site sub-license installs that license on only one remote server. An undocked user sublicense installs that license on one remote computer. However, create multiple site licenses and undocked licenses up to the maximum permitted by the Master License.

Site License

A Site License is a multiple-user sublicense for a remote office and is designated with the alpha-prefix S. Have an S-license for each user at the remote site.

- When creating any sublicense, note the entire license number created by GoldMine. The sub-license includes additional information needed when typing the license number on the remote computer and displays in its entirety during the creation process.
- A GoldSync License (Y-license) is required only if you are using an S-license and want to synchronize using GoldSync. You should have one Y-license to synchronize with the Master License and additional Y-licenses for Undocked users synchronizing with your site.
- Y licenses are not entered in the Enter GoldMine Serial Number dialog box. Only S licenses are entered during registration (the GoldSync Section remains disabled). Clicking Next displays an ALERT: Suggested Action(s)! if you attempt to enter Y licenses in the Enter GoldMine Serial Number dialog box.

- If this installation of GoldMine includes its own GoldSync sites, you enter the applicable Y-type sub-licenses to properly configure synchronization for this system.

  **TIP:** Highlight the complete serial number in GoldMine, copy it (CTRL+C) and paste it (CTRL+V) into Notepad.

**License**

Undocked licenses are sub-licenses created from a Master License or a Site license and are designated by the letter “U.” This license type is created for users who work with GoldMine at another location, on a laptop, or on a workstation disconnected from the server copy of GoldMine. Type the U-license, Key Code, and Site Code created in the License Manager.

---

**Creating Site Licenses**

1. Select **Tools > Configure > License Manager.**
   The GoldMine License Manager dialog box opens.
2. Select the **Licenses** tab and click **New Site.**
   The Create a Site License dialog box opens.
3. At the **Distributed License Type** area, select **GoldMine Site License.** Instructions for creating the GoldSync License follow.
4. **Type the Site Name.** The name of the site should have no more than 12 characters and spaces, such as Los Angeles.
5. **Type the Number of Users** who will need seats at the site. This will be the total number of users included in the sublicense.
6. **Click Create Site Sub-License.** The Sub-License for Remote Site [site name] dialog box appears. Select **I AGREE** if you accept the licensing terms.
7. GoldMine displays the new sublicense for the remote site, beginning with the letter S, in the field at the bottom of the dialog box. Make a copy of this number; you need it when licensing the site. When finished, select **Close.**
   **NOTE:** A unique sublicense number is needed for each remote computer installation. Send the remote site number to the remote location. The GoldMine administrator at the remote site can then type the license number during the GoldMine installation.
8. complete the process, click **OK** in the Create a Site License dialog box.
   GoldMine adds the sublicense to the Licenses tab browse window under previously installed license(s). The first character of a site sublicense serial number is S.
9. To synchronize between the remote site and the Master License site, you need at least one GoldSync License.
To Increase or Decrease Site Sublicenses

Site number of sublicenses can be increased or decreased by using the following procedure:

1. Verify/reset synchronization.
2. Delete the Site sublicense in the License Manager on the main GoldMine system (see "Removing Licenses" on page 382).
3. Create a new license with the necessary number of seats and GoldSync sublicenses (Y-Licenses).
4. Re-license the remote site with the new sublicense.

NOTE: Sites are allowed to sublicense undocked users.

Creating Undocked User License

GoldMine has a sub-license for an individual user called an Undocked License (U-License). This license type is created for users who work primarily with GoldMine at a remote location on a laptop, notebook, or home office computer but who also need to log on to the network occasionally. Before creating an undocked consider the following:

- Creating an undocked user decreases the available users of the network site (Master License or Site License) by one; however, when an undocked user logs on to the site from which they were sub-licensed, they do not take up an additional seat.
- Every user supported by the GoldMine license can have an Undocked license to work on a remote computer. For example, on a 5-user GoldMine system, 5 Undocked licenses can be created. This is in contrast to creating an “S” sub-license which requires one seat to remain available from the Master License.
- All undocked users, as well as the total number of users that make up the difference in the total number allowed by the Master License can log on to GoldMine. For example, on a 5-user GoldMine system with 3 undocked users, 3 undocked users plus 2 other users can log on to GoldMine.
- If you undock all users, only those users will be able to log in. If you have not assigned master rights to any of those undocked users, GoldMine administration cannot take place.
- When used in combination with GoldSync, administrators can synchronize security settings to undocked users including new passwords, menu items, and preferences in addition to data.
- To work on an undocked basis, users must have an Undocked license on their laptop. Create an Undocked license from the Master License or a Site license.

To Create an Undocked User License

1. From the GoldMine main menu, select Tools > Configure > License Manager.
2. At the License Manager window, click the Licenses tab and Undock Users.
3. At the Create Undocked User Licenses dialog box, select the check box next to the user you want to create a sub-license for, and click Create Undocked License.
4. At the Sub-Licenses dialog box, review the information and click I Agree.
   - The sub-license number for a remote user or an undocked user appears in the Sub-license for Remote Site [Name of Site] dialog box.
   - GoldMine adds the sublicense to the Licenses tab browse window under previously installed license(s). The first character of a site sublicense serial number is U.
5. Write the sub-license number down or copy it to Windows Notepad.

NOTE: A unique sublicense number is needed for each remote computer installation. Send the remote site number to the remote location. The GoldMine administrator at the remote site can then type the license number during the GoldMine installation.

NOTE: Licensing is not necessary on Undocked user installations when installation is done by a One-button installer package.
Creating GoldSync Licenses

GoldSync licenses are included with GoldMine Premium Edition and are issued concurrent with the E license. GoldSync seat purchased separately and can be added to E-Licenses. For more information about GoldSync, see “About GoldSync” on page 300.

To Create a GoldSync License

1. From the GoldMine main menu, open the Tools menu and select Configure > License Manager.
2. In the GoldMine License Manager, select the Licenses tab and click New Site. The Create a Site License dialog box appears.
3. In the Distributed License Type area, select GoldSync Site License.
4. Type the Site Name (no more than 12 characters and spaces).
5. Type the Number of Users who will need GoldSync licenses at the site (the total number of users included in the GoldSync sublicense). The site needs at least one GoldSync license to synchronize with the Master License.
6. Click Create Site License. The Sub-License for Remote Site [site name] dialog box appears.
7. Select I AGREE.
8. The new GoldSync sublicense for the remote site displays. Copy of this number, beginning with the letter Y; you need it when licensing the site.

   NOTE: A unique sublicense number is needed for each remote computer installation. Send the remote site number to the remote location. The GoldMine administrator at the remote site can then type the license number during the GoldMine installation.
9. Click Close.
10. Select OK in the Create a Site License dialog box.

   NOTE: GoldMine adds the sublicense to the Licenses tab browse window under previously installed license(s). The first character of a site sublicense serial number is Y.

Undocked Users

IMPORTANT: Do not allow undocked users to synchronize with an updated GoldMine system until that undocked user has updated to the same version and build as the updated site is using.

To update undocked users after performing a Net-Update on the main GoldMine system, locate the gmsetup.exe file. Depending on how undocked users communicate with the network and GoldMine system and on the connection speed, send the gmsetup.exe file to the undocked user by putting it on CD, posting it on an FTP site, e-mailing it, or placing it on an accessible network drive.

Include directions on executing the gmsetup.exe file and what undocked users should expect after the upgrade.

After the undocked users update to the same version of GoldMine, they can use Net-Update to sync with the master site.

To perform the update, click Net-Update Now and follow the prompts. To change the registration information, select Update Registration Information.
Removing Licenses

In a multi-license GoldMine installation, it be necessary to delete sublicenses such as site licenses, undocked user licenses, or GoldSync licenses. You cannot delete E or G-Licenses. Only users with Master Rights can delete licenses.

1. Select Tools > Configure > License Manager. The GoldMine License Manager dialog box appears.
2. From the Licenses tab, select the sublicense to delete and then click Remove License.
3. Click Yes to remove the license.

IMPORTANT: Removing licenses will prevent those licenses from being able to synchronize with GoldMine.

Updating Registration Information

The registration information for GoldMine is entered during product installation. However, you can make changes to this information in the License Manager. The changes you make take place when you perform the Net-Update.

To Update Registration Information

1. Tools > Configure > License Manager
2. Click the Net-Update tab.
3. Check the Update registration information box.
4. Click the Registration tab and make the desired registration changes as needed.
5. Click the Net-Update tab and the click the Net-Update Now button.
Integration

Overview

GoldMine can be integrated with both HEAT, IPCM, and .NET. For more information, refer to the following topics:

- Integrating with HEAT
- Integrating with IPCM
- Integrating with .NET

**NOTE:** For specific details regarding installation and configuration of each product, refer to each corresponding product’s installation guide.

Integrating with HEAT

You can configure HEAT with GoldMine so that the two applications share information. This configuration provides HEAT users with read/write access to GoldMine customer information from within the Call Logging module. GoldMine users can view Call Logging information from within the Tickets tab and the Details tab in GoldMine.

**NOTE:** You must be using GoldMine with an E-License on an SQL database to integrate with HEAT.

Configuring HEAT and GoldMine provides the following capabilities:

- HEAT users can view and modify GoldMine customer information, including the phone number, address, email address, etc. GoldMine can also be integrated to display a list of associated contacts for the selected Contact1 customer.
- HEAT users can view the GoldMine customer Sales-Pending information, including a list of scheduled sales activities for a particular GoldMine customer.
- HEAT users can view the GoldMine customer Sales-History information, including a list of sales activities that have taken place for a particular GoldMine customer.
- GoldMine users can view Call Logging Information, including call history information on the Detail, Journal, and Assignment tabs.

**NOTE:** The Ticket Transfer feature expands the viewing of Call Logging information in GoldMine by allowing the transfer of Call Record data to the ContSupp table. From there, it can be displayed in the GoldMine Details tab and synched to remote, undocked users.

- HEAT and GoldMine users can send internal email messages to each other.
- HEAT and GoldMine users can post alerts to each other about key customer issues.

For HEAT/GoldMine configuration details and procedures, refer to:

- How Configuration with GoldMine Works (see page 384)
- Configuration Process (see page 386)
How Configuration with GoldMine Works

HEAT and GoldMine communicate by sharing information in their database tables. An external link is created from HEAT to two GoldMine database tables: the Contact1 table and the ContSupp table. From the external link you can view and modify data. This allows data to flow in both directions between the databases and the applications.

**The Contact1 Table**

The Contact1 table stores information for GoldMine customers such as phone numbers, address, fax number, etc. HEAT displays the Contact1 table information using the Contact1 Customer Type in Call Logging. Information is displayed in the customer profile (often called the Customer window). Call Logging users can view and modify customer information.

**NOTE:** Information about pending sales and sales history is also displayed in the Customer window using the Sale-Pending and Sales-History tabs. This information is read-only.

In GoldMine, users can view Call Logging information (more specifically Call Record information) for Contact1 customers directly from the Tickets tab. Call History information is displayed in grid form. Users can right-click and select the **Zoom** command to view Detail, Journal, and Assignment information. Call Record information displayed in GoldMine is read-only.

**The ContSupp Table**

The ContSupp table stores information about a GoldMine customer's additional contacts and email addresses for all contacts. Additional contacts are displayed in the Contact tab in the Customer window.

**IMPORTANT:** You cannot modify the email addresses that autofill in the Profile and Subset forms in HEAT Call Logging.

**The GoldMine Ticket Transfer Feature**

The GoldMine Ticket Transfer feature runs as a service and queries the HEAT database for Contact1 Call Record information. Data is then transferred to the ContSupp table in the GoldMine database where it can be displayed in the GoldMine Details tab. You can then synchronize this information to remote, undocked users.
Data Flow Relationship

1. Data flows in both directions between the databases and the applications. Between the HEAT database and the HEAT modules, and between the GoldMine database and the GoldMine application, data flows via Open Database Connectivity (ODBC).

2. Contact information is validated from the GoldMine database through the Contact1 and ContSupp tables, and flows to the HEAT application, allowing HEAT users to view GoldMine customer information and additional contacts.

3. The Call Records created in HEAT flow to the Tickets tab in the GoldMine application via Dynamic Data Exchange (DDE) and ODBC.

4. You can view pending and history GoldMine activities in HEAT Call Logging. The information displayed in Call Logging is read-only. The data flows from the GoldMine database to the HEAT application via ODBC.

5. GoldMine Customer information and additional contact information (Contact1 and ContSupp tables), which is created or updated in the HEAT application, is sent to the GoldMine database via ODBC.

6. The SPFiles table in the GoldMine database stores data can be validated in the HEAT Administrator module.

7. Call Records are created and stored in the HEAT database. The Ticket Transfer Utility converts these Call Records into detail records on the GoldMine Details tab. The data flows from the HEAT database to the Ticket Transfer Utility via ODBC and then to the GoldMine database via ODBC.

8. Alerts data flows between the GoldMine database and the HEAT application. You can only define alerts in GoldMine. You can enable both HEAT and GoldMine to assign and display the other application’s alerts.
**Configuration Process**

HEAT configuration settings are located in the HEAT Administrator module, the Call Logging module, the Ticket Transfer Utility, and the GoldMine application. To integrate HEAT and GoldMine, complete the following steps in sequence:

1. **Install HEAT and GoldMine.** To install HEAT and GoldMine, refer to the product Installation guides. They can be installed in any order.

2. **Set HEAT Security Rights for GoldMine (see page 386).** Security rights must be granted in order for HEAT to integrate with GoldMine. You must also grant security rights for the Ticket Transfer feature and GoldMine mail. Security rights are set in the HEAT Administrator module.

3. **Run the GoldMine Connection Wizard (see page 387).** The GoldMine Connection wizard leads you through the steps necessary to connect HEAT with the GoldMine data source. The GoldMine Connection Wizard is run from within an Edit Set in the HEAT Administrator module.

4. **Set GoldMine Integration Defaults (see page 387).** GoldMine Integration options in the HEAT Administrator module let you set the path to the GoldMine application as well as configure default options for displaying information in the Call Logging Customer window.

5. **Set Call Logging User Preferences for GoldMine.** Specifies the GoldMine location so it can be launched directly from Call Logging and sets GoldMine display and logon options. Refer to the Call Logging online help topic "Customizing Call Logging: Set User Preferences" for details.

6. **Set Call Logging User Preferences for GoldMine Alerts.** Settings to display GoldMine alerts for GoldMine customers. Refer to the Call Logging online help topic "Customizing Call Logging: Set User Preferences" for details.

7. **Run the GoldMine Ticket Transfer Configuration Utility (see page 389).** This utility sets up options for the GoldMine Ticket Transfer service. The service allows you to transfer new and updated Call Record information to the ContSupp table in GoldMine.

8. **Set up HEAT Integration in GoldMine (see page 389).** HEAT Integration options on the Tickets tab in GoldMine let you enable integration with HEAT and define HEAT data source and login options.

**Set HEAT Security Rights for GoldMine**

To configure HEAT with GoldMine, you must grant security access to the role conducting the configuration steps (usually the administrator). Security rights for the GoldMine Alerts, Mail, and the Ticket Transfer feature should also be granted to the roles using those features.

**To Set HEAT Security Rights for GoldMine**

1. Launch the HEAT Administrator module.

2. In the Administrator Dashboard, click the **Edit Roles** link in the **System Security** section (or, in the Administrator main window, select **Security > Roles** from the menu bar). The **Roles** dialog box opens, listing all defined roles.

3. In the **Roles** list, select the role that will conduct the configuration process (usually this is the Administrator role).

4. Click the **Rights** tab.

5. In the **Category** drop-down box, select **Administrator Module** or **All Rights**. A list of areas associated with the selected category appears in the **Area** list; the Rights column lists the rights currently assigned to each area.

6. In the **Area** list, select **Integrations Setup**, then select the **Yes** option to allow rights.

7. Click **Apply**.

8. To add GoldMine rights for Alerts, Mail, and the Ticket Transfer feature for users, select the role in the **Roles** list, then click the **Roles** tab.

9. In the **Category** drop-down box, select **All Rights**.

10. Select the following roles:

    - **GoldMine Alerts** - Select View, Add, Edit, and/or Delete.
    - **GoldMine Mail** - Select Yes.
    - **GoldMine Ticket Transfer** - Select Yes.

11. Click **Apply**, then click **Close**.
Run the GoldMine Connection Wizard

The GoldMine Connection Wizard leads you through the steps necessary to connect HEAT with the GoldMine contacts data source, allowing HEAT and GoldMine to share customer information. When run, the wizard creates the Contact1 Customer Type in the HEAT Profile table, allowing HEAT users to view GoldMine information from within Call Logging. You can also configure the connection to share the GoldMine customer additional contact information. After the wizard creates the necessary connections, you are prompted to commit the changes to your HEAT database, accomplished by committing an Edit Set (the wizard is run and the Edit Set is committed from within the Edit Set interface in the HEAT Administrator module).

To Run the GoldMine Connection Wizard

1. Launch the HEAT Administrator module.
2. Create an Edit Set by clicking the Create Edit Set link in the Customizing Your System section of the Administrator Dashboard, or by selecting File > New Edit Set from the Administrator menu bar. The Edit Set interface opens.
4. In the Name drop-down list, select the GoldMine contact information data source you want to use.
   
   NOTE: Data sources for GoldMine are automatically set up during the installation process. If the data source is not available, click Connection Manager to locate the data source.
5. To view a GoldMine customer's additional contacts in the Call Logging Customer window, select the Use Contact information from GoldMine as well check box.
6. Click Finish. A confirmation dialog box opens when the Connection Wizard successfully completes. The wizard prompts you to commit the changes to your database using an Edit Set.

Set GoldMine Integration Defaults

GoldMine Integration defaults in HEAT Administrator let you set options for accessing GoldMine.

To Set GoldMine Integration Defaults

1. Launch the HEAT Administrator module.
2. Click the GoldMine Integration Setup link in the Set System Defaults section of the Administrator Dashboard, or select Defaults > GoldMine Integration Setup from the Administrator menu bar. The GoldMine Integration dialog box opens.
3. Select the **Enable GoldMine Integration** check box.

4. In the **GoldMine Path** field, type the path to the GoldMine executable, or click the **Browse** button to navigate to the location of the program file.

5. In the **User ID** and **Password** fields, type the User ID and password required to log on to GoldMine.

6. Next to the **Contact Data** field, click the **Select** button to choose the set of GoldMine contacts with which you want to integrate.

7. To define options for a particular role, select the **Change options based on user role?** check box, then select a role in the **Roles** drop-down list. If this check box is not selected, all roles are allowed to access any options selected in the **Customer Window Options** and **Data to Display** sections.

8. In the **Customer Window Options** section, select default options for the Call Logging Customer window:
   - **Show Pending Activities in Customer Window**: Displays the Sales.Pending tab in the Customer window. This allows HEAT Call Logging users to view a list of scheduled sales activities for a particular GoldMine customer.
   - **Show Activity History in Customer Window**: Displays the Sales.History tab in the Customer window. This allows HEAT Call Logging users to view a list of sales activities that took place for a particular GoldMine customer.
   - **Allow GoldMine to be launched from Customer Window**: Allows users to launch GoldMine directly from the Customer window in Call Logging.

9. In the **Data to Display** section, select the GoldMine information you want displayed by default.

10. To limit the view to only the activities the user creates or owns, select the **Limit Display to User’s Activities** check box.

11. Click **OK**.
Run the GoldMine Ticket Transfer Configuration Utility

The GoldMine Ticket Transfer feature runs as a service and queries the HEAT database for Contact1 Call Record information. Data is then transferred to the ContSupp table in the GoldMine database where it can be displayed in the GoldMine Details tab. Remote, undocked users can then synchronize to this information. The GoldMine Ticket Transfer Configuration Utility allows you to set up and establish options and preferences for the GoldMine Ticket Transfer service.

To Run the GoldMine Ticket Transfer Configuration Utility

1. Launch the GoldMine Ticket Transfer Configuration Utility from the HEAT CD. The GoldMine Ticket Transfer Configuration Utility dialog box opens.

2. In the Data Source field, type the path to your HEAT data source, or click Select to navigate to that location.

   NOTE: If your database is password protected, you might be prompted to type a database User ID and password.

3. In the HEAT User ID/Password section, type the User ID and password required to log on to HEAT.

4. In the Scheduling Query section, type a numeric value indicating how often you want the service to query the HEAT database, then select Minutes or Hours.

5. To query all Call Records in the HEAT database, click the Retransfer All Records button.

   NOTE: If you do not select this option, the query only pulls only Records created since the last poll.

6. Click OK.

Set up HEAT Integration in GoldMine

HEAT Integration options on the Tickets tab in GoldMine let you define HEAT data source and logon options.

To Set up HEAT Integration in GoldMine:

1. Launch GoldMine.

2. Click the Tickets tab.

3. On the Tickets tab, right-click and select HEAT options. The HEAT Integration dialog box opens.

4. To allow HEAT integration, select the Enable HEAT integration check box.

5. In the Data Source field, type the path to the HEAT data source you want to use, or click Select to locate the HEAT data source.

6. In the User ID and Password fields, type the User ID and password required to access the HEAT database.

7. Click OK.
About the Tickets Tab

Available when using GoldMine with an E-License, on a SQL database, and integrated with HEAT (see "Integrating with HEAT" on page 383). Integration gives users access to complete information about the service relationship with the customer. Displays the customer's service calls in HEAT Call Logging. Use the local menu to access related zooming, viewing, and e-mail functions.

Use the associated Ticket Transfer Utility (see "The GoldMine Ticket Transfer Feature" on page 384) to transfer the ticket information to the Details tab (ContSupp table) where the data is synchronized for remote users.

The tab contains these HEAT Call Logging fields:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Call ID</td>
<td>HEAT call identification number.</td>
</tr>
<tr>
<td>Call Desc</td>
<td>Description of the call as it appears in HEAT.</td>
</tr>
<tr>
<td>Company</td>
<td>Company name.</td>
</tr>
<tr>
<td>Recvd Date</td>
<td>Date call opened.</td>
</tr>
<tr>
<td>Contact</td>
<td>Contact associated with the call in HEAT.</td>
</tr>
<tr>
<td>Mod Date</td>
<td>Last date the call was modified in HEAT.</td>
</tr>
<tr>
<td>Priority</td>
<td>Priority assigned to the call.</td>
</tr>
<tr>
<td>Closed Date</td>
<td>Date call closed.</td>
</tr>
<tr>
<td>Call Status</td>
<td>Status of the call (Open, Pending, or Closed).</td>
</tr>
<tr>
<td>Slaurgency</td>
<td>Urgency assigned to the call.</td>
</tr>
<tr>
<td>Call Type</td>
<td>Type of call logged.</td>
</tr>
<tr>
<td>Tracker</td>
<td>Owner of call.</td>
</tr>
<tr>
<td>Category</td>
<td>Call category.</td>
</tr>
</tbody>
</table>

Ticket Tab Local Menu

Access the Ticket tab local menu by right-clicking to view the menu options.

NOTE: The Preview Pane can be used in place of the Zoom command on the context menu.

- Zoom Ticket…
- Edit Ticket…
- Send E-mail…
- HEAT/HEAT PowerDesk Options…

- Zoom Ticket: Opens the Call Ticket Details window. Displays the text of the call ticket in HEAT.
- Edit Ticket: Opens the call ticket in HEAT Call Logging.
- Send E-mail: Sends e-mail to the selected HEAT agent (see "Sending E-mail to HEAT/HEAT PowerDesk Agent" on page 391).
- HEAT/HEAT PowerDesk Options: Allows users with Master Rights to change the HEAT database and log on information.

Launching HEAT from GoldMine

If using GoldMine with an E-License and you configured HEAT integration, launch HEAT from GoldMine.

Select File > Login to HEAT.

Call Logging appears.
Sending E-mail to HEAT/HEAT PowerDesk Agent

Send an e-mail to a HEAT agent from the GoldMine Tickets tab.

1. In the **Tickets** tab, right-click and select **Send E-mail**. The dialog box appears.
2. From **Sent To**, select a HEAT agent.
3. Select a **Subject**.
4. Type the message in the **Notes** box.
5. Click **Send**. The message is sent to the specified HEAT recipients.

HEAT/HEAT PowerDesk Options

When integration is properly configured in HEAT, users with Master Rights can set integration options in GoldMine. Configure the integration using the GoldMine Login tab in User Preferences, or as follows:

1. On a Contact Record, select the **Tickets** tab.
2. Right-click and select **HEAT/HEAT PowerDesk Options**. The HEAT Service & Support Integration dialog box appears.
3. Select **Enable HEAT Service_Support Integration** to display call records on the Tickets tab. Integration is not configured, if:
   4. The **Tickets** tab is empty except for a blank gray bar across the top of the tab.
   5. Nothing happens when you select **File > Login to HEAT**. You cannot launch HEAT from GoldMine.
      
      **NOTE:** For more information, See the HEAT Administrator Module online Help.

   6. Click **Select** to change the **Datasource**. The data source should connect to the HEAT database.
   7. Type the integration's HEAT **User ID** and **Password**.
   8. Click **OK**.

Integrating with IPCM

This topic describes the IPCM/GoldMine configuration process. Administrators must have system administrator level knowledge of the FrontRange Solutions GoldMine and IPCM products.

**WARNING:** Install GoldMine before installing IPCM. The GoldMine installer overwrites IPCM data, resulting in irrevocable data loss.

The IPCM/GoldMine configuration uses the following GoldMine database tables.

<table>
<thead>
<tr>
<th>Table</th>
<th>Description</th>
</tr>
</thead>
</table>
| CONTACT1 | Primary contact information including:  
- Account Number (ACCOUNTNO)  
- Record ID (RECID)  
- Name (CONTACT)  
- Phone numbers (PHONE1, PHONE2, PHONE3)  
- Fax number (FAX) |
| CONTACT2 | Additional contact information including:  
- Fields for user defined keys (USERDEF01,...,USERDEF10)  
- The last the day of customer contact (LASTCONTON)  
- The next planned action (NEXTACTION)  
- The date the next action is planned (ACTIONON) |
The IPCM/GoldMine configuration consists of server and client installation. The server configuration enables a voice application to:

- Question callers.
- Search and update the GoldMine database (including call history records) using caller input.
- Configure a screenpop to display to the agent that receives the call.

The client configuration lets the IPCM Agent Dashboard communicate with GoldMine to perform a variety of tasks including:

- Display screenpops for inbound calls.
- Transfer the current Contact Info Window screenpop to another Agent Dashboard when the agent clicks the Send Screen button.
- Update the GoldMine database with input from the agent.

**IPCM/GoldMine Configuration**

The following procedures describe two installation options:

- **Same Computer Installation: Servers, Clients** - The IPCM and GoldMine servers can be installed on one computer with the clients installed a separate computer.
- **Separate Computer Installation: Server/Client, Server/Client** - The IPCM server/GoldMine client can be installed on one computer with the GoldMine server/IPCM client installed on a separate computer.

The IPCM and GoldMine have been installed, you can then create a Taskbar in GoldMine containing buttons that control IPCM Agent Dashboard functionality. For more information, refer to "Create Agent Dashboard Taskbar in GoldMine PE" on page 394.

**Same Computer Installation: Servers, Clients**

In this configuration the IPCM and GoldMine servers are installed together on one computer, and the IPCM and GoldMine clients are installed on a separate computer.

---

**WARNING:** Install GoldMine before installing IPCM. The GoldMine installer overwrites IPCM data, resulting in irrevocable data loss.

1. Install GoldMine. Refer to the GoldMine Installation Guide for information.
2. Close the GoldMine application.
3. Install IPCM as described in the **IPCM Administrator Guide**.
4. Restart the computer.
5. Configure IPCM to connect with the GoldMine database:
   a. Start IPCM and open Management Portal > System Configuration > Contact Center Server > Integrations. The integrations page opens.
   b. Click the GoldMine tab.
   c. Select the Enable check box. Click the Update button.

   **NOTE**: At this point, do not click the Commit Changes button or you will see errors in the Log, since the GoldMine connection has not yet been configured.

d. In the Name field, enter the name of the ODBC connection to your GoldMine database.
e. In the Description field, enter a description of the database connection, if desired.
f. Click the Add button.
g. Click the name of the connection, which now appears as a link. The connection settings appear.
h. Configure the connection settings:
   - **System Folder** - Type the location of the GoldMine installation folder.
   - **GoldMine Folder and Common Folder** - Type the alias for accessing the database. For example, to access SQL Server, an alias of GoldMine might be configured. The string to access this would be MSSQL: GoldMine: dbo: (where GoldMine is the database name).
   - **GM User Name** - Type the GoldMine user name.
   - **GM Password** - Type the GoldMine password.
   - **SQL User Name** - Type the GoldMine database user name.
   - **SQL Password** - Type the GoldMine database password.
i. Click the Commit Changes button.

**Separate Computer Installation: Server/Client, Server/Client**

In this configuration the GoldMine server and the IPCM client are installed on one computer, and the IPCM server and the GoldMine client are installed on a separate computer. Both computers must be members of the same Windows domain.

1. Install the GoldMine server. Refer to the GoldMine Installation Guide for information.
2. Install the IPCM client on the same computer as the GoldMine server.
3. Configure network sharing for the GoldMine server system directory (<install_dir>/Goldmine/Goldmine) on the GoldMine server host computer.

   **NOTE**: Making sure you grant full sharing rights and NTFS permissions to the computer account on which you plan to install the IPCM server.

   b. Click the Sharing tab, then select the Share this folder option.
   c. Click the Permissions button. The Permissions for GoldMine dialog box opens.
   d. Click the Add button. The Select Users, Computers, or Groups dialog box opens.
   e. Click the Object Types button. The Object Types dialog box opens.
   f. Select the Computers check box, then click OK to return to the Select Users, Computers, or Groups dialog box.
   g. In the Enter the object names to select field, type the name of the computer on which you plan to install the IPCM server, then click the Check Names button. The appropriate name of the IPCM server target host computer displays.
   h. Click OK to return to the Permissions for GoldMine dialog box.
   i. Click the Apply button, then click OK to return to the GoldMine Properties dialog box.
   j. Click the Security tab, then click the Add button. The Select Users, Computers, or Groups dialog box opens.
   k. Click the Object Types button. The Object Types dialog box opens.
   l. Select the Computers check box, then click OK to return to the Select Users, Computers, or Groups dialog box.
m. In the Enter the object names to select field, type the name of the computer on which you plan to install the IPCM server, then click the Check Names button. The appropriate name of the IPCM server target host computer displays.

n. Click OK to return to the Security tab.

o. Click Apply, then click OK.

p. Repeat steps 3a through 3o for the IPCM client.

4. Install the IPCM server on a different computer.

5. On IPCM server computer, map the shared GoldMine directory as the network drive by creating a script to map the drive on system startup.

   a. Start the Microsoft Management Console: select Start > Run. The Run dialog box opens. Type mmc in the Open field, then click OK.

   b. In the Microsoft Management Console, press CTRL+M or click File > Add/Remove Snap-in.

   c. Click the Add button.

   d. Select the Group Policy Object Editor snap-in and click the Add button.

   e. Click Finish in the next dialog box.

   f. Click Close, then click OK.

   g. Create a new text file map.bat in the C:\Windows\System32\GroupPolicy\Machine\Scripts\Startup folder.

      NOTE: GroupPolicy is often a hidden folder, so enable viewing of hidden folders in Windows Explorer (Tools > Folder Options > View tab). If the Scripts and Startup folders are missing, create them before proceeding.

   h. Use Notepad to edit the map.bat file, adding two lines:

      ```
      net use q: /delete  
      net use q: \GM_host_machine\share \ (e.g.: net use q:\ipcc-nlb2\goldmine)
      ```

      NOTE: The letter q is a placeholder for any unused drive letter you choose to use.

   i. Expand the tree in the left pane, then select Scripts (Startup/Shutdown).

   j. Double-click the Startup script in the right pane.

   k. Click Add, then click Browse.

   l. Double-click the map.bat file created earlier.

   m. Click Apply, then OK. Close the Management Console without saving the console settings.

   n. Reboot the IPCM server computer, and then verify the drive is mapped.

      NOTE: The drive may appear as a disconnected network drive in the My Computer folder.

6. Install the GoldMine client on the same computer on which the IPCM server was installed. In the installation wizard, when the GoldMine Shared Directory dialog box opens, specify the path to the GoldMine server location: \GoldMine_Host_Machine\GoldMine. Click Next, then continue installing the GoldMine client, in accordance with the GoldMine installation procedure.

Create Agent Dashboard Taskbar in GoldMine PE

GoldMine users can create a Taskbar containing buttons that control IPCM Agent Dashboard functionality such as indicating Go Ready or Not Ready, answering calls, hanging up calls, etc.

   NOTE: Open the Agent Dashboard and verify the default connector is specified (VPCC.GenericConnector.1) in the Dashboard Options dialog box. Refer to the IPCM online help topic "Agent Dashboard Configuration: IPCM Configuration with other FrontRange Products" for details.

1. On the GoldMine Taskbar, click Customize.

2. Right-click the Taskbar and select Add New Group.

3. Name the group Agent, then click OK.

4. Set the properties for each of the Agent Dashboard functions:
Go Ready
a. Right-click the Agent group and select Add New Item. The Taskbar Group Item Selection dialog box opens.

b. In the Item Type field, select External Application.

c. In the Caption field, type Go Ready.

d. In the Application field, type (or browse to) C:\Windows\System32\wscript.exe.

e. When you browse to the wscript.exe file, it automatically populates the Start Directory field with the setting C:\Windows\System32. You must change this path to: C:\Program Files\FrontRange Solutions\IP Communications Management\scripts\HEATVoice.

f. In the Command Line field, type set-ready-dashboard.js.

g. In the Icon File field, type or browse to C:\Program Files\FrontRange Solutions\IP Communications Management\scripts\HEATVoice\Ready.ico (the icon was installed with IPCM).

h. Click OK.

Go Not Ready
a. Right-click the Agent group and select Add New Item. The Taskbar Group Item Selection dialog box opens.

b. In the Item Type field, select External Application.

c. In the Caption field, type Go Not Ready.

d. In the Application field, type (or browse to) C:\Windows\System32\wscript.exe.

e. When you browse to the wscript.exe file, it automatically populates the Start Directory field with the setting C:\Windows\System32. You must change this path to: C:\Program Files\FrontRange Solutions\IP Communications Management\scripts\HEATVoice.

f. In the Command Line field, type set-not-ready-dashboard.js.

g. In the Icon File field, type or browse to C:\Program Files\FrontRange Solutions\IP Communications Management\scripts\HEATVoice\NotReady.ico (the icon was installed with IPCM).

h. Click OK.

Answer
a. Right-click the Agent group and select Add New Item. The Taskbar Group Item Selection dialog box opens.

b. In the Item Type field, select External Application.

c. In the Caption field, type Answer.

d. In the Application field, type (or browse to) C:\Windows\System32\wscript.exe.

e. When you browse to the wscript.exe file, it automatically populates the Start Directory field with the setting C:\Windows\System32. You must change this path to: C:\Program Files\FrontRange Solutions\IP Communications Management\scripts\HEATVoice.

f. In the Command Line field, type answer-dashboard.js.

g. In the Icon File field, type or browse to C:\Program Files\FrontRange Solutions\IP Communications Management\scripts\HEATVoice\answer.ico (the icon was installed with IPCM).

h. Click OK.
Hang Up

a. Right-click the Agent group and select **Add New Item**. The **Taskbar Group Item Selection** dialog box opens.

b. In the **Item Type** field, select **External Application**.

c. In the **Caption** field, type **Hang Up**.

d. In the **Application** field, type (or browse to) `C:\Windows\System32\wscript.exe`.

e. When you browse to the `wscript.exe` file, it automatically populates the **Start Directory** field with the setting `C:\Windows\System32`. You must change this path to: `C:\Program Files\FrontRange Solutions\IP Communications Management\scripts\HEATVoice`.

f. In the **Command Line** field, type `hangup-dashboard.js`.

g. In the **Icon File** field, type or browse to `C:\Program Files\FrontRange Solutions\IP Communications Management\scripts\HEATVoice\hangup.ico` (the icon was installed with IPCM).

h. Click **OK**.

Start Sales Scripts

a. Right-click the Agent group and select **Add New Item**. The **Taskbar Group Item Selection** dialog box opens.

b. In the **Item Type** field, select **Main Menu Action**.

c. In the tree, open **Go To > Sales Tools**, then click **OK**. The **Sales Scripts** icon is automatically selected.

Voice Applications

The IPCM Application Builder contains the following blocks specifically designed for creating voice applications for the IPCM/GoldMine configuration, utilizing the GoldMine database:

- **GoldMine Auto-Complete Activity Block** - Configures actions and corresponding notes to post to the contact record and History tab.

- **GoldMine Auto-Schedule Activity Block** - Configures the application to post actions and corresponding notes to the contact record Pending Activity tab as scheduled.

- **GoldMine Search Block** - Searches the GoldMine database for contact records, typically using a contact phone or account number as a search key. The result of search is stored as the record ID value. Call properties can define the values of the search keys, and store the values of fields returned.

- **GoldMine Screenpop Block** - Governs the GoldMine screenpop action when a call is routed to an agent.

- **GoldMine Update Block** - Updates fields in the GoldMine database. For information about copying, then editing (FrontRange does not recommend directly editing the sample applications) the GoldMineDemo voice application (described below) or creating a new application, refer to "Voice Application Design" in the IPCM Online Help.

GoldMineDemo Sample Voice Application

The GoldMineDemo voice application demonstrates how to identify a contact using the contact’s default phone number (PHONE1 field) and account number.

1. The GoldMine Screenpop block is configured to open a new contact window (the **Incoming call action** value is set to **Open**). The **Open Search Center** option is selected for callers IPCM does not identify as contacts.

2. The GoldMine Search block searches for the ANI. If the ANI is not found in the database, the voice application prompts the caller to enter a default phone number, and the GoldMine Search block searches the database for the number entered.

3. If the search is successful, the agent who receives the call also sees the screenpop configured in step 1.

4. When the call is complete, the voice application updates the GoldMine History database using GoldMine Auto-Complete Activity block.
**IPCM/GoldMine Call Scenario**

The client and Agent Dashboard configurations enable the following call scenario:

1. IPCM connects a caller to the GoldMine voice application. The voice application collects caller identification information either automatically using the ANI, or by prompting the caller to input identifying data such as a phone number, account number, or other types of data the GoldMine database stores in the CONTACT1, CONTACT2, and CONTSUPP tables.

2. The voice application accesses the GoldMine application and queries the GoldMine database for the caller’s record using the identification information. The GoldMine application returns the caller’s record to the voice application.

3. The voice application attaches the record to the interaction, prepares a screenpop using data in the record, and places the interaction in a queue that contains GoldMine calls (if you are using the GoldMineDemo application, this queue is the GoldMine Demo Queue).

4. When IPCM routes the interaction to an agent, the connector on the agent’s workstation requests data from the GoldMine database to populate the screenpop.

   **NOTE:** You can also configure the voice application to let the agent try to find the contact information manually using the GoldMine Search Center; however, even if the search is successful, the Agent Dashboard does not update the GoldMine database history fields automatically.

5. After the interaction is complete, the voice application updates the GoldMine database using the GoldMine Auto-Complete Activity block.
Integrating with .NET

The new API integrates with GoldMine by providing an XML-based programming interface and COM server. It is compatible with Microsoft .NET development tools (VB.NET and C#). The XML wrapper provides access to functions from the non-XML capable API available of previous GoldMine versions.

Also, user-interface integration tools let developers interact. For instance, replace DDE with COM, to gain:

- Implementation of current technology instead of DDE.
- Compatibility with COM-capable development tools.
- Compatibility with .NET applications.
- Ability to grow into a full UI API.
- Ability to rewrite the Excel/Word link.
- Easier implementation of an XML-based interface.

The COM server implements the relevant DDE functions. An application that previously used DDE can communicate to GoldMine using this interface.

The description has 2 parts:

- The XML API
- The UI API to run

The XML API and the UI API use the same basic schema to perform actions:

```
<GMPI call="CallName"><dataname="DataName">XXXXXX</data>...</GMPI>
```

Eventually, this will evolve into a retro-written XML-schema and DTD for the full APIs.

The XML API wraps the existing GM API into a simpler interface. Low-level functions performing actions needed by the non-XML API programmer are hidden. Failures are self-documented (no return messages).

**Suggested Prerequisites**

- **Using the interfaces (developers and Technology partners):** A working knowledge of COM and XML (or ability to build well-formed XML strings).
- **End users:** A working knowledge of the standard function calls for the older gmx32.dll version of the GoldMine API.

See the Open Developer section of our support Web site at http://support.frontrange.com or our Partner section of the Web site to become a Technology Partner.
Resources

•
•
• Additional Documentation

Additional Documentation

In addition to this guide, the following resources are available to provide you with information about GoldMine:

• **Online Help** - Accessed by clicking the Help menu option in GoldMine, online help provides topic overviews and step-by-step instructions to walk you through basic tasks, in addition to a comprehensive table of contents, index, and search function.

  **NOTE:** Guides are available in PDF format from the Installation kit for maintenance customers at [http://www.frontrange.com/support](http://www.frontrange.com/support).

• **Training Courses** - Information regarding training courses for FrontRange Solutions family of products can be found at: [http://frontrange.learn.com](http://frontrange.learn.com)

Contact Us

Support Site

FrontRange Solutions can answer your technical support questions about HEAT, FRS Foundation, GoldMine, and other FrontRange product families. Visit:

[http://www.frontrange.com/support](http://www.frontrange.com/support)
Contact Information

FrontRange Solutions Corporate Headquarters

FrontRange Solutions USA, Inc.
490 N. McCarthy Blvd., Suite 100
Milpitas, CA 95035 USA

Toll Free: 800.776.7889
Local: +1 408.601.2800
If calling from Canada, dial: 1.888.603.3270

Offices are also located in Latin America, Asia Pacific, Europe, South Africa, and the Middle East. For international contact information, go to the FrontRange Solutions Web site, click the Contact link at the top of the page, and then locate your region.
Glossary

#

.ics: iCalendar file extension.

A

**AccountNo:** The Account Number field uniquely identifies a contact record and is the common field value that links the Contact1 table to Contact2, Cal, ContSupp, ContHist, and OpMgr.

**Action:** The Automated Process action is the activity performed when triggered.

**Activities:** Activities are time-specific or event-based actions linked to contacts; for example calls, appointments, letters, or other types of activities, such as To Do tasks or events that are assigned to users.

**Activity list:** A window that displays task or event information. The Activity List displays eleven categories of information in a set of tabs.

**Additional Contact:** Individual associated with the primary contact, such as an administrative assistant. GoldMine stores this information in the Contacts tab of the primary contact’s record.

**Alphanumeric characters:** Letters A - Z and numeric digits.

**Attachment:** A file, for example, a Word document, created outside of GoldMine and attached to GoldMine as a linked document, InfoCenter attachment, or e-mail attachment.

**Auto-updating:** Allows you complete or delete many activities or resources.

B

**Bcc:** Blind Carbon Copy. A copy of a message, usually e-mail, is sent to a recipient that the main recipients cannot see.

**BDE:** Borland Database Engine. Serves as a connector between GoldMine and the databases.

**Break fields:** Break fields manage the grouping of information, determining how multiple entry information, such as Details, Calendar, and History, is displayed in a report template. The break field ensures that all the details or calendar entries are grouped together before moving on to the next contact record. Break fields can only be used in Sort Headers.

C

**Calculated field:** Field containing a mathematical expression rather than data.

**Cc:** Carbon Copy. Used in e-mail messages, memos, and letters.

**Character string:** Any series of alphanumeric characters including spaces that are treated as a group.

**Cloning:** The process of copying a user or report settings and configurations in order to quickly create a new user or report.

**CommonDir:** Used in the GM.ini, the CommonDir specifies the location of your default contact files.

**Contact files:** The tables storing a database’s contact information. Also referred to as Common files. The CommonDir line in the GM.ini points to the default contact files.
Contact record: Standard unit of information in GoldMine. GoldMine’s contact record incorporates standard information, such as name, company, phone, and address, and also serves as the basis for all scheduled work in GoldMine, acting as the central link between GoldMine’s Calendar and History by maintaining all past and pending events related to the individual contact records in the GoldMine database.

Contact set: Database consisting of the contact information: Contact1, Contact2, ContSupp, ContHist, ContGrps, ContUdef, Conttlog, and sometimes Lookup. GoldMine allows you to have more than one contact set.

Contact tabs: Set of tabs located below the main Contact Record containing information associated with the contact, including additional contacts, pending, and history information.

Contacts tab: Additional contacts associated with the Contact Record.

Curtaining: See Record curtaining

Custodian: The person responsible for the resource.

Database: A collection of data fields and related tables storing information that facilitates access and retrieval.

Details tab: Structured, user-defined information associated with each Contact Record.

Dialog field: A field created to open a dialog box and prompt the user for parameters to include in the report.

Digital ID: Digital signature and encryption keys sent with e-mail messages.

Entity: Used to refer to a single record type. Consists of a customized combination of primary fields views, custom screens, and GM+Views.

Event: Step-by-step instructions contained in an Automated Process, or track, that GoldMine must evaluate to perform a specified series of activities. An event consists of a trigger and an action. An Automated Process consists of a sequence of one or more events.

F2 Lookup: Special type of browse window that can be customized to contain frequently used or code-specific entries. Security options can control F2 lookups to ensure user input and allow standardization of data.

Field typing: Customizing field labels and colors using direct data or dBASE expressions.

Fields tab: Displays user-defined fields grouped together in user-defined screens.

File code: The unique 3-character identification assigned to each Contact Set, enabling synchronization and backing up.

Filter: Sort condition used to select a subset of records from the entire database.

Force log out: Forces users out at a particular time or when inactive for a period of time.

Free/busy times: Free and busy calendar times published to file, ftp, or http locations and made available to other users.

GM.ini: A file located in the GoldMine directory containing commands for general GoldMine operation. The most important are the SysDir, GoldDir, and CommonDir.

GM+View tab: User-defined HTML template-based views.

GoldDir: Used in the GM.ini, the GoldDir specifies the location of your GoldMine files also called your GMBase files.

GoldMine Business Contact Manager: An installation of GoldMine using a D-License and a dBASE database.

GoldMine e-mail: E-mail message to another GoldMine user or user group.

GoldMine files: The tables storing other database information. Also referred to as GMBase files. The GoldDir line in the GM.ini points to the shared GoldMine files.

GoldMine link to Excel: Creates a link between GoldMine and Excel, allowing you to add GoldMine fields to Excel or export data from Excel to GoldMine.

GoldMine link to Word: Creates a link between GoldMine and Word, allowing you to add GoldMine fields to a Word document or template.

GoldSync Server: A computer that handles the synchronization processes.

GoldSync Service: Runs the GoldSync application in the background without requiring a user to launch GoldMine.

Group: Fixed set of contact records that meet an initial set of conditions. Once selected, member records subsequently have instantaneous access to the subset. Alternate method to filters of maintaining a subset of data.

History tab: Completed activities associated with the Contact Record.

HTML: HyperText Markup Language. The authoring language used to define the structure and layout of a Web document by using a variety of tags and attributes.

Hyperlink: An element in an electronic document that links to another place in the same document or to an entirely different document. Click on the hyperlink to follow the link.

IIS: Internet Information Services.

InfoCenter: A resource used to maintain and display any type of information useful to an organization or an individual. The InfoCenter can archive information in a variety of formats, such as graphics, multimedia files, and program applications. Any of this information can be linked to a Contact Record.

Installing locally: Installing GoldMine .exe and .dll files on a local workstation in a network environment.

Instant sync: Automatically reminds undocked users to synchronize whenever a connection GoldSync is detected.

Internet e-mail: E-mail message to customers using your POP3 e-mail account.

Keyboard shortcuts: See Shortcut keys

Keyword: One or more words that succinctly describe a document’s contents.

KnowledgeBase: Information created by, for, and about an organization and available to multiple users.

Linked activities: Scheduled activities linked to a contact record.

Links tab: Documents, programs, and other files linked to the Contact Record.

Local menu: Also known as a shortcut menu, the local menu provides quick access to a set of commands affecting only the current browse window, tab, or pane.

LogStamp: Contains the time and date that the record was last changed.
Macros: A series of commands and/or keystrokes that launches or runs a action.

Maintaining: Process to improve performance by regenerating indexes, packing and rebuilding tables, and sorting and verifying data. The maintenance of the database should be performed by the system administrator or manager.

Members tab: Lists the contact Groups of which the Contact Record is a member.

Merge codes: Three-character codes used as the basis for e-mail and document merging for mass mailings.

Net-Update: Process of updating GoldMine over the Internet.

Notes tab: Free text notes associated with each Contact Record.

ODBC: Open Database Connectivity.

Operator: Specifies the value a field must have to be included in a record selection criteria. Examples of operators include the following: equal to, greater than, lesser than or equal to.

Opportunity: Involves a group working as a team with multiple organizations and contacts to successfully close a complex sale.

Opptys tab: Displays the Opportunities associated with the Contact Record.

Organization Chart: Graphically displays contact information and organizational relationships in a tree structure.

Packing: The process of actually deleting records that were marked for deletion. This process is only necessary for a dBASE database. Periodically packing the database files removes the “dead space” between records.

Personal Base: Information useful to an individual user that only the logged-in user can view and update.

Primary contact: The name of the contact on the Contact record.

Primary fields views: Primary field views are customized views of the primary fields. Primary fields are those in the upper four panes of a Contact Record and are Contact1 fields.

Process: A sequence of two or more events, which are the step-by-step instructions that GoldMine evaluates to perform a defined series of activities. Also known as an Automated Process.

Processes tab: Lists the Automated Processes attached to the Contact Record.

Project: Involves a group working as a team to complete a long-term project that involves multiple component tasks.

Projects tab: Displays the Projects associated with the Contact Record.

Rebuilding: Creates a new file structure or table, and copies data, record-by-record, from the old files/tables to the new ones.

Record curtaining: A Contact record can be curtained so that a user who does not own the record cannot view the record or can view only part of the record.

Record types: Customized combination of primary fields views, custom screens, and GM+Views. Configured in the Record Types Administration Center.

Record Types Administration Center: Allows you to create many Record Types based on combinations of your different Primary Field Views, Custom Screens, and GM+Views and to apply them based on your user-defined Record Type Rules.
Record typing: Customized combinations of Primary Fields Views, Custom Screens, and GM+Views.

Rectype: A record type code identifying different types of records within the database.

Referrals tab: Internal referrals within the Contact Set.

Rehost: Rehosting data is the process where one database is copied or converted to a new database.

Reports Center: Provides easy visual access to several reporting options available within GoldMine.

Required field: A field requiring data.

Resources: Resources that are commonly requested include conference rooms, projectors, demonstration products, company vehicles.

Rich Site Summary: See RSS.

RSS: Rich Site Summary -- a simple XML format designed for sharing Web Headlines.

Screen design toolbar: Used when you are designing your primary fields or Fields tab screens.

Seq: Sequence ordered number for each event in an Automated Process. The sequence number begins with either P for a Preemptive event or S for a Sequential event. Each event is processed in order based on the sequence number.

Shortcut keys: Shortcut keys are keyboard keys or key combinations that invoke a particular command.

Shortcut menu: See Local Menu

Site code: Matches a synchronization process to a site.

Sort Header: A section in a report that holds the labels, filters, and break filters for the section or for the corresponding detail section.

Sort order: The order that Contact records are displayed based on a specified field. The sort order for the database is determined by the Sort Order you select in the Contact Listing window. If a filter or group is active, the Sort Field you selected takes precedence.

Sorting: Orders the records in the files/tables by the most-used indexes.

Summary tab: Displays activity information about the current Contact Record.

Synchronization: GoldMine’s remote synchronization is a process that can update one GoldMine system with new or changed information that has been entered in another GoldMine system.

SyncStamp: Contains the time and date when the record was last successfully retrieved during synchronization.

SysDir: Used in the GM.ini, it specifies the location of gmw6.exe.

Task group: A group of task items on the GoldMine Taskbar.

Task item: An item on a taskbar that launches an action.

Taskbar: Frequently used GoldMine Menu commands and macros, links to documents and files, and a quick step for launching applications and web sites.

Tickets tab: Displays tickets from HEAT Call Logging when GoldMine/HEAT integration is installed.

Tlogs: The general name for the two types of logs: ContTlog and GMTlog. They track date and time stamps for changes to fields and the synchronization of the data.

Transfer set: A database of all the changes made to Contact Records during a specified time frame. The database with the changes is sent to other GoldMine locations and retrieved, updating that database with the new information.

Transformation sheet: A language for transforming XML documents into other XML documents.

Trigger: A predefined condition in an Automated Process event that, when the condition is true, causes GoldMine to execute an action.
Unlinked activities: Scheduled activities that are linked to a user but not to a contact.

URL: Abbreviation of Uniform Resource Locator, the global address of documents and other resources on the World Wide Web.

User groups: Users can be logically grouped according the functions that they perform.

User Preferences: Various settings that control how GoldMine looks and acts for each user.

User Properties: These settings define a user's security and access in GoldMine.

UserID: Field that contains the name of the user an activity is assigned to. UserID is based on the GoldMine username.

Username: Use this name to log into GoldMine. Identifies the user's activities.

Username.ini: An initialization file located in the GoldMine directory that stores user's individual settings.

Username.tbi: Stores the user's taskbar settings.

Verifying: Ensures that the data is readable and that all sync fields in the synchronization records of the database file(s. are populated, and no unique fields are duplicated.


XML: Acronym for Extensible Markup Language. XML is a universal format that uses tags for exchanging structured documents and data on the Internet.
Index

Symbols
GoldMine Tables 119
.INI Files and Macros 44
.NET Integration 398

A
About the Database Alias Manager 99
ACT!
  Importing versions 112
Adding
  Excel templates 352
Adding or Editing Holidays 31
Attaching 285
Auto-dialer settings 79
auto-linking 364
  Outlook Folders 365
Automated Processes 269
  Attaching 285
  Automated Process Center 271
Creating 272
  Actions 281
  Events 277
  Processes 275
  Triggers 278
Designing 269
Executing 286
Using 271
Automatic Maintenance 96, 98
Automating Routine Tasks 269

B
Backing Up 95

C
CGI 180
Changing Your Password 26
charts
  adding 137
Cloning
  Reports 240
  User Settings 44
Combining Hiding and Color 209
Communicating with Contacts
  About 71
Configuring
  GoldMine Premium Edition 223
  My GoldMine 339
Configuring GoldSync in the Server Agents Administrator 329
Configuring Sending and Retrieving E-mail in the Server Agents Administrator 328
Configuring the INI File 46
Configuring Your Computer to Access Your ISP 73
Contact Records 65
Converting
  Outlook 112
Creating
  Databases 83, 83
  E-mail rules 75
  One-Button Synchronization
    Profile 320
Creating Custom Screens 200
Creating Undocked User Licenses 313
Creating User Menu Templates 23
Crystal Reports
  Using 232, 234, 260
Customizing
  Auto-dialer settings 79
  Properties 220
Customizing Field Typing 208

D
Dashboard
  Macros 166
dashboard  
actions 171  
charts 159  
creating 134  
data binding 144  
drop-down list 143  
 events 171  
export 174  
GoldMine Help 152  
import 174  
management 133, 168  
new data source 143  
part properties 146  
sample dashboard tutorial 133  
splitters 145, 146  
tables 167  
tabs 145, 145  
XML file 174  
data binding  
destinations 152  
data source  
creating 135  
data source management 163  
Databases  
Creating 83  
Opening 82  
DDE Macros 55  
decrypt e-mails 38  
Deleting  
Contact Records 118  
Deleting an Alias 100  
Dependency Between Lookup Lists 334  
Selecting an entry by ignoring dependency settings. 336  
Setting up a dependency 334  
Document Management Center  
Adding 352  
duplicate record 183, 183  
Duplicate records 116  

E  
Editing  
Reports 241  
Editing an Alias 100  
Editing Knowledge Base Books, Folders, and Topics 343  
Editing Processes 276  
E-mail  
Rules 75  
Email  
Retrieving 73  
event  
adding 144  
Event Properties Dialog Box 277  
Events  
Creating 277  
Excel  
Exporting 114, 351  
GoldMine Link 345  
Templates 352  
Using 350  
Exporting 105, 108  
Considerations 106  
Excel to GoldMine 114, 351  
Export Wizard 108  
iCalendar Files 115  
XML 109  

F  
FBclient32.dll 83  

G  
gateway script 180  
Global Replacing 101  
Globally Updating Fields Using Advanced Options 102  
GMLinkInstaller.exe 346  
GMOutlookLog.txt 356  
GMOOutlookSpeed.txt 356  
GoldMine  
Integration 369  
Link 345  
Excel 114, 350, 351  
Installing  
Document Management Center 346  
GMLinkInstaller.exe 346  
Upgrading 346  
Word 350  
Link to Microsoft Office 345  
GoldMine Address Book  
Outlook 2003 354  
Outlook 2007 354  
Outlook 2010 354  
GoldMine Plus for Excel 346  
GoldMine Premium Edition  
Configuring settings for 223  
GoldMine Report Macros 61  
GoldMineMobile  
Troubleshooting setup 224
Notes 21
Completion Notes 32
DDE Macros 58
Format 52
HTML and Plain Text 45
View as HTML 49
View as Plain Text 49

O
OmniRush 345
One-Button Synchronization 319
Creating profile 320
Instant sync 320
Retrieving profiles 321
Synchronizing 319
Opportunity Trigger Dialog Box 287
Outlook 292
Converting 112
Importing 112
Outlook Conversion Wizard 112

P
Palm 292
plug-ins
  ActiveX controls 225
  HTML integrations 225
Pocket PC 292
Previewing 259
  Reports 259
Printing
  Correspondence 71
  Reports 260
Process Local Menu 272
Processes
  Attaching 285
  Creating 275
  Executing 286
Project Trigger Dialog Box 287

R
Record
  Contact
    see Contact Records 65
  Curtaining
    Fields 296
  Types
    About 189
    Record Types Administration Center 190
record curtaining 67
Recording Macros 54

Removing
  Attached Automated Processes 286
Report Properties 234
Report Properties, Profile Tab 235
Reports
  Creating 237
  Editing 241
  Previewing 259
  Printing 260
  Properties 234
  Saving with data 261
  Sorting data 261
  Using 234
  Viewing 261
Reports Center
  see Reports 232
Restoring 96
Retrieving 321
Retrieving Email 74
RightFax 345
Rules
  E-mail 75
Running
  GoldSync Service 316
  Processes 286

S
Saving
  Reports with data 261
SDF file 104
Selecting 116
Server
  Creating 313
  Processes 315
Server Agents
  see Server Agents Administrator 327
Server Agents Administrator 327
Starting 327
server scripts 180
Setting Calendar Publishing Output to XML 51
Setting Email Preview Text Amounts 51
Setting Internet Preferences on the Accounts Tab 37
Setting Internet Preferences on the Advanced Tab 39
Setting Internet Preferences on the Composing Tab 35
Setting Internet Preferences on the Retrieval Tab 36
Setting Internet Preferences on the Security Tab 37
Setting Keep or Clear on Tagged Records 51
Setting Options for the System Tab 41
Setting Preferences for the Alarms Tab 33
Setting Preferences for the Calendar Tab 29
Setting Preferences for the E-mail Tab 34

GoldMine Administrator Guide
Setting Preferences for the Lookup Tab  33
Setting Preferences for the Record Tab  26
Setting Preferences for the Schedule Tab  32
Setting Preferences for the Telephony Tab  40
Setting Preferences on the Personal Tab  26
Setting Report Properties, Profile Tab  235
Setting the User Profile  19
Setting up a Dependence  334
Setting Up Default Document File Names and Folders for Document Templates  71
Setting Up User Groups  20
Setting up User Groups  20
Setting Up User Membership  19
Site
  Creating Groups  311
  Sites  309
Sorting Report Data  261
SQL
  Restoring  96
  Starting  327
Sync
  See Synchronizing  289
Synchronization Settings  306
Synchronizing  289
  Copying and Moving Records  295
  GoldSync Administration Center  308
  One-button synchronization  319, 319
  Scenario  289
  Synchronization Wizard  297, 297
  With GoldSync  300
System
  Logs  99

T
Tagging
  Merging tagged records  118
Timeouts
  Synchronization Settings  306
To add a Topic Page  343
troubleshooting  356

U
Undocked Users
  Updating  44
User Groups  18
User Preferences
  Calendar  29
  Personal tab  26
  Record tab  26

Users
  Preferences  25
  Properties  44, 44
Using
  GoldSync Administration Center  308
  My GoldMine  340
  Reports  234

V
Viewing the User Time Clock  23
Visor  292

W
web forms  177
WinFax
  WinFaxPro  345
Wizards
  Import  106
  Maintenance  96
  Synchronization  297
Word
  GoldMine fields  350
  GoldMine Link  345

X
XML  108

Z
Zetafax  345